Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Pagine del manuale quasi incomprensibili
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Sep 01, 2009 1:28 pm    Post subject: [RISOLTO] Pagine del manuale quasi incomprensibili Reply with quote

Salve gente,

da qualche giorno sto combattendo con un problema al quale non ho ancora trovato una soluzione.
Le pagine del manuale, sono quasi totalmente "incasinate".
Ecco un esempio.

Come potete vedere ci sono diversi "ESC" per tutta la pagina.. Non capisco cosa possa essere. Ho anche provato
a riemergere man-pages (ho la versione 3.21) ma nulla di fatto.

Come posso risolvere?

Grazie
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Tue Sep 01, 2009 4:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2702
Location: Italy

PostPosted: Tue Sep 01, 2009 1:42 pm    Post subject: Reply with quote

Charset errato. sputaci fuori un env ed un locale.
;)
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Sep 01, 2009 3:40 pm    Post subject: Reply with quote

Cacchio!
Eppure non ho toccato nulla.. forse un dispatch-conf ha fatto casini..
Code:
# env
MANPATH=/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:
/usr/share/binutils-data/x86_64-pc-linux-gnu/2.18/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.2/man:
/etc/java-config/system-vm/man/:/usr/lib64/php5/man/:/usr/kde/3.5/share/man:/usr/qt/3/doc/man
KDE_MULTIHEAD=false
DM_CONTROL=/var/run/xdmctl
SHELL=/bin/bash
TERM=xterm
XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/flavio/.gtkrc-2.0:/home/flavio/.kde3.5/share/config/gtkrc-2.0
GS_LIB=/home/flavio/.fonts
GTK_RC_FILES=/etc/gtk/gtkrc:/home/flavio/.gtkrc:/home/flavio/.kde3.5/share/config/gtkrc
WINDOWID=67108869
QTDIR=/usr/qt/3
KDE_FULL_SESSION=true
ANT_HOME=/usr/share/ant
USER=root
PRELINK_PATH_MASK=/usr/lib64/klibc
LS_COLORS=rs=0:di=01;34:ln=01;36:hl=44;37:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01
:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:
*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.zip=01;31:*.z=01;31:*
.Z=01;31:*.dz=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*
.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:
*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:
*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:
*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:
*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:
*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:
*.yuv=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:
*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:
*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:
*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
GDK_USE_XFT=1
SESSION_MANAGER=local/FlaGentoo:@/tmp/.ICE-unix/5115,unix/FlaGentoo:/tmp/.ICE-unix/5115
CONFIG_PROTECT_MASK=/etc/gentoo-release /etc/sandbox.d /etc/env.d/java/ /etc/php/cli-php5/ext-active/
/etc/php/cgi-php5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/udev/rules.d /etc/fonts/fonts.conf /etc/gconf
 /etc/terminfo /etc/ca-certificates.conf /etc/texmf/web2c /etc/texmf/language.dat.d /etc/texmf/language.def.d
 /etc/texmf/updmap.d /etc/revdep-rebuild /etc/splash
PAGER=/usr/bin/less
FLTK_DOCDIR=/usr/share/doc/fltk-1.1.7-r2/html
XDG_CONFIG_DIRS=/usr/kde/3.5/etc/xdg
KONSOLE_DCOP=DCOPRef(konsole-9323,konsole)
PATH=/sbin:/bin:/usr/sbin:/usr/bin
DESKTOP_SESSION=default
PWD=/home/flavio
DISTCC_LOG=
KONSOLE_DCOP_SESSION=DCOPRef(konsole-9323,session-1)
JAVA_HOME=/etc/java-config-2/current-system-vm
EDITOR=/bin/nano
JAVAC=/etc/java-config-2/current-system-vm/bin/javac
KDE_SESSION_UID=1000
QMAKESPEC=linux-g++
DCCC_PATH=/usr/lib64/distcc/bin
DISTCC_VERBOSE=0
HOME=/root
SHLVL=3
JDK_HOME=/etc/java-config-2/current-system-vm
XCURSOR_THEME=default
LOGNAME=root
LESS=-R -M --shift 5
CVS_RSH=ssh
GCC_SPECS=
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ZUoSu4jvPE,guid=f3cd9cdf7384c1698653dafa4a9d1cb6
ROOTPATH=/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/local/bin:
/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/i686-pc-linux-gnu/gcc-bin/4.3.2:
/usr/x86_64-pc-linux-gnu/gcc-bin/4.3.2:/usr/qt/3/bin:/usr/games/bin
XDG_DATA_DIRS=/usr/kde/3.5/share:/usr/local/share:/usr/share
LESSOPEN=|lesspipe.sh %s
PKG_CONFIG_PATH=/usr/qt/3/lib64/pkgconfig
INFOPATH=/usr/share/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.18/info:
/usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.2/info
DISPLAY=:0.0
OPENGL_PROFILE=nvidia
USB_DEVFS_PATH=/dev/bus/usb
SANE_CONFIG_DIR=/etc/sane.d
LDPATH=/usr/kde/3.5/lib:/usr/kde/3.5/lib64:/usr/kde/3.5/lib32:
CONFIG_PROTECT=/usr/kde/3.5/share/config /usr/kde/3.5/env /usr/kde/3.5/shutdown /usr/share/config
XAUTHORITY=/root/.xauthlK24HG
COLORTERM=
_=/bin/env

Code:
# locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Wed Sep 02, 2009 9:12 am; edited 1 time in total
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Tue Sep 01, 2009 4:30 pm    Post subject: Reply with quote

Qualcosa non ti quadra? O hai messo posix di tua volontà?

Code:
$ locale
LANG=it_IT.UTF-8
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=


si imposta da quì
Code:
# cat /etc/env.d/02locale
LANG="it_IT.UTF-8"
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Sep 01, 2009 4:36 pm    Post subject: Reply with quote

No! Non ho messo io POSIX! E non so come ci sia andato.
In realtà non ho mai localizzato la distribuzione... :(

Quindi se è un problema di localizzazione, lo farò.. però non voglio la distribuzione in italiano.
Comunque, appena messo a posto il file 02locale, che in verità non esisteva, il manuale è tornato ad essere chiaro!

Grazie!

EDIT: in realtà però ho anche un'altra Gentoo su un hard disk secondario, e locale mi da lo stesso risultato, c'è sempre POSIX, e il problema non me lo da. E anche lì, il file 02locale non è presente!!!
Com'è possibile questa cosa?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Tue Sep 01, 2009 5:09 pm    Post subject: Reply with quote

Se non vuoi la localizzazione in italiano usa la lingua che preferisci:

Ita:

http://www.gentoo.org/doc/it/guide-localization.xml

UTF:

http://www.gentoo.org/doc/it/utf-8.xml

Internazionale:

http://www.gentoo.org/doc/en/guide-localization.xml

Visto che vai a modificare ed aggiornare le variabili d'ambiente forse hai installato in periodi diversi e gli stage contenevano valori predefiniti diversi (imho :D )!

Ciao
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Sep 01, 2009 5:21 pm    Post subject: Reply with quote

mack1 wrote:
Visto che vai a modificare ed aggiornare le variabili d'ambiente forse hai installato in periodi diversi e gli stage contenevano valori predefiniti diversi (imho :D )!

Eh sì! E' probabile che sia quello il motivo. In effetti è un bel po' che questo filesystem è stato creato! :(

A proposito, c'è un modo per stabilire in modo esatto il giorno in cui ho fatto l'installazione? Sono diversi anni.. ma chi si ricorda? :)
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Tue Sep 01, 2009 8:49 pm    Post subject: Reply with quote

Mah non credo.... :oops:

Ot = Comunque è il post più largo che abbia mai visto sul forum di Gentoo :lol:

Ciao
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Sep 01, 2009 9:37 pm    Post subject: Reply with quote

mack1 wrote:
Ot = Comunque è il post più largo che abbia mai visto sul forum di Gentoo :lol:

Mica l'ho capita sai!!! :? :? :?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Sep 02, 2009 5:04 am    Post subject: Reply with quote

fbcyborg wrote:

A proposito, c'è un modo per stabilire in modo esatto il giorno in cui ho fatto l'installazione? Sono diversi anni.. ma chi si ricorda? :)

Code:

cloc3@s939 ~ $ genlop -lt|head -n 4
 * app-portage/gentoolkit

     Sun Jul 30 12:49:53 2006 >>> app-portage/gentoolkit-0.2.2
       merge time: 11 seconds.

Ot = Comunque è il post più largo che abbia mai visto sul forum di Gentoo :lol:
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Sep 02, 2009 6:06 am    Post subject: Reply with quote

Eh sì, è proprio largo!
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Sep 02, 2009 6:59 am    Post subject: Reply with quote

fbcyborg wrote:
Eh sì, è proprio largo!

è colpa di quelle righe troppo lunghe nei code di questo post.
accorciale, mandandole a capo o tagliandone la coda, che non contengono informazioni di sostanza.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Wed Sep 02, 2009 7:06 am    Post subject: Reply with quote

@fbcyborg non è mica una colpa :wink: !!!
@cloc3 buono a sapersi!

Ciao
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Sep 02, 2009 9:10 am    Post subject: Reply with quote

Ok!!! Scusate, ma ho un 22" e non me ne sono accorto.
Il fatto è che non capendo cominciavo a credere che mi steste prendendo per il cu.0....
Infatti savo per pregarvi di spiegarmi il motivo del commento, visto che di solito, sto attento a non scrivere post in cui si debbano usare anche le scrollbar orizzontali.

Cerco di aggiustare subito il post. Spero che ora si sia ristretto!!! :)
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Sep 02, 2009 2:02 pm    Post subject: Reply with quote

Dunque, ritorno a parlare di questo problema perché a quanto pare ancora persiste.
Se apro il manuale da utente, si legge bene. Da root NO.

Anticipo subito che ho voluto rimodificare il file 02locale, perché ad un tratto mi sono trovato diverse cose in italiano.

Allora ho modificato il file 02locale scrivendoci LANG="en_GB.UTF-8", ma continuo a ricevere alcuni messaggi, come quello che ho appena citato, in italiano.
Ora sto ricompilando il sistema anche senza la variabile LANG impostata nel make.conf. Però dando un emerge --info ottengo sempre un:
Code:
LANG="it_IT.UTF-8"

Mi sa che sono un po' in confusione.. (help!).

Dove può essere il problema (ammesso che ce ne sia uno solo)?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Sep 02, 2009 4:49 pm    Post subject: Reply with quote

RISOLTO!
Ma soprattutto trovata la causa di questo problema.
Leggendo questo post ho trovato la soluzione.
Effettivamente mancava quel -c, di cui si parla nel post. Ora è tornato tutto a posto finalmente.

Quindi non c'entra nulla la localizzazione!
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Dec 21, 2010 2:41 pm    Post subject: Reply with quote

Scusate se riapro questo thread, ma sto avendo un problema simile con dispatch-conf.
Ad esempio, ecco cosa succede:
Code:
ESC[1;31m--- /etc/dhcpcd.conf   2010-04-08 22:56:22.000000000 +0200ESC[0;0m
ESC[1;34m+++ /etc/._cfg0000_dhcpcd.conf 2010-12-21 14:48:47.000000000 +0100ESC[0;0m
ESC[1;35m@@ -1,13 +1,23 @@ESC[0;0m
ESC[0;0m # A sample configuration for dhcpcd.ESC[0;0m
ESC[0;0m # See dhcpcd.conf(5) for details.ESC[0;0m
ESC[0;0m ESC[0;0m
ESC[1;31m-# dhcpcd-run-hooks uses these options.ESC[0;0m
ESC[1;31m-option domain_name_servers, domain_name, domain_search, host_nameESC[0;0m
ESC[1;34m+# Inform the DHCP server of our hostname for DDNS.ESC[0;0m
ESC[1;34m+hostnameESC[0;0m
ESC[1;34m+# To share the DHCP lease across OSX and Windows a ClientID is needed.ESC[0;0m
ESC[1;34m+# Enabling this may get a different lease than the kernel DHCP client.ESC[0;0m
ESC[1;34m+# Some upstream DHCP servers may also require a ClientID, such as FRITZ!Box.ESC[0;0m
ESC[1;34m+#clientidESC[0;0m
ESC[0;0m ESC[0;0m
ESC[1;31m-# Most distros have ntp support.ESC[0;0m
ESC[1;34m+# A list of options to request from the DHCP server.ESC[0;0m
ESC[1;34m+option domain_name_servers, domain_name, domain_search, host_nameESC[0;0m
ESC[1;34m+option classless_static_routesESC[0;0m
ESC[1;34m+# Most distributions have NTP support.ESC[0;0m
ESC[0;0m option ntp_serversESC[0;0m
ESC[1;34m+# Respect the network MTU.ESC[0;0m
ESC[1;34m+option interface_mtuESC[0;0m
ESC[1;34m+# A ServerID is required by RFC2131.ESC[0;0m
ESC[1;34m+require dhcp_server_identifierESC[0;0m
ESC[0;0m ESC[0;0m
ESC[1;31m-# We should behave nicely on networks and respect their MTU.ESC[0;0m
ESC[1;31m-# However, a lot of buggy DHCP servers set invalid MTUs so this is notESC[0;0m
ESC[1;31m-# enabled by default.ESC[0;0m
ESC[1;31m-#option interface_mtuESC[0;0m
ESC[1;34m+# A hook script is provided to lookup the hostname if not set by the DHCPESC[0;0m
ESC[1;34m+# server, but it should not be run by default.ESC[0;0m
ESC[1;34m+nohook lookup-hostnameESC[0;0m


È vero che ho aggiornato di recente (sempre tramite dispatch-conf) il file /etc/dispatch-conf.conf, ma non capisco dove possa essere il problema.
Il file di configurazione è questo:
Code:
archive-dir=/etc/config-archive
use-rcs=yes
diff="colordiff -Nu '%s' '%s' | less --no-init --QUIT-AT-EOF"
merge="sdiff --suppress-common-lines --output='%s' '%s' '%s'"
replace-cvs=yes
replace-wscomments=no
replace-unmodified=yes
ignore-previously-merged=no


C'è qualcosa di sbagliato?

EDIT: ho risolto seguendo il consiglio in questo post.
Spero possa essere utile anche ad altri.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum