Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel UEFI, GPT, mount / like ro & don't mount /boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 193

PostPosted: Tue Jun 06, 2017 2:18 pm    Post subject: Kernel UEFI, GPT, mount / like ro & don't mount /boot Reply with quote

Hi comunity, (please pardon for my English)

Im trying to configure a new custom kernel, but it does not work.

When the Kernel starts, the root partition is like read only mounted. On the other hand /boot (Efi) and /home are not mounted


I obtain the next info from openrc:

Code:

cant create /proc/sys/kernel/hotplug

call flock failed; function is not implemented;


that is my fstab:

Code:

cat /etc/fstab

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

tmpfs                   /tmp            tmpfs           size=9000M             0 0
tmpfs                   /var/log        tmpfs           size=200M              0 0
tmpfs                   /var/tmp        tmpfs           size=900M              0 0


#/dev/sda1------------------------------------------------------------------------>
/dev/sda1       /boot           vfat            auto,noatime            1 2

#/dev/sda9------------------------------------------------------------------------->
/dev/sda9       /               xfs             noatime,nodiratime      0 1
#/dev/sda7------------------------------------------------------------------------->
/dev/sda7       /home           xfs             noatime,nodiratime      0 2
#/dev/cdrom             /mnt/cdrom      auto            noauto,ro               0 0


and here is the config for my kernel v4.9.6

https://pastebin.com/UC9GeZjT

I have search and too much readed, but without luck

Any help ist appreciated. Thans in advance
Back to top
View user's profile Send private message
Telemin
l33t
l33t


Joined: 25 Aug 2005
Posts: 734
Location: Glasgow, UK

PostPosted: Tue Jun 06, 2017 3:05 pm    Post subject: Reply with quote

Usually these are symptoms of init not being able to make sense of your fstab to remount things correctly. I suggest that if at all possible you rewrite your fstab to mount by LABEL= / UUID= rather than by path, as if for some reason your disks get enumerated differently on boot (it can happen sometimes due to kernel/udev changes) then everything will break.

Also can you clarify, is this a machine that *was* working until you tried to upgrade the kernel, or is it a new install?

-Telemin-
_________________
The Geek formerly known as -Freestyling-
When you feel your problem has been solved please add [Solved] to the topic title.
Please adopt an unanswered post
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39300
Location: 56N 3W

PostPosted: Tue Jun 06, 2017 3:26 pm    Post subject: Reply with quote

Yczo,

Root is mounted read only to start with. Whet rootfsck has run successfully, its remounted read write.

Root is mounted from the root= statement on the kernel command line, not by reading /etc/fstab.
/etc/fstab itself is on the root filesystem so it can't be read until root is mounted.

There may be some useful information in dmesg but you will need to save it to a file to post it.
You can remount root read/write and save it there but this can be a very bad thing if the reason root is not mouting in because there are uncorrected filesystem errors.
Its safer to mount a usb stick and save the dmesg there, then put it onto a pastebin.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 193

PostPosted: Wed Jun 07, 2017 10:04 am    Post subject: Reply with quote

Thank you Telemin and NeedySeagon,

I have all config files for PARTUUID changed (Yes it is a new install, but after repartitioning an old syteme)

Code:

/dev/sda1: LABEL="ESP" UUID="A841-5975" TYPE="vfat" PARTUUID="e3ca0dc6-382b-4812-1cc6-5b12b46a389d"
/dev/sda3: LABEL="OS" UUID="01D1A59B744BE5A0" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b5f474bc-05b9-4d06-357e-a949bf2da3cd"
/dev/sda4: UUID="B2C0B77CC0B7457F" TYPE="ntfs" PARTUUID="577aa14b-824c-42ac-8670-b9a9cc5a397e"
/dev/sda5: LABEL="WINRETOOLS" UUID="01D1A59B7C0EBE70" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="1ddb3a8e-1fd3-4702-dc4b-e0673f7b7b99"
/dev/sda6: LABEL="Image" UUID="01D1A59BFE45DB80" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="71e299a6-d8b3-48f4-2875-b9e70e6343bf"
/dev/sda7: LABEL="home" UUID="70ef3567-5816-41fa-9647-b4e9ef8f05a4" TYPE="xfs" PARTUUID="988f2191-209e-475b-870c-442f972dabb5"
/dev/sda9: UUID="a6943e82-8de6-45f8-9b26-1779f0a37b8e" TYPE="xfs" PARTLABEL="Linux filesystem" PARTUUID="ceb86975-7012-4518-bdfe-ecda0af79c6c"


here is my new fstab

Code:

tmpfs                   /tmp            tmpfs           size=9000M             0 0
tmpfs                   /var/log        tmpfs           size=200M              0 0
tmpfs                   /var/tmp        tmpfs           size=900M              0 0

#Sin comillas cuando hablamos de codigos PARTUUID o UUID;
#Partuuid identifica particiones GPT, UUID sistemas de ficheros
#/dev/sda1------------------------------------------------------------------------>
PARTUUID=e3ca0dc6-382b-4812-1cc6-5b12b46a389d           /boot           vfat            auto,noatime            1 2     

#/dev/sda7------------------------------------------------------------------------->           
PARTUUID=988f2191-209e-475b-870c-442f972dabb5           /home               xfs             noatime,nodiratime      0 1

#/dev/sda9------------------------------------------------------------------------->
PARTUUID=ceb86975-7012-4518-bdfe-ecda0af79c6c           /           xfs             noatime,nodiratime      0 2
#/dev/cdrom             /mnt/cdrom      auto            noauto,ro               0 0



and my kernel config

Code:

 [*] Built-in kernel command line                                                                                  │ │ 
  │ │                                           (root=PARTUUID=ceb86975-7012-4518-bdfe-ecda0af79c6c rootfstype=xfs) Built-in kernel command string                │ │ 
  │ │                                           [*]   Built-in command line overrides boot loader arguments


and my grub config

Code:

# cat /etc/default/grub
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/files/grub.default-3,v 1.4 2014/10/16 04:04:02 floppym Exp $
#
# To populate all changes in this file you need to regenerate your
# grub configuration file afterwards:
#     'grub2-mkconfig -o /boot/grub/grub.cfg'
#
# See the grub info page for documentation on possible variables and
# their associated values.

GRUB_DISTRIBUTOR="Funtoo"

# Default menu entry
#GRUB_DEFAULT=0

# Boot the default entry this many seconds after the menu is displayed
#GRUB_TIMEOUT=5
#GRUB_TIMEOUT_STYLE=menu

# Append parameters to the linux kernel command line
#Anadir parametros a la interfaz de comandos del kernel

#
# Examples:
#
# Boot with network interface renaming disabled
# GRUB_CMDLINE_LINUX="net.ifnames=0"
#
# Boot with systemd instead of sysvinit (openrc)
#GRUB_CMDLINE_LINUX="video=i915:1366x768-24 init=/usr/lib/systemd/systemd rootfstype=xfs"

# Append parameters to the linux kernel command line for non-recovery entries
#lo que quiere decir pasar parametros al kernel para aquellos no recovery
GRUB_CMDLINE_LINUX_DEFAULT="root=PARTUUID=ceb86975-7012-4518-bdfe-ecda0af79c6c rootfstype=xfs init=/usr/lib/systemd/systemd"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal.
# Note that you can use only modes which your graphic card supports via VBE.
# You can see them in real GRUB with the command `vbeinfo'.

#Ajustar resolución y profundiudad de color del menu grub
GRUB_GFXMODE=1024x768x32

# Set to 'text' to force the Linux kernel to boot in normal text
# mode, 'keep' to preserve the graphics mode set using
# 'GRUB_GFXMODE', 'WIDTHxHEIGHT'['xDEPTH'] to set a particular
# graphics mode, or a sequence of these separated by commas or
# semicolons to try several modes in sequence.

#Mantener resolucion cuando se carga el núcleo
#GRUB_GFXPAYLOAD_LINUX=keep

# Path to theme spec txt file.
# The starfield is by default provided with use truetype.
# NOTE: when enabling custom theme, ensure you have required font/etc.
#GRUB_THEME="/boot/grub/themes/starfield/theme.txt"

# Background image used on graphical terminal.
# Can be in various bitmap formats.
#GRUB_BACKGROUND="/boot/grub/mybackground.png"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to kernel
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY=true



Curiosly, now the kernel don't boot; I obtain the next info:

Code:

Block device PARTUUID=ceb86975-7012-4518-bdfe-ecda0af79c6c is not a valid root device


Should back in /dev/sda9 mode (because boot) and demesg info save?

Thank you very much, Greetings
Back to top
View user's profile Send private message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 193

PostPosted: Thu Jun 08, 2017 9:57 am    Post subject: Reply with quote

hi, after checking that with PARTUUID, don't work, i have tried with UUID, Achieving the same results as with /dev/sdX

root partition "/" mounted like read only, /boot & /home not mounted.

new fstab
Code:

#/dev/sda1------------------------------------------------------------------------>
UUID=A841-5975          /boot           vfat            auto,noatime            1 2     

#/dev/sda7------------------------------------------------------------------------->           
UUID=70ef3567-5816-41fa-9647-b4e9ef8f05a4               /home               xfs             noatime,nodiratime      0 1

#/dev/sda9------------------------------------------------------------------------->
UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e               /           xfs             noatime,nodiratime      0 2



new /etc/default/grub config
Code:

GRUB_CMDLINE_LINUX_DEFAULT="root=UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e rootfstype=xfs init=/usr/lib/systemd/systemd"


new kernel Built in chain

Code:

[*] Built-in kernel command line                                                                                  │ │ 
  │ │                                           (root=UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e rootfstype=xfs) Built-in kernel command string                    │ │ 
  │ │                                           [*]   Built-in command line overrides boot loader arguments


hier is my dmesg output (Thanks in advance)

[url]
https://pastebin.com/gTgdGUYV
[/url]

Greetings
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39300
Location: 56N 3W

PostPosted: Thu Jun 08, 2017 12:40 pm    Post subject: Reply with quote

Moved from Kernel & Hardware to Unsupported Software.

Funtoo is not Gentoo.

Your dmesg shows that sda9 and sda7 are both mounted.

You have things that need firmware built into the kernel but not the firmware itself.
Code:
[    1.533658] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2.


What happened in this 10 sec gap?
Code:
[    3.433371] clocksource: Switched to clocksource tsc
[   13.896167] XFS (sda9): Mounting V5 Filesystem

and this 105 sec gap?
Code:
[   51.424546] hid-generic 0003:046D:C52B.0005: hiddev0,hidraw4: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-1/input2
[   58.973200] random: crng init done
[  156.964450] XFS (sda7): Mounting V5 Filesystem


I seem to recall that Funtoo does not support systemd at all - even for Gnome
Code:
[    0.000000] Command line: BOOT_IMAGE=/vmlinuz-4.9.6-gentoo-r1 root=UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e ro root=UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e rootfstype=xfs init=/usr/lib/systemd/systemd

but you are trying to use it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 193

PostPosted: Thu Jun 08, 2017 2:04 pm    Post subject: Reply with quote

Tank you very much Needy;

Pardon me for the Funtoo; I am gentoo user since 2009/2010. The reason of install funtoo is Qt and QtCreator. In last times I had always horrible dependency problemes from ist Overlay. I have not always understand how to fix. :-(

but, its the gentoo kernel ;-)

hummm a detail, that i had not seen: the kernel in [00] mount like "ro" ..... the question is why and how i can change that xddd, perhaps for systemd???
Code:

[    0.000000] Command line: BOOT_IMAGE=/vmlinuz-4.9.6-gentoo-r1 root=UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e ro root=UUID=a6943e82-8de6-45f8-9b26-1779f0a37b8e rootfstype=xfs init=/usr/lib/systemd/systemd


Greetings
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum