Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with rt73usb
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
kreon28
Apprentice
Apprentice


Joined: 08 Jul 2006
Posts: 165

PostPosted: Sat Aug 29, 2009 8:54 am    Post subject: Problem with rt73usb Reply with quote

Hi,

I've got problem to connect to internet with my wifi card (Realink DWL-G122)
I went confused with all the wiki's, I have found on the net and now I don't know what I should do

my /etc/conf.d/net
Code:

config_wlan0=( "dhcp" )
modules=( "wpa_supplicant" )
wpa_supplicant_eth0="-Dmadwifi"


/etc/wpa_supplicant/wpa_supplicant.conf
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=1
# first network
network={
        ssid="mieszek"
        scan_ssid=1
        psk="****"
        priority=5
}


iwlist scan gives me:
Code:

wlan0     Scan completed :
          Cell 01 - Address: 00:15:E9:E2:8A:FB
                    ESSID:"mieszek"
                    Mode:Master
                    Channel:7
                    Frequency:2.442 GHz (Channel 7)
                    Quality=50/100  Signal level:-56 dBm 
                    Encryption key:on
                    IE: Unknown: 00076D6965737A656B
                    IE: Unknown: 010482848B96
                    IE: Unknown: 030107
                    IE: Unknown: 2A0100
                    IE: Unknown: 32080C1218243048606C
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=0000000a94d04179
                    Extra: Last beacon: 330ms ago
 


but iwconfig wlan0 says:
Code:

wlan0     IEEE 802.11bg  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=0 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

So no ESSID and no Access Point
any clue, [/code]please?
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1779
Location: Scotland

PostPosted: Sat Aug 29, 2009 12:27 pm    Post subject: Reply with quote

You can use the in-kernel driver for rt73usb, and you'll need to change /etc/conf.d/net line to

Code:
wpa_supplicant_eth0="-Dwext"


Which tells wpa_supplicant to use the in-kernel wireless extension.

I've got an rt61pci card myself but the theory is the same, just different kernel module.

EDIT - You'll also need the rt73-firmware ebuild installed.
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum