Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[mise à jour] paquets bloqués (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Mon Aug 24, 2009 5:33 pm    Post subject: [mise à jour] paquets bloqués (résolu) Reply with quote

Bonsoir,

Je cherche à faire une mise à jour (emerge -uDN world) mais j'ai un problème de paquets bloqués, que j'ai supprimés mais qui continuent d'apparaitre dans la liste... Que faire?
Voile le resultat de la commande :
Code:
# emerge -uDN world

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U ] app-arch/cpio-2.9-r2 [2.9-r1]
[ebuild   R   ] sys-devel/patch-2.5.9  USE="(-build%)"
[ebuild   R   ] sys-libs/ncurses-5.6-r2  USE="(-bootstrap%) (-build%)"
[ebuild     U ] net-misc/iputils-20071127 [20070202]
[ebuild  N F  ] dev-java/sun-jce-bin-1.6.0
[ebuild     U ] sys-apps/less-429 [416]
[ebuild     U ] sys-apps/which-2.19 [2.16]
[ebuild  N    ] virtual/pager-0
[ebuild   R   ] x11-libs/cairo-1.8.6-r1  USE="-svg*"
[ebuild     U ] sys-apps/grep-2.5.4-r1 [2.5.1a-r1]
[ebuild     U ] net-misc/wget-1.11.4 [1.10.2]
[ebuild     U ] app-arch/gzip-1.3.12-r1 [1.3.12]
[ebuild     U ] sys-apps/gawk-3.1.6 [3.1.5-r5]
[ebuild     U ] app-arch/tar-1.20 [1.19-r1]
[ebuild     U ] app-editors/nano-2.1.9 [2.0.7] USE="spell*"
[ebuild   R   ] sys-devel/gcc-4.3.2-r3  USE="build*"
[ebuild     U ] app-admin/syslog-ng-2.1.4 [2.0.10] USE="-sql%"
[ebuild     U ] sys-apps/groff-1.20.1-r1 [1.19.2-r1] USE="X* -examples%" LINGUAS="-ja%"
[ebuild     U ] sys-apps/util-linux-2.14.2 [2.13.1.1] USE="(-uclibc)"
[ebuild     U ] sys-process/psmisc-22.6 [22.5-r2] USE="X*"
[ebuild     U ] sys-apps/man-1.6f-r3 [1.6e-r3] USE="-lzma%"
[ebuild  N    ] app-i18n/man-pages-fr-2.39.0
[ebuild  N    ] sys-apps/man-pages-posix-2003a
[ebuild  N    ] sys-apps/man-pages-3.21  USE="nls" LINGUAS="fr -cs -da -de -es -it -ja -nl -pl -ro -ru -zh_CN"
[ebuild   R   ] dev-lang/python-2.6.2-r1  USE="build*"
[ebuild   R   ] dev-java/sun-jdk-1.6.0.15  USE="jce* nsplugin*"
[ebuild   R   ] sys-apps/baselayout-1.12.11.1  USE="build*"
[ebuild     U ] sys-apps/module-init-tools-3.5 [3.4]
[ebuild     U ] sys-fs/udev-141 [115-r1]
[ebuild   R   ] media-sound/sox-14.2.0  USE="png*"
[ebuild   R   ] media-libs/libquicktime-1.1.1  USE="png*"
[ebuild   R   ] sys-kernel/gentoo-sources-2.6.30-r4  USE="build* -symlink*"
[ebuild     U ] sys-apps/busybox-1.13.2 [1.8.2]
[ebuild     U ] sys-apps/shadow-4.1.2.2 [4.0.18.1-r1] USE="-audit%"
[ebuild     U ] net-misc/openssh-5.2_p1-r1 [4.7_p1-r6] USE="X* -pkcs11%"
[ebuild   R   ] app-text/aspell-0.60.6  LINGUAS="fr*"
[ebuild  N    ] app-dicts/aspell-fr-0.60
[ebuild   R   ] dev-lang/perl-5.8.8-r5  USE="build*"
[uninstall    ] dev-perl/Locale-gettext-1.05
[blocks b     ] dev-perl/Locale-gettext ("dev-perl/Locale-gettext" is blocking dev-lang/perl-5.8.8-r5)
[ebuild  N    ] perl-core/Test-Harness-3.10
[ebuild  N    ] perl-core/PodParser-1.35
[ebuild   R   ] media-libs/lcms-1.18-r1  USE="tiff*"
[ebuild   R   ] x11-libs/gtk+-2.14.7-r2  USE="tiff*"
[ebuild     U ] kde-base/kdelibs-3.5.10-r6 [3.5.9-r4] USE="tiff*"
[ebuild   R   ] app-cdr/k3b-1.0.5-r6  LINGUAS="fr*"
[blocks B     ] perl-core/Test-Harness ("perl-core/Test-Harness" is blocking dev-lang/perl-5.8.8-r5)
[blocks B     ] perl-core/PodParser ("perl-core/PodParser" is blocking dev-lang/perl-5.8.8-r5)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') pulled in by
    >=dev-lang/perl-5.8.2-r1 required by ('installed', '/', 'net-im/pidgin-2.5.9', 'nomerge')
    dev-lang/perl required by ('installed', '/', 'dev-perl/XML-SAX-0.16', 'nomerge')
    dev-lang/perl required by ('installed', '/', 'dev-perl/XML-LibXML-Common-0.13', 'nomerge')
    (and 19 more)

  ('ebuild', '/', 'perl-core/Test-Harness-3.10', 'merge') pulled in by
    >=perl-core/Test-Harness-2.56 required by ('installed', '/', 'dev-lang/perl-5.8.8-r5', 'nomerge')

  ('ebuild', '/', 'perl-core/PodParser-1.35', 'merge') pulled in by
    >=perl-core/PodParser-1.32 required by ('installed', '/', 'dev-lang/perl-5.8.8-r5', 'nomerge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Merci beaucoup par avance,

Kevin57

Edit : la simple commande emerge --update fonctionne quant à elle...
Edit 2 : et emerge --update --deep fonctionne aussi... D'où venait le problème alors?


Last edited by Kevin57 on Tue Aug 25, 2009 6:23 pm; edited 2 times in total
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Mon Aug 24, 2009 8:30 pm    Post subject: Reply with quote

Hello, le problème vient du useflag build sur le paquet dev-lang/perl.
Quote:

[ebuild N ] sys-apps/man-pages-posix-2003a
[ebuild N ] sys-apps/man-pages-3.21 USE="nls" LINGUAS="fr -cs -da -de -es -it -ja -nl -pl -ro -ru -zh_CN"
[ebuild R ] dev-lang/python-2.6.2-r1 USE="build*"
[ebuild R ] dev-java/sun-jdk-1.6.0.15 USE="jce* nsplugin*"
[ebuild R ] sys-apps/baselayout-1.12.11.1 USE="build*"
[ebuild U ] sys-apps/module-init-tools-3.5 [3.4]
[ebuild U ] sys-fs/udev-141 [115-r1]
[ebuild R ] media-sound/sox-14.2.0 USE="png*"
[ebuild R ] media-libs/libquicktime-1.1.1 USE="png*"
[ebuild R ] sys-kernel/gentoo-sources-2.6.30-r4 USE="build* -symlink*"
[ebuild U ] sys-apps/busybox-1.13.2 [1.8.2]
[ebuild U ] sys-apps/shadow-4.1.2.2 [4.0.18.1-r1] USE="-audit%"
[ebuild U ] net-misc/openssh-5.2_p1-r1 [4.7_p1-r6] USE="X* -pkcs11%"
[ebuild R ] app-text/aspell-0.60.6 LINGUAS="fr*"
[ebuild N ] app-dicts/aspell-fr-0.60
[ebuild R ] dev-lang/perl-5.8.8-r5 USE="build*"
[uninstall ] dev-perl/Locale-gettext-1.05
[blocks b ] dev-perl/Locale-gettext ("dev-perl/Locale-gettext" is blocking dev-lang/perl-5.8.8-r5)
[ebuild N ] perl-core/Test-Harness-3.10
[ebuild N ] perl-core/PodParser-1.35
[ebuild R ] media-libs/lcms-1.18-r1 USE="tiff*"
[ebuild R ] x11-libs/gtk+-2.14.7-r2 USE="tiff*"
[ebuild U ] kde-base/kdelibs-3.5.10-r6 [3.5.9-r4] USE="tiff*"
[ebuild R ] app-cdr/k3b-1.0.5-r6 LINGUAS="fr*"
[blocks B ] perl-core/Test-Harness ("perl-core/Test-Harness" is blocking dev-lang/perl-5.8.8-r5)
[blocks B ] perl-core/PodParser ("perl-core/PodParser" is blocking dev-lang/perl-5.8.8-r5)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') pulled in by
>=dev-lang/perl-5.8.2-r1 required by ('installed', '/', 'net-im/pidgin-2.5.9', 'nomerge')
dev-lang/perl required by ('installed', '/', 'dev-perl/XML-SAX-0.16', 'nomerge')
dev-lang/perl required by ('installed', '/', 'dev-perl/XML-LibXML-Common-0.13', 'nomerge')
(and 19 more)

('ebuild', '/', 'perl-core/Test-Harness-3.10', 'merge') pulled in by
>=perl-core/Test-Harness-2.56 required by ('installed', '/', 'dev-lang/perl-5.8.8-r5', 'nomerge')

('ebuild', '/', 'perl-core/PodParser-1.35', 'merge') pulled in by
>=perl-core/PodParser-1.32 required by ('installed', '/', 'dev-lang/perl-5.8.8-r5', 'nomerge')

Quote:

$ equery uses perl
[ Searching for packages matching perl... ]
[ Colour Code : set unset ]
[ Legend : Left column (U) - USE flags from make.conf ]
[ : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for dev-lang/perl-5.8.8-r5 ]
U I
+ + berkdb : Adds support for sys-libs/db (Berkeley DB for MySQL)
- - build : !!internal use only!! DO NOT SET THIS FLAG YOURSELF!, used for creating build images and the first half of bootstrapping [make stage1]
- - debug : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml
- - doc : Adds extra documentation (API, Javadoc, etc)
- - elibc_FreeBSD : ELIBC setting for systems that use the FreeBSD C library
+ + gdbm : Adds support for sys-libs/gdbm (GNU database libraries)
- - ithreads : Enable Perl threads, has some compatibility problems
- - perlsuid : Enable Perl SUID install. Has some risks associated.

Sans le --newuse, la compilation de perl ne se refait pas, et le problème n'apparait pas.
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Mon Aug 24, 2009 9:42 pm    Post subject: Reply with quote

Merci pour l'explication. N'y a-t-il pas moyen de s'arranger pour enlever ce useflag? Parce que emerge --update --deep a déjà mis pas mal de choses à jour mais il en reste toujours qui ne l'ont pas été quand je tapes emerge --update --deep --newuse...
Back to top
View user's profile Send private message
philius
n00b
n00b


Joined: 13 Aug 2009
Posts: 61
Location: sur la route, j'arrive !

PostPosted: Tue Aug 25, 2009 12:47 am    Post subject: Reply with quote

Kevin57 wrote:
Merci pour l'explication. N'y a-t-il pas moyen de s'arranger pour enlever ce useflag? Parce que emerge --update --deep a déjà mis pas mal de choses à jour mais il en reste toujours qui ne l'ont pas été quand je tapes emerge --update --deep --newuse...


il semblerait que se soit toi qui est rajouté dans ton /etc/make.conf dans la variable use le flag build
ou alors paquet par paquet dans /etc/portage/package.use

cette flag n'est pas activé par defaut et plusieurs de tes paquets semblent l'avoir

la supprimer tout simplement des fichiers cité plus haut
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Aug 25, 2009 8:12 am    Post subject: Reply with quote

Salut ! Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue Aug 25, 2009 9:57 am    Post subject: Reply with quote

OK merci je jette un oeil à tout ça dès que je rentre chez moi!

geekounet : désolé je n'avais pas vu ce message, je corrige tout de suite!
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue Aug 25, 2009 6:23 pm    Post subject: Reply with quote

Alors je viens de vérifier. En effet, j'avais bien le flag build dans mon USE. Je l'ai donc enlevé et le problème de paquets bloqués disparait. Après un autre problème de flags à régler, tout marche! Merci beaucoup!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum