Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
revdep-rebuild & emul-linux-x86-soundlibs-20080418
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sun Aug 23, 2009 9:01 am    Post subject: revdep-rebuild & emul-linux-x86-soundlibs-20080418 Reply with quote

Ciao. Ogni volta che faccio revdep-rebuild mi ricompila SEMPRE questo pacchetto. Anche se subito dopo rifaccio il revdep. Quindi deduco ci sia qualcosa che non va.. secondo voi cosa potrebbe essere?
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Sun Aug 23, 2009 9:28 am    Post subject: Re: revdep-rebuild & emul-linux-x86-soundlibs-20080418 Reply with quote

lordalbert wrote:
Ciao. Ogni volta che faccio revdep-rebuild mi ricompila SEMPRE questo pacchetto. Anche se subito dopo rifaccio il revdep. Quindi deduco ci sia qualcosa che non va.. secondo voi cosa potrebbe essere?


controlla di aver cancellato i file di revdep prima di lanciarlo, e apparte questo si, è possibile che ci siano dei problemi relativi alle libs: il pacchetto è *effettivamente* richiesto da qualcun altro ?
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sun Aug 23, 2009 2:03 pm    Post subject: Re: revdep-rebuild & emul-linux-x86-soundlibs-20080418 Reply with quote

Peach wrote:
lordalbert wrote:
Ciao. Ogni volta che faccio revdep-rebuild mi ricompila SEMPRE questo pacchetto. Anche se subito dopo rifaccio il revdep. Quindi deduco ci sia qualcosa che non va.. secondo voi cosa potrebbe essere?


controlla di aver cancellato i file di revdep prima di lanciarlo, e apparte questo si, è possibile che ci siano dei problemi relativi alle libs: il pacchetto è *effettivamente* richiesto da qualcun altro ?


non credo siano i file di revdep, perchè a volte ci sono 4-5 pacchetti che ricompila, e alla fine ne rimane solo uno, quel emul-linux-blabla...
Stavo giusto cercando di capire come vedere quale pacchetto lo richiede come dipendenza. ma sono appena tornato dalle ferie e il cervello è spento...
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Wed Sep 02, 2009 9:42 am    Post subject: Re: revdep-rebuild & emul-linux-x86-soundlibs-20080418 Reply with quote

Peach wrote:
lordalbert wrote:
Ciao. Ogni volta che faccio revdep-rebuild mi ricompila SEMPRE questo pacchetto. Anche se subito dopo rifaccio il revdep. Quindi deduco ci sia qualcosa che non va.. secondo voi cosa potrebbe essere?


controlla di aver cancellato i file di revdep prima di lanciarlo, e apparte questo si, è possibile che ci siano dei problemi relativi alle libs: il pacchetto è *effettivamente* richiesto da qualcun altro ?


Si, è richiesto da altri pacchetti:

Code:

# equery depends emul-linux-x86-soundlibs
[ Searching for packages depending on emul-linux-x86-soundlibs... ]
app-emulation/emul-linux-x86-medialibs-20071114 (>=app-emulation/emul-linux-x86-soundlibs-20071114)
app-emulation/emul-linux-x86-sdl-20080316 (>=app-emulation/emul-linux-x86-soundlibs-20071114)
app-emulation/wine-1.1.28 (!win64 & amd64 & X? >=app-emulation/emul-linux-x86-soundlibs-2.1)
www-plugins/adobe-flash-10.0.32.18 (amd64 & multilib & 32bit? app-emulation/emul-linux-x86-soundlibs)


e quindi non lo posso cancellare. Però continua a ripresentarsi ad ogni revdep-rebuild
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Wed Sep 02, 2009 10:58 am    Post subject: Reply with quote

allora controlla che i file incriminati siano effettivamente appartenenti al pacchetto (qfile -o <nomefile>). e' possibile che siano dei refusi di versioni precedenti.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Wed Sep 02, 2009 11:21 am    Post subject: Reply with quote

allora.. l'output di revdep-rebuild è

Code:
 [ 27% ]  *   broken /usr/kde/3.5/lib32/libqtmcop.so.1.0.0 (requires libqt-mt.so.3)



ho provato con qfile ma...

Code:

# qfile -o /usr/kde/3.5/lib32/libqtmcop.so.1.0.0
#
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum