Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fluxbox: cpu-usage 90-100% audacious2, opera,... [SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 20 Aug 2009
Posts: 4

PostPosted: Thu Aug 20, 2009 2:33 pm    Post subject: fluxbox: cpu-usage 90-100% audacious2, opera,... [SOLVED] Reply with quote

I have trouble to find out why these applications causes such a high cpu-usage in the case these applications just running and I do not do anything. This means for example that I had just started audacious2 and without even playing a music-file the cpu-usage is between 90-100% These are the "bad" applications.

soffice.bin > 90 %
audacious2 > 90 %
opera > 90 %
thunderbird-bin > 90 %

Other applications does not causes such a high CPU usage in this case, e.g:
mousepad < 1 %
abiword < 1 %
gnumeric < 1%
lynx < 1 %
mp3blaster < 1 %

These are the ways I tried to figure out that cpu-usage-problem: strace, ltrace, dstat, google.

Hardware: Pentium III (old ibm A20m) 700 MHz Coppermine

Any Ideas are welcome. If you need more information I will provide them.

As follows you will find the package-settings of audacious (high cpu usage) and abiword (low-cpu-usage) and then the System Settings. (emerge --info audacious/ abiword)
Package Settings audacious2

media-sound/audacious-2.1 was built with the following:
USE="nls session (-altivec) -chardet -libsamplerate -sse2"

Package Settings abiword

app-office/abiword-2.6.4 was built with the following:
USE="spell xml -debug -gnome"

System Settings
System uname: Linux-2.6.30-gentoo-r4-i686-Pentium_III_-Coppermine-with-glibc2.0
Timestamp of tree: Thu, 20 Aug 2009 08:45:02 +0000
ccache version 2.4 [enabled]
app-shells/bash: 3.2_p39
dev-lang/python: 2.5.4-r3
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache: 2.4-r7
sys-apps/sandbox: 1.6-r2
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils: 2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 1.5.26
virtual/os-headers: 2.6.27-r2
CFLAGS="-O2 -march=pentium3m -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium3m -pipe"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo capslib cdr cli cracklib crypt cups dbus dga dri dts dvd dvdr eds emboss encode esd evo fam firefox flac gdbm gif gpm gstreamer gtk hal iconv isdnlog jpeg libnotify mad mikmod mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection sdl sdl-sound session spell spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis win32codecs x264 x86 xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="r128 fbdev mach64 vesa"

Last edited by lowperf on Thu Aug 27, 2009 12:00 pm; edited 2 times in total
Back to top
View user's profile Send private message

Joined: 06 Jul 2005
Posts: 6319
Location: /usr/lib64/lv2

PostPosted: Fri Aug 21, 2009 10:55 pm    Post subject: Reply with quote

Well, first of all, you do have an old machine. I assume you're running recent versions of these programs, which are not designed to run with a small footprint on fairly old machines.

Second, the programs you mentioned having a heavy CPU load, keeping the above point in mind, ARE heavy-duty programs. So of course your CPU load is going to get eaten up by these programs. By contrast, the programs you mentioned as having a light CPU footprint ARE light programs designed to do very simple things, as opposed to office, Opera and Thunderbird which are multi-purpose programs designed to do a whole bunch of things.

I don't think there's a lot you can do, compile-wise. But you may be able to edit some config files for these programs to force them not to use as many of their options when running, which would make them lighter on your system. I wouldn't know what to edit for these particular programs, though.

Hopefully someone else will chime in to provide some more advice - but keep in mind the older your machine, the faster the CPU will get eaten and there's little you can do about it except run really old programs or find comparable programs designed to be less CPU-intensive.
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message

Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Sat Aug 22, 2009 7:55 pm    Post subject: Reply with quote

Its not the CPU, 700mhz coppermine shouldn't be at 90% simply running any of those applications..... Especially not opera, thunderbird or audacious doing not playing a file. I have no input on why but its not normal.
This message self destructed a long time ago.
Back to top
View user's profile Send private message

Joined: 20 Aug 2009
Posts: 4

PostPosted: Wed Aug 26, 2009 4:36 pm    Post subject: Reply with quote

Thatnks for the replies. This issue is solved now. I think the problem was graphic-driver/xorg-1.5 related. It was not easy for me to solve the problem, so I would like provide some information for people with the same problem that the graphic-card ATI RAGE MOBILITY is not supported.

As follows the downgrades/upgrades I had performed:

sys-kernel/gentoo 2.6.30 > 2.6.25-r9
x11-base/xorg-server-1.5.3-r6 > #unmerge libpciaccess before emerge xorg-server
x11-base/x11-drm-20090320 > 20070314
not installed > x11-drivers/xf86-input-keyboard-1.1.1
not installed > xf86-input-mouse-1.4.0
media-libs/mesa-7.3-r1 > mesa-6.5.2-r1
x11-drivers/xf86-video-mach64-6.8.0 > x11-drivers/xf86-video-mach64-6.8.2

Next the contents of package.mask and package.unmask for performing the downgrades:

Content of /etc/portage/package.mask

Content of /etc/portage/package.unmask

Then I had emerged all the packages with the commands "emerge gentoo-sources", "emerge xorg-server", etc...

The reason why I had chosen that way follows now:
"eselect news read 2009-07-12-xorg-74-alpha" gives information that not all graphic-cards are supported for xorg-server-1.5.3. This seems to fit to my ATI Rage Mobility card. Compiling the mach64-driver and using it in /etc/X11/xorg.conf ends up in kernel panic with kernel 2.6.29/30. This news item gives also information that xorg-server-1.5 needs kernel 2.6.29/30. That's why I think I was forced to use xorg-server 1.3 or 1.4 with kernel <2.6.29 (I have just chosen 2.6.25) and all the other packages like mesa-6.5.2-r1,...

Information why my way will not work in future possibly follows now...

While I had just the following content in /etc/portage/package.mask and /etc/portage/package.unmask I got the following message with the command "emerge -p xorg-server"...
Content of package.mask:

Content of package.unmask:

Message of "emerge -p xorg-server":

Calculating dependencies...

!!! All ebuilds that could satisfy "x11-base/xorg-server" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-base/xorg-server-1.6.3 (masked by: ~x86 keyword)
- x11-base/xorg-server- (masked by: ~x86 keyword)
- x11-base/xorg-server-1.5.3-r7 (masked by: ~x86 keyword)
- x11-base/xorg-server-1.5.3-r6 (masked by: package.mask)
- x11-base/xorg-server-1.4.2 (masked by: package.mask, ~x86 keyword)
# Rémi Cardona <> (06 Aug 2009)
# Big Xorg 1.3/1.4 mask. Masked for removal Real Soon Now (tm)
# xf86-input-evtouch going out completely, switch to evdev
- x11-base/xorg-server- (masked by: package.mask)

The highlightened line of that message let me conclude that an old notebook like mine needs to live with such limitations that some applications need more than 90 % and that 2D/3D-acceleration does not work because xorg-server 1.3/1.4 will be removed soon.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum