Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installazione kde 3.5 problema emerge kopete [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Tue Aug 11, 2009 4:50 pm    Post subject: Installazione kde 3.5 problema emerge kopete [risolto] Reply with quote

Come da titolo sto incontrando un'errore durante l'installazione del pacchetto relativo a kopete.
Ho letto e riletto il log, ma non riesco a capire quale sia effettivamente il problema (forse il kernel...uno dei primi che configuro a mano).
Qui dentro non posso incollarlo, wgetpaste mi restituisce un'errore...
Una situazione disperata!
Code:
ERROR: kde-base/kopete-3.5.10-r4 failed.
Call stack:
ebuild.sh, line 49: Called src_compile
environment, line 4485: Called kde_src_compile
environment, line 3245: Called kde_src_compile 'all'


Cosa posso postare per dare una mano ad aiutarmi?


Last edited by mrl4n on Wed Aug 12, 2009 6:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Tue Aug 11, 2009 5:58 pm    Post subject: Reply with quote

Non ho parole.
Ma non ti vergogni a impestare il forum con certe oscenità?

Ma dico io, hai mai letto almeno 1 volta le linee guida del forum???
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Tue Aug 11, 2009 10:56 pm    Post subject: Re: Installazione kde 3.5 problema emerge kopete Reply with quote

mrl4n wrote:
Come da titolo sto incontrando un'errore durante l'installazione del pacchetto relativo a kopete.

Cosa posso postare per dare una mano ad aiutarmi?

puoi postare semplicemente le ultime 20/30 righe che appaiono quando sovviene l'errore con kopete. Le poche righe da te evidenziate sono un po' scarse...

Inoltre l'output di
Code:
emerge --info
può esser d'aiuto

E no, in questo caso non centra nulla il kernel.
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Wed Aug 12, 2009 1:49 pm    Post subject: Re: Installazione kde 3.5 problema emerge kopete Reply with quote

mrl4n wrote:
...
Qui dentro non posso incollarlo, wgetpaste mi restituisce un'errore...
Una situazione disperata!
...


Giusto per capire (e anche un po' per saziare la mia curiosità), cosa vuol dire che non puoi incollarlo qui dentro? Non ti serve wgetpaste.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Wed Aug 12, 2009 3:42 pm    Post subject: Reply with quote

Code:
emerge --info
E' visibile qui.
Quello che sono riuscito a recuperare del messaggio d'errore invece è visibile qui

Il log è forse troppo grande e non trovo il sistema per incollarlo da nessuna parte...
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Wed Aug 12, 2009 4:19 pm    Post subject: Reply with quote

Continuo a non capire, posso sapere il motivo per cui non puoi postare qui dentro gli errori ?

Perche stai usando un servizio esterno come dpaste.com per i log e quant'altro ???

Chiariamo una cosa, il forum gentoo non è il tuo consulente personale per i tuoi problemi, è il forum di una comunità!!!!

Se usi servizi esterni al forum per riportare errori, log e altro materiale utile alla comprensione e/o risoluzione del problema, il thread diventa utile soltanto a te (e questo va contro i principi del forum che vogliono thread utili all'intera comunità).

Se tra 1 mese i tuoi bellissimi link (dpaste.com & company) vanno a puttane, mi dici come faranno gli utenti futuri a trarre giovamento da questa discussione (visto che non possono capire se il loro problema è inerente o meno)??? Per non parlare della ricerca sul forum, ovviamente il materiale che posti esternamente non è indicizzato. Ora ci mancherebbe altro che magari qualcuno posta la soluzione stessa su dpaste.com cosi siamo sicuri all 100% di fottere gli utenti futuri.

Sono stato abbastanza chiaro o c'è qualche punto oscuro? Perché se è cosi basta dirlo.

Tornando al problema:

Allora l'errore di compilazione è ancora troppo corto. Inizia con
Code:

.libs/avdeviceconfig.o: In function `AVDeviceConfig::~AVDeviceConfig()':
avdeviceconfig.cpp:(.text+0xb01): undefined reference to `QGLWidget::~QGLWidget(
)'

Quel undefined reference puo essere causato da un header o un file incluso mancante (magari un po' piu riportato sopra), anche un errore nel makefile (ma dubito visto che dovrebbe essere software ultra testato).

P.s. sei sicuro di avere la flag opengl sulle qt3 ??? E poi non abbiamo(non conosciamo) la tua versione delle qt.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Wed Aug 12, 2009 4:25 pm    Post subject: Reply with quote

Ah ecco il problema, come pensavo è la flag opengl.

C'è un bug aperto su bugs.gentoo.org, precisamente qui https://bugs.gentoo.org/show_bug.cgi?id=274047 e precisamente il commento numero 8 spiega la soluzione.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Wed Aug 12, 2009 4:28 pm    Post subject: Reply with quote

Non posso postare qui dentro gli errori, perchè non mi incolla il testo all'interno della finestra di edit del post.
Ti ringrazio per le indicazioni, so benissimo che il forum è una comunità, quindi cerchiamo di usare un linguaggio appropriato!!
Se hai qualche problema possiamo risolvere la cosa in privato, evitiamo di usare spazi comuni per perdite di tempo utili a nessuno.

P.S. non avevo fin'ora pensato ad usare anche bugzilla come riferimento per risolvere i problemi, grazie per il suggerimento... :wink:
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Wed Aug 12, 2009 5:05 pm    Post subject: Reply with quote

Codice di errore:
Code:

.libs/avdeviceconfig.o: In function `AVDeviceConfig::~AVDeviceConfig()':
avdeviceconfig.cpp:(.text+0xb01): undefined reference to `QGLWidget::~QGLWidget(
)'
.libs/avdeviceconfig.o: In function `AVDeviceConfig::AVDeviceConfig(QWidget*, ch
ar const*, QStringList const&)':
avdeviceconfig.cpp:(.text+0xc96): undefined reference to `QGLWidget::QGLWidget(Q
Widget*, char const*, QGLWidget const*, unsigned int)'
.libs/avdeviceconfig.o: In function `AVDeviceConfig::AVDeviceConfig(QWidget*, ch
ar const*, QStringList const&)':
avdeviceconfig.cpp:(.text+0x1156): undefined reference to `QGLWidget::QGLWidget(
QWidget*, char const*, QGLWidget const*, unsigned int)'
collect2: ld returned 1 exit status
make[5]: *** [kcm_kopete_avdeviceconfig.la] Error 1
make[5]: Leaving directory `/var/tmp/portage/kde-base/kopete-3.5.10-r4/work/kope
te-3.5.10/kopete/kopete/config/avdevice'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/kde-base/kopete-3.5.10-r4/work/kope
te-3.5.10/kopete/kopete/config'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/kde-base/kopete-3.5.10-r4/work/kope
te-3.5.10/kopete/kopete'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kde-base/kopete-3.5.10-r4/work/kope
te-3.5.10/kopete'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kde-base/kopete-3.5.10-r4/work/kope
te-3.5.10'
make: *** [all] Error 2
 *
 * ERROR: kde-base/kopete-3.5.10-r4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 4485:  Called kde_src_compile
 *             environment, line 3245:  Called kde_src_compile 'all'
 *             environment, line 3260:  Called kde_src_compile 'make'
 *             environment, line 3252:  Called die
 * The specific snippet of code:
 *                   emake || die "died running emake, $FUNCNAME:make"
 *  The die message:
 *   died running emake, kde_src_compile:make
 *
 * If you need support, post the topmost build error, and the call stack if rele
vant.
 * A complete build log is located at '/var/tmp/portage/kde-base/kopete-3.5.10-r
4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kopete-3
.5.10-r4/temp/environment'.
 *

>>> Failed to emerge kde-base/kopete-3.5.10-r4, Log file:

>>>  '/var/tmp/portage/kde-base/kopete-3.5.10-r4/temp/build.log'

 * Messages for package kde-base/kopete-3.5.10-r4:

 *
 * ERROR: kde-base/kopete-3.5.10-r4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 4485:  Called kde_src_compile
 *             environment, line 3245:  Called kde_src_compile 'all'
 *             environment, line 3260:  Called kde_src_compile 'make'
 *             environment, line 3252:  Called die
 * The specific snippet of code:
 *                   emake || die "died running emake, $FUNCNAME:make"
 *  The die message:
 *   died running emake, kde_src_compile:make



emerge --info
Code:

Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r4-i686-Intel-R-_Core-TM-2_CPU_6400_@_2.13GHz-with-glibc2.0
Timestamp of tree: Sun, 09 Aug 2009 14:30:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.4-r3
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.inode.at/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl alsa berkdb bzip2 cdr cli cracklib crypt cups dri dvd fortran gdbm gpm gtk hal iconv ipv6 isdnlog kde mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python qt3 qt4 readline reflection session spl ssl svg sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Nessun problema personale. Il fatto che tu creda che post di questo tipo siano perdite di tempo non mi trova d'accordo sulla faccenda, il fatto che le soluzioni ci siano ma vengono perse è un problema importante.

Non c'è cosa piu irritante che trovare la soluzione, sapere che c'è, ma non poter accederci perche il link è scaduto o altro. Non è forse un dramma per problemi del tipo che hai postato tu, visto che c'è una copia della soluzione in bugs.gentoo.org, ma se la soluzione non fosse cosi nota e il problema piu raro...

Questa discussione, ripeto, ci porta su un problema importante e siccome non sei il primo che ha usato dpaste & company per "postare informazioni", mi chiedo se è il caso di contattare qualche moderatore per esplicitare un po' meglio questa cosa sulle linee guida o quantomeno prendere una posizione/decisione ufficiale in merito.

Aspettiamo che passi di qui un moderatore e sentiamo il suo parere.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Aug 14, 2009 6:47 pm    Post subject: Reply with quote

Sono d'accordo sul fatto che non c'è cosa più brutta che cercare una soluzione ad un problema, trovarla e non poterci accedere per un messaggio del tipo "Impossibile visualizzare la pagina"...
Ho utilizzato dpaste perchè da shell di X non avevo modo di incollare i risultati dei comandi e il log, ho letto e conosco le linee guida del forum sono d'accordo e cerco nel limite del possibile di rispettarle sempre.
Grazie di nuovo per l'aiuto.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum