Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Abilitare syslog
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue Aug 11, 2009 8:30 am    Post subject: [RISOLTO] Abilitare syslog Reply with quote

Salve, vorrei abilitare un log che mi scriva in /var/log/messages dal momento che questo file non esiste.
Ho provato a installare syslog con un emerge, ho dato un'occhiata anche qui:
http://www.gentoo.org/doc/it/security/security-handbook.xml?part=1&chap=3&style=printable

Alla fine se lancio syslogd a manina da shell allora parte e inizia a scrivere in /var/log/messages ma io ho bisogno che parta da solo al boot quindi ho fatto quanto segue perchè nell'ignoranza piu' totale non sapevo che fare, e ovviamente avro' sbagliato qualcosa.

In /etc/init.d/ non c'era niente e quindi ho trovato con un locate syslogd che sta in /usr/sbin/ quindi ho fatto
Code:
ln -s /usr/sbin/syslogd /etc/init.d/


quindi ho aggiunto il file all'avvio, poi in realtà ho provato anche in default anzichè boot ma credo sia boot il posto piu' indicato
Code:
# rc-update add syslogd boot


Ad ogni modo all'avvio vedo che mi esce un messaggio:
Code:
usage: syslogd [-drvh] [-l hostlist] [-m markinterval] [-n] [-p path]
 [-s domainlist] [-f conffile] [-i IP address] [-u username]


Se mi aiutate vi ringrazio, ho bisogno di avere un logo che devo vedere un paio di cose all'avvio :)


Last edited by lsegalla on Wed Aug 12, 2009 11:52 am; edited 1 time in total
Back to top
View user's profile Send private message
IlGab
Guru
Guru


Joined: 26 Nov 2004
Posts: 486

PostPosted: Tue Aug 11, 2009 8:39 am    Post subject: Reply with quote

In /etc/init.d vanno gli script di avvio, con il link simbolico che hai fatto ci hai messo il binario di syslogd.
Mi pare molto strano che emergendo syslog non ti abbia installato lo script, sei sicuro che quello che hai in /usr/bin non sia il link a busybox ?

Fai una bella cosa, rimuovi il link che hai creato in /etc/init.d, poi emergi sysklogd o syslog-ng e vedrai che ti installa anche lo script di avvio.
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue Aug 11, 2009 9:54 am    Post subject: Reply with quote

Fatto, era necessario emergere syslog-ng, senza di quello non arrivavo da nessuna parte.
Già che ci siamo ti chiedo una ultimissima cosa: durante il boot vedo degli errori (ad esempio che non è possibile rimuovere dei files temporanei, ci son dei problemi di permessi sembrerebbe), in /var/log/messages non vedo niente a riguardo

Dove trovo il log della sequenza di boot?
Vorrei analizzare ed eventualmente copia-incollare quegli errori...
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Tue Aug 11, 2009 10:02 am    Post subject: Reply with quote

In fase di installazione c'è una pagina dedicata :
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=9#doc_chap1
è possibile che il problema sia che il logger forse non deve partire al runlevel boot ma a quello default
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue Aug 11, 2009 10:09 am    Post subject: Reply with quote

Alcune domande:
1. Il logger parte già dal runlevel default in questo momento, forse devo metterlo in boot ?
2. è indifferente usare syslog-ng o sysklogd ?
3. è importante avere logrotate installato o per questa fase me ne frega gran poco ?

Quello che spiega la guida è esattamente cio' che ho fatto prima comunque, e non riesco a vedere quei messaggi d'errore che citavo sopra.
Per il momento resto fermo a quello che dice la guida, in attesa di risposte....

PS - il problema che ho al boot è subito dopo la dicitura wiping /tmp directory e poi iniziano gli errorini di vari ACCESS DENIED
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Tue Aug 11, 2009 8:39 pm    Post subject: Reply with quote

lsegalla wrote:
Alcune domande:
1. Il logger parte già dal runlevel default in questo momento, forse devo metterlo in boot ?

prova, non dovrebbe morire nessuno :wink:
Quote:

2. è indifferente usare syslog-ng o sysklogd ?

sono due sw diversi quindi non è proprio la stessa cosa, soprattutto a livello di configurazione io preferisco syslog-ng ma per un blando controllo di un desktop c'è poca differenza
Quote:

3. è importante avere logrotate installato o per questa fase me ne frega gran poco ?

secondo me è importante mettertelo o rischi di dimenticartelo, tanto in 5 secondi lo installi e la configurazione di default dovrebbe andarti bene (e ci metti 5 secondi a personalizzarla)
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
IlGab
Guru
Guru


Joined: 26 Nov 2004
Posts: 486

PostPosted: Tue Aug 11, 2009 9:51 pm    Post subject: Reply with quote

Io syslog-ng ce l'ho in default e non ho problemi.

Per i file temporanei controlla cos'hai in tmp o nelle directory indicate, ed eventualmente eliminali tu (se non servono :) )
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Aug 12, 2009 7:16 am    Post subject: Reply with quote

Ho installato logrotate (che non so usare) e da me gira ora in boot syslog-ng; continua a verificarsi al boot quell'errore della /tmp directory che già ho provato a piallare via da dentro /tmp con un
Code:
rm -Rf *.*


continuo a non vedere nulla nei log e continua a uscire sto errore, se volete faccio una foto e vi faccio vedere perchè comincia a esser fastidioso veder sta cosa che magari è indice di qualche altro problema...

-- EDIT --
Ecco la foto, gioco d'anticipo
http://www.bernaparkhotel.it/uploads/linux/err_boot.jpg
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Aug 12, 2009 8:28 am    Post subject: Reply with quote

quei file sono di proprietà di "root" e, probabilmente, tu usi il comando di cancellazione come "user"! Se vuoi cancellarli devi lanciare lo script (o il comando) come "su" oppure "sudo"!
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Aug 12, 2009 9:10 am    Post subject: Reply with quote

Tigerwalk wrote:
quei file sono di proprietà di "root" e, probabilmente, tu usi il comando di cancellazione come "user"! Se vuoi cancellarli devi lanciare lo script (o il comando) come "su" oppure "sudo"!

negativo, sempre fatto tutto da root
fra l'altro se faccio un locate quei files non li trovo nell'hard disk
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Aug 12, 2009 9:43 am    Post subject: Reply with quote

lsegalla wrote:
fra l'altro se faccio un locate quei files non li trovo nell'hard disk

questo spiega perchè non riesce a cancellarli ma non spiega l'errore, se il file non esiste dovrebbe darti un "no such file or directory"

adesso non riesco ad accedere alla mia gentoo box ma dovrebbe esserci un qualche servizio (prova a cercare in local.start) che si occupa di cercare di ripulire /tmp (magari tmpwatch) ed evidentemente fa qualche casino ...

Prova a dare un'occhiata :wink:
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Aug 12, 2009 10:19 am    Post subject: Reply with quote

una cosa interessante, mi esce lo stesso problema su un altro file...
https://forums.gentoo.org/viewtopic-p-5929762.html#5929762

potrebbe essere un disco sputtanato ?
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Aug 12, 2009 11:52 am    Post subject: Reply with quote

Confermo, casualmente due minuti dopo che ho scritto mi son andate giu' le batterie e il sistema riavviandosi ha fatto un check trovando degli errori che non riusciva a risolvere (mentre qualcos'altro ha risolto invece).

Sono entrato in shell e ho fatto il check della parte reiserfs (/dev/sda3) con l'opzione --rebuild-tree
Ora gli errori al boot non ci sono piu'

Relativamente al mio post precedente invece il revdep-rebuild ora me lo porta al termine... forse mi tengo ancora il problema di akregator...[/code]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum