Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge: there are no ebuilds built with USE flags to satisfy
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fonzie_ITA
n00b
n00b


Joined: 26 Apr 2009
Posts: 4

PostPosted: Mon Aug 03, 2009 8:52 am    Post subject: emerge: there are no ebuilds built with USE flags to satisfy Reply with quote

Ciao,
ho questo problema:

Code:

# emerge -avDu world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/cairo-1.4.6[svg]".
!!! One of the following packages is required to complete your request:
- x11-libs/cairo-1.8.6-r1 (Change USE: +svg)
(dependency required by "net-analyzer/rrdtool-1.3.8" [ebuild])
(dependency required by "sys-apps/lm_sensors-2.10.7" [installed])
(dependency required by "world" [argument])


Qualcuno mi puo' spiegare ?
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Aug 03, 2009 9:02 am    Post subject: Reply with quote

Devi attivare la flag USE "svg" per l'ebuild x11-libs/cairo.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
fonzie_ITA
n00b
n00b


Joined: 26 Apr 2009
Posts: 4

PostPosted: Mon Aug 03, 2009 9:03 am    Post subject: Reply with quote

ma perchè ?
prima non me lo chiedeva ......
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Aug 03, 2009 9:31 am    Post subject: Reply with quote

fonzie_ITA wrote:
ma perchè ?
prima non me lo chiedeva ......

Perchè lo richiede net-analyzer/rrdtool-1.3.8:
Code:

...
RDEPEND="
...   >=x11-libs/cairo-1.4.6[svg]
...

Prima non te lo chiedeva perchè (suppongo) avevi installato una versione precedente che non conteneva tale restrizione.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum