Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problema spegnimento dopo aggiornamento kernel
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Fri Jul 24, 2009 2:54 pm    Post subject: [RISOLTO] Problema spegnimento dopo aggiornamento kernel Reply with quote

Dopo l'aggiornamento del kernel da 2.6.28-r5 al 2.6.29-r5 la mia macchina non si spegne piu' correttamente.
Si blocca sempre durante l'unload dei moduli alsa... non riesco a capire perchè
se torno al vecchio kernel tutto funziona regolarmente e quindi per ora lavoro lì...

(uso genkernel, ho provato anche col menuconfig ma il risultato è sempre quello)


Last edited by lsegalla on Mon Aug 10, 2009 9:50 am; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Jul 24, 2009 4:13 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-771098-highlight-.html
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Sat Jul 25, 2009 9:20 am    Post subject: Reply with quote

Ache io ho avuto lo stesso problema!
Pero l'ho risolto applicando la patch che ho trovato in questo sito, per applicare la patch ho fatto :
Code:

sudo patch -b alsasound -l /home/giuseppe/alsasound.patch


Il problema di smontare i moduli l'ho risolto, ma il pc non si spegne corretamente perchè si blocca in un punto dicendomi questo :
Code:

* Remounting remaining filesystems read-only...
* Remounting / read only...
INIT: no more processes left in this runlevel.


Non mi segnala nessun errore! Penso che non sia piu dovuto al bug di alsasound...
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Jul 25, 2009 10:39 am    Post subject: Reply with quote

Pes88 wrote:
questo sito

Code:

*             environment, line 2532:  Called die
  * The specific snippet of code:
  *               missing link


:P
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
uoslagelo
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jul 2009
Posts: 81

PostPosted: Sat Jul 25, 2009 10:51 am    Post subject: Reply with quote

io ho risolto impostando UNLOAD_ON_STOP="no"
in /etc/conf.d/alsasound
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Sat Jul 25, 2009 11:03 am    Post subject: Reply with quote

Non ho capito il post che ha fatto cloc3, forse questo sito è unh po ambiguo intedevo www.gentoo.org nella sezione dei bug!

Quote:

Codice:

* environment, line 2532: Called die
* The specific snippet of code:
* missing link

:?: :?: :?: :?:
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Aug 10, 2009 9:50 am    Post subject: Reply with quote

Ho risolto anche io mettendo le mani in /etc/conf.d/alsasound
Ma in teoria se io avessi aspettato un kernel successivo avrei potuto risolvere la cosa o in genere quando si verifica un problema di questo tipo ce lo si porta avanti anche nelle versioni di kernel successive ?
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Mon Aug 10, 2009 10:50 am    Post subject: Reply with quote

Io credo di no! Perchè poi ho avuto un mare di altri problemi ho dovuto formatare e sono passato al kenel 2.6.29.r4\ e il problema di alsasound non si è presentato...
Quindi penso che il problema di alsa nelle versioni recenti del kernel sia risolto..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum