Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xfree no coincide el digest
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
kabutor
l33t
l33t


Joined: 12 Dec 2002
Posts: 821
Location: Benalmadena - Melrose Place

PostPosted: Tue Aug 26, 2003 2:40 pm    Post subject: Xfree no coincide el digest Reply with quote

Vaya dia hoy, emerge -up world ayer por la noche en la maquina del trabajo, y esta mañana me he encontrado con el error (gtk+ pango xft libgnomecanvas) q a alguno le sonara, la solucion parece q pasa por recompilar Xfree, pero cuando lo intento:

Code:
!!! File is corrupt or incomplete. (Digests do not match)
>>> our recorded digest: 567903747018f2534965ab6cb3976b38
>>>  your file's digest: f83e238a4d4e94ff6a760b5d7608ecff
!!! File does not exist: /usr/portage/distfiles//X430src-4.tgz


Estoy probando cambiando el mirror con mirrorselect a ver.. :(
(q por cierto mirrorselect -a me dice q no puede seleccionar ningun mirror)

A alguien se le ocurre algo?

Sera un fallo de hardware?
Back to top
View user's profile Send private message
Eleazar Anzola
Veteran
Veteran


Joined: 17 Jul 2003
Posts: 1282
Location: Caracas / Venezuela

PostPosted: Tue Aug 26, 2003 5:20 pm    Post subject: Reply with quote

Tu problema es que se han actualizado los Digests de tus archivos pero los tar.bz2 no :D
busca dentro de:

/usr/portage/distfiles

borra los archivos que te estan ocasionando el problema como por ejemplo X430src-1.tgz X430src-2.tgz X430src-3.tgz y X430src-4.tgz y vuelve a emerger, con esto me parece solucionas tu problema.

Si no funciona vuelve a un
emerge rsync
emerge world

borra los archivos de /usr/portage/distfiles que te dan problemas y emerge otra vez a esos archivos.

Espero te sirva de algo

Salu2
Eleazr Anzola
Back to top
View user's profile Send private message
kabutor
l33t
l33t


Joined: 12 Dec 2002
Posts: 821
Location: Benalmadena - Melrose Place

PostPosted: Tue Aug 26, 2003 8:09 pm    Post subject: Reply with quote

Pues al final lo arregle cambiando de mirror y haciendo un rsync otra vez.

Lo q pasa es q tras emerger xfree otra vez no me arreglo mi problema...

Es mas, me equivoque y borre /var/db/portage y ahora me temo q he perdido todo lo q estaba instalado en cuanto a la base de datos de portage (ouch) :(

Mas q nada pq hago un emerge -p gkt+ y son 55 los paquetes a instalar...

Y es q hay dias q mejor no tocar nada...
Back to top
View user's profile Send private message
Javier Lopez
Guru
Guru


Joined: 13 Sep 2002
Posts: 377
Location: Barcelona

PostPosted: Tue Aug 26, 2003 8:47 pm    Post subject: Reply with quote

Si tienes instaladas las gentoolkit prueba a ver si esto te reconstruye el portage:

Code:
rm /var/cache/edb/world
qpkg -I -nc > /var/cache/edb/world


Si no las tienes instaladas, prueba:
Code:
regenworld
Back to top
View user's profile Send private message
kabutor
l33t
l33t


Joined: 12 Dec 2002
Posts: 821
Location: Benalmadena - Melrose Place

PostPosted: Wed Aug 27, 2003 12:06 am    Post subject: Reply with quote

Nada, oh dios mio!

A reinstalar todo :( :( :( :cry:

(emerge gnome evolution) para empezar a abrir boca.. menos mal q el sistema aun funciona...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum