Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X server dice che i plugin sono di altre versioni...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Giepi
Apprentice
Apprentice


Joined: 29 Sep 2004
Posts: 164
Location: Non pallo, io!

PostPosted: Sun Jul 05, 2009 12:58 pm    Post subject: X server dice che i plugin sono di altre versioni... Reply with quote

Ho aggiornato un po' di tempo fa il sistema e da allora X non va più. Posto solo ora che sono stato impegnato a fare esami, vabbeh...

So' che la risposta dovrebbe essere "riemergi allora il plugin..." solo che io ho riemerso un paio di volte * prima e dopo un ulteriore aggiornamento di X * atidrivers ma con la stessa risposta :( incollo Xorg.0.log e chiedo lumi... non posso aggiornare incondizionatamente a buffo perchè senza X non va networkmanager... e per connettermi via cavo devo togliere a tutti la connessione wifi, ma farò ovviamente il possibile per fare tornare vivo X (magari nottetempo)

Aspetto speranzoso e Grazie in anticipo!

Code:
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.6.1.901 (1.6.2 RC 1)
Release Date: 2009-5-8
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.25-gentoo-r7 i686
Current Operating System: Linux ethelsith 2.6.25-gentoo-r7 #5 SMP PREEMPT Sat Mar 28 11:27:56 CET 2009 i686
Build Date: 25 June 2009  12:12:00PM
 
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun 25 16:48:18 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Main Layout"
(**) |-->Screen "aticonfig-Screen[0]" (0)
(**) |   |-->Monitor "aticonfig-Monitor[0]"
(**) |   |-->Device "aticonfig-Device[0]"
(**) |-->Input Device "Synaptic"
(**) |-->Input Device "Mouse"
(**) |-->Input Device "Keyboard1"
(**) Option "BlankTime" "10"
(**) Option "StandbyTime" "20"
(**) Option "SuspendTime" "30"
(**) Option "OffTime" "60"
(**) Option "AIGLX" "true"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/local" does not exist.
   Entry deleted from font path.
(**) FontPath set to:
   /usr/share/fonts/misc,
   /usr/share/fonts/Type1,
   /usr/share/fonts/TTF,
   /usr/share/fonts/75dpi,
   /usr/share/fonts/100dpi,
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/,
   built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(**) Extension "Composite" is enabled
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse
(WW) Disabling Keyboard1
(II) Loader magic: 0xfa60
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 5.0
   X.Org XInput driver : 4.0
   X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 8

(--) PCI:*(0@1:0:0) ATI Technologies Inc M76 [Radeon Mobility HD 2600 Series] rev 0, Mem @ 0xd0000000/268435456, 0xfc000000/65536, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) System resource ranges:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded by default.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded by default.
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
   compiled for 1.4.99.906, module version = 8.59.2
   Module class: X.Org Video Driver
[atiddxSetup] X version mismatch - detected X.org 7.1.1.901, required X.org 7.4.-1.906
(II) UnloadModule: "fglrx"
(II) Unloading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.1.2
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 2.1
(EE) module ABI major version (2) doesn't match the server's version (4)
(II) UnloadModule: "synaptics"
(II) Unloading /usr/lib/xorg/modules/input//synaptics_drv.so
(EE) Failed to load module "synaptics" (module requirement mismatch, 0)
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.6.1.901, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "xtrap"
(WW) Warning, couldn't open module xtrap
(II) UnloadModule: "xtrap"
(EE) Failed to load module "xtrap" (module does not exist, 0)
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.6.1.901, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.6.1.901, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.6.1.901, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Reloading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(WW) Warning, couldn't open module type1
(II) UnloadModule: "type1"
(EE) Failed to load module "type1" (module does not exist, 0)
(II) LoadModule: "freetype"
(WW) Warning, couldn't open module freetype
(II) UnloadModule: "freetype"
(EE) Failed to load module "freetype" (module does not exist, 0)
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
   compiled for 1.6.1.901, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(**) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.6.1.901, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
   compiled for 1.4.99.906, module version = 8.59.2
   Module class: X.Org Video Driver
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.1.2
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 2.1
(EE) module ABI major version (2) doesn't match the server's version (4)
(II) UnloadModule: "synaptics"
(II) Unloading /usr/lib/xorg/modules/input//synaptics_drv.so
(EE) Failed to load module "synaptics" (module requirement mismatch, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

_________________
I SEE THE FLASH! THE FLAAASH!
AND YOU INFEDEL WILL DIE!!!
SLEEEPEEER AWAAAKEE!!!
* allucinato *
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Jul 05, 2009 1:50 pm    Post subject: Reply with quote

Dalla tua spiegazione si capisce molto poco, e le indicazioni generiche che hai dato non sono adatte per farsi aiutare sui forum; al termine della compilazione di xorg-server esce il messaggio
Code:
You must rebuild all drivers if upgrading from xorg-server 1.5
or earlier, because the ABI changed. If you cannot start X because
of module version mismatch errors, this is your problem.

You can generate a list of all installed packages in the x11-drivers
category using this command:
emerge portage-utils; qlist -I -C x11-drivers/
che spiega perfettamente cosa devi fare per evitare i problemi che hai avuto.

Se hai problemi di incompatibilità con i driver ATI installa almeno temporaneamente la versione opensource, x11-drivers/xf86-video-ati.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Jul 05, 2009 5:05 pm    Post subject: Re: X server dice che i plugin sono di altre versioni... Reply with quote

Giepi wrote:
Code:

(EE) Failed to load module "synaptics" (module requirement mismatch, 0)
(EE) No drivers available.

sembra proprio che il modulo appartenga ad una versione sbagliata e che tu debba ricompilare quella giusta.

comunque synaptics serve solo per il touchpad.
quantomeno dovresti riuscire ad avviare X senza touchpad.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Jul 05, 2009 11:45 pm    Post subject: Reply with quote

No, sopra c'è l'errore del driver ati:
Code:
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
   compiled for 1.4.99.906, module version = 8.59.2
   Module class: X.Org Video Driver
[atiddxSetup] X version mismatch - detected X.org 7.1.1.901, required X.org 7.4.-1.906
(II) UnloadModule: "fglrx"
(II) Unloading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
Back to top
View user's profile Send private message
Giepi
Apprentice
Apprentice


Joined: 29 Sep 2004
Posts: 164
Location: Non pallo, io!

PostPosted: Mon Jul 06, 2009 6:15 pm    Post subject: Reply with quote

ho appena eseguito quel comando reinstallando la roba che elencava... Niente...

Allora ho fatto un emerge --sync e visto che ci stavano nuovi xorg-serve e atidrivers che ho installato.
Adesso appena viene lanciato X compare uno schermo nero e si freeza l'intera systema e devo fare hard reboot :(
Considerando che X viene lanciato all'avvio... D'oh!
_________________
I SEE THE FLASH! THE FLAAASH!
AND YOU INFEDEL WILL DIE!!!
SLEEEPEEER AWAAAKEE!!!
* allucinato *
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Mon Jul 06, 2009 6:40 pm    Post subject: Reply with quote

E se tornassi a Xorg stabile (1.5.3)? A meno che tu non ne abbia reale bisogno, non credo sia una buona mossa avanzare il server grafico ad una versione release candidate (quindi nemmeno dichiarata stabile).
Back to top
View user's profile Send private message
Giepi
Apprentice
Apprentice


Joined: 29 Sep 2004
Posts: 164
Location: Non pallo, io!

PostPosted: Mon Jul 06, 2009 8:41 pm    Post subject: Reply with quote

Mi sono affidato a quanto diceva portage... non ho sbloccato nulla di hard masked... cmq sia non posso fare nulla, visto che non posso neanche ad accedere al sistema visto che prova subito a caricare X e poi si pianta completamente!
_________________
I SEE THE FLASH! THE FLAAASH!
AND YOU INFEDEL WILL DIE!!!
SLEEEPEEER AWAAAKEE!!!
* allucinato *
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Tue Jul 07, 2009 6:56 am    Post subject: Reply with quote

Appena dopo il boot del kernel, ma prima di cominciare l'init, dovrebbe esserci una scritta che recita piu o meno cosi:
Code:

Press I to interactive boot


Se pigi "I" dovresti poter scegliere servizio per servizio cio che deve partire. Fai partire tutto tranne "xdm".
Dopo batti un
Code:
 rc-update del xdm
in modo da togliere dall'avvio xdm finche fai le prove.

P.s. quando hai installato i driver ati, sei sicuro di aver il link giusto di "/usr/src/linux" con il kernel che stai usando ?
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Tue Jul 07, 2009 9:46 am    Post subject: Reply with quote

da root dai questo comando:

emerge -1av `qlist -C -I x11-drivers/*`

(occhio agli apici rovesci `` che non sono '')

ps: questo comando è pressoché obbligatorio per una corretta transazione dei moduli/drivers da 1.5 a 1.6
Back to top
View user's profile Send private message
Giepi
Apprentice
Apprentice


Joined: 29 Sep 2004
Posts: 164
Location: Non pallo, io!

PostPosted: Tue Jul 07, 2009 3:23 pm    Post subject: Reply with quote

Ho fatto tutto... ho pure provato a downgrade xorg come suggerito... poi ho provato pure a downgradare atidrivers... provato i comandi consigliati, emerso quuanto aveva a che fare con i driver di Xorg... Niente!

Appena do startx, mi si inchioda TUTTA!
_________________
I SEE THE FLASH! THE FLAAASH!
AND YOU INFEDEL WILL DIE!!!
SLEEEPEEER AWAAAKEE!!!
* allucinato *
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Tue Jul 07, 2009 4:35 pm    Post subject: Reply with quote

Sistema "a mali estremi, estremi rimedi": rimuovi X, tutte le dipendenze, tutti i driver, e tutto quello con cui hanno a che fare; rimuovi qualsiasi voce in package.keywords e package.unmask; riemergi il tutto, così che sia tutto stabile.
Back to top
View user's profile Send private message
Giepi
Apprentice
Apprentice


Joined: 29 Sep 2004
Posts: 164
Location: Non pallo, io!

PostPosted: Wed Jul 08, 2009 12:27 pm    Post subject: Reply with quote

ehm ma c'è un metodo per avere l'elenco della roba da cancellare? il comando di sopra?
_________________
I SEE THE FLASH! THE FLAAASH!
AND YOU INFEDEL WILL DIE!!!
SLEEEPEEER AWAAAKEE!!!
* allucinato *
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Jul 09, 2009 5:28 pm    Post subject: Reply with quote

Il "comando di sopra" ti elenca i driver da ricompilare. Con eix -IcC x11* trovi tutti i pacchetti che hanno a che fare con X installati sul tuo sistema. Quelli importanti sono, secondo me, x11-apps, x11-base, x11-drivers, x11-libs, x11-proto.
Back to top
View user's profile Send private message
viralex
Apprentice
Apprentice


Joined: 24 Apr 2008
Posts: 237
Location: Viareggio (Lu,Italy)

PostPosted: Thu Jul 09, 2009 9:04 pm    Post subject: Reply with quote

io ho risolto così

Code:

Section "ServerFlags"
   Option "IgnoreABI" "True"
EndSection


ho l' X server 1.6.2 e tutti gli altri componenti anche a versione 9999. funziona perfettamente con la mia nvidia
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Fri Jul 10, 2009 11:24 pm    Post subject: Reply with quote

riverdragon wrote:
Il "comando di sopra" ti elenca i driver da ricompilare. Con eix -IcC x11* trovi tutti i pacchetti che hanno a che fare con X installati sul tuo sistema. Quelli importanti sono, secondo me, x11-apps, x11-base, x11-drivers, x11-libs, x11-proto.


Beh, aspetta. Il "comando di sopra" usa qlist per ricavare i pacchetti che hai già installato che appartengono alla categoria x11-drivers (che è la stessa cosa di eix -IcC x11-drivers*).

Tale lista la concatena a emerge per l'emersione.

Comunque io credo che ci sia qualcos'altro poiché io ho sempre dato quel comando che ho indicato sopra e non ho mai avuto problemi di versione.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum