Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KERNEL] Aide pour le compiler (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Fri Jul 03, 2009 5:33 am    Post subject: [KERNEL] Aide pour le compiler (résolu) Reply with quote

Salut,

J'ai un nouvel ordinateur qui peut compiler un logiciel sans prendre deux jours, et je voulais donc me remettre à Gentoo.
J'ai installé pas mal de truc déjà, mais je bootais avec le kernel de ma archlinux (qui est fait automatiquement).

Le problème c'est quand compilant les drivers nvidia, j'ai eu une erreur comme quoi je devais supprimer l'option de virtualisation de mon noyau.
Donc je trouvais que c'était une bonne occasion de me remettre à la compilation du noyau.

MAIS, j'y arrive plus :lol: . Alors je vous sollicite pour m'en sortir.

J'y arrive plus = Kernel panic quand le noyau veut monter ma partition root.

Je vous fais un lspci, un mount et si vous pouviez me dire : tu as pensé à mettre ci, ça. Ce serait top.


Merci !!


lspci
Code:

00:00.0 Host bridge: ATI Technologies Inc RX780/RX790 Chipset Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
00:0a.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port F)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
01:00.0 VGA compatible controller: nVidia Corporation GeForce 9500 GT (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
03:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Lin


mount
Code:

/dev/sda9 on / type jfs (rw,noatime,nodiratime)
none on /dev type ramfs (rw,relatime)
none on /proc type proc (rw,relatime)
none on /sys type sysfs (rw,relatime)
none on /dev/pts type devpts (rw)
none on /dev/shm type tmpfs (rw)
/dev/sda11 on /home type xfs (rw,noatime,nodiratime)
/dev/sda6 on /boot type ext2 (rw)


edit : J'aimerais ne pas avoir de initrd.


Last edited by TrizoLakai on Fri Jul 03, 2009 6:44 am; edited 2 times in total
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Jul 03, 2009 5:45 am    Post subject: Reply with quote

Nvidia qui déconne à cause d'options de virtualisation? c'est nouveau ça. chezmoiçamarche.com
Bon il nous manque un tas d'infos:

- Quelle version du noyau essais tu d'installer?
- Quelle est ta ligne de boot?
- As tu mis le support de JFS en dur dans ton noyau?

etc...
Back to top
View user's profile Send private message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Fri Jul 03, 2009 5:51 am    Post subject: Reply with quote

Version du noyau : 2.6.29-gentoo (gentoo-sources)

lignes de boot :
kernel /vmlinuz26_gentoo root=/dev/disk/by-uuid/7a1133e7-f8ea-42b7-a7c9-eea370657d16 ro quiet

(J'ai essayé en mettant directement root=/dev/sda9 aussi, ça fonctionne pas plus)




Filesystem :
Code:

                                                                      <*> Second extended fs support                   
  │ │                                                               <*> Ext3 journalling file system support 
  │ │                                                               < > The Extended 4 (ext4) filesystem 
  │ │                                                               <*> Reiserfs support
  │ │                                                               <*> JFS filesystem support
  │ │                                                               [*]   JFS POSIX Access Control Lists 
  │ │                                                               [*]   JFS Security Labels
  │ │                                                               [ ]   JFS debugging
  │ │                                                               [ ]   JFS statistics 
  │ │                                                               [*] Enable POSIX file locking API   
  │ │                                                               <*> XFS filesystem support


ATA ATAPI Support
Code:

 [ ]   Support for SATA (deprecated; conflicts with libata SATA driver)
  │ │          <*>   generic ATA/ATAPI disk support
  │ │          [*]     ATA disk support
  │ │          <*>   Include IDE/ATAPI CDROM support
  │ │          <M>   Include IDE/ATAPI TAPE support
  │ │          <*>   generic/default IDE chipset support
  │ │          <M>   Platform driver for IDE interfaces
  │ │          <*>   CMD640 chipset bugfix/support
  │ │          <*>   PNP EIDE support
... (Rien selectionne)
  │ │          <*>   AMD and nVidia IDE support
  │ │          <*>   ATI IXP chipset IDE support
... (Rien selectionne)


SATA support
Code:

          --- Serial ATA (prod) and Parallel ATA (experimental) drivers
  │ │          [*]   ATA ACPI Support
  │ │          [*]   SATA Port Multiplier support
  │ │          <M>   AHCI SATA support
  │ │          <M>   Silicon Image 3124/3132 SATA support
  │ │          [*]   ATA SFF support
  │ │          < >     ServerWorks Frodo / Apple K2 SATA support
... (rien de selectionne)
  │ │          <*>     AMD/NVidia PATA support
  │ │          < >     ARTOP 6210/6260 PATA support
  │ │          <*>     ATI PATA support 
... (rien de selectionne)


Comme j'ai southbridge ATI, j'ai mis que ça pour le SATA aussi.


Last edited by TrizoLakai on Fri Jul 03, 2009 5:59 am; edited 3 times in total
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Jul 03, 2009 5:55 am    Post subject: Reply with quote

Quel est le message d'erreur exactement?

Vires "quiet" et essais de lire assez vite pour remarquer si le noyau détecte bien ton disque. (En principe il affiche /dev/sda et la liste des partitions numérotés). Si c'est pas le cas alors c'est un soucis de détection du contrôleur. (tu utilises les ACL sur ton FS? c'est pas gênant d'avoir le support mais si tu l'utilises pas autant de virer)

[edit] vires "ro" aussi il sert à rien [/edit]
Back to top
View user's profile Send private message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Fri Jul 03, 2009 5:56 am    Post subject: Reply with quote

Re, non j'utilise pas ACL. J'ai édité mon post d'avant, j'y ajoute encore ce que j'ai mis pour le SATA et je reboot voir si je vois le listing des partitions sans le quiet.
Back to top
View user's profile Send private message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Fri Jul 03, 2009 6:07 am    Post subject: Reply with quote

Bon j'ai refais deux fois le processus sans voir le listing. Je sais pas par contre si c'est moi qui suis bligleux ou pas (ça défile super vite)

Donc j'ai noté ce qu'il fait avant de paniquer :)

- Un truc avec l'usb
- Un message : Failed to disable AUX port but continuig anyway... Is this a Sis ?
- Un truc avec scsi0
- Un truc de la souris (mice)
- NET blabla
- VFS : Cannot open root device sda9 or ...


Voilà, si ça permet de savoir quelques truc... :/

Merci !
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Jul 03, 2009 6:10 am    Post subject: Reply with quote

Bizarre ta conf. Pour le SATA mieux vaut virer tout support ATA/ATAPI/MFM/RLL support

Mets AHCI en dur. Tu as bien des disques SATA ?
Ton controleur SATA semble ne gérér que le mode IDE??? --> SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode] ?

[edit]
Oublies la souris, l'usb et le net. Par contre scsi, faut voir. Le support scsi est obligatoire en SATA. regrades dans SCSI si tu as le support disque.[/edit]
Back to top
View user's profile Send private message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Fri Jul 03, 2009 6:17 am    Post subject: Reply with quote

kwenspc wrote:
Bizarre ta conf. Pour le SATA mieux vaut virer tout support ATA/ATAPI/MFM/RLL support


Mets AHCI en dur.

Ok je vais essayer ça.

Quote:

Tu as bien des disques SATA ?

Heu bin oui c'est un disque dur en SATA2, branché sur les prises SATA de ma carte mère :o

Quote:

Ton controleur SATA semble ne gérér que le mode IDE??? --> SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode] ?

Alors là ! J'avais même pas fais attention, je sais pas du tout pourquoi c'est écrit ça. Comment je fais pour vérifier ? Dans le BIOS ? Une commande ?

Quote:

[edit]
Oublies la souris, l'usb et le net. Par contre scsi, faut voir. Le support scsi est obligatoire en SATA. regrades dans SCSI si tu as le support disque.[/edit]

Haha j'ai vu ton edite que dans mon 'quote' :). Je regarde ça !


voilà :

SCSI Transports
Code:

[*]   ATA support for libsas (requires libata)
[*]   Support for SMP interpretation for SAS hosts


SCSI device support
Code:

               < > RAID Transport Class
  │ │          -*- SCSI device support 
  │ │          {M} SCSI target support
  │ │          [*] legacy /proc/scsi/ support
  │ │              *** SCSI support type (disk, tape, CD-ROM) ***
  │ │          <*> SCSI disk support
  │ │          <M> SCSI tape support 
  │ │          <M> SCSI OnStream SC-x0 tape support
  │ │          <*> SCSI CDROM support
  │ │          [*]   Enable vendor-specific extensions (for SCSI CDROM)
  │ │          <M> SCSI generic support 
  │ │          <M> SCSI media changer support 
  │ │              *** Some SCSI devices (e.g. CD jukebox) support multiple LUNs ***   
  │ │          [ ] Probe all LUNs on each SCSI device
  │ │          [ ] Verbose SCSI error reporting (kernel size +=12K) 
  │ │          [ ] SCSI logging facility 
  │ │          [*] Asynchronous SCSI scanning 
  │ │              SCSI Transports  --->   
  │ │          [*] SCSI low-level drivers  ---> 
  │ │          < > SCSI Device Handlers  --->


Je pense que ça roule pour ça ?

Bon je recompile le noyau avec ce que tu m'as demandé de changer.
Back to top
View user's profile Send private message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Fri Jul 03, 2009 6:43 am    Post subject: Reply with quote

Ok ça fonctionne !

Merci beaucoup kwenspc.

Je finirais de compiler xorg ce soir :) et peut être que demain je vous lirais depuis ma nouvelle Gentoo.

Je marque résolu, encore merci.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Jul 03, 2009 7:00 am    Post subject: Reply with quote

Bon retour sur Gentoo! :wink:
Back to top
View user's profile Send private message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Fri Jul 03, 2009 4:46 pm    Post subject: Reply with quote

kwenspc wrote:
Bon retour sur Gentoo! :wink:


Merci,

Je vous parle de Gentoo là. (Openbox + Firefox-bin), pour avoir une interface graphique rapidement.
J'ai redécouvert eix !

Bon maintenant faut que je trouve comment installer aweome 3 et que je compile le vrai firefox :D Et après : midori (qui est masked en svn ! Que du bon)

Tiens j'ai une question en passant : je vois souvent en USE : sqlite.

Vous en pensez quoi ? C'est applicable si je partage mon /home avec d'autres distributions ? (Je pense pas)

Bye,
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Fri Jul 03, 2009 4:53 pm    Post subject: Reply with quote

TrizoLakai wrote:

Tiens j'ai une question en passant : je vois souvent en USE : sqlite.

Vous en pensez quoi ? C'est applicable si je partage mon /home avec d'autres distributions ? (Je pense pas)

Ça dépend du soft sur lequel tu appliques ce use flag. C'est assez commun de softs avec db sous sqlite, amha les autres distribs doivent l'intégrer de base non? Faut voir.

Sinon perso awesome 3 m'a déçu. C'était censé être un wm léger, maintenant ça part un peu en sucette ce truc (le fait d'avoir intégrer d'office LUA, le fait que ce dernier ne gère pas le multithreading etc...). Je suis resté sur la version 2.0. perso. (cette critique est totalement subjective bien entendue. Je conçois qu'on utilise awesome 3 :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum