Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Font characters being "smudged", obscured
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Punchcutter
Apprentice
Apprentice


Joined: 11 Feb 2007
Posts: 212

PostPosted: Thu Jul 02, 2009 1:42 am    Post subject: [SOLVED] Font characters being "smudged", obscured Reply with quote

I recently did an emerge world, and am now having a very strange problem. Some font characters are not being rendered properly (in KDE). They are covered with black "smudges" (it's hard to find a better word to describe it), which are sometimes rectangular, or partly so, but not always. The smudges are not fixed and permanent, but can be made to go away by (for example) scrolling the web page up and down (if they're on a web page), mousing over them, or selecting them. For example, in Thunderbird mail, if you select the message that has these characters in its Subject, they will "clean up" and display properly.

This machine makes heavy use of Japanese, and Japanese text is most affected by this, but not exclusively. Some English text is affected if it's (say) on an HTML form button. Also, the KDM login page is covered with smudges (all English).

Has anyone ever seen this? Could it possibly be related to the upgrade of xorg-server to >1.5 ? I'm imagining it's connected to some low-level library like cairo or pango, perhaps? I'm not sure what sort of information I could provide would be useful, so I'll leave it at this and see what people have to say.

Many thanks in advance for any hints or clues, no matter how remote and tentative, you can provide.

Dave


Last edited by Punchcutter on Fri Jul 03, 2009 1:47 am; edited 1 time in total
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1028
Location: Romania

PostPosted: Thu Jul 02, 2009 4:55 am    Post subject: Reply with quote

using nvidia-drivers? https://forums.gentoo.org/viewtopic-t-769826-highlight-.html
_________________
My Smooth Computer
MB: VIA 82C598MVP on DFI P5BV3+/Rev. B+
CPU: AMD K6-II 333 MHz | RAM: 256 MB SDRAM
Video: Asus MB19TU on nVidia GeForce MX4000 64 MB
Sound: CM8738 | Net: RTL-8139
PATA HDD WD 80 GB & DVD-RW LG 16x
Back to top
View user's profile Send private message
Punchcutter
Apprentice
Apprentice


Joined: 11 Feb 2007
Posts: 212

PostPosted: Fri Jul 03, 2009 1:45 am    Post subject: Reply with quote

That was it! :o Thanks very much.

Dave
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2671
Location: here, there or in transit

PostPosted: Fri Jul 03, 2009 1:56 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads.
See topic linked above.
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum