Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[mrtg&lmsensors] valeur ne progressant pas
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 461
Location: Martinique

PostPosted: Mon Jun 29, 2009 5:57 am    Post subject: [mrtg&lmsensors] valeur ne progressant pas Reply with quote

Bonjour,

Quelqu'un saurait-il m'expliquer pour quelle raison une valeur peut ne pas progresser dans mrtg ?

Je m'explique :
Je monitore un certain nombre de choses avec mrtg. Tout fonctionne bien, sauf :
Code:
head /var/log/www/mrtg/localhost.20-cmtemp.log
1246254303 50000 50000
1246254303 0 0 0 0
1246254003 0 0 0 0
1246254000 0 0 0 0
1246253700 0 0 0 0
1246253400 0 0 0 0
1246253100 0 0 0 0
1246252800 0 0 0 0

Seules les 2 valeurs de la première ligne changent, au gré des véritables valeurs, mais le remplissage ne se poursuit jamais, contrairement aux autres logs.
Comme par hasard, c'est la seule config ou je tape dans lm_sensors mais je ne vois vraiment pas le rapport puisque :
Code:
snmpget -v 1 -c public localhost .1.3.6.1.4.1.2021.13.16.5.1.3.1 .1.3.6.1.4.1.2021.13.16.5.1.3.2
LM-SENSORS-MIB::lmMiscSensorsValue.1 = Gauge32: 49000
LM-SENSORS-MIB::lmMiscSensorsValue.2 = Gauge32: 48000


La config :
Code:
WorkDir: /var/log/www/mrtg
LoadMIBs: /usr/share/snmp/mibs/LM-SENSORS-MIB.txt
Target[localhost.20-cmtemp]: .1.3.6.1.4.1.2021.13.16.5.1.3.1&.1.3.6.1.4.1.2021.13.16.5.1.3.2:public@localhost
Options[localhost.20-cmtemp]: nopercent,growright,gauge,noinfo,pngdate
Title[localhost.20-cmtemp]: CPUTemperature
PageTop[localhost.20-cmtemp]: <H1>CPU Temperature</H1>
MaxBytes[localhost.20-cmtemp]: 100
Factor[localhost.20-cmtemp]: 0.001
YTicsFactor[localhost.20-cmtemp]: 0.001
PNGTitle[localhost.20-cmtemp]: CPU Temperature
kMG[localhost.20-cmtemp]: °C
YLegend[localhost.20-cmtemp]: CPU Temperature
ShortLegend[localhost.20-cmtemp]:
LegendI[localhost.20-cmtemp]: CPU0
LegendO[localhost.20-cmtemp]: CPU1
Legend1[localhost.20-cmtemp]: CPU Temperature
Language: french

Bon, c'est vrai que je pourrai faire un script de parsing de la sortie de sensors, et c'est probablement ce à quoi j'arriverai si je ne trouve pas de solution directe, mais j'aimerais bien comprendre.

Si vous voyez que je commets une erreur grossière...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum