Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problema wireless b43 e rtl8187..
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Joystik
n00b
n00b


Joined: 24 Jun 2009
Posts: 8

PostPosted: Wed Jun 24, 2009 1:28 pm    Post subject: problema wireless b43 e rtl8187.. Reply with quote

Salve a tutti colgo l'occasione per rigranziare tutti per l'ottima documentazione che si trova, sono un nuovo utente gentoo, e apparte qualche problemuccio inizziale inizzio ad amare la nostra metadistribuzione, solo che è da 2 giorni che mi è sorto un problema, l'altro ieri ho dovuto ricompilare il kernel per un problema di fglrx che sono poi riuscito a risolvere, solo che ogni volta che ricompilo il kernel, mi tocca reinstallare i driver per la broadcom 4311 e per la rtl818 seguendo la rispettive guide: [/url] http://linuxwireless.org/en/users/Drivers/b43 e attivando il supporto bcm43xx nel kernel(anche se non capisco il motivo) , solo che prima seguendo la guida funzionava ora non riesco più a farle funzionare, nonostante i moduli vengano caricati.
Code:
lsmod
Module                  Size  Used by
fglrx                1803020  0
tun                     9860  0
r8187                  41220  0
ieee80211_rtl          52868  1 r8187
b43                   124192  0
ieee80211_crypt_rtl     4740  1 ieee80211_rtl


Code:
iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.


Non so più come venirne fuori ho provato anche con queste guide: http://en.gentoo-wiki.com/wiki/Broadcom_43xx
[/url][url][/url] http://www.linuxfeed.org/informatica/broadcom-bcm4312-rev-02-finalmente.html ma niente. :cry:
il mio notebook è un dell 1501 isnpiron.

Grazie a tutti.
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Wed Jun 24, 2009 1:37 pm    Post subject: Reply with quote

puoi postare il risultato di:
Code:
lspci|grep Broadcom

?
_________________
LP
Back to top
View user's profile Send private message
Joystik
n00b
n00b


Joined: 24 Jun 2009
Posts: 8

PostPosted: Wed Jun 24, 2009 1:44 pm    Post subject: Reply with quote

lucapost wrote:
puoi postare il risultato di:
Code:
lspci|grep Broadcom

?


certo

Code:

05:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
08:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Wed Jun 24, 2009 2:06 pm    Post subject: Reply with quote

Controlla di avere il kernel aggiornato e con le opzioni indicate abilitate, riavvia la nuova immagine.
Come indiacato in http://en.gentoo-wiki.com/wiki/Broadcom_43xx#Firmware_.2F_fwcutter, esegui quindi i seguenti comandi da root:
Code:
cd /root/
emerge b43-fwcutter
wget http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
tar xjf broadcom-wl-4.150.10.5.tar.bz2
mkdir -p /lib/firmware
b43-fwcutter -w /lib/firmware ./broadcom-wl-4.150.10.5/driver/wl_apsta_mimo.o

la scheda dovrebbe essere dunque funzionante.

Posta gli eventuali errori.
_________________
LP
Back to top
View user's profile Send private message
Joystik
n00b
n00b


Joined: 24 Jun 2009
Posts: 8

PostPosted: Wed Jun 24, 2009 2:36 pm    Post subject: Reply with quote

fatto tutto, nessuno errore ma non va...

Code:

iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

Code:

lsmod
Module                  Size  Used by
fglrx                1803020  0
tun                     9860  0



Code:

ls /lib/firmware/b43/
a0g0bsinitvals4.fw   a0g1initvals5.fw     lp0bsinitvals13.fw  pcm5.fw
a0g0bsinitvals5.fw   a0g1initvals9.fw     lp0bsinitvals14.fw  ucode11.fw
a0g0bsinitvals9.fw   b0g0bsinitvals13.fw  lp0bsinitvals15.fw  ucode13.fw
a0g0initvals4.fw     b0g0bsinitvals4.fw   lp0initvals13.fw    ucode14.fw
a0g0initvals5.fw     b0g0bsinitvals5.fw   lp0initvals14.fw    ucode15.fw
a0g0initvals9.fw     b0g0bsinitvals9.fw   lp0initvals15.fw    ucode4.fw
a0g1bsinitvals13.fw  b0g0initvals13.fw    n0absinitvals11.fw  ucode5.fw
a0g1bsinitvals5.fw   b0g0initvals4.fw     n0bsinitvals11.fw   ucode9.fw
a0g1bsinitvals9.fw   b0g0initvals5.fw     n0initvals11.fw
a0g1initvals13.fw    b0g0initvals9.fw     pcm4.fw

il modulo non viene caricato perchè nella ricompilazione l'ho messo integrato, giusto??
bo non capisco proprio cosa non vada bene...
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Wed Jun 24, 2009 2:42 pm    Post subject: Reply with quote

controlla l'output dei comandi:
Code:
#> zcat /proc/config.gz |grep -v "#" |grep mac8
CONFIG_MAC80211=y
CONFIG_MAC80211_RC_MINSTREL=y
CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
CONFIG_MAC80211_RC_DEFAULT="minstrel"
CONFIG_MAC80211_LEDS=y
CONFIG_MAC80211_DEBUG_MENU=y
CONFIG_MAC80211_DEBUG_PACKET_ALIGNMENT=y
CONFIG_MAC80211_NOINLINE=y
CONFIG_MAC80211_VERBOSE_DEBUG=y
CONFIG_MAC80211_HT_DEBUG=y
CONFIG_MAC80211_TKIP_DEBUG=y
CONFIG_MAC80211_IBSS_DEBUG=y
CONFIG_MAC80211_VERBOSE_PS_DEBUG=y

#> zcat /proc/config.gz |grep -v "#" |grep b43
CONFIG_B43=y
CONFIG_B43_PCI_AUTOSELECT=y
CONFIG_B43_PCICORE_AUTOSELECT=y
CONFIG_SSB_B43_PCI_BRIDGE=y

ricompila eventualmente il kernel, posta anche
Code:
uname -a

_________________
LP
Back to top
View user's profile Send private message
Joystik
n00b
n00b


Joined: 24 Jun 2009
Posts: 8

PostPosted: Wed Jun 24, 2009 2:53 pm    Post subject: Reply with quote

uname -a
Code:

 uname -a
Linux Ghostshadow 2.6.27-gentoo-r10 #22 SMP Tue May 19 16:47:15 Local time zone must be set--see zic i686 AMD Turion(tm) 64 X2 Mobile Technology TL-50 AuthenticAMD GNU/Linux



Code:

#> zcat /proc/config.gz |grep -v "#" |grep mac8


ehm.. non mi restituisce nulla... e non ho il file config.gz o almeno non in proc.
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Wed Jun 24, 2009 3:17 pm    Post subject: Reply with quote

l'ultimo kernel stabile è il 2.6.29-r5, aggiorna portage e quindi anche il kernel.
quindi riprendi la guida che hai postato.

Ho il tuo stesso processore, ma kernel x86_64.
_________________
LP
Back to top
View user's profile Send private message
Joystik
n00b
n00b


Joined: 24 Jun 2009
Posts: 8

PostPosted: Wed Jun 24, 2009 4:39 pm    Post subject: Reply with quote

Interessante ora non mi faà montare /boot

Code:

 mount /dev/sda1 /boot/
mount: unknown filesystem type 'ext2'


eppure nel configurazione del kerne è in builtin visto che ho preso il vecchio .config.
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Wed Jun 24, 2009 8:03 pm    Post subject: Reply with quote

Fai montare in automatico la partizione di boot quando avvii la macchina, modificando opportunamente il file /etc/fstab.
Il mio ad esempio è così:
Code:
/dev/sda1               /boot           ext3            defaults,noatime                        1 2

_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
viralex
Apprentice
Apprentice


Joined: 24 Apr 2008
Posts: 237
Location: Viareggio (Lu,Italy)

PostPosted: Fri Jun 26, 2009 9:18 pm    Post subject: Reply with quote

Puoi provare i driver "net-wireless/broadcom-sta". il modulo si chiama wl.
Quando avevo la broadcom i b43 non erano proprio compatibili con la mia scheda.

Adesso ho messo una fantastica atheros :P eheh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum