Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Problems with thunar and hal
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 24 May 2007
Posts: 153
Location: Jyväskylä, Finland

PostPosted: Thu Jun 11, 2009 12:38 pm    Post subject: [solved] Problems with thunar and hal Reply with quote


For a long time I've been using Gentoo without HAL, since I only had bad experiences with it. Yesterday I decided to try hal once again. I faced a few problems but overcame them easily, all but this one.

When I try to run thunar as a normal user when it's compiled with USE="hal", I get this:
~ % thunar
process 18820: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "(error) == NULL || !dbus_error_is_set ((error))" failed in file dbus-connection.c line 3301.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
zsh: abort      thunar

I don't know if this is thunar specific or not, since I don't use that many GUI programs. Sonata uses dbus but not hal and it works fine, though. Pulseaudio also starts up fine with the hal plugin enabled (though I'm having a bucketload of other issues with PulseAudio, but they're beyond the scope of this thread).

However the same build of thunar starts up fine as root, so this must be some kind of configuration issue? I had to add some permissive rules to /etc/dbus-1/system.d/ for pulseaudio to be able to use the hal plugin (I got permission denied errors before that), but I don't really know what should I add for thunar in there. And since I haven't found any information about this by googling or searching the bugzilla, this might be a HAL/DBus configuration issue somewhere else.

Here's some additional information:

~ # emerge --info
Portage (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-gentoo-r4 x86_64)
System uname: Linux-2.6.29-gentoo-r4-x86_64-Intel-R-_Pentium-R-_D_CPU_3.00GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 10 Jun 2009 15:05:01 +0000
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.4.4-r13, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=nocona -fomit-frame-pointer"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona -fomit-frame-pointer"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/sunrise /usr/local/portage/layman/mpd /usr/local/portage/layman/x11"
USE="X acl alsa amd64 avi berkdb bzip2 cairo cli cracklib crypt cups curl dbus dri flac fortran gdbm gif gpm gtk hal iconv isdnlog jpeg jpg lame mad midi mmx mp3 mpeg mpg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png pppd pulseaudio python readline reflection session smp spl sse sse2 ssl sysfs tcpd theora threads truetype unicode vorbis x264 xcomposite xft xinerama xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="intel vesa i810"

~ # eix '^(dbus|hal|thunar)$'
[I] sys-apps/dbus
     Available versions:  1.0.2-r2 (~)1.1.4 1.1.20 (~)1.2.1 (~)1.2.3 1.2.3-r1 (~)1.2.12 {X debug doc kernel_FreeBSD kernel_linux selinux test}
     Installed versions:  1.2.12(19:52:54 04/28/09)(X -debug -doc -selinux -test)
     Description:         A message bus system, a simple way for applications to talk to each other

[I] sys-apps/hal
     Available versions: (~)0.5.11-r4 0.5.11-r8 (~)0.5.12_rc1-r4 (~)0.5.12_rc1-r6 {X acpi apm consolekit crypt debug dell disk-partition doc kernel_FreeBSD kernel_linux laptop pcmcia policykit selinux}
     Installed versions:  0.5.12_rc1-r6(04:25:27 06/10/09)(X consolekit crypt kernel_linux -acpi -apm -debug -dell -disk-partition -doc -kernel_FreeBSD -laptop -policykit -selinux)
     Description:         Hardware Abstraction Layer

[I] xfce-base/thunar
     Available versions:  0.9.3 1.0.1 {X dbus debug doc exif gnome hal pcre startup-notification trash-plugin}
     Installed versions:  1.0.1(15:27:52 06/11/09)(X dbus hal pcre -debug -doc -exif -gnome -startup-notification -trash-plugin)
     Description:         File manager

Found 3 matches.

Any ideas would be much appreciated.
Thanks in advance.



I had to create and add this to /etc/dbus-1/system.d/myuser.conf:
<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
        <policy user="jh">
            <allow send_destination="org.freedesktop.Hal"
            <allow send_destination="org.freedesktop.Hal"

"I'm sorry, I only accept criticism in the form of sed expressions."
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 01 Feb 2006
Posts: 105
Location: TX, USA

PostPosted: Fri Jun 19, 2009 4:37 pm    Post subject: Reply with quote

That did the trick for me. Thanks. I noticed that myuser.conf was the literal name, not to be replaced with "username".conf, where the actual username is entered in the config file.
Back to top
View user's profile Send private message

Joined: 13 Nov 2005
Posts: 388
Location: Socialist land of North America

PostPosted: Sat Jun 20, 2009 2:31 am    Post subject: Reply with quote

Did not work for me, but hal seem to to broken on my system anyway so it may be the problem. Emerging thunar with -hal solved my problem.

@krovisser: Thx for the link
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 25 Dec 2004
Posts: 116
Location: /local/pub

PostPosted: Sat Jul 11, 2009 5:05 pm    Post subject: Reply with quote

I had the same issue running xfdesktop.
Following your solution did the trick for me.

no way to happiness, happiness is the way
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 08 Dec 2007
Posts: 98
Location: Germany

PostPosted: Fri Jul 24, 2009 1:01 pm    Post subject: yaaaaaaaaaaaaaay :-) Reply with quote

thanx for that one!

i barely can´t remember since when i started to accept not to have a working desktop with icons anymore :-D; i simply didnt have the time to look out for that problem´s solution.

this fixed that problem for me too :-)

thanks again a 1000 times!
Back to top
View user's profile Send private message

Joined: 27 Nov 2003
Posts: 13

PostPosted: Sat Jul 25, 2009 8:16 pm    Post subject: Reply with quote

thx!!! works perfect! :)
Back to top
View user's profile Send private message

Joined: 31 May 2008
Posts: 720

PostPosted: Sat Jul 25, 2009 9:07 pm    Post subject: Reply with quote

Are you in the plugdev group? It looks like if you are the same settings should be there already in the default /etc/dbus-1/system.d/hal.conf.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum