Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] dvb: 'AVerMedia A309' non funzionante
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sat Jun 06, 2009 7:53 am    Post subject: [RISOLTO] dvb: 'AVerMedia A309' non funzionante Reply with quote

Buongiorno a tutti,

sul mio portatile è presente un ricevitore DVB modello AVerMedia A309.

Premetto che in un'altra partizione ho installato ubuntu, che vede ed utilizza tale ricevitore senza troppi problemi.

Ora, in gentoo sto usando il kernel 2.6.28-gentoo-r5, ho incluso il supporto al dvb nel kernel e ho impostato come modulo dvb_usb_af9015. Il firmware è presente in /lib/firmware/ :
Quote:
# ls -l /lib/firmware/
totale 1040
-rw-r--r-- 1 root root 12700 28 mag 12:06 dvb-usb-af9015.fw
-rw-r--r-- 1 root root 345008 30 mag 10:09 iwlwifi-5000-1.ucode
-rw-r--r-- 1 root root 353240 30 mag 13:05 iwlwifi-5000-2.ucode
-rw-r--r-- 1 root root 116925 4 giu 09:01 sihp1005.dl
-rw-r--r-- 1 root root 222443 4 giu 09:01 sihpP1005.dl


Ora, all'avvio qualcuno mi carica il modulo, quindi in dmesg trovo:
Quote:
[ 7.527268] dvb-usb: found a 'AVerMedia A309' in cold state, will try to load a firmware
[ 7.527272] usb 2-8: firmware: requesting dvb-usb-af9015.fw
[ 7.856859] dvb-usb: downloading firmware from file 'dvb-usb-af9015.fw'
[ 7.910861] dvb-usb: found a 'AVerMedia A309' in warm state.
[ 7.910930] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 7.911231] DVB: registering new adapter (AVerMedia A309)
[ 8.439993] DVB: registering adapter 0 frontend 0 (Afatech AF9013 DVB-T)...
[ 8.737006] DVB: Unable to find symbol mxl5005s_attach()
[ 8.737015] dvb-usb: AVerMedia A309 successfully initialized and connected.
[ 8.745544] usbcore: registered new interface driver dvb_usb_af9015

(Ho controllato, in ubuntu ottengo le stesse righe tranne quella in grassetto).

E trovo anche:
Quote:
# ls -l /dev/dvb/adapter0/
totale 0
crw-rw---- 1 root video 212, 4 6 giu 09:39 demux0
crw-rw---- 1 root video 212, 5 6 giu 09:39 dvr0
crw-rw---- 1 root video 212, 3 6 giu 09:39 frontend0
crw-rw---- 1 root video 212, 7 6 giu 09:39 net0


Quindi "credo" sia giusto.
Ho confrontato ubuntu e:
1- usa lo stesso modulo
2- usa lo stesso firmware
3- usa il kernel 2.6.28-11

La situazione è semplice: in Ubuntu va, in Gentoo no.
Il ricevitore dvb viene riconosciuto da tutti i programmi.
In xine (dove utilizzo lo stesso channels.conf creato in ubuntu), una volta cliccato sul tasto DVB la situazione è questa:
Quote:
$ xine
Questo è xine (X11 gui) - un riproduttore video libero v0.99.5.
(c) 2000-2007 Team di xine.
input_dvb: continuing in get_instance

e resta così per sempre.

In kaffeine invece, la ricerca dei canali fallisce senza mai superare lo 0% di segnale.

Nel .config del kernel, per quanto riguarda il dvb ho:
Quote:
CONFIG_DVB_CORE=y
CONFIG_DVB_CAPTURE_DRIVERS=y
CONFIG_DVB_USB=y
CONFIG_DVB_USB_DEBUG=y
CONFIG_DVB_USB_AF9015=m
CONFIG_DVB_PLL=y
CONFIG_DVB_AF9013=y


In /var/log/messages nessun errore. Dmesg non dice altro.

Mi sembra davvero che non manchi niente, eppure resto così bloccato.
Qualcuno sa aiutarmi, o indirizzarmi verso la soluzione?


Vi ringrazio fin d'ora,
buon weekend!
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]


Last edited by MajinJoko on Sun Jun 07, 2009 4:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sun Jun 07, 2009 4:53 pm    Post subject: Reply with quote

Grazie alla mia testa molto dura ho risolto.

In pratica, guardando nel menuconfig l'help relativo al modulo dvb-usb-af9015, ho trovato:
Quote:
CONFIG_DVB_USB_AF9015:
Say Y here to support the Afatech AF9015 based DVB-T USB2.0 receiver
Symbol: DVB_USB_AF9015 [=m]
Prompt: Afatech AF9015 DVB-T USB2.0 support
Defined at drivers/media/dvb/dvb-usb/Kconfig:291
Depends on: HAS_IOMEM && DVB_CAPTURE_DRIVERS && DVB_CORE && DVB_USB && EXPERIMENTAL
Location:
-> Device Drivers
-> Multimedia devices
-> DVB/ATSC adapters (DVB_CAPTURE_DRIVERS [=y])
-> Support for various USB DVB devices (DVB_USB [=y])
Selects: DVB_AF9013 && DVB_PLL && MEDIA_TUNER_MT2060 && MEDIA_TUNER_QT1010 && MEDIA_TUNER_TDA18271 && MEDIA_TUNER_MXL5005S


A questo punto, per puro tentativo in verità, ho provato ad abilitare tutto quanto veniva elencato alla voce select. Beh, bingo!
In dmesg ora ottengo:
Quote:
[ 8.081238] DVB: registering adapter 0 frontend 0 (Afatech AF9013 DVB-T)...
[ 8.081424] MXL5005S: Attached at address 0xc6
[ 8.081431] dvb-usb: AVerMedia A309 successfully initialized and connected.

E ora funziona.
Credo sia sufficiente abilitare MEDIA_TUNER_MXL5005S, non ne ho la certezza perché ora ho ancora tutto abilitato.
Chissà, magari un giorno tornerà utile a qualcuno.


Ad maiora!
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum