Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problema emerge
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
eraserhead
n00b
n00b


Joined: 05 Jun 2009
Posts: 6

PostPosted: Fri Jun 05, 2009 6:25 pm    Post subject: [RISOLTO] Problema emerge Reply with quote

Ciao a tutti....ho installato gentoo oggi....dopo 3 anni passati con ubuntu..

Ho scaricato il livecd del 2008 e fatto l'installazione grafica...che mi ha dato molti problemi....visto che sul sito c'era scritto che la 2008 era deprecated (°.°) allora ho scaricato la minimal cd del 2007....

Ho scaricato la guida for dummies e ho finito piu o meno senza problemi....
L'installazione l'ho eseguita due volte....la prima sono arrivato fino al punto in cui dice di aggiornare con emerge --sync ed emerge portage (se non sbaglio).....c'era scritto che non era fondamentale...ma l'ho fatto lo stesso e al momento della compilazione del kernel gcc dava problemi assurdi...

Cosi ho rifatto l'installazione senza quel passo ed è andato tutto ok.....(piu o meno tutto ok....finita mi ritrovo con la tastiera americana....ed internet ogni volta lo devo avviare manualmente con ifconfig e route...ma cmq sono piccolezze)...

Contento come una pasqua per la riuscita installazioni seguo la guida per installare gnome....preparo le use flags e varie....do un bel emerge gnome...dopo 3 ore a cercare le dipendenze mi da tanti errori che non trova i pacchetti...

Allora ho pensato fosse arrivato il momento di ridare un bel emerge --sync per aggiornare il tutto....fatto questo ora non posso piu fare emerge con nulla.....

Se faccio emerge gnome mi da:

All ebuilds thaht could satisfy "gnome" have been masked
One of the following masked pages is required to complete your request
gnome-base/gnome-2.24.1 (masked by required EAPI1 supported EAPI 0)
""/gnome-2.26.2 ""
""/gnome-2.22.3 ""

....da quanto ho capito....molto poco, per smascherarli devo aggiungere nel profilo una use con quei nomi....ma penso di aver capito male.....

tra l'altro mi dice che ho un profilo "deprecated" e non supportato piu....e mi dice di fare un upgrade del profilo al 2008...cosa che avevo fatto nella prima instllazione e anche questa cosa mi aveva dato parecchi problemi....mi diceva che mancava un syslink e googlando un po avevo risolto...cmq se si puo vorrei evitare...

Dopo sto papiro cmq la domanda è come faccio a far rifunzionare emerge? Vi posterei piu output per darvi piu informazioni....ma visto che devo copiare manualmente il tutto magari ditemi quali vi servono, sempre che vi servano....

Grazie della mano....ciao


Last edited by eraserhead on Sun Jun 07, 2009 11:36 am; edited 2 times in total
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Fri Jun 05, 2009 7:37 pm    Post subject: Reply with quote

aggiorna il portage

Code:

emerge -uDN portage

_________________
Darkman
Back to top
View user's profile Send private message
eraserhead
n00b
n00b


Joined: 05 Jun 2009
Posts: 6

PostPosted: Fri Jun 05, 2009 7:50 pm    Post subject: Reply with quote

darkmanPPT wrote:
aggiorna il portage

Code:

emerge -uDN portage


...mi da questo

All ebuilds thaht could satisfy ">=dev-lang/python-2.5" have been masked
One of the following masked pages is required to complete your request
dev-lang/python-2.5.4-r2 (masked by required EAPI1 supported EAPI 0)
""/python-2.6.2-r1""
""/python-2.5.4-r3""

E' come se col comando emerge --sync mi avesse mascherato tutti i pacchetti....
qualsiasi emerge dia, mi da prima
Your current profile is deprecated and not support anymore
Please upgrade to the following profile if possible
default/linux/x86/2008.0
e poi mi da il messaggio dei pacchetti masked....qualsiasi pacchetto provi non cambia....

Non c'è un comando per smascherare tutto il sistema? :D


Last edited by eraserhead on Fri Jun 05, 2009 10:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
Thanas
n00b
n00b


Joined: 02 Oct 2006
Posts: 29

PostPosted: Fri Jun 05, 2009 7:54 pm    Post subject: Reply with quote

eraserhead wrote:
Your current profile is deprecated and not support anymore
Please upgrade to the following profile if possible
default/linux/x86/2008.0


Ti da anche la risposta ;)
Sistema il profilo e riprova, dovrebbe andare...

Saluti
un Thanas... che vecchi profili...

EDIT: scusa, ho letto ora che hai installato dal minimal del 2007... Hum... come mai installando oggi non hai utilizzato uno dei minimal prodotti settimanalmente?
Back to top
View user's profile Send private message
eraserhead
n00b
n00b


Joined: 05 Jun 2009
Posts: 6

PostPosted: Fri Jun 05, 2009 9:13 pm    Post subject: Reply with quote

Thanas wrote:

Ti da anche la risposta ;)
Sistema il profilo e riprova, dovrebbe andare...

Saluti
un Thanas... che vecchi profili...

EDIT: scusa, ho letto ora che hai installato dal minimal del 2007... Hum... come mai installando oggi non hai utilizzato uno dei minimal prodotti settimanalmente?


Bho non lo so.....ho scaricato il livecd del 2008 e mi dava un sacco di problemi con i moduli da caricare....non mi funzionava il framebuffer....non mi funzionava una ceppa....
ritornando sul sito ho fatto caso che vicino al link del 2008 c'era scritto che avrebbero levato presto il link perche la 2008 era "deprecated"...allora ho pensato che forse con la 2007 avrei avuto meno problemi....e ho scaricato quindi il minimal.....ed in effetti da meno problemi....solo che ora non so cosa fare con questo emerge....

Edit1
Googlando ho trovato il metodo per smascherare manualmente i pacchetto
echo "..../....." >> /etc/portage/package.keywords
Cosa che non risolve assolutamente i miei problemi.....comincio a barcollare ma non mollo

Edit2
Ho provato anche ad aggiornare il profilo al 2008....quando faccio emerge non mi dice piu di aggiornare il profilo ma cmq i pacchetti rimangono mascherati.....

Il fatto è che non riesco a capire questo EAPI che ciufolo è?!.....cercando ho visto che di solito vengono mascherati i pacchetti quando sono ancora in beta...
invece a me li ha mascherati tutti....e smascherandoli manualmente uno ad uno non cambia nulla....
Facendo emerge --sync o emerge-webrsync sembra che vada tutto bene e aggiorna...però poi dando emerge portage o emerge -uDN portage o emerge gnome o emerge qualsiasi cosa è tutto mascherato.....
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Jun 06, 2009 12:33 pm    Post subject: Reply with quote

Ti consiglio di provare ad installare partendo dalla iso che trovi qui che perlomeno ti permette di partire da un sistema compilato con gcc-4.3, cosa che né i cd del 2008 né del 2007 forniscono.

Poi, credo che tu abbia fatto qualche dimenticanza nell'installazione, anziché la guida "for dummies" (non ho idea di dove tu possa averla trovata), cerca di seguire la guida ufficiale. Andando ad intuito mi viene da pensare che potrebbe mancarti l'indicazione ACCEPT_KEYWORDS="x86" in /etc/make.conf, ma è solo un'ipotesi.
Back to top
View user's profile Send private message
eraserhead
n00b
n00b


Joined: 05 Jun 2009
Posts: 6

PostPosted: Sat Jun 06, 2009 1:52 pm    Post subject: Reply with quote

riverdragon wrote:
Ti consiglio di provare ad installare partendo dalla iso che trovi qui che perlomeno ti permette di partire da un sistema compilato con gcc-4.3, cosa che né i cd del 2008 né del 2007 forniscono.

Poi, credo che tu abbia fatto qualche dimenticanza nell'installazione, anziché la guida "for dummies" (non ho idea di dove tu possa averla trovata), cerca di seguire la guida ufficiale. Andando ad intuito mi viene da pensare che potrebbe mancarti l'indicazione ACCEPT_KEYWORDS="x86" in /etc/make.conf, ma è solo un'ipotesi.


Ehm :D la guida l'ho trovata su gentoo.it....

E purtroppo, anche se quella stringa mancava nel make.conf, non è quello il problema....anche perche pur non essendoci, prima di fare emerge --sync funzionava anche senza....
Potrei dire una vaccata colossale, ma il problema non potrebbe essere che il mio kernel è il 2.6.19?! mi sembra molto vecchio.....

Cmq.......visto che googlando non si trova assolutamente nulla sull'argomento penso che seguirò il tuo consiglio e reinstallerò con questa versione, sperando che non mi dia problemi come la 2008....

....in giornata vi faccio sapere......
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Jun 06, 2009 3:00 pm    Post subject: Reply with quote

emerge --sync è semplicemente una sincronizzazione dell'albero di portage (gli ebuild e compagnia varia), ed è indipendente dall'architettura usata, quindi è normale che funzioni.
Per installare qualcosa invece portage ha bisogno di sapere che architettura stai usando, quindi se gli dici che sei su x86 è in grado di capire cosa non è mascherato, viceversa maschera tutto quanto.

Il kernel di certo non è la causa dei problemi.
Back to top
View user's profile Send private message
eraserhead
n00b
n00b


Joined: 05 Jun 2009
Posts: 6

PostPosted: Sat Jun 06, 2009 3:56 pm    Post subject: Reply with quote

riverdragon wrote:
emerge --sync è semplicemente una sincronizzazione dell'albero di portage (gli ebuild e compagnia varia), ed è indipendente dall'architettura usata, quindi è normale che funzioni.
Per installare qualcosa invece portage ha bisogno di sapere che architettura stai usando, quindi se gli dici che sei su x86 è in grado di capire cosa non è mascherato, viceversa maschera tutto quanto.

Il kernel di certo non è la causa dei problemi.


No non ha capito....dicevo che prima di fare la sincronizzazione, emerge funzionava.....ora non piu....

Cmq ho scaricato l'iso che mi hai indicato ma non funziona....ho bruciato 3 cd e l'hash era apposto.....mi si fermava nel montaggio delle device, non so perche....

Allora ho scaricato il minimal del 2008 e sto facendo la procedura manuale, sto compilando il kernel.....vi faccio sapere....
Back to top
View user's profile Send private message
eraserhead
n00b
n00b


Joined: 05 Jun 2009
Posts: 6

PostPosted: Sun Jun 07, 2009 11:35 am    Post subject: Reply with quote

Con la minimal 2008 è andata......gnome dopo un'intera notte a scaricare 354 pacchetti non funziona.....avessi saputo prima che gnome-light con 4 pacchetti ti dava un interfaccia minimale ma funzionante avrei scaricato direttamente quello....

Ancora non ho dato emerge -sync.......mi dovesse ridare problemi non mi va proprio di reinstallre tutto.....

Ora cerco di installare ndiswrapper.....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum