Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(Risolto) Passaggio a qt 4.5 blocchi
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Meconiotronic
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2007
Posts: 99

PostPosted: Thu Jun 04, 2009 8:28 pm    Post subject: (Risolto) Passaggio a qt 4.5 blocchi Reply with quote

Ragazzi sto ammattendo con il passaggio a qt 4.5

Ho questo blocco:

[blocks B ] >x11-libs/qt-gui-4.4.2-r9999 (">x11-libs/qt-gui-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-opengl-4.4.2, x11-libs/qt-webkit-4.4.2-r1)
[blocks B ] >x11-libs/qt-sql-4.4.2-r9999 (">x11-libs/qt-sql-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-opengl-4.4.2, x11-libs/qt-webkit-4.4.2-r1)
[blocks B ] <x11-libs/qt-xmlpatterns-4.5.1 ("<x11-libs/qt-xmlpatterns-4.5.1" is blocking x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1-r2, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks B ] >x11-libs/qt-webkit-4.4.2-r9999 (">x11-libs/qt-webkit-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-opengl-4.4.2)
[blocks B ] >x11-libs/qt-core-4.4.2-r9999 (">x11-libs/qt-core-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-opengl-4.4.2, x11-libs/qt-webkit-4.4.2-r1)
[blocks B ] >x11-libs/qt-svg-4.4.2-r9999 (">x11-libs/qt-svg-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-opengl-4.4.2, x11-libs/qt-webkit-4.4.2-r1)
[blocks B ] >x11-libs/qt-qt3support-4.4.2-r9999 (">x11-libs/qt-qt3support-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-opengl-4.4.2, x11-libs/qt-webkit-4.4.2-r1)
[blocks B ] >x11-libs/qt-opengl-4.4.2-r9999 (">x11-libs/qt-opengl-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-webkit-4.4.2-r1)
[blocks B ] >x11-libs/qt-dbus-4.4.2-r9999 (">x11-libs/qt-dbus-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-opengl-4.4.2, x11-libs/qt-webkit-4.4.2-r1)
[blocks B ] >x11-libs/qt-test-4.4.2-r9999 (">x11-libs/qt-test-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-opengl-4.4.2, x11-libs/qt-webkit-4.4.2-r1)
[blocks B ] >x11-libs/qt-script-4.4.2-r9999 (">x11-libs/qt-script-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-opengl-4.4.2, x11-libs/qt-webkit-4.4.2-r1)

Total: 89 packages (56 upgrades, 14 downgrades, 19 new, 1 uninstall), Size of downloads: 323,914 kB
Conflict: 24 blocks (11 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'x11-libs/qt-gui-4.5.1-r2', 'merge') pulled in by
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/krossruby-4.2.4', 'merge')
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/konqueror-4.2.4', 'merge')
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/plasma-workspace-4.2.4', 'merge')
(and 45 more)

('ebuild', '/', 'x11-libs/qt-test-4.5.1', 'merge') pulled in by
>=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'kde-base/kwin-4.2.4', 'merge')
>=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'kde-base/kde-menu-icons-4.2.4', 'merge')
>=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'kde-base/konqueror-4.2.4', 'merge')
(and 33 more)

('ebuild', '/', 'x11-libs/qt-qt3support-4.5.1', 'merge') pulled in by
>=x11-libs/qt-qt3support-4.5.1:4[accessibility] required by ('ebuild', '/', 'kde-base/kde-menu-icons-4.2.4', 'merge')
>=x11-libs/qt-qt3support-4.4.2:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.4.4-r2', 'merge')
>=x11-libs/qt-qt3support-4.5.1:4[accessibility] required by ('ebuild', '/', 'kde-base/konqueror-4.2.4', 'merge')
(and 33 more)

('ebuild', '/', 'x11-libs/qt-sql-4.5.1', 'merge') pulled in by
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/libtaskmanager-4.2.4', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kioclient-4.2.4', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kpasswdserver-4.2.4', 'merge')
(and 33 more)

('ebuild', '/', 'x11-libs/qt-svg-4.5.1-r1', 'merge') pulled in by
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/phonon-kde-4.2.4', 'merge')
x11-libs/qt-svg:4 required by ('installed', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'nomerge')
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/libplasmaclock-4.2.4', 'merge')
(and 33 more)

('ebuild', '/', 'x11-libs/qt-dbus-4.5.1', 'merge') pulled in by
x11-libs/qt-dbus:4 required by ('installed', '/', 'app-misc/strigi-0.6.5', 'nomerge')
x11-libs/qt-dbus:4 required by ('installed', '/', 'dev-libs/soprano-2.2.2', 'nomerge')
>=x11-libs/qt-dbus-4.4.0 required by ('ebuild', '/', 'x11-misc/google-gadgets-0.11.0', 'merge')
(and 4 more)

('ebuild', '/', 'x11-libs/qt-webkit-4.5.1', 'merge') pulled in by
>=x11-libs/qt-webkit-4.4.0 required by ('ebuild', '/', 'x11-misc/google-gadgets-0.11.0', 'merge')
>=x11-libs/qt-webkit-4.4.2:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.4.4-r2', 'merge')
>=x11-libs/qt-webkit-4.5.1:4 required by ('ebuild', '/', 'kde-base/kdelibs-4.2.4', 'merge')

('ebuild', '/', 'x11-libs/qt-script-4.5.1', 'merge') pulled in by
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/dolphin-4.2.4-r1', 'merge')
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/soliduiserver-4.2.4', 'merge')
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/phonon-kde-4.2.4', 'merge')
(and 34 more)

('ebuild', '/', 'x11-libs/qt-xmlpatterns-4.4.2', 'merge') pulled in by
x11-libs/qt-xmlpatterns:4 required by ('installed', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'nomerge')
>=x11-libs/qt-xmlpatterns-4.4.0 required by ('ebuild', '/', 'x11-misc/google-gadgets-0.11.0', 'merge')

('ebuild', '/', 'x11-libs/qt-core-4.5.1', 'merge') pulled in by
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/libkcddb-4.2.4', 'merge')
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/pykde4-4.2.4', 'merge')
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/soliduiserver-4.2.4', 'merge')
(and 45 more)

('ebuild', '/', 'x11-libs/qt-opengl-4.5.1', 'merge') pulled in by
>=x11-libs/qt-opengl-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.3.1', 'nomerge')
>=x11-libs/qt-opengl-4.5.1:4 required by ('ebuild', '/', 'kde-base/libplasmaclock-4.2.4', 'merge')
x11-libs/qt-opengl:4 required by ('installed', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'nomerge')
(and 6 more)

Non capisco come risolverlo.

Grazie


Last edited by Meconiotronic on Fri Jun 05, 2009 11:12 am; edited 1 time in total
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Fri Jun 05, 2009 12:20 am    Post subject: Reply with quote

controlla tutti i pacchetti qt marcati come 4.4 e rimuovili, inoltre controlla se hai x11-libs/qt-qt3support installato controlla che la use flag accessibility sia coerente con quella delle qt. inoltre per non tirarti matto metti temporaneamente i pacchetti qt-4.4 in package.mask, sintassi:
=categoria/nome-pacchetto-4.4* va bene.
in questo modo se hai dei blocchi ti verrà anche visualizzato quale pacchetto richiede ancora le qt 4.4.
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Fri Jun 05, 2009 5:57 am    Post subject: Reply with quote

A me portage li ha risolti da solo quei conflitti.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
table
Apprentice
Apprentice


Joined: 17 Feb 2007
Posts: 279
Location: Gazzaniga (BG) Italy

PostPosted: Fri Jun 05, 2009 7:53 am    Post subject: Reply with quote

bandreabis wrote:
A me portage li ha risolti da solo quei conflitti.


anche a me, me li ha risolti da solo.

In ogni caso dopo l'aggiornamento kwrite ha iniziato a dare i numeri, nel senso che parte del testo non viene visualizzato, mentre prima funzionava tutto :cry:
_________________
Pulisci l'html con:
Code:
sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'

skype: matteopinguino
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Fri Jun 05, 2009 10:27 am    Post subject: Reply with quote

a me no, motivo principale le flag use le imposto in package.use e non erano coerenti tra qt e qt-qt3-support per dirne una.
mi scazzava il fatto che skype richiedesse la flag use accessibility impostata e lyx no.
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Fri Jun 05, 2009 10:37 am    Post subject: Reply with quote

table wrote:
bandreabis wrote:
A me portage li ha risolti da solo quei conflitti.


anche a me, me li ha risolti da solo.

In ogni caso dopo l'aggiornamento kwrite ha iniziato a dare i numeri, nel senso che parte del testo non viene visualizzato, mentre prima funzionava tutto :cry:

Stasera do un occhio anche io a kwrite.

@l'uomodighiaccio:
come ti trovi con Lyx per LaTex?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Meconiotronic
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2007
Posts: 99

PostPosted: Fri Jun 05, 2009 11:10 am    Post subject: Reply with quote

Risolto, mancavano altri pacchetti al package.keywords che portage non mi segnalava.
A me kwrite sembra funzionare bene, in compenso non mi funziona più l'alt+f2 ... ci campo e ora mi trovo abbastanza male.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Jun 05, 2009 4:14 pm    Post subject: Reply with quote

bandreabis wrote:
A me portage li ha risolti da solo quei conflitti.

alla fina anche a me, ma solo dopo l'ultimo sync.
mi è sembrato, ad un certo punto, che mancasse qualche ebuild fondamentale.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Fri Jun 05, 2009 7:43 pm    Post subject: Reply with quote

OT
bandreabis wrote:

@l'uomodighiaccio:
come ti trovi con Lyx per LaTex?

beh... in effetti non è che lyx sia un frontend per latex. semplicemente utilizza latex come motore. tu scrivi normalmente, selezioni dal menu il tipo di layout che vuoi etc etc. il problema principale è che spesso e volentieri sputa fuori errori irrisolvibili (per me) e con un codice d'errore veramente scarno o vago.
A volte penso che sia meglio mettermi ad imparare latex piuttosto che rischiare di non finire quello che stavo facendo.

/OT
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Fri Jun 05, 2009 9:37 pm    Post subject: Reply with quote

Ic3M4n wrote:
OT
bandreabis wrote:

@l'uomodighiaccio:
come ti trovi con Lyx per LaTex?

beh... in effetti non è che lyx sia un frontend per latex. semplicemente utilizza latex come motore. tu scrivi normalmente, selezioni dal menu il tipo di layout che vuoi etc etc. il problema principale è che spesso e volentieri sputa fuori errori irrisolvibili (per me) e con un codice d'errore veramente scarno o vago.
A volte penso che sia meglio mettermi ad imparare latex piuttosto che rischiare di non finire quello che stavo facendo.

/OT

E' tipo kile?
Mi piacerebbe imparare LaTex, cosa consigli?

PS: è meglio se apriamo un topic in "Forum di discussione"?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sat Jun 06, 2009 12:37 am    Post subject: Reply with quote

no, non centra assolutamente nulla con kile.
beh... se ti servono altre info è meglio, o se un mod passa per caso può splittare?
in ogni caso se vuoi più info le trovi qui: http://www.lyx.org/
non credo ci sia metodo migliore per capire come funziona un programma della home page del progetto e di un
emerge lyx ;)
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Sat Jun 06, 2009 8:40 am    Post subject: Reply with quote

Prima di un emerge vorrei capire.
Volevo avere notizie di prima mano.
Lyx l'ho su windows, ma lo stesso avrei bisogno di aiuto da chi li conosce già (anche gli altri).
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
geps2
Apprentice
Apprentice


Joined: 12 Jul 2006
Posts: 267

PostPosted: Sun Jun 07, 2009 10:39 am    Post subject: Re: (Risolto) Passaggio a qt 4.5 blocchi Reply with quote

Meconiotronic wrote:
Ragazzi sto ammattendo con il passaggio a qt 4.5

Mi aggancio anch'io: dopo l'ultimo sync (e dopo un emerge portage) ho la serie incredibile di blocchi che riporto sotto.
Prima di emerge vorrei capire: dite che emerge risolve da solo?
Code:
~ # emerge -atuDNpv world
>>> --pretend disables --ask... removing --ask from options.

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] media-gfx/sane-backends-1.0.19-r2  USE="ipv6 -doc -gphoto2 -usb -v4l"
[ebuild     U ]  sys-libs/libieee1284-0.2.11 [0.2.8] USE="-doc" 273 kB
[nomerge      ] app-crypt/gnupg-2.0.11  USE="bzip2 ldap nls openct pcsc-lite smartcard -caps -doc (-selinux) -static"
[ebuild     U ]  sys-apps/pcsc-lite-1.5.3 [1.4.2] USE="-hal% -static -usb% (-debug%)" 459 kB
[nomerge      ] media-video/ffmpeg-0.5-r1  USE="3dnow 3dnowext X encode hardcoded-tables ipv6 mmx mmxext ssse3 vorbis xvid zlib -alsa (-altivec) -amr -bindist -custom-cflags -debug -dirac -doc -faac -faad -gsm -ieee1394 -jpeg2k -mp3 -network -oss -schroedinger -sdl -speex -test -theora -threads -v4l -v4l2 -vhook -x264"
[ebuild     U ]  media-libs/xvid-1.2.2-r1 [1.1.3] USE="-examples -pic% (-altivec%)" 629 kB
[nomerge      ] media-libs/libdvdread-0.9.7
[ebuild     U ]  media-libs/libdvdcss-1.2.10 [1.2.9-r1] USE="-doc" 302 kB
[ebuild     U ] x11-libs/qt-4.5.1 [4.4.2] USE="dbus* qt3support* -kde% -opengl" 0 kB
[ebuild     U ] net-ftp/vsftpd-2.1.0-r1 [2.1.0] USE="pam ssl tcpd -caps (-selinux) -xinetd" 0 kB
[ebuild     U ] net-misc/socat-1.7.1.0 [1.7.0.0] USE="ipv6 readline ssl tcpd" 412 kB
[ebuild     U ] sys-apps/iproute2-2.6.28 [2.6.26-r2] USE="berkdb -atm -minimal" 357 kB
[ebuild     U ] net-misc/tor-0.2.0.34-r2 [0.2.0.34] USE="bundledlibevent -debug" 0 kB
[ebuild  NS   ] sys-kernel/gentoo-sources-2.6.29-r5 [2.6.25-r8, 2.6.25-r9, 2.6.28-r5] USE="symlink -build" 55,376 kB
[ebuild     U ] sys-power/acpi-1.4 [0.06-r5] 85 kB
[nomerge      ] x11-libs/qt-svg-4.4.2  USE="-custom-cxxflags -debug -pch"
[blocks b     ]  >x11-libs/qt-script-4.4.2-r9999 (">x11-libs/qt-script-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks b     ]  >x11-libs/qt-test-4.4.2-r9999 (">x11-libs/qt-test-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-core-4.4.2-r2)
[nomerge      ] x11-libs/qt-test-4.4.2  USE="-custom-cxxflags -debug -pch"
[blocks b     ]  >x11-libs/qt-svg-4.4.2-r9999 (">x11-libs/qt-svg-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks b     ]  >x11-libs/qt-dbus-4.4.2-r9999 (">x11-libs/qt-dbus-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks b     ]  >x11-libs/qt-qt3support-4.4.2-r9999 (">x11-libs/qt-qt3support-4.4.2-r9999" is blocking x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks b     ]  >x11-libs/qt-assistant-4.4.2-r9999 (">x11-libs/qt-assistant-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks b     ]  >x11-libs/qt-phonon-4.4.2-r9999 (">x11-libs/qt-phonon-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks b     ]  >x11-libs/qt-core-4.4.2-r9999 (">x11-libs/qt-core-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2)
[blocks b     ]  >x11-libs/qt-webkit-4.4.2-r9999 (">x11-libs/qt-webkit-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[nomerge      ] x11-libs/qt-4.5.1 [4.4.2] USE="dbus* qt3support* -kde% -opengl"
[nomerge      ]  x11-libs/qt-assistant-4.5.1 [4.4.2-r1] USE="-custom-cxxflags -debug -pch (-webkit%*)"
[blocks b     ]   <x11-libs/qt-xmlpatterns-4.5.1 ("<x11-libs/qt-xmlpatterns-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-assistant-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[nomerge      ] x11-libs/qt-svg-4.4.2  USE="-custom-cxxflags -debug -pch"
[blocks b     ]  >x11-libs/qt-sql-4.4.2-r9999 (">x11-libs/qt-sql-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-script-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks b     ]  >x11-libs/qt-gui-4.4.2-r9999 (">x11-libs/qt-gui-4.4.2-r9999" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[ebuild     U ]   x11-libs/qt-xmlpatterns-4.5.1 [4.4.2] USE="-custom-cxxflags -debug -pch" 111,980 kB
[blocks b     ]    <x11-libs/qt-test-4.5.1 ("<x11-libs/qt-test-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-assistant-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks b     ]  >x11-libs/qt-xmlpatterns-4.4.2-r9999 (">x11-libs/qt-xmlpatterns-4.4.2-r9999" is blocking x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r3, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2-r2)
[ebuild     U ]   x11-libs/qt-test-4.5.1 [4.4.2] USE="iconv%* -custom-cxxflags -debug -pch" 0 kB
[blocks b     ]    <x11-libs/qt-svg-4.5.1 ("<x11-libs/qt-svg-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-assistant-4.5.1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ]     x11-libs/qt-svg-4.5.1-r1 [4.4.2] USE="iconv%* -custom-cxxflags -debug -pch" 0 kB
[blocks b     ]      <x11-libs/qt-assistant-4.5.1 ("<x11-libs/qt-assistant-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ]       x11-libs/qt-assistant-4.5.1 [4.4.2-r1] USE="-custom-cxxflags -debug -pch (-webkit%*)" 0 kB
[blocks b     ]        <x11-libs/qt-webkit-4.5.1 ("<x11-libs/qt-webkit-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-assistant-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1)
[ebuild     U ]         x11-libs/qt-webkit-4.5.1 [4.4.2-r1] USE="-custom-cxxflags -debug -kde% -pch" 0 kB
[ebuild  N    ]          x11-libs/qt-phonon-4.5.1  USE="dbus -custom-cxxflags -debug -pch" 0 kB
[blocks b     ]           <x11-libs/qt-qt3support-4.5.1 ("<x11-libs/qt-qt3support-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-assistant-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ]            x11-libs/qt-qt3support-4.5.1 [4.4.2] USE="accessibility -custom-cxxflags -debug -kde% -pch -phonon%" 0 kB
[blocks b     ]             <x11-libs/qt-gui-4.5.1 ("<x11-libs/qt-gui-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-assistant-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ]              x11-libs/qt-gui-4.5.1 [4.4.2-r3] USE="accessibility cups dbus glib gtkstyle%* qt3support -custom-cxxflags -debug -mng -nas -nis -pch -raster% -tiff -xinerama" INPUT_DEVICES="(-wacom%)" 0 kB
[blocks b     ]               <x11-libs/qt-script-4.5.1 ("<x11-libs/qt-script-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-assistant-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ]                x11-libs/qt-script-4.5.1 [4.4.2] USE="iconv%* -custom-cxxflags -debug -pch" 0 kB
[blocks b     ]                 <x11-libs/qt-sql-4.5.1 ("<x11-libs/qt-sql-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-assistant-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ]                  x11-libs/qt-sql-4.5.1 [4.4.2-r1] USE="iconv mysql qt3support sqlite -custom-cxxflags -debug -firebird -odbc -pch -postgres" 0 kB
[blocks b     ]                   <x11-libs/qt-dbus-4.5.1 ("<x11-libs/qt-dbus-4.5.1" is blocking x11-libs/qt-phonon-4.5.1, x11-libs/qt-assistant-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ]                    x11-libs/qt-dbus-4.5.1 [4.4.2] USE="-custom-cxxflags -debug -pch" 0 kB
[ebuild     U ]                     x11-libs/qt-core-4.5.1 [4.4.2-r2] USE="glib iconv qt3support ssl -custom-cxxflags -debug -doc -pch" 0 kB
[ebuild  N    ]           media-libs/gst-plugins-base-0.10.22  USE="nls -debug" 2,069 kB
[ebuild  N    ]            media-libs/gstreamer-0.10.22  USE="nls -test" 2,699 kB
[ebuild  N    ]             dev-libs/check-0.9.5-r1  509 kB
[ebuild  N    ]            dev-libs/liboil-0.3.15  USE="-doc" 803 kB

Total: 27 packages (21 upgrades, 5 new, 1 in new slot), Size of downloads: 175,948 kB
Conflict: 22 blocks
Back to top
View user's profile Send private message
geps2
Apprentice
Apprentice


Joined: 12 Jul 2006
Posts: 267

PostPosted: Thu Jun 11, 2009 5:50 pm    Post subject: Re: (Risolto) Passaggio a qt 4.5 blocchi Reply with quote

geps2 wrote:
Prima di emerge vorrei capire: dite che emerge risolve da solo?

Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Fri Jun 12, 2009 8:22 pm    Post subject: Reply with quote

è successo anche a me però mi sono rotto subito le balle e ho aggiornato esplicitamente i pacchetti delle qt con l'opzione -O

bandreabis wrote:

E' tipo kile?
Mi piacerebbe imparare LaTex, cosa consigli?
http://users.dimi.uniud.it/~gianluca.gorni/TeX/itTeXdoc/CorsoTeX.pdf
io ho letto questo per fare la tesi
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum