Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 3.5 Blockers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
causality
Apprentice
Apprentice


Joined: 03 Jun 2006
Posts: 163

PostPosted: Sat May 30, 2009 7:08 pm    Post subject: KDE 3.5 Blockers Reply with quote

So I haven't performed an "emerge --sync" and "emerge --update --deep world" for a bit less than a month. Today I do the sync and I checked the output of "emerge --update --deep --pretend world". This is what I saw:

Code:

localhost ~ # ionice -c2 -n7 nice -n 20 emerge --update --deep world --pretend

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] sys-devel/gcc-config-1.4.1 [1.4.0-r4]
[ebuild     U ] dev-db/sqlite-3.6.14.2 [3.6.14]
[ebuild     U ] app-arch/cabextract-1.2-r1 [1.2] USE="-extra-tools%"
[ebuild     U ] dev-libs/libevent-1.4.10 [1.4.9]
[ebuild     U ] dev-java/java-config-wrapper-0.16 [0.15]
[ebuild  N    ] virtual/cdrtools-0
[ebuild     U ] net-misc/ntp-4.2.4_p7 [4.2.4_p6]
[ebuild  N    ] dev-util/boost-build-1.35.0-r1  USE="python -examples"
[ebuild     U ] dev-python/pysqlite-2.5.5 [2.4.1]
[ebuild  N    ] dev-libs/boost-1.35.0-r2  USE="-debug -doc -expat -icu -mpi -tools"
[ebuild     U ] app-admin/eselect-1.0.12 [1.0.11-r1]
[ebuild     U ] app-admin/syslog-ng-2.1.4 [2.1.3]
[ebuild     U ] media-sound/mpg123-1.7.3 [1.7.2]
[ebuild  NS   ] sys-kernel/hardened-sources-2.6.28-r9 [2.6.28-r6, 2.6.28-r7] USE="symlink -build"
[ebuild     U ] x11-libs/pango-1.24.2 [1.22.4]
[ebuild     U ] dev-util/cmake-2.6.4 [2.6.2-r1]
[ebuild  NS   ] sys-libs/db-4.6.21_p4 [4.5.20_p2-r1] USE="-doc -java -nocxx -tcl -test"
[ebuild     U ] dev-libs/libusb-0.1.12-r5 [0.1.12-r1] USE="-nocxx%"
[ebuild     U ] media-libs/libvorbis-1.2.1_rc1-r2 [1.2.1_rc1] USE="aotuv%*"
[ebuild     U ] sys-boot/grub-0.97-r9 [0.97-r6]
[ebuild  N    ] virtual/libusb-0
[ebuild     U ] media-libs/libsndfile-1.0.20 [1.0.19] USE="-jack%"
[ebuild     U ] media-gfx/imagemagick-6.5.2.9 [6.5.1.0]
[ebuild     U ] net-misc/whois-4.7.30 [4.7.27]
[ebuild  N    ] kde-base/kdialog-3.5.9-r1  USE="kdeenablefinal -arts -debug -kdehiddenvisibility -xinerama"
[ebuild  N    ] kde-base/libkonq-3.5.9  USE="kdeenablefinal -arts -debug -kdehiddenvisibility -xinerama"
[ebuild     U ] net-analyzer/wireshark-1.0.8 [1.0.7]
[ebuild     U ] x11-misc/icon-naming-utils-0.8.90 [0.8.7]
[ebuild  N    ] kde-base/kdebase-kioslaves-3.5.9  USE="hal kdeenablefinal -arts -debug -kdehiddenvisibility -ldap -openexr -samba -xinerama"
[ebuild     U ] app-emulation/wine-1.1.22 [1.1.21]
[ebuild     U ] kde-misc/krusader-1.90.0-r1 [1.90.0]
[ebuild     U ] gnome-base/gnome-desktop-2.24.3-r1 [2.24.3]
[ebuild     U ] x11-base/xorg-server-1.5.3-r6 [1.5.3-r5]
[ebuild     U ] gnome-base/nautilus-2.24.2-r3 [2.24.2]
[ebuild  NS   ] net-p2p/ktorrent-2.2.8-r2 [2.2.8] USE="kdeenablefinal -arts -avahi -debug -xinerama" LINGUAS="-ar -bg -br -ca -cs -cy -da -de -el -en_GB -es -et -fa -fr -gl -hu -it -ja -ka -lt -ms -nb -nds -nl -pa -pl -pt -pt_BR -ru -rw -sk -sr -sr@Latn -sv -tr -uk -zh_CN -zh_TW"
[uninstall    ] net-p2p/ktorrent-2.2.8
[blocks b     ] <net-p2p/ktorrent-2.2.8-r2 ("<net-p2p/ktorrent-2.2.8-r2" is blocking net-p2p/ktorrent-2.2.8-r2)
[blocks B     ] kde-base/kdebase-kioslaves:3.5 ("kde-base/kdebase-kioslaves:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/libkonq:3.5 ("kde-base/libkonq:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdialog:3.5 ("kde-base/kdialog:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] =kde-base/kdebase-3.5* ("=kde-base/kdebase-3.5*" is blocking kde-base/kdebase-kioslaves-3.5.9, kde-base/kdialog-3.5.9-r1, kde-base/libkonq-3.5.9)                                                                                                                                                         

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'kde-base/kdebase-kioslaves-3.5.9', 'merge') pulled in by
    kde-base/kdebase-kioslaves:3.5 required by ('ebuild', '/', 'net-p2p/ktorrent-2.2.8-r2', 'merge')
    kde-base/kdebase-kioslaves:3.5 required by ('ebuild', '/', 'kde-misc/krusader-1.90.0-r1', 'merge')

  ('ebuild', '/', 'kde-base/libkonq-3.5.9', 'merge') pulled in by
    kde-base/libkonq:3.5 required by ('ebuild', '/', 'kde-misc/krusader-1.90.0-r1', 'merge')

  ('installed', '/', 'kde-base/kdebase-3.5.9-r4', 'nomerge') pulled in by
    =kde-base/kdebase-3.5* required by ('installed', '/', 'x11-themes/fusionx-aqua-1.1', 'nomerge')
    kde-base/kdebase required by world
    ~kde-base/kdebase-3.5.9 required by ('installed', '/', 'kde-base/kdeutils-3.5.9-r1', 'nomerge')
    (and 15 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

localhost ~ #


I decided that since items like kdebase/kdialog and kdebase/kdebase-kioslaves were conflicting with kdebase/kdebase, that perhaps I should stop using the monolithic kdebase/kdebase package. So I did "emerge --unmerge kdebase" followed by "emerge kdebase-meta". All 43 packages built and installed without issue. So now I thought my "emerge --update --deep world" should go smoothly now. Then I received a surprise. This is what happens when I do that now:

Code:

localhost ~ # ionice -c2 -n7 nice -n 20 emerge --update --deep world --pretend

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] sys-devel/gcc-config-1.4.1 [1.4.0-r4]
[ebuild     U ] dev-db/sqlite-3.6.14.2 [3.6.14]
[ebuild     U ] app-arch/cabextract-1.2-r1 [1.2] USE="-extra-tools%"
[ebuild     U ] dev-libs/libevent-1.4.10 [1.4.9]
[ebuild     U ] dev-java/java-config-wrapper-0.16 [0.15]
[ebuild  N    ] virtual/cdrtools-0
[ebuild     U ] net-misc/ntp-4.2.4_p7 [4.2.4_p6]
[ebuild  N    ] dev-util/boost-build-1.35.0-r1  USE="python -examples"
[ebuild     U ] dev-python/pysqlite-2.5.5 [2.4.1]
[ebuild  N    ] dev-libs/boost-1.35.0-r2  USE="-debug -doc -expat -icu -mpi -tools"
[ebuild     U ] app-admin/eselect-1.0.12 [1.0.11-r1]
[ebuild     U ] app-admin/syslog-ng-2.1.4 [2.1.3]
[ebuild     U ] media-sound/mpg123-1.7.3 [1.7.2]
[ebuild  NS   ] sys-kernel/hardened-sources-2.6.28-r9 [2.6.28-r6, 2.6.28-r7] USE="symlink -build"
[ebuild     U ] x11-libs/pango-1.24.2 [1.22.4]
[ebuild     U ] dev-util/cmake-2.6.4 [2.6.2-r1]
[ebuild  NS   ] sys-libs/db-4.6.21_p4 [4.5.20_p2-r1] USE="-doc -java -nocxx -tcl -test"
[ebuild     U ] dev-libs/libusb-0.1.12-r5 [0.1.12-r1] USE="-nocxx%"
[ebuild     U ] media-libs/libvorbis-1.2.1_rc1-r2 [1.2.1_rc1] USE="aotuv%*"
[ebuild     U ] sys-boot/grub-0.97-r9 [0.97-r6]
[ebuild  N    ] virtual/libusb-0
[ebuild     U ] media-libs/libsndfile-1.0.20 [1.0.19] USE="-jack%"
[ebuild     U ] media-gfx/imagemagick-6.5.2.9 [6.5.1.0]
[ebuild     U ] net-misc/whois-4.7.30 [4.7.27]
[ebuild     U ] net-analyzer/wireshark-1.0.8 [1.0.7]
[ebuild     U ] x11-misc/icon-naming-utils-0.8.90 [0.8.7]
[ebuild     U ] app-emulation/wine-1.1.22 [1.1.21]
[ebuild  N    ] kde-base/kdebase-3.5.9-r4  USE="cups hal joystick kdeenablefinal opengl pam xcomposite xscreensaver -arts -branding -debug -ieee1394 -java -kdehiddenvisibility -ldap -lm_sensors -logitech-mouse -openexr -samba -xinerama"
[ebuild     U ] kde-misc/krusader-1.90.0-r1 [1.90.0]
[ebuild     U ] gnome-base/gnome-desktop-2.24.3-r1 [2.24.3]
[ebuild     U ] x11-base/xorg-server-1.5.3-r6 [1.5.3-r5]
[ebuild     U ] gnome-base/nautilus-2.24.2-r3 [2.24.2]
[ebuild  NS   ] net-p2p/ktorrent-2.2.8-r2 [2.2.8] USE="kdeenablefinal -arts -avahi -debug -xinerama" LINGUAS="-ar -bg -br -ca -cs -cy -da -de -el -en_GB -es -et -fa -fr -gl -hu -it -ja -ka -lt -ms -nb -nds -nl -pa -pl -pt -pt_BR -ru -rw -sk -sr -sr@Latn -sv -tr -uk -zh_CN -zh_TW"
[uninstall    ] net-p2p/ktorrent-2.2.8
[blocks b     ] <net-p2p/ktorrent-2.2.8-r2 ("<net-p2p/ktorrent-2.2.8-r2" is blocking net-p2p/ktorrent-2.2.8-r2)
[blocks B     ] kde-base/ksystraycmd:3.5 ("kde-base/ksystraycmd:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdeprint:3.5 ("kde-base/kdeprint:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/ksplashml:3.5 ("kde-base/ksplashml:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/khelpcenter:3.5 ("kde-base/khelpcenter:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kicker:3.5 ("kde-base/kicker:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/ksysguard:3.5 ("kde-base/ksysguard:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kpager:3.5 ("kde-base/kpager:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/ktip:3.5 ("kde-base/ktip:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/konsole:3.5 ("kde-base/konsole:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/konqueror:3.5 ("kde-base/konqueror:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdcop:3.5 ("kde-base/kdcop:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kreadconfig:3.5 ("kde-base/kreadconfig:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kate:3.5 ("kde-base/kate:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/drkonqi:3.5 ("kde-base/drkonqi:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdialog:3.5 ("kde-base/kdialog:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] =kde-base/kdebase-3.5* ("=kde-base/kdebase-3.5*" is blocking kde-base/ksystraycmd-3.5.9, kde-base/knetattach-3.5.9, kde-base/kdialog-3.5.9-r1, kde-base/kappfinder-3.5.9, kde-base/konsole-3.5.9, kde-base/kscreensaver-3.5.9, kde-base/kfind-3.5.9, kde-base/kcheckpass-3.5.9, kde-base/kmenuedit-3.5.9, kde-base/kreadconfig-3.5.9, kde-base/kate-3.5.9, kde-base/kpager-3.5.9, kde-base/ksmserver-3.5.9, kde-base/khotkeys-3.5.9, kde-base/kdebase-kioslaves-3.5.9, kde-base/drkonqi-3.5.9, kde-base/kdeprint-3.5.9, kde-base/kdebase-data-3.5.9, kde-base/kdepasswd-3.5.9, kde-base/nsplugins-3.5.9, kde-base/kdebase-startkde-3.5.9, kde-base/kdesu-3.5.9, kde-base/klipper-3.5.9, kde-base/kdebugdialog-3.5.9, kde-base/ksysguard-3.5.9, kde-base/kdcop-3.5.9, kde-base/kdesktop-3.5.9-r1, kde-base/khelpcenter-3.5.9, kde-base/libkonq-3.5.9, kde-base/kcontrol-3.5.9, kde-base/kpersonalizer-3.5.9, kde-base/konqueror-3.5.9, kde-base/kstart-3.5.9, kde-base/ktip-3.5.9, kde-base/ksplashml-3.5.9, kde-base/kicker-3.5.9, kde-base/kxkb-3.5.9, kde-base/kwin-3.5.9-r1, kde-base/kdm-3.5.9, kde-base/kcminit-3.5.9)
[blocks B     ] kde-base/nsplugins:3.5 ("kde-base/nsplugins:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/knetattach:3.5 ("kde-base/knetattach:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kxkb:3.5 ("kde-base/kxkb:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kappfinder:3.5 ("kde-base/kappfinder:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/libkonq:3.5 ("kde-base/libkonq:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kstart:3.5 ("kde-base/kstart:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kfind:3.5 ("kde-base/kfind:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kpersonalizer:3.5 ("kde-base/kpersonalizer:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kmenuedit:3.5 ("kde-base/kmenuedit:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kwin:3.5 ("kde-base/kwin:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kcontrol:3.5 ("kde-base/kcontrol:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdesktop:3.5 ("kde-base/kdesktop:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/khotkeys:3.5 ("kde-base/khotkeys:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdepasswd:3.5 ("kde-base/kdepasswd:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdebase-kioslaves:3.5 ("kde-base/kdebase-kioslaves:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdebase-data:3.5 ("kde-base/kdebase-data:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kcheckpass:3.5 ("kde-base/kcheckpass:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/ksmserver:3.5 ("kde-base/ksmserver:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdm:3.5 ("kde-base/kdm:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdebugdialog:3.5 ("kde-base/kdebugdialog:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/klipper:3.5 ("kde-base/klipper:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdesu:3.5 ("kde-base/kdesu:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kscreensaver:3.5 ("kde-base/kscreensaver:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdebase-startkde:3.5 ("kde-base/kdebase-startkde:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kcminit:3.5 ("kde-base/kcminit:3.5" is blocking kde-base/kdebase-3.5.9-r4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'kde-base/kdebase-3.5.9-r4', 'merge') pulled in by
    ~kde-base/kdebase-3.5.9 required by ('installed', '/', 'kde-base/kde-3.5.9', 'nomerge')
    ~kde-base/kdebase-3.5.9 required by ('installed', '/', 'kde-base/kdeadmin-3.5.9', 'nomerge')
    ~kde-base/kdebase-3.5.9 required by ('installed', '/', 'kde-base/kdegames-3.5.9', 'nomerge')
    (and 5 more)

  ('installed', '/', 'kde-base/kcontrol-3.5.9', 'nomerge') pulled in by
    kde-base/kcontrol required by ('installed', '/', 'x11-themes/redhat-artwork-5.0.8-r4', 'nomerge')
    >=kde-base/kcontrol-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdejava-3.5.9', 'nomerge')
    >=kde-base/kcontrol-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    (and 4 more)

  ('installed', '/', 'kde-base/kdesu-3.5.9', 'nomerge') pulled in by
    kde-base/kdesu required by ('installed', '/', 'sys-apps/qtparted-0.4.5', 'nomerge')
    >=kde-base/kdesu-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    kde-base/kdesu required by ('installed', '/', 'app-portage/portato-0.12.1', 'nomerge')
    (and 1 more)

  ('installed', '/', 'kde-base/ksysguard-3.5.9', 'nomerge') pulled in by
    >=kde-base/ksysguard-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kpersonalizer-3.5.9', 'nomerge') pulled in by
    >=kde-base/kpersonalizer-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-startkde-3.5.9', 'nomerge')
    >=kde-base/kpersonalizer-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kdebase-kioslaves-3.5.9', 'nomerge') pulled in by
    >=kde-base/kdebase-kioslaves-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    kde-base/kdebase-kioslaves:3.5 required by ('ebuild', '/', 'net-p2p/ktorrent-2.2.8-r2', 'merge')
    kde-base/kdebase-kioslaves:3.5 required by ('ebuild', '/', 'kde-misc/krusader-1.90.0-r1', 'merge')
    (and 2 more)

  ('installed', '/', 'kde-base/knetattach-3.5.9', 'nomerge') pulled in by
    >=kde-base/knetattach-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/libkonq-3.5.9', 'nomerge') pulled in by
    kde-base/libkonq:3.5 required by ('ebuild', '/', 'kde-misc/krusader-1.90.0-r1', 'merge')
    >=kde-base/libkonq-3.5.9:3.5 required by ('installed', '/', 'kde-base/kcontrol-3.5.9', 'nomerge')
    >=kde-base/libkonq-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    (and 5 more)

  ('installed', '/', 'kde-base/kdebugdialog-3.5.9', 'nomerge') pulled in by
    >=kde-base/kdebugdialog-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kwin-3.5.9-r1', 'nomerge') pulled in by
    kde-base/kwin required by ('installed', '/', 'x11-themes/redhat-artwork-5.0.8-r4', 'nomerge')
    =kde-base/kwin-3.5* required by ('installed', '/', 'x11-themes/liquid-0.9.7', 'nomerge')
    =kde-base/kwin-3.5* required by ('installed', '/', 'x11-themes/qinx-1.4', 'nomerge')
    (and 5 more)

  ('installed', '/', 'kde-base/ktip-3.5.9', 'nomerge') pulled in by
    >=kde-base/ktip-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kdm-3.5.9', 'nomerge') pulled in by
    >=kde-base/kdm-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/ksystraycmd-3.5.9', 'nomerge') pulled in by
    >=kde-base/ksystraycmd-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kfind-3.5.9', 'nomerge') pulled in by
    >=kde-base/kfind-3.5.9:3.5 required by ('installed', '/', 'kde-base/konqueror-3.5.9', 'nomerge')
    >=kde-base/kfind-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/ksplashml-3.5.9', 'nomerge') pulled in by
    >=kde-base/ksplashml-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-startkde-3.5.9', 'nomerge')
    >=kde-base/ksplashml-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kstart-3.5.9', 'nomerge') pulled in by
    >=kde-base/kstart-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/konsole-3.5.9', 'nomerge') pulled in by
    >=kde-base/konsole-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kicker-3.5.9', 'nomerge') pulled in by
    >=kde-base/kicker-3.5.9:3.5 required by ('installed', '/', 'kde-base/kcontrol-3.5.9', 'nomerge')
    >=kde-base/kicker-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    >=kde-base/kicker-3.5.9:3.5 required by ('installed', '/', 'kde-base/kappfinder-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kxkb-3.5.9', 'nomerge') pulled in by
    >=kde-base/kxkb-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kdeprint-3.5.9', 'nomerge') pulled in by
    >=kde-base/kdeprint-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kcheckpass-3.5.9', 'nomerge') pulled in by
    >=kde-base/kcheckpass-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdesktop-3.5.9-r1', 'nomerge')
    >=kde-base/kcheckpass-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/konqueror-3.5.9', 'nomerge') pulled in by
    >=kde-base/konqueror-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    =kde-base/konqueror-3.5* required by ('installed', '/', 'x11-themes/baghira-0.7', 'nomerge')
    =kde-base/konqueror-3.5* required by ('installed', '/', 'media-sound/amarok-1.4.10-r2', 'nomerge')
    (and 1 more)

  ('installed', '/', 'kde-base/kscreensaver-3.5.9', 'nomerge') pulled in by
    >=kde-base/kscreensaver-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/khotkeys-3.5.9', 'nomerge') pulled in by
    >=kde-base/khotkeys-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    >=kde-base/khotkeys-3.5.9:3.5 required by ('installed', '/', 'kde-base/kcontrol-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kreadconfig-3.5.9', 'nomerge') pulled in by
    >=kde-base/kreadconfig-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-startkde-3.5.9', 'nomerge')
    >=kde-base/kreadconfig-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kdialog-3.5.9-r1', 'nomerge') pulled in by
    >=kde-base/kdialog-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdesktop-3.5.9-r1', 'nomerge')
    >=kde-base/kdialog-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    >=kde-base/kdialog-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-kioslaves-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kcminit-3.5.9', 'nomerge') pulled in by
    >=kde-base/kcminit-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-startkde-3.5.9', 'nomerge')
    >=kde-base/kcminit-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    >=kde-base/kcminit-3.5.9:3.5 required by ('installed', '/', 'kde-base/kcontrol-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/drkonqi-3.5.9', 'nomerge') pulled in by
    >=kde-base/drkonqi-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kappfinder-3.5.9', 'nomerge') pulled in by
    >=kde-base/kappfinder-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kmenuedit-3.5.9', 'nomerge') pulled in by
    >=kde-base/kmenuedit-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/khelpcenter-3.5.9', 'nomerge') pulled in by
    >=kde-base/khelpcenter-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    >=kde-base/khelpcenter-3.5.9:3.5 required by ('installed', '/', 'kde-base/kcontrol-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kdepasswd-3.5.9', 'nomerge') pulled in by
    >=kde-base/kdepasswd-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    >=kde-base/kdepasswd-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdm-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/klipper-3.5.9', 'nomerge') pulled in by
    >=kde-base/klipper-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/nsplugins-3.5.9', 'nomerge') pulled in by
    >=kde-base/nsplugins-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kdebase-startkde-3.5.9', 'nomerge') pulled in by
    >=kde-base/kdebase-startkde-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kdcop-3.5.9', 'nomerge') pulled in by
    >=kde-base/kdcop-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kate-3.5.9', 'nomerge') pulled in by
    >=kde-base/kate-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kdesktop-3.5.9-r1', 'nomerge') pulled in by
    >=kde-base/kdesktop-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')
    >=kde-base/kdesktop-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdm-3.5.9', 'nomerge')
    >=kde-base/kdesktop-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-startkde-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kpager-3.5.9', 'nomerge') pulled in by
    >=kde-base/kpager-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kdebase-data-3.5.9', 'nomerge') pulled in by
    >=kde-base/kdebase-data-3.5.9:3.5 required by ('installed', '/', 'kde-base/kcontrol-3.5.9', 'nomerge')
    >=kde-base/kdebase-data-3.5.9:3.5 required by ('installed', '/', 'kde-base/kicker-3.5.9', 'nomerge')
    >=kde-base/kdebase-data-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/ksmserver-3.5.9', 'nomerge') pulled in by
    >=kde-base/ksmserver-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-startkde-3.5.9', 'nomerge')
    >=kde-base/ksmserver-3.5.9:3.5 required by ('installed', '/', 'kde-base/kdebase-meta-3.5.9', 'nomerge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

localhost ~ #                                                                                                             


The problem is that the dependencies are listed as "kdebase/kdebase" and not as "kdebase/whatever_specific_app". So even though I have every last component of kdebase, it's not recognizing this when it comes time to determine the dependencies, like so:

Code:

ocalhost ~ # equery depends kdebase
[ Searching for packages depending on kdebase... ]
app-portage/portato-0.12.1 (!userpriv & kde? kde-base/kdebase)
kde-base/kde-3.5.9 (~kde-base/kdebase-3.5.9)
kde-base/kdeadmin-3.5.9 (~kde-base/kdebase-3.5.9)
kde-base/kdeartwork-3.5.9 (~kde-base/kdebase-3.5.9)
kde-base/kdegames-3.5.9 (~kde-base/kdebase-3.5.9)
kde-base/kdegraphics-3.5.9 (~kde-base/kdebase-3.5.9)
kde-base/kdejava-3.5.9 (>=kde-base/kdebase-3.5.9:3.5)
kde-base/kdenetwork-3.5.9 (~kde-base/kdebase-3.5.9)
kde-base/kdepim-3.5.9-r1 (~kde-base/kdebase-3.5.9)
kde-base/kdeutils-3.5.9-r1 (~kde-base/kdebase-3.5.9)
kde-misc/krusader-1.90.0 (kde? =kde-base/kdebase-3.5*)
mail-client/kbiff-3.8 (=kde-base/kdebase-3.5*)
media-sound/amarok-1.4.10-r2 (kde? =kde-base/kdebase-3.5*)
net-p2p/ktorrent-2.2.8 (=kde-base/kdebase-3.5*)
sys-apps/qtparted-0.4.5 (kde? kde-base/kdebase)
x11-themes/baghira-0.7 (=kde-base/kdebase-3.5*)
x11-themes/fusionx-aqua-1.1 (=kde-base/kdebase-3.5*)
x11-themes/liquid-0.9.7 (=kde-base/kdebase-3.5*)
x11-themes/qinx-1.4 (=kde-base/kdebase-3.5*)
x11-themes/redhat-artwork-5.0.8-r4 (kde? kde-base/kdebase)
localhost ~ #


I have read other posts that state you can have either monolithic KDE packages, or the individual ones, but not both. I think I would like to migrate to the individual packages. So how would I complete that migration in a way that gets rid of this problem? Can anyone help?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7897

PostPosted: Sun May 31, 2009 5:59 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, refer to "Blocked package confusion".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum