Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema xinit e flag use
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Tue May 26, 2009 5:09 pm    Post subject: Problema xinit e flag use Reply with quote

Ciao a tutti, da poco uso gentoo e sto riscontrando tante difficolta nel capire il sistema portage ed usare emerge...
Comunque volevo installare il server x ma mi fallisce la compilazione della libreria xinit, ho provato a compilare solo questa ma il risultato non cambia...
l'errore che ottengo è :
Code:

you must build sys-apps/dbus with the x Use flag enabled.

ERROR : mi dice che è fallita la compilazione
Call stack
ebuild.sh line 48 :called pkg_setup
xinit-1.0.8-r4.ebuild, line 36 : Called die


Poi scrive un paio di volte la frase iniziale... ( non avevo voglia di riscreverla)

da quel che ho capito è colpa del mio flag use!!!

Allora ho pensato di settare il flag use apposta per questo pachetto, quindi ho dato il comando emerge -pv xinit, ma quando vado a cercare il file :
/etc/portage/package.use non trovo neanche la cartella. Che faccio la creo io e dentro ci metto la configurazione del flag use relativa a quel paccheto???

Il flag use che ho nel file make.conf è :
Code:

USE=" gtk -qt3 -qt4 -kde dvd alsa hal dbus wifi pam -debug -minimal"

Tengo a precisare che , pam -debug -minimal, li ho aggiunti per il file xinit, ottenuti come ho detto prima!
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue May 26, 2009 5:27 pm    Post subject: Reply with quote

puoi postare l'output di eselect profile list e emerge --info? Si parte da li quando le use portano rogna.
In ogni caso mi pare che ti manchi la use X globale.
I file o le directory /etc/portage/package.* vanno creati manulmente ed usati "cum grano salis" di guareschiana memoria. :wink:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Tue May 26, 2009 5:58 pm    Post subject: Reply with quote

Ho aggiunto il flag X ma non è cambiato niente!! Ho lanciato i comando che mi hai detto e i risultati sono stati :

eselect :
Code:

Available profile symlink targets:
  [1]   default/linux/x86/2008.0 *
  [2]   default/linux/x86/2008.0/desktop
  [3]   default/linux/x86/2008.0/developer
  [4]   default/linux/x86/2008.0/server
  [5]   hardened/x86
  [6]   selinux/2007.0/x86
  [7]   selinux/2007.0/x86/hardened
  [8]   hardened/linux/x86


emerge --info

Code:

Portage 2.1.6.11 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r5 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.28-gentoo-r5-i686-Intel-R-_Pentium-R-_M_processor_1.73GHz-with-glibc2.0
Timestamp of tree: Tue, 26 May 2009 06:00:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.4-r2
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa berkdb bzip2 cli cracklib crypt cups dbus dri dvd fortran gdbm gpm gtk hal iconv ipv6 isdnlog midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl ssl sysfs tcpd unicode wifi x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue May 26, 2009 10:50 pm    Post subject: Reply with quote

Code:
emerge -1NDu dbus ; emerge -1NDu hal ; emerge -1NDu xinit
vedi se si sblocca.

Personalmente selezionerei il profilo desktop ed andrei a disabilitare globalmente le use che non ti servono e provere a lanciare un
Code:
emerge -NDuv system ; emerge -NDuv world ; revdep-rebuild -i
ma facile che peggiori le cose.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Wed May 27, 2009 8:34 am    Post subject: Reply with quote

ora è andata!! e ho selzionato il profilo desktop....

Ma quindi il poblema era installare dbus e hal???
Quindi se mi si ripresenta lo stesso problema mi conviene installare i pacchetti con le opzioni che mi hai postato qui, soprattutto con -D per includere tutte le dipedenzee d N che non ho capito bene a che serva...
Back to top
View user's profile Send private message
table
Apprentice
Apprentice


Joined: 17 Feb 2007
Posts: 279
Location: Gazzaniga (BG) Italy

PostPosted: Wed May 27, 2009 9:45 am    Post subject: Reply with quote

Pes88 wrote:


-D per includere tutte le dipedenzee d N che non ho capito bene a che serva...


N sta per newuse, verifica se vi sono stati cambiamenti nelle use flags e, se sì, ricompila i pacchetti interessati da questi cambiamenti
_________________
Pulisci l'html con:
Code:
sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'

skype: matteopinguino


Last edited by table on Wed May 27, 2009 10:53 am; edited 1 time in total
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Wed May 27, 2009 10:27 am    Post subject: Reply with quote

Pes88 wrote:
Ma quindi il poblema era installare dbus e hal???
no, il probelma era compilare dbus con la use X attivata (di default col profilo desktop), cosa che il messaggio di errore stesso ti ha suggerito di fare
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Wed May 27, 2009 11:03 am    Post subject: Reply with quote

OK!!! Capito... grazie per la spiegazione...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum