Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Correzione login manager [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat May 23, 2009 3:17 pm    Post subject: Correzione login manager [RISOLTO] Reply with quote

Ho eseguito un'aggiornamento di un file di configurazione e innavvertitamente ho modificato il login manager da gdm a xdm, che non mi riconosce più nè tastiera nè mouse.
Quest'operazione non l'ho mai eseguita e anche cercando in giro non sono riuscito a trovare un'aiuto utile per risolvere la situazione.
Immagino di dover usare il minimal cd per correggere il tutto ma non idea in pratica cosa dovrei fare.
Qualcuno può illuminarmi?


Last edited by mrl4n on Sun May 24, 2009 6:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat May 23, 2009 3:31 pm    Post subject: Reply with quote

edita /etc/conf.d/xdm, /etc/conf.d/rc e /etc/rc.conf (facilmente sarà solo il primo ad essere stato reimpostato ma nel dubbio verificali tutti e tre)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat May 23, 2009 3:35 pm    Post subject: Reply with quote

djinnZ wrote:
edita /etc/conf.d/xdm, /etc/conf.d/rc e /etc/rc.conf


Qualcosina sono riuscito ad imparare...ma come ho specificato ho mouse e tastiera bloccati...immagino che la procedura sia di chrootare da minimal cd, operazione che non ho mai eseguito, quindi se non faccio quello come edito?... :roll:
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat May 23, 2009 4:20 pm    Post subject: Reply with quote

mrl4n wrote:
quindi se non faccio quello come edito?... :roll:

cerca di accedere in modalità carattere.
durante il boot è sempre possibile (nella configurazione di default) arrestare la procedura di avvio dei servizi pigiando il tasto i.
ti viene proposto un accesso con password di amministratore in linea di comando, che dovrebbe permetterti di sistemare le cose.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat May 23, 2009 4:37 pm    Post subject: Reply with quote

Si, avvio interattivo, credo si chiami...quindi la mia idea del chroot era una str*****a... :oops:
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat May 23, 2009 4:53 pm    Post subject: Reply with quote

Se il problema è di hal possibile che non ti riesca di far nulla, in ogni caso premi il tasto i dopo che il bootlevel (in realtà in gentoo i runlevel sono 2 il bootlevel ed il softlevel) è stato completato, eviterai diverse rogne.
Non è che da chroot sia una str... solo che è initile visto che poi ti basta dare un rc default per vedere se le tue modifiche hanno risolto.

nel caso vedi se abilitando/disabilitando hal nel bootlevel aiuta

vedi che succede, altrimenti usi il chroot (non capisco quale sia il problema, segui i soliti passi della guida e lavori da consolle come se fossi sul tuo normale sistema.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat May 23, 2009 5:32 pm    Post subject: Reply with quote

La mia solita fortuna...xdm è configurato nel modo corretto, in rc non c'è nulla che si riferisce a mouse e tastiera, rc.conf nemmeno esiste...
Avevo già pensato ad hal e l'ho configurato in modo che possa funzionare tutto correttamente, ma anche in questo caso nulla di fatto...
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat May 23, 2009 7:32 pm    Post subject: Reply with quote

a questo devi procedere leggendo l'output di /var/log/Xorg.0.log .
molto probabilmente, non vengono caricati i driver di mouse e tastiera.

se è vero, poi bisogna capire il perché.
magari hai effettuato un aggiornamento che ne impone una ricompilazione.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sun May 24, 2009 6:08 pm    Post subject: Reply with quote

Ho controllato il file di log ed effettivamente ho scoperto che il sistema cercava di utilizzare hal, anche se non avevo fatto l'emerge di xorg con il driver evdev.
Interrompendo il boot prima di caricare la rete, non potevo riemergere xorg con evedev, quindi ho disattivato in xorg.conf l'autoadddevices e riavviato...
Ora funziona; probabilmente avrò sporcato un pò dovunque, quindi adesso vedrò di capire se e come posso ripulire...
Grazie.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum