Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Xorg e nVIDIA 9800GTX+
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Thu May 21, 2009 8:34 pm    Post subject: [RISOLTO] Xorg e nVIDIA 9800GTX+ Reply with quote

Ciao a tutti, dopo quasi un anno che per veri motivi non uso più Gentoo sono tornato ad installarlo sul nuovo fisso. Sino al kernel tutto ok, il sistema parte e son poche le cose da sistemare (credo), ho compilato Xorg ed ora vorrei farlo partire... Ma non riesco! Durante la compilazione varie volte, soprattutto negli ultimi pacchetti, sono stampati diversi warning simili od analoghi a quello che segue, purtroppo per la gran velocità non sono riuscito a leggerli e/o copiarli tutti:
Code:
* QA Notice: Package has poor programming practices which may compile
 *            fine but exhibit random runtime failures.
 * window.c:1496: warning: implicit declaration of function 'miPaintWindow'
 * ../cfb/cfbpixmap.c:167: warning: implicit declaration of function 'mfbGetendtab'
 * ../cfb/cfbpixmap.c:167: warning: implicit declaration of function 'mfbGetendtab'
 * ../cfb/cfbcppl.c:388: warning: implicit declaration of function 'mfbGetpartmasks'
 * ../cfb/cfbcppl.c:394: warning: implicit declaration of function 'mfbGetstarttab'
 * ../cfb/cfbcppl.c:394: warning: implicit declaration of function 'mfbGetendtab'
 * glthread.c:84: warning: implicit declaration of function 'perror'
 * xf86Xinput.c:165: warning: implicit declaration of function 'AssignTypeAndName'
 * xf86Xinput.c:174: warning: implicit declaration of function 'XkbSetExtension'
 * xalloc.c:108: warning: implicit declaration of function 'strlcpy'
 * xaaInit.c:198: warning: implicit declaration of function 'miInitializeCompositeWrapper'

 * Please do not file a Gentoo bug and instead report the above QA
 * issues directly to the upstream developers of this software.
 * Homepage: http://xorg.freedesktop.org/

>>> Installing x11-base/xorg-server-1.5.3-r5
 * >>> SetUID: [chmod go-r] /usr/bin/Xorg ...                             [ ok ]

Switching to xorg-x11 OpenGL interface... done
 * Users of reduced blanking now need:
 *    Option "ReducedBlanking"
 * In the relevant Monitor section(s).
 * Make sure your reduced blanking modelines are safe!

 * You must rebuild all drivers if upgrading from xorg-server 1.4.1
 * or earlier, because the ABI changed. If you cannot start X because
 * of module version mismatch errors, this is your problem.

 * You can generate a list of all installed packages in the x11-drivers
 * category using this command:
 * emerge portage-utils; qlist -I -C x11-drivers/
Scusatemi ma non capisco dove vuole portarmi... Sottolineo che sto usando l'ultimo rilascio di xorg-x11, stesso discorso per i driver nVIDIA. La mia scheda video:
Code:
01:00.0 VGA compatible controller: nVidia Corporation GeForce 9800 GTX (rev a2)

Ho tentato prima un X -configure, che però non sembra aver fatto bene il suo lavoro in quanto quando tento di testare X sul monitor si vede tutto come una TV non sintonizzata ed in centro il cursore che nemmeno riesco a muovere. L'errore:
Code:
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.

Ho quindi tentato anche la generazione semiautomatica del file xorg.conf, che sembra esser andata meglio, solo che come driver usa VGA e come DefaultDept 1. Ho editato facendogli usare i driver nVIDIA e cambiandogli il DefaultDepth: uso startx per avviare e per un nanosecondo appare il logo nVIDIA, quindi i le classiche tre shell di X e l'orologio in alto a destra, solo che la tastiera non risponde ed il mouse neppure. Questo l'output sino a che X è attivo:
Code:
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.
xinit:  No such file or directory (errno 2):  Cannot register with ConsoleKit: org.freedesktop.CkConnector.Error: Unable to open session: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
Quando lo killo appare anche questo:
Code:
waiting for X server to shut down X connection to :0.0 broken (explicit kill or server shutdown).
xterm:  fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0"
xterm:  fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0"
login:  fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0"
La linea con "xinit: blablabla" mi dice qualcosa, ma ho dimenticato gli appunti in ufficio e non posso controllare... Per quanto riguarda tastiera e mouse sono installati i driver xf86-input-keyboard e xf86-input-mouse, che dovrebbero esser giusti. Questo l'xorg.conf, che tra l'altro mi pare parecchio incompleto:
Code:
Section "Module"
    Load        "dbe"     # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
EndSection

Section "Files"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/TTF/"
    FontPath   "/usr/share/fonts/OTF"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath   "/usr/share/fonts/75dpi/"
EndSection

Section "ServerFlags"
EndSection

Section "InputDevice"

    Identifier   "Keyboard1"
    Driver   "kbd"

    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc104"
    Option "XkbLayout"   "it"

EndSection

Section "InputDevice"
    Identifier   "Mouse1"
    Driver   "mouse"
    Option "Protocol"    "Auto"   # Auto detect
    Option "Device"      "/dev/input/mice"
    Option "ZAxisMapping"   "4 5 6 7"
    Option "Emulate3Buttons"
EndSection

Section "Monitor"

    Identifier  "My Monitor"
    HorizSync   31.5
    VertRefresh 50-70

EndSection

Section "Device"
    Identifier   "Standard VGA"
    VendorName   "Unknown"
    BoardName   "Unknown"
    Driver     "vga"
EndSection

Section "Device"
    Identifier  "My Video Card"
    Driver      "nvidia"
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "My Video Card"
    Monitor     "My Monitor"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "Simple Layout"

    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection
Consigli?

Grazie anticipatamente :)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)


Last edited by spillo on Sat May 23, 2009 9:53 am; edited 1 time in total
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu May 21, 2009 9:57 pm    Post subject: Reply with quote

Ciao spillo!

In effetti se si segue passo per passo la Guida alla configurazione di X server non viene preso in considerazione il fatto che la nuova versione stabile, la 1.5.3, introduce una gestione più avanzata delle periferiche di input, tramite il demone HAL.

Troverai le istruzioni su come attivare correttamente mouse e tastiera nella Guida all'aggiornamento a Xorg 1.5.

Per quanto riguarda questi errori:
Code:

(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.

assicurati che nel tuo xorg.conf ci sia una sezione più o meno così:
Code:


...

Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "nVIDIA 9800GTX+"
EndSection

...



Comunque la generazione automatica tramite X -configure va già più che bene (il fatto che mouse e tastiera non ti funzionassero è per via della gestione tramite HAL, da sistemare leggendo la guida d'aggiornamento); controlla di usare il driver "nvidia".

Inoltre assicurati di aver caricato il modulo del kernel "nvidia", e di aver impostato i driver OpenGL sempre su Nvidia
Code:

eselect opengl set nvidia


Per l'errore
Code:

xinit:  No such file or directory (errno 2):  Cannot register with ConsoleKit: org.freedesktop.CkConnector.Error: Unable to open session: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

probabilmente avrai compilato hal con la flag "consolekit" attivata, che ti avrà introdotto la dipendenza sys-auth/consolekit. Assicurati che il relativo demone sia attivato all'avvio:
Code:

/etc/init.d/consolekit start
rc-update add consolekit default


C'è già un bug aperto per l'aggiornamento di questa guida, abbiate fede, o cari discepoli Gentooisti 8)
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Fri May 22, 2009 6:33 am    Post subject: Reply with quote

Grazie per l'esauriente risposta, oggi che torno a casa provo assolutamente :)

EDIT: provato e sembra essere tutto a posto :) ho dovuto anche, ovviamente, avviare "hald" visto che ora è lui a gestire il tutto... Con ciò che mi hai consigliato sembra che nemmeno la scheda video dia più problemi, aspetto a dar tutto per risolto però così tocchiccio ancora un po' :) Grazie mille!

EDIT 2: metto il "risolto", anche gnome sembra a posto :)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum