Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installazione stampante USB (HP C4180) [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat May 09, 2009 8:16 am    Post subject: Installazione stampante USB (HP C4180) [RISOLTO] Reply with quote

Sto cercando di installare una photosmart c4180 e per questo motivo ho configurato e ricompilato il kernel che all'avvio mi rileva la stampante (fin qui tutto bene).
Accedo a KDE e tramite il centro di controllo cerco di aggiungere la suddetta.
Seleziono la stampante dalla lista, procedo con l'installazione. Mi vengono chiesti i driver; scarico dal sito HP il file e recupero "hplip-3.9.4b.run" che se seleziono il programma d'installazione mi dice "formato driver sbagliato".
Provo a lanciare direttamente il file e un messaggio mi avvisa che se salvo un file binario otterrò un file corrotto...
Come dovrei comportarmi?


Last edited by mrl4n on Tue May 12, 2009 5:59 am; edited 2 times in total
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Sat May 09, 2009 8:23 am    Post subject: Reply with quote

Quando collego una nuova stampante al mio notebook, avvio cups:
Code:
eselect rc restart cupsd

accedo a http://localhost:631, clicco sul menù Administration, clicco su Find New Printers.
Se non riesco a farla funzionare al primo colpo, incomincio a cercare su google il driver da utilizzare.
_________________
LP
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat May 09, 2009 8:25 am    Post subject: Reply with quote

Ottimo grazie, vado subito a vedere!

Edit: pare che per la mia stampante esista questo file "hplip-3.9.4b.run" che se eseguo mi avvia un processo di installazione automatico che mi chiede quale sia la mia distro senza includere gentoo...posso procedere con questo sistema? le scelte possibili sono le seguenti:
0 Mepis
1 Debian
2 SUSE Linux
3 Mandriva Linux
4 Fedora
5 Red Hat
6 Red Hat Enterprise Linux
7 Ubuntu
8 PCLinuxOS
9 Linux Mint
10 gOS
11 IGOS
12 Boss

Posso provarne una per una, ma se qualcuno sa già quale devo scegliere, evito di incasinarmi il sistema... :lol:
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Sat May 09, 2009 9:16 am    Post subject: Reply with quote

Code:
# emerge -av net-print/hplip

Io i driver per la mia hp li ho installati così, poi ho configurato il tutto tramite l'interfaccia web di cups ( http://localhost:631 )
Installare roba senza usare emerge non è in genere una buona idea.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat May 09, 2009 9:46 am    Post subject: Reply with quote

Onip wrote:
Code:
# emerge -av net-print/hplip

Io i driver per la mia hp li ho installati così, poi ho configurato il tutto tramite l'interfaccia web di cups ( http://localhost:631 )
Installare roba senza usare emerge non è in genere una buona idea.


Avevo un leggero sospetto, però d'altronde i miei ancora possono essere impressioni molto sbagliate per la pochissima esperienza...grazie :)
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Sat May 09, 2009 10:13 am    Post subject: Reply with quote

per facilitare una futura ricerca, consiglio di editare il titolo del thread indicando il modello della stampante.
_________________
LP
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Sat May 09, 2009 12:19 pm    Post subject: Reply with quote

Onip wrote:
Code:
# emerge -av net-print/hplip

Io i driver per la mia hp li ho installati così, poi ho configurato il tutto tramite l'interfaccia web di cups ( http://localhost:631 )
Installare roba senza usare emerge non è in genere una buona idea.


L'interfaccia web l'avevo già aperta, ma anche dopo aver fatto l'emerge che mi hai indicato, tra i modelli disponibili, il mio non compare comunque... :cry:
Un sospetto mi assale...deve essere per forza una stampante di rete?
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Mon May 11, 2009 9:44 am    Post subject: Reply with quote

Da un'infinità di ricerche sul web ho verificato che la mia stampante è supportata da HPLIP che viene fornito con il proprio installer oppure utilizzato in modo manuale
Code:
sh nome del file
.
Potrei cambiare la stampante, ma vorrei anche sapere prima i possibili problemi di una installazione extra-emerge.
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon May 11, 2009 1:30 pm    Post subject: Reply with quote

per prima cosa prova ad emergere hplip in versione ~, magari la stabile non è abbastanza recente. poi, dall'interfaccia web di cups vai in amministrazione -> aggiungi stampante e in dispositivo scegli quello che rispecchia la tua. Io ho re-installato la mia hp deskjet 5150 usb proprio la settimana scorsa in questo modo.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon May 11, 2009 4:31 pm    Post subject: Reply with quote

mrl4n wrote:
possibili problemi di una installazione extra-emerge
devastazione completa del sistema di stampa al punto da essere costretto a rimuovere manualmente tutti i file collegati (esperienza vissuta con driver spl samsung/xerox) ma anche sostituzione di qualche libreria di base con versioni più vecchie e conseguente blocco completo del sistema. Questo non vale solo per gentoo ma per qualsiasi altra distribuzione.
Troppe volte questi pseudo driver sono realizzati in modo approssimativo e maldestro.
mrl4n wrote:
Potrei cambiare la stampante
Se è per boicottare questa pratica idiota (economicamente il rilascio "closed" dei driver è giustificato, nel senso che non comporta un autentico danno economico rispetto al rilascio "open", solo dalla programmazione stretta dell'obsolescenza o dalla produzione in cessione di tecnologia piuttosto che in appalto, tutte pratiche in ogni caso assai discutibili) fai bene ma in ogni caso se leggi qui è supportata da un pezzo.
Al massimo prova a ricompilare cups & C (di sicuro verifica come è impostato e con quali use flag) perchè il driver che vorresti scaricare non è altro che hplip installato di default da gentoo.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Tue May 12, 2009 6:00 am    Post subject: Reply with quote

Grazie...nonostante dopo l'aggiornamento di CUPS e HPLIP non mi ha permesso di scegliere il modello esatto (e per questo motivo non mi permette di acquisire con lo scanner), ho stampato una pagina di prova e una pagina internet...pare funzionare.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue May 12, 2009 1:08 pm    Post subject: Reply with quote

hai aggiunto la use scanner ed installato sane-backends?
Se non hai volgia di installarti tutti i maledetti ppd puoi sempre scaricare quello che fa al caso tuo ed installarlo manualmente (cosa assai più comoda).
Puoi postare l'output di emerge -pv cups sane hplip?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Tue May 12, 2009 1:10 pm    Post subject: Reply with quote

djinnZ wrote:
hai aggiunto la use scanner ed installato sane-backends?
Se non hai volgia di installarti tutti i maledetti ppd puoi sempre scaricare quello che fa al caso tuo ed installarlo manualmente (cosa assai più comoda).
Puoi postare l'output di emerge -pv cups sane hplip?


No... :oops:

Code:
emerge -pv cups sane hplip

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "sane".


Edit: aggiunto la USE installato sane-backends, rifatto l'emerge HPLIP, provato Xsane; funziona solo da root ma funziona. GRAZIE :)
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue May 12, 2009 4:44 pm    Post subject: Reply with quote

mrl4n wrote:

Edit: aggiunto la USE installato sane-backends, rifatto l'emerge HPLIP, provato Xsane; funziona solo da root ma funziona. GRAZIE :)

credo tu debba aggiungere il tuo utente al gruppo scanner
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Tue May 12, 2009 5:07 pm    Post subject: Reply with quote

L'avevo già aggiunto, ma quando apro Xsane da utente mi dice "no devices available" :roll:
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Wed May 13, 2009 8:14 am    Post subject: Reply with quote

perchè la modifica dei gruppi diventi effettiva devi almeno fare logout\login col tuo utente, l'hai fatto?

Code:
$ groups
tty lp wheel uucp audio cdrom dialout www video games cdrw usb users scanner plugdev ppp samba sshusers

Questi sono i miei e il mio scanner funziona da utente
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Wed May 13, 2009 8:29 am    Post subject: Reply with quote

L'ho fatto più di una volta...ma se controllo i gruppi esistenti non lo trovo

Code:
# groups
root bin daemon sys adm disk wheel floppy dialout tape video


Quindi la mia soluzione è capire perchè
Code:
# gpasswd -a <utente> scanner
non mi aggiunge nulla...

Edit: ho eseguito un aggiornamento completo
Code:
# emerge --update --deep --newuse world
e la cosa mi ha sconvolto diverse impostazioni, ma ora per quanto dal pannello vedo la stampante come modello diverso (deskjet 1.3 invece di photosmart c4180), funziona sia da stampante che da scanner per il root e per l'utente...anche se non capisco perchè utilizzano due versioni di cups diverse.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum