Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg] Plus possible de charger les modules (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Lucio_
n00b
n00b


Joined: 20 Oct 2008
Posts: 31

PostPosted: Sat Apr 25, 2009 10:21 am    Post subject: [Xorg] Plus possible de charger les modules (résolu) Reply with quote

Voila, avant hier j'ai mis a jour quelque paquets, je ne sais pas si c'est lies, mais depuis je ne peut plus demarer le server X :(
J'obtiens apres avoir tape startx:
Code:
(EE) Failed to load module "freetype" (module does not exist, 0)
(EE) module ABI major version (1) doesn't match the server's version (4)
(EE) Failed to load module "nv" (module requirement mismatch, 0)
(EE) No drivers available.

Fatal server error:
no screens found
giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.


:
J'ai fait des recherches sur internet,je n'ai rien trouve...


Last edited by Lucio_ on Sat May 09, 2009 1:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sat Apr 25, 2009 11:08 am    Post subject: Reply with quote

Suffit de lire les iindications en fin d'emerge xorg-server, qui te disent de recompiler tous les drivers xorg ;)
Back to top
View user's profile Send private message
bivittatus
l33t
l33t


Joined: 31 Jan 2006
Posts: 687
Location: Roissy-en-Brie (France)

PostPosted: Sat Apr 25, 2009 11:22 am    Post subject: Reply with quote

Un petit
Code:
emerge -1 $(qlist -IC x11-drivers)
devrait résoudre ton problème
_________________
Linus TORVALDS: "Je ne suis pas là pour détruire Microsoft. Ce sera juste un effet secondaire tout à fait involontaire."
Back to top
View user's profile Send private message
Lucio_
n00b
n00b


Joined: 20 Oct 2008
Posts: 31

PostPosted: Mon Apr 27, 2009 9:08 pm    Post subject: Reply with quote

Merci beaucoup pour vos aides, je peux a present demarer kde, mais plus de clavier, ni d'USB, je vais voire si je peux reparer ca... :(
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Apr 28, 2009 7:51 am    Post subject: Reply with quote

Il n'est pas interdit de Lire la doc quand on fait une mise à jour majeure de Xorg. Ou encore de faire une recherche ou ou
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Lucio_
n00b
n00b


Joined: 20 Oct 2008
Posts: 31

PostPosted: Tue May 05, 2009 8:59 pm    Post subject: Reply with quote

Bon après plusieurs tentative et en lisant la doc ainsi que les threads du forum, en essayant une recompilation du paquet xorg-server sans hal, aucun changement, ça ne marche toujours pas.. :(

Edit: en fait il semble que dans le log se ne soit pas un erreur mais un warning:
Quote:
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(WW) Disabling Keyboard0


Meme en changeant a off, ca ne change rien...
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed May 06, 2009 6:26 am    Post subject: Reply with quote

Lucio_ wrote:
Bon après plusieurs tentative et en lisant la doc ainsi que les threads du forum, en essayant une recompilation du paquet xorg-server sans hal, aucun changement, ça ne marche toujours pas.. :(

'alute

as-tu essayé de recompiler xinit également ? (avec et/ou sans le USE hal histoire d'être sur...)

Btw: je m'en voudrais d'être de mauvaise augure mais... il n'y a qu'un pas :cry:

Edit : Oops dsl ! j'ai lu en travers ce matin... j'avais aps vu que ton kde se lançait maintenant.
Reste que cette histoire de clavier alors ?? es-tu avec ou sans hal actuellement sur tous les packages dépendants de hal ? est-ce que le xorg.conf est correct pour chacun des deux cas de test (cad avec et sans les entrées Input et fdi pour le keybord) ?
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Lucio_
n00b
n00b


Joined: 20 Oct 2008
Posts: 31

PostPosted: Wed May 06, 2009 3:44 pm    Post subject: Reply with quote

Je suis avec hal pour tout les paquets sauf xorg-server au moyen du fichier /etc/portage/package.use

Sinon le xorg.conf semble correcte du moins il n'y pas pas d'erreur dans le log, uniquement des warning (mais un qui désactive le clavier)
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu May 07, 2009 8:47 am    Post subject: Reply with quote

Lucio_ wrote:
Sinon le xorg.conf semble correcte

Tu es sûr de tes sections "InputDevices" ?
Tu es sûr d'avoir (re)compilé les pilotes de clavier/souris ?

Le plus simple serait tout de même que tu nous donne ton xorg.conf ainsi que le contenu de la variable INPUT_DEVICES :
grep INPUT_DEVICES /etc/make.conf
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 495

PostPosted: Thu May 07, 2009 4:16 pm    Post subject: Reply with quote

Le sujet a déjà été évoqué plusieurs fois...

Code:
Option "AllowEmptyInput" "true"
au bon endroit (cf. man xorg.conf) devrait faire l'affaire.

Sinon, je te laisse chercher les autres solutions, je ne les ai plus toutes de têtes. (il y a notamment se passer de xorg.conf mais ça n'est pas toujours faisable)
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu May 07, 2009 9:28 pm    Post subject: Reply with quote

YetiBarBar wrote:
Code:
Option "AllowEmptyInput" "true"
au bon endroit (cf. man xorg.conf) devrait faire l'affaire.

Heu, YetiBarBar, tu n'aurais pas loupé ce post de Lucio_, des fois ?
Lucio_ wrote:
Edit: en fait il semble que dans le log se ne soit pas un erreur mais un warning:
Quote:
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(WW) Disabling Keyboard0


Meme en changeant a off, ca ne change rien...


Quote:
(il y a notamment se passer de xorg.conf mais ça n'est pas toujours faisable)

Sans hal, ça va pas nécessairement être facile ! ;-)
Back to top
View user's profile Send private message
Lucio_
n00b
n00b


Joined: 20 Oct 2008
Posts: 31

PostPosted: Fri May 08, 2009 10:39 am    Post subject: Reply with quote

Déjà merci beaucoup pour vos aides..


ghoti wrote:
Tu es sûr de tes sections "InputDevices" ?

Non pas vraiment, je n’y est pas touché depuis la mise a jour
Code:
   InputDevice    "Keyboard0" "CoreKeyboard"



Quote:
Tu es sûr d'avoir (re)compilé les pilotes de clavier/souris ?

J’ai recompilé kbd, mais ça ne change rien…


ghoti wrote:
Le plus simple serait tout de même que tu nous donne ton xorg.conf ainsi que le contenu de la variable INPUT_DEVICES :
grep INPUT_DEVICES /etc/make.conf

Code:
Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
#       Load "freetype"
        # Load "xtt"
        Load  "extmod"
        Load  "glx"
        Load  "dri"
        Load  "dbe"
        Load  "record"
        Load  "xtrap"
#       Load  "type1"
EndSection

Section "InputDevice"
        Driver      "synaptics"
        Identifier "Mouse0"
        Option      "SendCoreEvents"
        Option      "Device" "/dev/input/mouse2"
        Option      "Protocol" "auto-dev"
        Option      "SHMConfig" "on"
  Option         "AlwaysCore"
    Option         "LeftEdge" "120"
    Option         "RightEdge" "830"
    Option         "TopEdge" "120"
    Option         "BottomEdge" "650"
    Option         "FingerLow" "14"
    Option         "FingerHigh" "15"
    Option         "MaxTapTime" "180"
    Option         "MaxTapMove" "110"
    Option         "ClickTime" "0"
    Option         "EmulateMidButtonTime" "75"
    Option         "VertScrollDelta" "20"
    Option         "HorizScrollDelta" "20"
    Option         "MinSpeed" "0.3"
    Option         "MaxSpeed" "0.75"
    Option         "AccelFactor" "0.015"
    Option         "EdgeMotionMinSpeed" "200"
    Option         "EdgeMotionMaxSpeed" "200"
    Option         "UpDownScrolling" "1"
    Option         "CircularScrolling" "1"
    Option         "CircScrollDelta" "0.1"
    Option         "CircScrollTrigger" "2"
#Option      "AutoAddDevices"    "false"

EndSection


Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "gb"
       Option "AllowEmptyInput" "off"
EndSection

Section "Monitor"        Identifier   "Monitor0"
        HorizSync    31.5 - 79.0
        VertRefresh  50.0 - 70.0
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "nv"
        Card        "NVIDIA GeForce"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0

                Depth     24
                Modes    "1280x960" "1152x864"
        EndSubSection
EndSection


Code:
INPUT_DEVICES="keyboard mouse synaptics"


Avant il y avait evdev aussi, mais je l’ai retire... ce qui n’a rien changé du tout..


Pour se passer de xorg, j’ai essayé au début, mais ça n’a pas marché non plus.
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Fri May 08, 2009 11:00 am    Post subject: Reply with quote

Salut,
Les options AutoAddDevices, AllowEmptyInput, ... doivent être dans une section ServerFlags.
comme cela (cf man xorg.conf):
Code:

Section "ServerFlags"
        Option  "AutoAddDevices" "off" # default on
        #Option  "AllowEmptyInput" "off" # default on if AutoAddDevices = on && AutoEnableDevices = on, else off
EndSection


essaye d'abord, juste avec Option "AutoAddDevices" "false".
le reste de ton xorg.conf a l'air correct pour une config sans hal.

Bruno
Back to top
View user's profile Send private message
Lucio_
n00b
n00b


Joined: 20 Oct 2008
Posts: 31

PostPosted: Sat May 09, 2009 1:33 pm    Post subject: Reply with quote

Merci beaucoup, ca marche maintenant, sans hal et avec cette option, je mets le sujet en résolu!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum