Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[réseau] conflit dans les sous-réseaux ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Thu Apr 23, 2009 2:31 pm    Post subject: [réseau] conflit dans les sous-réseaux ? Reply with quote

Bonjour,



J'utilise un réseau classe C depuis plusieurs années ... et ce n'est que maintenant que je constate ce genre de chose :

Code:
Thu Apr 23 16:19:28 2009 WARNING: potential route subnet conflict between local LAN [10.2.1.0/255.255.255.0] and remote VPN [10.2.1.0/255.255.255.0]



En fait, c'est ainsi sur un de mes pc dans le LAN :
Code:
eth0      Link encap:Ethernet  HWaddr 00:01:02:ae:27:60                                                                     
          inet adr:10.2.1.46  Bcast:10.2.1.63  Masque:255.255.255.192                                                       
          adr inet6: fe80::201:2ff:feae:2760/64 Scope:Lien                                                                   
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                                                                 
          Packets reçus:37648 erreurs:0 :0 overruns:0 frame:0                                                               
          TX packets:23682 errors:0 dropped:0 overruns:0 carrier:0                                                           
          collisions:0 lg file transmission:1000                                                                             
          Octets reçus:52139661 (52.1 MB) Octets transmis:1866132 (1.8 MB)                                                   
          Interruption:9 Adresse de base:0x4000
tap0      Link encap:Ethernet  HWaddr 86:09:dc:e1:ff:a5 
          inet adr:10.2.1.193  Bcast:10.2.1.255  Masque:255.255.255.192
          adr inet6: fe80::8409:dcff:fee1:ffa5/64 Scope:Lien           
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1           
          Packets reçus:2 erreurs:0 :0 overruns:0 frame:0             
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0       
          collisions:0 lg file transmission:100                       
          Octets reçus:156 (156.0 B) Octets transmis:3842 (3.8 KB)



Donc en francais, ca donne :
- réseau classe C (10.2.1.0/24)
- qui est coupé en 4 sous-réseaux : .0, .64, .128, .192 (mask = 255.255.255.192)
- dernier hote de chaque réseau = gateway


Bon, jusqu'ici, rien de grave ... Mais maintenant, revenons à l'exemple ci-dessus :
- LAN = 10.2.1.0
- VPN = 10.2.1.192

... Si l'on regarde le broadcast du dernier réseau (.192), on s'appercois vite que ... 10.2.1.255 => c'est égal au broadcast de tout le réseau classe C. D'ou mon inquiétude :s.

Pour le moment, tout va bien, mais que pourrait-il se passer ? Le VPN qui broadcast sur 2 interfaces au lieux de une seule (eth0 et tap0) ?

Aurais-je du omettre l'utilisation du dernier sous-réseau ?

Devrais-je ignorer les dires d'OpenVPN ? (car il dit que mon réseau LAN est en 10.2.1.0/24 et non /26 ...


:?

EDIT: mon serveur tourne (tournera) avec les 4 sous-réseaux connectés physiquement à la machine ...
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
thejack
n00b
n00b


Joined: 15 Oct 2008
Posts: 37

PostPosted: Sat Apr 25, 2009 4:30 pm    Post subject: Reply with quote

Si tu as vraiment 4 sous réseau le dernier broadcast n'aura pas d'ambiguité.

Le 255 sera le broadcast du dernier réseau. Ces sous réseaux, même sous le même réseau physique ne communiquerons pas au niveau IP.

Je vois plus un probleme de config OpenVPN, celle-ci n'etant pas configurée avec les mêmes sous réseaux.
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Tue Apr 28, 2009 5:48 pm    Post subject: Reply with quote

Mmmm, je n'utilise aucunement le réseau class C direct, j'utilise que les sous-réseaux donc, ca devrait pas poser de problème (oui, les interfaces sur le serveur n'utilisent que des /26 et aucunement du /24).




Ah que arf :
(configuration de ospfd de quagga)
Code:
 passive-interface tap0
 network 10.2.1.0/24 area 0.0.0.1


Pour faire plus simple, j'ai utilisé du /24 pour pas devoir préciser xX /26 ; je pense pas que le problème vienne de la.



Sinon, pour openvpn :
Code:
ifconfig 10.2.1.254 255.255.255.192


serveur ~ # ifconfig -a | grep 10.2.1
          inet adr:10.2.1.62  Bcast:10.2.1.63  Masque:255.255.255.192
          inet adr:10.2.1.65  Bcast:10.2.1.127  Masque:255.255.255.192
          inet adr:10.2.1.254  Bcast:10.2.1.255  Masque:255.255.255.192

c'est donc aussi OK.


Donc, au final, je pense que c'est juste un stress de OpenVPN, rien de plus :wink:
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum