Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Disabilitare touchpad se attacco il mouse
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Apr 22, 2009 8:14 am    Post subject: [RISOLTO] Disabilitare touchpad se attacco il mouse Reply with quote

Nel mio portatile siccome ho il touchpad mooolto sensibile penso che questo mi dia dei problemi.
Vorrei provare o a settarlo meglio o comunque a disabilitare il touchpad quando attacco il mouse USB (il mio notebook è un SONY VAIO).

Con un altro portatile e una versione vecchia di mandriva che avevo all'epoca (penso la 2005) so che questa cosa capitava di default ma a distanza di tempo ricordo solo questo, sapete se c'è qualche modo di disabilitare il touchpad SOLO quando attacco il mouse ?


Last edited by lsegalla on Tue May 19, 2009 12:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Wed Apr 22, 2009 8:44 am    Post subject: Reply with quote

Dovrebbe essere abbastanza semplice, in teoria.
Una soluzione potrebbe essere quella di identificare con udev gli eventi di inserimento/rimozione della periferica usb, e creare delle regole locali in /etc/udev/rules.d/10-local.rules:
Code:
.............  RUN+="synclient -l | grep -q 'TouchpadOff.*1' ; synclient TouchpadOff=$?"

o qualcosa del genere.
Personalmente, il comando sopra lo associo ad un evento acpi legato alla prssione di un tasto del mio asus.

/edit
c'è anche questo: http://en.gentoo-wiki.com/wiki/Synaptics_Touchpad#Prevent_Accidental_Mouse_Movement
_________________
LP
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Wed Apr 22, 2009 5:27 pm    Post subject: Re: Disabilitare touchpad se attacco il mouse Reply with quote

lsegalla wrote:
Nel mio portatile siccome ho il touchpad mooolto sensibile penso che questo mi dia dei problemi.
Vorrei provare o a settarlo meglio o comunque a disabilitare il touchpad quando attacco il mouse USB (il mio notebook è un SONY VAIO).

Con un altro portatile e una versione vecchia di mandriva che avevo all'epoca (penso la 2005) so che questa cosa capitava di default ma a distanza di tempo ricordo solo questo, sapete se c'è qualche modo di disabilitare il touchpad SOLO quando attacco il mouse ?


io, quando parte gnome, ho impostato che venga eseguito ad avvio sessione questo comando:

syndaemon -i1 -d

In pratica ti inibisce il touchpad solamente mentre scrivi :)
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Apr 22, 2009 7:22 pm    Post subject: Reply with quote

Syndaemon l'ho odiato perché lavora anche quando stai usando il touchpad stesso, se usi il computer con un po' di velocità è dannatamente limitante. Mi sono creato uno scriptino con un launcher sul pannello, con il quale accendo/spengo anche la lucina apposita
Code:
if [ `cat /sys/class/leds/asus::touchpad/brightness` -eq 1 ]
then
        synclient TouchpadOff=1
        echo 0 > /sys/class/leds/asus::touchpad/brightness
else
        echo 1 > /sys/class/leds/asus::touchpad/brightness
        synclient TouchpadOff=0
fi
Di solito deve essere lanciato un paio di volte perché funzioni, non capisco come mai. Se qualcuno riesce ad ottenere l'effetto chiesto da Isegalla ben venga!
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue May 19, 2009 7:20 am    Post subject: Reply with quote

Non mi funzia
Code:

luca@user8-gentoo ~ $ syndaemon -i1 -d
Can't access shared memory area. SHMConfig disabled?


Ho scoperto che in xorg.conf non avevo caricato il driver synaptics e or è caricato correttamente, almeno sembra
Code:
luca@user8-gentoo ~ $ grep synaptics /var/log/Xorg.0.log
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"


Adesso mi son bloccato, ho sempre sto errore.

-- EDIT --
Ho rifatto tutto quel che c'era nella guida e son riuscito. Almeno sembra, chiudo.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun May 31, 2009 9:58 pm    Post subject: Reply with quote

ti serve questa stringa nel file di configurazione di hal:
Code:

<merge key="input.x11_options.SHMConfig" type="string">true</merge>

bada che sia alta a sufficienza nel file, affinché preceda le altre impostazioni.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue Jun 02, 2009 11:12 pm    Post subject: Reply with quote

Si, ci ero riuscito, come avevo scritto nel thread, grazie comunque.
Ad ogni modo ho visto che non risolve il mio problema, anzi da qualche tempo mi capita anche che qualche tasto sembra incastrarsi, non so cosa sia... ogni tanto mentre navigo mi ritrovo col firefox incriccato mentre fa la ricerca e scrive "ddddddddddddddddddd"... (eccetera)

che balle.... :?
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Jun 03, 2009 8:31 am    Post subject: Reply with quote

Mi sembra però che l'idea iniziale "mouse staccato -> touchpad attivato", "mouse attaccato -> touchpad disattivato", non sia ancora stata raggiunta, sbaglio?
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Jun 03, 2009 10:58 am    Post subject: Reply with quote

cloc3 wrote:
ti serve questa stringa nel file di configurazione di hal:
Code:

<merge key="input.x11_options.SHMConfig" type="string">true</merge>

bada che sia alta a sufficienza nel file, affinché preceda le altre impostazioni.

comunque non ce l'ho questa riga in /etc/dbus-1/system.d/hal.conf

adesso io non conosco bene quel file di configurazione ma il concetto "sufficientemente alta" mi è relativamente chiaro: potrei metterla prima di tutto ma non so se sarebbe corretto
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Jun 03, 2009 12:24 pm    Post subject: Reply with quote

lsegalla wrote:
ma il concetto "sufficientemente alta" mi è relativamente chiaro

ovviamente neanche a me, se no sarei stato più preciso.

una volta ho avuto un problema simile al tuo e ho provato a spostare quella riga qualche posto più in alto, ma non ho approfondito la sintassi più di tanto.
comunque, una piccola ricerca binaria può dirti rapidamente se la mia dritta si applica al tuo caso oppure no.


-- tra l'altro, credo che la configurazione di hal deba stare in /etc/hal/fdi/policy/... come dicono le guide sul nuovo xorg-server.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum