Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[xorg migration 1.5] j'ai peur ![resolu]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Apr 21, 2009 9:05 am    Post subject: [xorg migration 1.5] j'ai peur ![resolu] Reply with quote

Salut,

Voilà un moment que je n'avais pas eu le temps de mettre mon arbre à jour (il y a des moments je me demande même si ce n'est pas une meilleure idée de ne toucher à rien quand ça marche... bref).

J'ai un max de paquet mais surtout j'ai trouvé le doux message d'eselect news (je connaissais pas cet outil d'ailleurs et j'avoue qu'il est très bien et surtout très efficace).
Code:
ataualpa ben # eselect news read 2009-04-06-x_server-1_5
2009-04-06-x_server-1_5
  Title                      Migration to X.org Server 1.5
  Author                     Remi Cardona <remi@gentoo.org>
  Author                     Christian Faulhammer <fauli@gentoo.org>
  Posted                     2009-04-06
  Revision                   1

A lot of changes regarding device recognition and use by the X server
have been introduced in the 1.5 update.  As that version is going
stable on all architectures, users should read the upgrade guide [0]
before actually updating the package.

[0] http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.5-upgrade-guide.xml

J'ai regardé le guide et franchement... j'ai rien compris.
Je me suis donc dirigé sur le forum pour voir la casse chez les autres... et entre les clavier pas reconnu et les écrans noirs là j'ai pris peur... on est plus en 1999 qu'en même !

Donc ma question est simple. J'ai un vieux PC qui tourne encore avec de la sd ram une carte nvidia qui fait parti de la liste des reliques du driver nvidia et j'ai surtout pas beaucoup de temps pour faire cette mise à jour. Alors pouvez-vous me guider pas à pas... parce que là même avec le guide je vois pas par où commencer !


Last edited by BENJI on Mon Jun 29, 2009 12:11 pm; edited 2 times in total
Back to top
View user's profile Send private message
nico_calais
l33t
l33t


Joined: 09 Jun 2005
Posts: 628
Location: Saint Julien en Genevois

PostPosted: Tue Apr 21, 2009 9:24 am    Post subject: Reply with quote

Y a pas à avoir peur :wink:

Le truc qui peut pauser problème, c'est evdev. Si tu l'utilises pour gérer ton clavier et ta souris, pas de problème

Si tu n'utilise pas evdev ou ne veux pas utiliser evdev, tu dois compiler xorg-server avec le use flag "-hal"

Code:
USE="-hal" emerge xorg-server

_________________
"Unix IS user friendly... It's just selective about who its friends are." — Tollef Fog Heen tollef@add.no
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Tue Apr 21, 2009 9:29 am    Post subject: Reply with quote

Euh perso je suis plus que gêné par ce changement... mon affichage est devenu lent!
Genre je fais ALT+F2, je vois maintenant la fenêtre apparaître sans les décorations (la barre en haut et le tour de la fenêtre quoi) et les déco arrivent après dans la foulée. Bon, ça se fait en 0.2 sec mais ça se voit et c'est moche.

J'ai l'impression aussi que le scrolling dans Firefox est encore plus lent qu'avant (et pourtant c'est déjà bien lourd).

... bref, je n'aime vraiment pas du tout ce changement!

Pis c'est de la merde quoi, faut le dire! Avant je branchais n'importe quelle souris elle était reconnue sans que je ne fasse rien, ça marchait très bien... maintenant je branche une souris USB il ne se passe rien... c'est quoi cette merde???
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Apr 21, 2009 9:34 am    Post subject: Reply with quote

bon... je suis pas vraiment rassuré
y a t-il un moyen de contourner cette mise à jour ?
comment savoir si j'utilise evdev ?
Back to top
View user's profile Send private message
nico_calais
l33t
l33t


Joined: 09 Jun 2005
Posts: 628
Location: Saint Julien en Genevois

PostPosted: Tue Apr 21, 2009 9:41 am    Post subject: Reply with quote

Temet wrote:
Euh perso je suis plus que gêné par ce changement... mon affichage est devenu lent!
Genre je fais ALT+F2, je vois maintenant la fenêtre apparaître sans les décorations (la barre en haut et le tour de la fenêtre quoi) et les déco arrivent après dans la foulée. Bon, ça se fait en 0.2 sec mais ça se voit et c'est moche.

J'ai l'impression aussi que le scrolling dans Firefox est encore plus lent qu'avant (et pourtant c'est déjà bien lourd).

... bref, je n'aime vraiment pas du tout ce changement!

Pis c'est de la merde quoi, faut le dire! Avant je branchais n'importe quelle souris elle était reconnue sans que je ne fasse rien, ça marchait très bien... maintenant je branche une souris USB il ne se passe rien... c'est quoi cette merde???


Ah ben merde...J'ai fait la mise à jour sur un portable et un poste fixe. J'ai pas ces soucis.
_________________
"Unix IS user friendly... It's just selective about who its friends are." — Tollef Fog Heen tollef@add.no
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Apr 21, 2009 9:58 am    Post subject: Reply with quote

Comme quoi il n'y a pas de science exacte!
Sinon j'avais toujours deux questions sur le feu et besoin d'un bon coup de main.
BENJI wrote:
bon... je suis pas vraiment rassuré
y a t-il un moyen de contourner cette mise à jour ?
comment savoir si j'utilise evdev ?


car justement... il semblerait que je n'utilise pas evdev alors que faut-il faire ?
Code:
ben@ataualpa ~ $ emerge -s evdev
Searching...
[ Results for search key : evdev ]
[ Applications found : 1 ]

*  x11-drivers/xf86-input-evdev
      Latest version available: 2.1.3
      Latest version installed: [ Not Installed ]
      Size of files: 271 kB
      Homepage:      http://xorg.freedesktop.org/
      Description:   Generic Linux input driver
      License:       xf86-input-evdev


J'ai donc lancé un
Code:
sudo USE="-hal" emerge -av xorg-server

mais il y a autre chose qui coince on dirait !
Code:
!!! The following installed packages are masked:
- dev-python/PyQt4-4.3.3 (masked by: package.mask)
/usr/portage/profiles/arch/x86/package.mask:
# Markus Meier <maekke@gentoo.org> (18 Jan 2009)
# mask these versions for a smooth upgrade of x11-libs/qt-4.4.2 wrt bug #248038.

- x11-libs/qt-4.3.3 (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Je vois du Qt-4 il est vrai que je suis toujours sous kde3.5.
Que faut-il faire ?
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Tue Apr 21, 2009 11:00 am    Post subject: Reply with quote

Bah j'ai eu des emmerdes avec mon Desktop et mon Laptop...
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
swilmet
n00b
n00b


Joined: 14 Mar 2007
Posts: 70
Location: Belgium

PostPosted: Tue Apr 21, 2009 11:37 am    Post subject: Reply with quote

Moi c'est mon touchpad qui foire... Heureusement je l'utilise pas très souvent.
Back to top
View user's profile Send private message
nonas
Guru
Guru


Joined: 17 Apr 2005
Posts: 328

PostPosted: Tue Apr 21, 2009 12:00 pm    Post subject: Reply with quote

Sur ma station c'est le basculement de X vers un tty qui freeze la machine et j'ai toujours pas trouvé pourquoi :(
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Tue Apr 21, 2009 12:39 pm    Post subject: Reply with quote

Salut.

Un petit conseil, concernant nvidia et xorg-server-1.5:
Si tu est en drivers legacy (nvidia-96.xx), la version stable (96.43.09) provoque des erreurs de rendu des fontes avec wine (winecfg) et un peu avec firefox. Une petite recherche sur le bugzilla (https://bugs.gentoo.org/show_bug.cgi?id=265260) m'a amené à la version (96.43.11) qui résoud le problème.

Voilà.
Bruno
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Apr 21, 2009 1:13 pm    Post subject: Reply with quote

ah merci ça me sera utile puisqu'effectivement j'utilise le même driver
Code:
Latest version installed: 96.43.09

Sais-tu me dire comment contourner mon pb d'emerge de xorg-server
car je viens de lancer un
Code:
USE="-hal" emerge -av xorg-server
et voilà le message qu'il me retourne sans rien compiler !
Quote:
!!! The following installed packages are masked:
- dev-python/PyQt4-4.3.3 (masked by: package.mask)
/usr/portage/profiles/arch/x86/package.mask:
# Markus Meier <maekke@gentoo.org> (18 Jan 2009)
# mask these versions for a smooth upgrade of x11-libs/qt-4.4.2 wrt bug #248038.

- x11-libs/qt-4.3.3 (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Tue Apr 21, 2009 1:47 pm    Post subject: Reply with quote

Je dirais que ce message d'erreur n'a rien avoir avec xorg-server... c'est au niveau de Qt4 et son bindings python (PyQt4).
Tu as un paquets qui réclame PyQt4-4.3.3 et qt4.4.3.3 et ceux-ci sont masqués. c'est bizarre car ils ne sont plus dans portage:
Code:

$ eix --exact qt
[U] x11-libs/qt
     Available versions: 
   (3)   [M]3.3.8-r4 3.3.8b-r1
   (4)   4.4.2 ~4.5.0
$ eix --exact PyQt4
* dev-python/PyQt4
     Available versions:  ~4.4-r1 4.4.4-r1 4.4.4-r2 ~4.4.4-r3 {X dbus debug doc examples opengl qt3support svg webkit}


Cela peut venir de ta configuration: qt4 masqué manuellement...
qt3 et qt4 peuvent être installé en même temps, et kde3.5 devrait uniquement dépendre de qt3 et ignorer qt3.

Bruno
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Tue Apr 21, 2009 2:05 pm    Post subject: Reply with quote

BENJI wrote:
Code:
USE="-hal" emerge -av xorg-server

Deux remarques :
1. En procédant d'une manière aussi crade, il y a de fortes chances que ton prochain upgrade ramène quand même le flag "hal" à l'insu de ton plein gré ;)
La manière propre est d'utiliser le fichier /etc/portage/package.use ...
2. deuzio, si par la suite tu décidais quand-même d'utiliser hal, tu devrais recompiler avec le flag.
L'astuce, c'est de compiler avec le flag "hal" et de rajouter l'option suivante dans la Section "ServerFlags" de ton xorg.conf :
Code:
Option "AutoAddDevices" "False"

De cette manière, tu conserves la possibilité "hal" pourlecazou mais tu forces xorg à utiliser ta config habituelle sans rien changer.
Pour expérimenter l'une ou l'autre approche, il suffit dès lors simplement de jouer avec l'option AutoAddDevices

Pour les problèmes qt4, comme le signale brubru, ces versions ne sont même plus dans portage.
Tu peux trouver les paquets qui les réclament en faisant
Code:
equery d qt-4.3.3
equery d PyQt4-4.3.3
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Wed Apr 22, 2009 3:29 pm    Post subject: Reply with quote

Voilà le résultat de equery ! A part vlc je sais pas d'où le reste sort !
Code:
ataualpa ben # equery d qt-4.3.3

[ Searching for packages depending on qt-4.3.3... ]
app-crypt/qca-2.0.0-r2 (>=x11-libs/qt-4.2.0:4)
app-text/poppler-bindings-0.8.7 (qt4? =x11-libs/qt-4.3*)
dev-python/PyQt4-4.3.3 (=x11-libs/qt-4.3*)
games-emulation/dboxfe-0.1.3 (x11-libs/qt:4)
media-video/vlc-0.9.8a (qt4? =x11-libs/qt-4.3*:4)
                       (skins? =x11-libs/qt-4.3*:4)
x11-libs/qscintilla-2.1-r1 (qt4? =x11-libs/qt-4.3*:4)

ataualpa ben # equery d PyQt4-4.3.3

[ Searching for packages depending on PyQt4-4.3.3... ]
dev-python/pynotifier-0.7.0 (qt4? dev-python/PyQt4)
dev-python/qscintilla-python-2.1 (qt4? dev-python/PyQt4)
media-video/subdownloader-2.0.7 (dev-python/PyQt4)


Qu'est-ce que je dois faire ?

Sinon je te rassure "USE=..." c'est pas mon genre d'installer ça comme ça par contre pour un essai (-av) c'est bien pratique !
Je suivrai ton conseil pour l'option false. J'ai retrouvé dans tes explications un petit peu de ce que j'avais entrevu dans le guide de migration. Merci pour ton résumer il est tout ce qu'il y a de plus clair !
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Thu Apr 23, 2009 7:03 am    Post subject: Reply with quote

Est-ce que je peux pas tout simplement commencer par désinsitaller les deux paquet qui bloquent ?
qt-4.3.3
PyQt4-4.3.3
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Thu Apr 23, 2009 8:34 am    Post subject: Reply with quote

BENJI wrote:
Est-ce que je peux pas tout simplement commencer par désinsitaller les deux paquet qui bloquent ?
qt-4.3.3
PyQt4-4.3.3


Mets les à jour :)
Les versions 4.3.x ne sont même plus dans l'arbre :lol:
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Thu Apr 23, 2009 9:18 am    Post subject: Reply with quote

Je ne doute pas que ce que tu me dis sois la solution mais j'avoue ne pas comprendre concrètement ce que tu me demandes de faire ?
La mise à jour est bloque, ça ne change rien
Code:
ataualpa ben # emerge -av x11-libs/qt

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-libs/qt-core-4.4.2-r2  USE="glib iconv qt3support ssl -custom-cxxflags -debug -doc -pch" 102,858 kB
[ebuild  N    ] x11-libs/qt-sql-4.4.2-r1  USE="iconv mysql qt3support sqlite -custom-cxxflags -debug -firebird -odbc -pch -postgres" 0 kB
[ebuild  N    ] x11-libs/qt-script-4.4.2  USE="-custom-cxxflags -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.4.2  USE="-custom-cxxflags -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-custom-cxxflags -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-dbus-4.4.2  USE="-custom-cxxflags -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-gui-4.4.2-r3  USE="accessibility cups dbus glib qt3support tiff -custom-cxxflags -debug -mng -nas -nis -pch -xinerama" INPUT_DEVICES="-wacom" 0 kB
[ebuild  N    ] x11-libs/qt-qt3support-4.4.2  USE="accessibility -custom-cxxflags -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-webkit-4.4.2-r1  USE="-custom-cxxflags -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-opengl-4.4.2  USE="qt3support -custom-cxxflags -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-svg-4.4.2  USE="-custom-cxxflags -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-assistant-4.4.2-r1  USE="webkit -custom-cxxflags -debug -pch" 0 kB
[ebuild     U ] x11-libs/qt-4.4.2 [4.3.3] USE="opengl -dbus -qt3support* (-accessibility%*) (-cups%*) (-debug%) (-doc%) (-examples%) (-firebird%) (-gif%*) (-glib%) (-jpeg%*) (-mng%) (-mysql%*) (-nas%) (-nis%) (-odbc%) (-pch%) (-png%*) (-postgres%) (-sqlite%) (-sqlite3%) (-ssl%*) (-tiff%*) (-xinerama%) (-zlib%*)" INPUT_DEVICES="(-wacom%)" 0 kB
[blocks b     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)
[blocks b     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-opengl-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks b     ] <x11-libs/qt-4.4.0:4 ("<x11-libs/qt-4.4.0:4" is blocking x11-libs/qt-assistant-4.4.2-r1)

Total: 13 packages (1 upgrade, 12 new), Size of downloads: 102,858 kB
Conflict: 3 blocks

Would you like to merge these packages? [Yes/No] n

Quitting.


A vrai dire, je ne comprends plus rien, comment faut-il gérer ce genre de problème. Je suis complètement bloqué, je n'ose rien faire car je ne comprend même pas mon problème. Si l'un d'entre vous pouvait m'aider à arrêter de m'en faire une montagne ce serait vraiment très sympa.
Comment faut-il lire ce message ?
4 paquets sont bloqués mais à cause de qui, pourquoi ça j'arrive pas à me débrouiller tout seul pour le comprendre !
Ensuite sont-ils nécessaire... je ne sais même pas le dire. Ma machine est vieille, les temps de compilation sont long donc j'évite de partir dans tous les sens !

Code:
Total: 78 packages (65 upgrades, 12 new, 1 in new slot), Size of downloads: 297,882 kB
Conflict: 4 blocks (3 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [?] indicates that the source repository could not be determined

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-libs/qt-script-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')

  ('ebuild', '/', 'media-libs/mesa-7.3-r1', 'merge') pulled in by
    media-libs/mesa required by ('installed', '/', 'kde-base/kopete-3.5.9', 'nomerge')
    media-libs/mesa required by ('installed', '/', 'games-action/armagetronad-0.2.8.2.1', 'nomerge')
    media-libs/mesa required by ('installed', '/', 'x11-libs/qt-3.3.8b-r1', 'nomerge')
    (and 17 more)

  ('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')

  ('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge') pulled in by
    x11-libs/qt-core:4 required by ('installed', '/', 'app-crypt/qca-2.0.0-r2', 'nomerge')
    ~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
    ~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge')
    (and 4 more)

  ('installed', '/', 'x11-libs/qt-4.3.3', 'nomerge') pulled in by
    =x11-libs/qt-4.3* required by ('installed', '/', 'dev-python/PyQt4-4.3.3', 'nomerge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- dev-python/PyQt4-4.3.3 (masked by: package.mask)
/usr/portage/profiles/arch/x86/package.mask:
# Markus Meier <maekke@gentoo.org> (18 Jan 2009)
# mask these versions for a smooth upgrade of x11-libs/qt-4.4.2 wrt bug #248038.

- x11-libs/qt-4.3.3 (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Code:
cat /etc/portage/package.mask
#>=x11-drivers/nvidia-drivers-1.0.9700
>=x11-drivers/nvidia-drivers-97.0.0
<=media-video/ffmpeg-0.4.9_p20070616-r20
=media-video/vlc-0.9.0
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Thu Apr 23, 2009 12:11 pm    Post subject: Reply with quote

Salut.

1.
Quelle est ta version de portage ? (emerge --info)
Les dernières versions gèrent les blocks de façon quasi-automatique dans certains cas.
Un petit emerge -1av portage est une bonne idée avant de mettre un système complet à jour.

2.
le paquet qt4 a été divisé en plusieurs partie qt4-core, qt4-gui... à partir de la version 4.4 je crois, d'où les blocages avec qt-4.3. Si portage ne résous pas les blocks tous seul, le plus simple est de virer qt-4.4.3 manuellement et de laisser emerge world installer qt-4.4. Attention aux problèmes de dépendances avec les autres applis qt-4 qui risquent de ne plus marcher le temps de la mise à jour.

3.
Si tu utilise vlc (d'après le package.mask), l'interface graphique est passée de wxWindows a Qt4 aux alentours de vlc-0.8.6. D'où la dépendance de Qt4. Si tu n'en veux pas tu peut toujours désactiver le USE qt4 pour vlc mais tu n'auras plus d'interface graphique. Après il y a peut-être d'autres applications qui dépendent de Qt4.

4.
Je pense que tu pourrais aussi bloquer (masquer) la mise à jour de Qt4, mais portage gère mal les versions de programmes installés mais plus dans l'arbre portage. Il y aura un message d'erreur et c'est pas sùr qu'il arrive à résoudre l'arbre des dépendances (comme actuellement).

Bruno.
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Thu Apr 23, 2009 12:52 pm    Post subject: Reply with quote

Voilà, j'ai l'impression que portage est à jour :
Code:
ataualpa ben # emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.25-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r8-i686-Intel-R-_Celeron-TM-_CPU_1300MHz-with-glibc2.0
Timestamp of tree: Tue, 21 Apr 2009 05:30:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo http://gentoo.modulix.net/gentoo/ "
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j2"
PKGDIR="/mnt/oasis/gentoo_package"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/armagetron /usr/portage/local/layman/pro-audio /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl alsa apache2 berkdb bluetooth bzip2 cli cracklib crypt cups dri dvd dvdread encode fortran fr gd gdbm gif gpm hal iconv ipv6 isdnlog jpeg kde lirc midi mp3 mudflap mysql ncurses nls nptl nptlonly opengl openmp pam pcre perl png pppd python qt3 qt4 readline reflection samba sdl session simplexml spl ssl sysfs tcpd tiff truetype unicode usb vorbis x86 xml xml2 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="fbdev nv nvidia vesa vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Apr 27, 2009 8:33 am    Post subject: Reply with quote

la compile est terminée et au final il n'y a eu aucun blocage...
Au démarrage xdm ne se lance plus.
un startx me lance KDE mais la souris et le clavier sont inutilisables... pratique pour l'éteindre ensuite.

Une idée ?
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Mon Apr 27, 2009 12:29 pm    Post subject: Reply with quote

Qu'indique /var/log/Xorg.0.log ?
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Apr 27, 2009 2:52 pm    Post subject: Reply with quote

Code:
ben@ataualpa ~ $ tail -30 /var/log/Xorg.0.log
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(II) config/hal: Adding input device ImPS/2 Generic Wheel Mouse
(II) LoadModule: "evdev"

(WW) Warning, couldn't open module evdev
(II) UnloadModule: "evdev"
(EE) Failed to load module "evdev" (module does not exist, 0)
(EE) No input driver matching `evdev'
(EE) config/hal: NewInputDeviceRequest failed
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) LoadModule: "evdev"

(WW) Warning, couldn't open module evdev
(II) UnloadModule: "evdev"
(EE) Failed to load module "evdev" (module does not exist, 0)
(EE) No input driver matching `evdev'
(EE) config/hal: NewInputDeviceRequest failed
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Mon Apr 27, 2009 3:00 pm    Post subject: Reply with quote

BENJI wrote:
(EE) No input driver matching `evdev'

As-tu emergé xf86-input-evdev ?
Que donne grep INPUT_DEVICES /etc/make.conf :?:
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Apr 27, 2009 3:16 pm    Post subject: Reply with quote

Code:
ben@ataualpa ~ $ grep INPUT_DEVICES /etc/make.conf
INPUT_DEVICES="keyboard mouse"
ben@ataualpa ~ $ emerge -s xf86-input-evdev
Searching...
[ Results for search key : xf86-input-evdev ]
[ Applications found : 1 ]

*  x11-drivers/xf86-input-evdev
      Latest version available: 2.1.3
      Latest version installed: [ Not Installed ]
      Size of files: 271 kB
      Homepage:      http://xorg.freedesktop.org/
      Description:   Generic Linux input driver
      License:       xf86-input-evdev

evdev n'est pas installé c'est juste.

faut-il faire plus que
Code:
emerge -av xf86-input-evdev

Faut-il que ce paquet soit dans world ?
Back to top
View user's profile Send private message
Trapamoosch
Apprentice
Apprentice


Joined: 08 May 2004
Posts: 203

PostPosted: Mon Apr 27, 2009 5:17 pm    Post subject: Reply with quote

Pour que evdev soit installé automatiquement, il te faut cette ligne dans ton /etc/make.conf :
Code:
INPUT_DEVICES="evdev"


Et ensuite fais un :
Code:
emerge -NDau xorg-server


Ça devrait tout remettre en place.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum