Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
configurazione internet usando cellulare
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Sun Apr 12, 2009 11:42 am    Post subject: configurazione internet usando cellulare Reply with quote

Salve, ho un nokia 6680 e mi sono fatto l'opzione Alice Maxxi Web Recharge di Tim per navigare
ora il cello mi ci connetto senza problemi via Bluetooth
il mio problema attualmente è questo:
ho copiato la configurazione di /etc/conf.d/net da questa guida su gentoo-wiki
ma dai log appare questo:
Code:
chat[14676]: abort on (BUSY)
chat[14676]: abort on (ERROR)
chat[14676]: abort on (NO ANSWER)
chat[14676]: abort on (NO CARRIER)
chat[14676]: abort on (NO DIALTONE)
chat[14676]: abort on (Invalid Login)
chat[14676]: abort on (Login incorrect)
chat[14676]: failed

e da lì riparte dandomi l'impressione che abbia problemi ad inizializzare
cercando in giro ho trovato delle stringhe di inizializzazione che però non so dove piazzare:
Code:
ATZ
AT+CGDCONT=1,"IP","ibox.tim.it",,0,0


qualcuno sa aiutarmi?
stasera appena rientro riprovo.
grazie e buona pasqua :)
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Sun Apr 12, 2009 5:52 pm    Post subject: Reply with quote

allora aggiorno un attimo
lo script di connessione l'ho modificato così:
Code:
config_ppp0=( "ppp" )
link_ppp0="/dev/rfcomm0"
phone_number_ppp0=( "*99#" )
pppd_ppp0=(
       "maxfail 10"
       "noauth"
       "lcp-echo-interval 5"
       "lcp-echo-failure 12"
       "debug"
       "noipdefault"
       "defaultroute"
       "usepeerdns"
       "ipcp-accept-remote"
       "ipcp-accept-local"
       "holdoff 3"
       "noaccomp noccp nobsdcomp nodeflate nopcomp novj novjccomp"
       "912600"
       "lock"
       "nocrtscts"
)
chat_ppp0=(
      'ABORT' 'BUSY'
      'ABORT' 'ERROR'
      'ABORT' 'NO ANSWER'
      'ABORT' 'NO CARRIER'
      'ABORT' 'NO DIALTONE'
      'ABORT' 'Invalid Login'
      'ABORT' 'Login incorrect'
      'TIMEOUT' '5'
      '' 'ATZ'
      'OK' 'AT+CGDCONT=1,"IP","ibox.tim.it",,0,0'
      'OK' 'ATDT\T'
      'TIMEOUT' '60'
      'CONNECT'
      'TIMEOUT' '5'
      '~--'
)


dove ho inserito le righe di inizializzazione che ho trovato.

e il risultato è questo:
Code:
pppd[3951]: speed 912600 not supported
chat[4041]: abort on (BUSY)
chat[4041]: abort on (ERROR)
chat[4041]: abort on (NO)
chat[4041]: expect (ANSWER)
chat[4041]: alarm
chat[4041]: Failed
pppd[3951]: Connect script failed

il che mi fa intuire che c'è qualcos'altro
il dispositivo si connette al cello visto che sul cello vedo la connessione BT attiva.
e rfcomm non da errori (normalmente uscirebbe qualcosa nei log)

non so dove sbattere la testa.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Mon Apr 13, 2009 6:44 pm    Post subject: Reply with quote

ho avuto un problema simile poco tempo fa. penso che sia un problema di baselayout nel gestire le virgolette nelle varie opzioni.
avevo risolto utilizzando wvdial.

purtroppo ho cancellato quei file di configurazione.
_________________
LP
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Tue Apr 14, 2009 11:31 am    Post subject: Reply with quote

lucapost wrote:
ho avuto un problema simile poco tempo fa. penso che sia un problema di baselayout nel gestire le virgolette nelle varie opzioni.
avevo risolto utilizzando wvdial.

purtroppo ho cancellato quei file di configurazione.


grazie luca, infatti ho notato che nel file net postato su gentoo-wiki aveva degli errori proprio di apici
in ogni caso ho dato un occhio a net.example e ho notato questo:
/etc/conf.d/net.example:
# Here you should specify what pppd plugins you want to use
# Available plugins are: pppoe, pppoa, capi, dhcpc, minconn, radius,
#          radattr, radrealms and winbind
plugins_ppp0=(
   "pppoe"
   "pppoa vc-encaps"
   "capi"
)

perché da quello che ho capito questo è nuovo modulo introdotto con il nuovo baselayout
non vorrei che fosse questo che blocca il tutto.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Tue Apr 14, 2009 12:00 pm    Post subject: Reply with quote

Giunsi alle stesse conclusioni.
Ora non utilizzo più quel genere di connessioni, ma tempo fa per un piccolo bug in baselayout2, partecipai ad una discussione sul forum internazionale.
Nel giro di poche ore Roy Marples mi fornì direttamente una patch, all'ebuild successivo il problema era stato risolto.
Io proverei questa strada fossi in te... :wink:
_________________
LP
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Tue Apr 14, 2009 12:03 pm    Post subject: Reply with quote

lucapost wrote:
Io proverei questa strada fossi in te... :wink:

aka forum internazionale ?
[edit]ok fatto il post
se e quando risolverò, provvederò a sincronizzare anche questo post.
grazie ancora lucapost per il tempo :)
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum