Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Aggiornamento portage] qt-4.5 e qt-4.4.2
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
luigi.malago
Apprentice
Apprentice


Joined: 31 May 2005
Posts: 292
Location: Mantova (Italy)

PostPosted: Sat Apr 11, 2009 7:34 pm    Post subject: [Aggiornamento portage] qt-4.5 e qt-4.4.2 Reply with quote

Salve a tutti,
ho un problema di dipendenze di qt...

Code:

tux luigi # emerge -DupN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] app-arch/cpio-2.9-r2 [2.9-r1]
[ebuild     U ] dev-libs/libsigc++-2.2.3 [2.2.2]
[ebuild     UD] media-plugins/live-2008.09.02 [2008.11.13]
[ebuild     U ] net-misc/dhcpcd-4.0.7 [4.0.2]
[ebuild     U ] sys-libs/timezone-data-2009c [2009b]
[ebuild     U ] dev-libs/eventlog-0.2.9 [0.2.7]
[ebuild     U ] sys-fs/dosfstools-3.0.1 [3.0.0]
[ebuild   R   ] sys-libs/libstdc++-v3-3.3.6  USE="(-build%) (-nptl%*)"
[ebuild     U ] net-dns/bind-tools-9.4.3_p1 [9.4.2_p2]
[ebuild     U ] dev-db/sqlite-3.6.11 [3.6.10]
[ebuild     U ] app-arch/rpm2targz-9.0.0.3g [9.0-r7]
[ebuild     U ] dev-libs/libburn-0.5.8 [0.5.2]
[ebuild     U ] app-dicts/myspell-en-20081002 [20060316]
[ebuild     U ] dev-libs/libisofs-0.6.12 [0.6.8]
[ebuild     U ] dev-libs/libksba-1.0.5 [1.0.3]
[ebuild  N    ] dev-lang/lua-5.1.4  USE="deprecated readline -static"
[ebuild     U ] app-emacs/emacs-common-gentoo-1.0 [0.3] USE="X%*"
[ebuild     U ] dev-java/sun-jdk-1.5.0.18 [1.5.0.17]
[ebuild  N F  ] dev-java/sun-jms-1.1-r2  USE="doc"
[ebuild     U ] net-misc/whois-4.7.27 [4.7.26]
[ebuild     U ] x11-misc/util-macros-1.2.1 [1.1.5]
[ebuild     U ] dev-libs/check-0.9.5-r1 [0.9.5]
[ebuild  N    ] media-libs/xvid-1.1.3  USE="(-altivec) -examples"
[ebuild     U ] app-admin/syslog-ng-2.1.3 [2.0.9] USE="-sql%"
[ebuild     U ] dev-util/valgrind-3.4.0 [3.3.1]
[ebuild     U ] media-libs/libsamplerate-0.1.4 [0.1.2-r1]
[ebuild     U ] x11-proto/xproto-7.0.14 [7.0.10]
[ebuild     U ] x11-proto/inputproto-1.5.0 [1.4.2.1]
[ebuild     U ] x11-libs/xtrans-1.2.3 [1.2.1]
[ebuild     U ] x11-proto/randrproto-1.2.2 [1.2.1]
[ebuild     U ] x11-libs/libdrm-2.4.5 [2.3.0]
[ebuild     U ] x11-proto/xf86driproto-2.0.4 [2.0.3]
[ebuild     U ] x11-proto/printproto-1.0.4 [1.0.3]
[ebuild     U ] x11-libs/pixman-0.14.0-r1 [0.12.0]
[ebuild   R   ] x11-proto/fontcacheproto-0.1.2  USE="(-debug%)"
[ebuild  N    ] x11-proto/dri2proto-1.99.3
[ebuild     U ] x11-proto/xextproto-7.0.4 [7.0.2]
[ebuild     U ] x11-libs/libXau-1.0.4 [1.0.3]
[ebuild     U ] x11-apps/rgb-1.0.3 [1.0.1]
[ebuild     U ] x11-libs/libX11-1.1.5 [1.1.4]
[ebuild     U ] x11-libs/libSM-1.1.0 [1.0.3]
[ebuild     U ] x11-libs/libXext-1.0.4 [1.0.3]
[ebuild     U ] x11-libs/libxkbfile-1.0.5 [1.0.4]
[ebuild     U ] x11-libs/libXinerama-1.0.3 [1.0.2]
[ebuild     U ] x11-libs/libXi-1.2.1 [1.1.3]
[ebuild     U ] x11-libs/libXv-1.0.4 [1.0.3]
[ebuild     U ] x11-libs/libXxf86vm-1.0.2 [1.0.1]
[ebuild     U ] x11-libs/libXScrnSaver-1.1.3 [1.1.2]
[ebuild     U ] x11-apps/xkbcomp-1.0.5 [1.0.3]
[ebuild     U ] x11-misc/xkeyboard-config-1.5 [1.1]
[ebuild     U ] x11-libs/libXmu-1.0.4 [1.0.3]
[ebuild     U ] x11-libs/libXrandr-1.2.3 [1.2.1]
[ebuild     U ] x11-libs/libXfont-1.3.4 [1.3.1-r1]
[ebuild     U ] x11-apps/xauth-1.0.3 [1.0.2]
[ebuild     U ] x11-wm/twm-1.0.4 [1.0.3]
[ebuild     U ] x11-apps/xrandr-1.2.3 [1.2.2]
[ebuild     U ] media-libs/mesa-7.3-r1 [7.0.3] USE="nptl*"
[ebuild     U ] x11-libs/libXaw-1.0.5 [1.0.4]
[ebuild     U ] sys-apps/groff-1.20.1-r1 [1.19.2-r1] LINGUAS="-ja%"
[ebuild     U ] x11-apps/xmessage-1.0.2-r1 [1.0.2]
[ebuild     U ] x11-apps/mesa-progs-7.3 [7.0.1]
[ebuild     U ] dev-libs/openssl-0.9.8k [0.9.8j]
[ebuild     U ] net-misc/ntp-4.2.4_p6 [4.2.4_p5]
[ebuild     U ] dev-python/pyorbit-2.24.0 [2.14.3]
[ebuild   R   ] app-portage/layman-1.1.1  USE="-subversion%"
[ebuild     U ] media-libs/lcms-1.18 [1.17]
[ebuild  N    ] dev-java/json-simple-20080420  USE="doc -source"
[ebuild     U ] dev-java/glazedlists-1.7.0 [1.5.0] USE="java5%*"
[ebuild     U ] dev-java/commons-collections-3.2.1 [3.2] USE="-test% -test-framework%"
[ebuild     U ] dev-java/icu4j-3.8.1-r1 [3.8.1]
[ebuild     U ] media-libs/netpbm-10.44.00-r1 [10.43.00]
[ebuild     U ] app-text/gnome-doc-utils-0.14.2 [0.12.2-r1]
[ebuild     U ] sys-apps/man-1.6f-r3 [1.6f-r2] USE="-lzma%"
[ebuild     U ] app-editors/nano-2.1.7-r1 [2.1.7]
[ebuild     U ] sys-devel/gdb-6.8-r1 [6.7.1-r3] USE="-multitarget%"
[ebuild     U ] sys-fs/e2fsprogs-1.41.3-r1 [1.41.3]
[ebuild  N    ] media-sound/twolame-0.3.12
[ebuild  N    ] app-text/enscript-1.6.4-r4  USE="nls -ruby"
[ebuild  N    ] app-text/asciidoc-8.2.6  USE="-examples -vim-syntax"
[ebuild     U ] app-text/enchant-1.4.2 [1.3.0] USE="hunspell%* -aspell% -zemberek%"
[ebuild     U ] sys-apps/iproute2-2.6.26-r2 [2.6.22.20070710]
[ebuild  NS   ] sys-devel/gcc-4.3.2-r3 [3.4.6-r2, 4.1.2] USE="doc fortran gtk mudflap nls openmp (-altivec) -bootstrap -build (-fixed-point) -gcj (-hardened) -ip28 -ip32r10k -libffi (-multilib) -multislot (-n32) (-n64) -nocxx -nopie -objc -objc++ -objc-gc -test -vanilla"
[ebuild  N    ] media-libs/babl-0.0.22  USE="-mmx -sse"
[ebuild     U ] sys-apps/man-pages-3.19 [3.15]
[ebuild   R   ] app-office/openoffice-bin-3.0.0  LINGUAS="-ru%"
[ebuild     U ] dev-libs/elfutils-0.131-r2 [0.127]
[ebuild     U ] net-libs/gnutls-2.6.4 [2.4.1-r2] USE="cxx%*"
[ebuild     U ] app-cdr/cdrdao-1.2.2-r3 [1.2.2-r2]
[ebuild  NS   ] dev-java/commons-lang-2.4 [2.0-r2] USE="doc -source -test"
[ebuild     U ] dev-libs/libcroco-0.6.2 [0.6.1] USE="doc%*"
[ebuild     U ] app-portage/gentoolkit-0.2.4.2-r1 [0.2.4.2]
[ebuild  N    ] dev-java/jpf-1.5.1
[ebuild  NS   ] dev-java/avalon-logkit-2.1-r2 [1.2-r2] USE="doc -source -test"
[ebuild  N    ] dev-java/xom-1.0-r7  USE="doc -examples -source"
[ebuild     U ] dev-java/ant-antlr-1.7.1-r1 [1.7.1]
[ebuild  N    ] dev-java/saxpath-1.0-r2  USE="doc -source -test"
[ebuild     U ] dev-java/ant-apache-bsf-1.7.1-r1 [1.7.1] USE="python%* -javascript% -tcl%"
[ebuild  N    ] dev-java/jdom-1.0_beta9-r2  USE="doc -examples -source"
[ebuild  N    ] dev-java/werken-xpath-0.9.4_beta-r1  USE="doc -source"
[ebuild     U ] x11-libs/libXft-2.1.13 [2.1.12]
[ebuild     U ] app-text/poppler-0.10.5 [0.10.4]
[ebuild  N    ] virtual/poppler-0.10.5
[ebuild     U ] x11-terms/xterm-242 [239]
[ebuild     U ] x11-apps/xclock-1.0.3-r1 [1.0.3]
[ebuild     U ] app-text/xpdf-3.02-r2 [3.02-r1]
[ebuild  N    ] virtual/poppler-utils-0.10.4  USE="abiword"
[ebuild     U ] sys-apps/busybox-1.13.2 [1.11.3]
[ebuild     U ] sys-apps/shadow-4.1.2.2 [4.0.18.2] USE="-audit%"
[ebuild     U ] net-misc/openssh-5.2_p1-r1 [5.1_p1-r1] USE="-pkcs11%"
[ebuild     U ] x11-apps/xsm-1.0.1-r1 [1.0.1]
[ebuild     U ] x11-apps/xinit-1.0.8-r4 [1.0.5-r1]
[ebuild     U ] x11-apps/xdm-1.1.8 [1.1.6]
[ebuild   R   ] dev-cpp/gtkmm-2.12.7  USE="(-accessibility%)"
[ebuild     U ] www-client/mozilla-firefox-bin-3.0.8 [3.0.5]
[ebuild     U ] net-ftp/gftp-2.0.19 [2.0.18-r6]
[ebuild     U ] www-plugins/adobe-flash-10.0.22.87 [10.0.15.3] USE="32bit%* (-multilib)"
[ebuild     U ] media-gfx/gqview-2.1.5 [2.0.4] USE="-lcms%"
[ebuild   R   ] sci-electronics/gerbv-1.0.1-r1  USE="xinerama*"
[ebuild   R   ] net-wireless/wifi-radar-1.9.8-r1  USE="svg*"
[ebuild     U ] dev-python/pygtksourceview-2.4.0 [2.2.0]
[ebuild   R   ] dev-libs/cyrus-sasl-2.1.22-r2  USE="ldap* mysql*"
[ebuild     U ] app-admin/sudo-1.7.0 [1.6.9_p17]
[ebuild     U ] app-text/djvu-3.5.21_p20090103 [3.5.21]
[ebuild     U ] x11-libs/libnotify-0.4.5 [0.4.4]
[ebuild     U ] x11-misc/notification-daemon-0.4.0 [0.3.7] USE="gstreamer%*"
[ebuild   R   ] x11-libs/qt-gui-4.5.0  USE="xinerama*"
[ebuild     U ] net-wireless/wpa_supplicant-0.6.4 [0.5.7] USE="-debug% -ps3%"
[ebuild     U ] net-im/skype-2.0.0.72 [2.0.0.68]
[ebuild     U ] app-text/aspell-0.60.6 [0.60.5] LINGUAS="it%* -af% -be% -bg% -br% -ca% -cs% -cy% -da% -de% -el% -en% -eo% -es% -et% -fi% -fo% -fr% -ga% -gl% -he% -hr% -is% -nl% -no% -pl% -pt% -ro% -ru% -sk% -sl% -sr% -sv% -uk% -vi%"
[ebuild     U ] app-editors/emacs-22.3-r2 [22.3-r1]
[ebuild     UD] media-gfx/splashutils-1.5.4.2 [1.5.4.3]
[ebuild     U ] media-gfx/splash-themes-gentoo-20080914 [20050429]
[ebuild  NS   ] sys-kernel/gentoo-sources-2.6.27-r8 [2.6.17-r7, 2.6.17-r8, 2.6.18-r3, 2.6.18-r4, 2.6.18-r6, 2.6.19-r5, 2.6.20-r7, 2.6.20-r8, 2.6.21-r4, 2.6.22-r2, 2.6.22-r8, 2.6.23-r3, 2.6.24-r8, 2.6.25-r6, 2.6.26-r3, 2.6.27-r7] USE="-build -symlink"
[ebuild   R   ] media-libs/svgalib-1.9.25  USE="kernel-helper%* (-no-helper%)"
[ebuild     UD] x11-base/x11-drm-20070314 [20080710]
[ebuild     U ] sys-fs/fuse-2.7.4 [2.7.0]
[ebuild   R   ] net-wireless/libbtctl-0.9.0  USE="(-mono%)"
[ebuild   R   ] app-editors/nvu-1.0-r4  USE="xinerama*"
[ebuild     U ] gnome-extra/libgsf-1.14.11 [1.14.10]
[ebuild     U ] media-gfx/imagemagick-6.4.8.3 [6.4.4.6]
[ebuild   R   ] net-libs/xulrunner-1.8.1.19  USE="xinerama*"
[ebuild     U ] dev-libs/apr-1.3.3 [1.3.2] USE="urandom*"
[ebuild     U ] media-libs/libexif-0.6.17 [0.6.16-r1]
[ebuild     UD] app-text/libspectre-0.2.1 [0.2.2]
[ebuild   R   ] kde-base/kdelibs-3.5.9-r4  USE="xinerama*"
[ebuild     U ] dev-libs/apr-util-1.3.4 [1.3.2]
[ebuild     U ] dev-dotnet/libgdiplus-2.0 [1.2.4]
[ebuild   R   ] dev-util/kdevelop-3.5.2-r1  USE="xinerama*"
[ebuild     U ] media-gfx/exif-0.6.17 [0.6.15]
[ebuild     U ] app-admin/apache-tools-2.2.10 [2.2.9]
[ebuild     U ] www-servers/apache-2.2.10 [2.2.9-r1]
[ebuild     U ] dev-util/subversion-1.5.5 [1.5.4]
[ebuild     U ] dev-lang/mono-2.0.1-r1 [1.2.5.1-r1] USE="-minimal%"
[ebuild     U ] net-mail/gnubiff-2.2.10 [2.1.3] USE="fam%* nls%* -debug%"
[ebuild     U ] net-im/pidgin-2.5.5 [2.5.3]
[ebuild  NS   ] dev-java/swt-3.4-r2 [3.3.1.1] USE="cairo gnome opengl xulrunner"
[ebuild     U ] net-p2p/vuze-4.0.0.4 [3.0.4.2-r1]
[ebuild     U ] x11-plugins/pidgin-msn-pecan-0.0.18 [0.0.17]
[ebuild     UD] dev-util/anjuta-2.2.0-r1 [2.24.2]
[ebuild     U ] gnome-extra/gdesklets-core-0.36.1 [0.36-r1]
[ebuild     U ] www-client/epiphany-extensions-2.24.3-r10 [2.22.2]
[ebuild     U ] sys-block/gparted-0.4.1 [0.3.8]
[ebuild     U ] x11-libs/wxGTK-2.8.9.1-r3 [2.8.9.1-r2]
[ebuild     U ] media-video/ffmpeg-0.4.9_p20090201 [0.4.9_p20081219] USE="alsa%* -3dnow% -oss%"
[ebuild     U ] media-libs/libmpeg2-0.5.1 [0.4.1]
[ebuild  N    ] dev-libs/zziplib-0.13.49-r1  USE="sdl -test"
[ebuild     U ] media-video/mjpegtools-1.9.0 [1.8.0-r1]
[ebuild     U ] net-p2p/amule-2.2.3 [2.2.0_pre20080304]
[ebuild     U ] net-ftp/filezilla-3.2.0 [3.1.6] USE="dbus%*"
[ebuild     U ] app-cdr/brasero-0.8.4-r1 [0.8.2] USE="nautilus%* -cdrkit% -cdrtools%"
[ebuild     U ] app-editors/xemacs-21.4.22 [21.4.21-r1]
[ebuild   R   ] media-video/vlc-0.9.8a  USE="xinerama* -cddax% -pda% (-vcd%*)"
[ebuild     U ] media-video/mplayer-1.0_rc2_p28450 [1.0_rc2_p28058-r1] USE="dts* dv* live* md5sum* mp2* oss* x264* xinerama* xvid*"
[ebuild     U ] dev-util/meld-1.2.1 [1.2]
[ebuild     U ] x11-drivers/xf86-video-ati-6.12.2 [6.12.1]
[ebuild  N    ] x11-drivers/xf86-input-synaptics-1.0.0  USE="hal -debug"
[ebuild     U ] x11-drivers/xf86-input-mouse-1.4.0 [1.2.3]
[ebuild     UD] x11-libs/qt-core-4.4.2-r2 [4.5.0]
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-custom-cxxflags -debug -pch"
[ebuild     UD] x11-libs/qt-dbus-4.4.2 [4.5.0]
[ebuild     UD] x11-libs/qt-script-4.4.2 [4.5.0]
[ebuild     UD] x11-libs/qt-sql-4.4.2-r1 [4.5.0]
[ebuild     UD] x11-libs/qt-gui-4.4.2-r3 [4.5.0] USE="xinerama*" INPUT_DEVICES="-wacom%"
[ebuild     UD] x11-libs/qt-qt3support-4.4.2 [4.5.0]
[ebuild     U ] app-text/poppler-bindings-0.10.4 [0.8.7]
[ebuild  N    ] virtual/poppler-glib-0.10.4  USE="cairo"
[ebuild  N    ] dev-java/jdom-1.0-r4  USE="doc -examples -source"
[ebuild  N    ] dev-java/velocity-1.5  USE="doc -examples -source -test"
[ebuild  N    ] dev-java/jaxen-1.1.1  USE="doc -examples -source -test"
[ebuild  N    ] dev-java/jdom-jaxen-1.0-r1
[ebuild  N    ] dev-java/jpfcodegen-0.4
[ebuild     U ] app-text/jabref-2.4.2 [2.3.1]
[ebuild  N    ] dev-ruby/ruby-config-0.3.2
[ebuild  N    ] dev-lang/ruby-1.8.6_p287-r5  USE="berkdb doc gdbm ipv6 ssl -debug -emacs -examples -rubytests -socks5 -threads -tk -xemacs"
[ebuild  N    ] media-libs/gegl-0.0.22  USE="cairo doc jpeg png sdl svg -debug -ffmpeg -mmx -openexr -raw -sse -v4l"
[ebuild  N    ] media-gfx/gimp-2.6.4  USE="alsa dbus doc gnome hal jpeg pdf png python svg tiff -aalib (-altivec) -curl -debug -exif -lcms -mmx -mng -smp -sse -webkit -wmf"
[ebuild  N    ] app-text/texlive-core-2008-r4  USE="X doc -source -tk"
[ebuild  N    ] virtual/tex-base-0
[ebuild  N    ] dev-texlive/texlive-documentation-base-2008  USE="-source"
[ebuild  N    ] dev-texlive/texlive-basic-2008  USE="doc -source"
[ebuild  N    ] dev-tex/mplib-1.110  USE="lua"
[ebuild  N    ] app-text/evince-2.24.2  USE="dbus djvu doc dvi nautilus tiff -debug -gnome-keyring -t1lib"
[ebuild  N    ] dev-tex/luatex-0.30.3  USE="doc"
[ebuild  N    ] dev-texlive/texlive-fontsrecommended-2008  USE="doc -source"
[ebuild  N    ] dev-texlive/texlive-latex-2008-r1  USE="doc -source"
[ebuild  N    ] dev-texlive/texlive-latexrecommended-2008-r2  USE="doc -source"
[uninstall    ] app-text/tetex-3.0_p1-r6
[blocks b     ] app-text/tetex ("app-text/tetex" is blocking app-text/texlive-core-2008-r4)
[ebuild     U ] app-text/pdfjam-1.20-r1 [1.20]
[ebuild     U ] dev-lang/R-2.8.1 [2.7.2]
[ebuild     U ] sci-visualization/gnuplot-4.2.5 [4.2.4-r1] USE="-lua%"
[ebuild  N    ] x11-libs/libpciaccess-0.10.5  USE="-debug -minimal"
[ebuild     U ] x11-base/xorg-server-1.5.3-r5 [1.4.2] USE="nptl*" INPUT_DEVICES="-virtualbox%" VIDEO_CARDS="-ast% -radeonhd% -virtualbox%"
[blocks b     ] <x11-base/xorg-server-1.5 ("<x11-base/xorg-server-1.5" is blocking x11-libs/libpciaccess-0.10.5)
[ebuild     U ] x11-drivers/xf86-input-evdev-2.1.3 [1.1.5-r1] USE="hal%*"
[ebuild  N    ] dev-dotnet/glib-sharp-2.12.8  USE="-debug"
[ebuild  N    ] dev-dotnet/gtk-sharp-gapi-2.12.8  USE="-debug"
[ebuild  N    ] dev-dotnet/pango-sharp-2.12.8  USE="-debug"
[ebuild  N    ] dev-dotnet/atk-sharp-2.12.8  USE="-debug"
[ebuild  N    ] dev-dotnet/gdk-sharp-2.12.8  USE="-debug"
[ebuild     U ] dev-dotnet/gtk-sharp-2.12.8 [2.10.0] USE="-debug%"
[blocks b     ] <=dev-dotnet/gtk-sharp-2.12.7:2 ("<=dev-dotnet/gtk-sharp-2.12.7:2" is blocking dev-dotnet/pango-sharp-2.12.8, dev-dotnet/gtk-sharp-gapi-2.12.8, dev-dotnet/atk-sharp-2.12.8, dev-dotnet/glib-sharp-2.12.8, dev-dotnet/gdk-sharp-2.12.8)
[blocks b     ] dev-dotnet/gdk-sharp ("dev-dotnet/gdk-sharp" is blocking dev-dotnet/gtk-sharp-2.10.0)
[blocks b     ] dev-dotnet/gtk-sharp-gapi ("dev-dotnet/gtk-sharp-gapi" is blocking dev-dotnet/gtk-sharp-2.10.0)
[blocks b     ] dev-dotnet/pango-sharp ("dev-dotnet/pango-sharp" is blocking dev-dotnet/gtk-sharp-2.10.0)
[blocks b     ] dev-dotnet/glib-sharp ("dev-dotnet/glib-sharp" is blocking dev-dotnet/gtk-sharp-2.10.0)
[blocks b     ] dev-dotnet/atk-sharp ("dev-dotnet/atk-sharp" is blocking dev-dotnet/gtk-sharp-2.10.0)
[ebuild     U ] dev-dotnet/evolution-sharp-0.18.1 [0.17.4]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

  ('ebuild', '/', 'x11-libs/qt-script-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')

  ('installed', '/', 'x11-libs/qt-script-4.5.0', 'nomerge') pulled in by
    ~x11-libs/qt-script-4.5.0[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.0', 'merge')

x11-libs/qt-core:4

  ('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge') pulled in by
    ~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-test-4.4.2', 'merge')
    ~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge')
    ~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge')
    (and 7 more)

  ('installed', '/', 'x11-libs/qt-core-4.5.0', 'nomerge') pulled in by
    ~x11-libs/qt-core-4.5.0[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.0', 'nomerge')
    ~x11-libs/qt-core-4.5.0[-debug] required by ('installed', '/', 'x11-libs/qt-script-4.5.0', 'nomerge')
    ~x11-libs/qt-core-4.5.0[glib,qt3support,-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.0', 'merge')
    (and 6 more)

x11-libs/qt-sql:4

  ('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge') pulled in by
    ~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')

  ('installed', '/', 'x11-libs/qt-sql-4.5.0', 'nomerge') pulled in by
    ~x11-libs/qt-sql-4.5.0[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.0', 'nomerge')

x11-libs/qt-dbus:4

  ('installed', '/', 'x11-libs/qt-dbus-4.5.0', 'nomerge') pulled in by
    ~x11-libs/qt-dbus-4.5.0[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.0', 'merge')
    (and 1 more)

  ('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
    (and 1 more)

x11-libs/qt-gui:4

  ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge') pulled in by
    ~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')
    ~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge')
    (and 5 more)

  ('ebuild', '/', 'x11-libs/qt-gui-4.5.0', 'merge') pulled in by
    ~x11-libs/qt-gui-4.5.0[qt3support,accessibility,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.0', 'nomerge')
    ~x11-libs/qt-gui-4.5.0[qt3support] required by ('installed', '/', 'x11-libs/qt-core-4.5.0', 'nomerge')
    (and 5 more)

app-text/poppler:0

  ('ebuild', '/', 'app-text/poppler-0.10.5', 'merge') pulled in by
    ~app-text/poppler-0.10.5 required by ('ebuild', '/', 'app-text/xpdf-3.02-r2', 'merge')
    ~app-text/poppler-0.10.5 required by ('ebuild', '/', 'dev-tex/luatex-0.30.3', 'merge')
    ~app-text/poppler-0.10.5 required by ('ebuild', '/', 'virtual/poppler-0.10.5', 'merge')

  ('installed', '/', 'app-text/poppler-0.10.4', 'nomerge') pulled in by
    ~app-text/poppler-0.10.4 required by ('installed', '/', 'app-misc/tracker-0.6.6-r1', 'nomerge')
    ~app-text/poppler-0.10.4 required by ('installed', '/', 'net-print/cups-1.3.9-r1', 'nomerge')
    ~app-text/poppler-0.10.4 required by ('ebuild', '/', 'virtual/poppler-utils-0.10.4', 'merge')
    (and 1 more)

x11-libs/qt-qt3support:4

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')

  ('installed', '/', 'x11-libs/qt-qt3support-4.5.0', 'nomerge') pulled in by
    ~x11-libs/qt-qt3support-4.5.0[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.0', 'merge')


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.




ho cercato sui forum e ho visto che il problema è noto, ma non sono riuscito a venirne fuori.
Il problema è capire chi vuole la versione 4.4.2. Dopo averla mascherata in package.mask
mi compare questo

Code:

tux luigi # emerge -DupN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

  ('ebuild', '/', 'app-text/poppler-0.10.5', 'merge') pulled in by
    ~app-text/poppler-0.10.5 required by ('ebuild', '/', 'app-text/xpdf-3.02-r2', 'merge')
    ~app-text/poppler-0.10.5 required by ('ebuild', '/', 'dev-tex/luatex-0.30.3', 'merge')
    ~app-text/poppler-0.10.5 required by ('ebuild', '/', 'virtual/poppler-0.10.5', 'merge')

  ('installed', '/', 'app-text/poppler-0.10.4', 'nomerge') pulled in by
    ~app-text/poppler-0.10.4 required by ('installed', '/', 'net-print/cups-1.3.9-r1', 'nomerge')
    ~app-text/poppler-0.10.4 required by ('ebuild', '/', 'virtual/poppler-utils-0.10.4', 'merge')
    ~app-text/poppler-0.10.4 required by ('ebuild', '/', 'app-text/poppler-bindings-0.10.4', 'merge')


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy "~x11-libs/qt-core-4.4.2" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-core-4.4.2-r2 (masked by: package.mask)
- x11-libs/qt-core-4.4.2 (masked by: package.mask)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "x11-libs/qt-test-4.4.2" [ebuild])
(dependency required by "app-text/poppler-bindings-0.10.4" [ebuild])
(dependency required by "app-text/evince-2.24.2" [ebuild])
(dependency required by "gnome-base/gnome-2.24.1" [installed])
(dependency required by "world" [argument])


che mi pare strano come risultato, visto che ho pochi pacchetti in ~x86.

grazie mille,
luigi
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Apr 12, 2009 5:32 pm    Post subject: Reply with quote

Da quello che hai postato non si capisce, portage omette qualche informazione che evidentemente è importante. Lancia emerge con l'opzione -t per vedere chi chiama cosa, da quello dovresti riuscire a risalire al pacchetto incriminato.
Back to top
View user's profile Send private message
luigi.malago
Apprentice
Apprentice


Joined: 31 May 2005
Posts: 292
Location: Mantova (Italy)

PostPosted: Sun Apr 12, 2009 10:30 pm    Post subject: Reply with quote

credo di aver capito il problema. la versione stabile delle qt e la 4.4
la 4.5 è stata smascherata come dipendenza di skype in ~x86.
è bastato mettere skype stable e il problema delle dipendenze si è risolto.
mi tengo la 4.4 come è "giusto" che sia.
sto ricompilando tutto, una volta completata se non ci sono problemi legati alle qt metto il tag risolto.

grazie mille,
Luigi
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Apr 12, 2009 11:03 pm    Post subject: Reply with quote

Difficile, skype richiede le qt4 senza specificare 4.4 o 4.5.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum