Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
krb4, kerberos, cannot find -lkrb4 for apache emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
idiotprogrammer
Apprentice
Apprentice


Joined: 29 Jul 2002
Posts: 179
Location: Texas

PostPosted: Fri Aug 15, 2003 10:32 pm    Post subject: krb4, kerberos, cannot find -lkrb4 for apache emerge Reply with quote

(Am relabeling this post. Haven't gotten any responses on my original label).

When I tried to emerge to apache2, it gives the same error:

cannot find -lkrb4 Looking up on google, this appears to be related to kerberos, and on this bug https://bugs.gentoo.org/show_bug.cgi?id=18758, they suggested adding the keyword krb4 use flag.

Well, voila! Adding krb4 keyword solved this problem! Now apache can emerge. But what have I done? Is it good to have this optional kerberos 4 support? Will that hurt other applications? Why the hell did apache insist upon this? Is this just a bug that needs to be ignored? Is this USE variable telling the system to use an older (and maybe buggier and less secure) version of kerberos instead of the latest and greatest?



bin/sh /var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/srclib/apr/libtool --silent --mode=link gcc -pthread -O2 -mcpu=i686 -pipe -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -DAP_HAVE_DESIGNATED_INITIALIZER -I/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/srclib/apr/include -I/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/srclib/apr-util/include -I. -I/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/os/unix -I/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/server/mpm/prefork -I/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/modules/http -I/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/modules/filters -I/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/modules/proxy -I/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/include -I/usr/include/openssl -I/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/modules/dav/main -export-dynamic -L/usr/lib -o htdigest htdigest.lo -lz /var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/srclib/pcre/libpcre.la /var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/srclib/apr-util/libaprutil-0.la -lldap -llber -lgdbm -ldb -lexpat /var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/srclib/apr/libapr-0.la -lrt -lm -lcrypt -lnsl -ldl
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lkrb4
collect2: ld returned 1 exit status
make[2]: *** [htpasswd] Error 1
make[2]: *** Waiting for unfinished jobs....
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lkrb4
collect2: ld returned 1 exit status
make[2]: *** [htdigest] Error 1
make[2]: Leaving directory `/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/support'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/apache-2.0.47/work/httpd-2.0.47/support'
make: *** [all-recursive] Error 1

!!! ERROR: net-www/apache-2.0.47 failed.
!!! Function src_compile, Line 163, Exitcode 2
!!! problem compiling Apache2

*****keywords before I added the krb4 USE variable
USE="oss 3dnow apm avi foomaticdb mad mikmod nls pdflib xv slang guile sdl gpm pam esd opengl acpi -apache apache2 berkdb cdr crypt cups encode evo flash gb gdbm gif -gnome -gtk gtkhtml imap imlib innodb ipv6 java jikes jpeg kde kerberos lcms ldap libg++ libgda libwww mbox mmx motif mozilla mpeg mule mysql ncurses odbc oggvorbis pda perl pic png python postgres qt qtmt quicktime readline ruby samba scanner spell ssl svga tcltk tcpd truetype X xml xml2 xmms zeo x86 zlib arts"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum