Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema avvio[RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Thu Apr 09, 2009 5:53 pm    Post subject: Problema avvio[RISOLTO] Reply with quote

Ho installato GRUB con l'opzione del doppio boot (WIN/GENTOO).
Funziona se i due SO sono installati su 2 hd diversi?

Nel caso durante la compilazione del kernel avessi sbagliato a dare il nome della cartella che lo contiene e quindi questo impedisse l'avvio perchè non trova il percorso corretto, significa che devo ricominciare da capo o posso correggere l'errore?


Last edited by mrl4n on Fri Apr 10, 2009 2:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Thu Apr 09, 2009 6:11 pm    Post subject: Re: Problema avvio Reply with quote

mrl4n wrote:
Ho installato GRUB con l'opzione del doppio boot (WIN/GENTOO).
Funziona se i due SO sono installati su 2 hd diversi?

solo il SO di Redmond ha questi problemi. Deve trovarsi su una partizione primaria del primo disco. Non so se svista ha risolto, ma non ci giurerei.

mrl4n wrote:
Nel caso durante la compilazione del kernel avessi sbagliato a dare il nome della cartella che lo contiene e quindi questo impedisse l'avvio perchè non trova il percorso corretto, significa che devo ricominciare da capo o posso correggere l'errore?

nome della cartella del kernel??? scusa???
cioè vuoi dire che non hai fatto semplicemente:
Code:
emerge -av gentoo-sources
??
in ogni caso, anche se l'avessi fatto, quello che conta è il collegamento simbolico /usr/src/linux alla suddetta cartella.
Questo collegamento simbolico serve ai moduli per trovare gli header per compilare correttamente, di solito ti avvisano e cmq parliamo di moduli esterni e/o binari (nvidia, iwl e balle varie)
considera che i moduli del kernel cmq verranno installati dal comando "make modules_install" in /lib/modules/
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Thu Apr 09, 2009 6:32 pm    Post subject: Re: Problema avvio Reply with quote

Peach wrote:
solo il SO di Redmond ha questi problemi. Deve trovarsi su una partizione primaria del primo disco. Non so se svista ha risolto, ma non ci giurerei.


La mia situazione è questa: windows XP installato su un hd IDE e gentoo su un hd SATA. Cosa intendi quando dici "...deve trovarsi su una partizione primaria del primo disco..."?

Peach wrote:
nome della cartella del kernel??? scusa???
cioè vuoi dire che non hai fatto semplicemente:
Code:
emerge -av gentoo-sources
??


No, ho seguito l'handbook ed ho eseguito la configurazione manuale.
Il problema credo si sia verificato durante l'installazione con
Code:
cp arch/i386/boot/image/bzImage /boot/"kernel-2.6.24-gentoo-r5"
che devo avere modificato in 2.6.27-gentoo-r8 (la versione più recente aggiornata da portage)

Ciliegina sulla torta...ho già riavviato :cry: :cry: :cry: :cry:
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Thu Apr 09, 2009 10:51 pm    Post subject: Re: Problema avvio Reply with quote

mrl4n wrote:
Nel caso durante la compilazione del kernel avessi sbagliato a dare il nome della cartella che lo contiene e quindi questo impedisse l'avvio perchè non trova il percorso corretto, significa che devo ricominciare da capo o posso correggere l'errore?


basta modificare il file /boot/grub/menu.lst, che di solito è un link simbolico a grub.conf, oppure rinominare il file

mrl4n wrote:
Cosa intendi quando dici "...deve trovarsi su una partizione primaria del primo disco..."?


una partizione primaria, cioè non un'unità logica di una partizione estesa. il primo disco cioè quello che il bios riconosce per primo, per grub è visto come (hd0)

se posti il tuo grub.conf magari si riesce a capire meglio cosa c'è che non va
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Apr 10, 2009 7:16 am    Post subject: Reply with quote

Volentieri...ma come faccio ad accedere al contenuto del disco se non si avvia?
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Fri Apr 10, 2009 7:30 am    Post subject: Reply with quote

mrl4n wrote:
Volentieri...ma come faccio ad accedere al contenuto del disco se non si avvia?


impara ad usare il livecd, è l'ancora di salvezza in questi casi (o in casi in cui devi riparare il disco o correggere errori fatti)
ri effettua tutti i passi fino al chroot e l'env-update && source e sei apposto
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Apr 10, 2009 7:41 am    Post subject: Reply with quote

Gentoo 4 - mrl4n 0

E' un'altro giorno...che si inizi la sfida!!!

Grazie mille. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum