Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg 1.5] Super instable depuis mise à jour (+/- Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Poch
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2006
Posts: 105
Location: Namur, Belgique

PostPosted: Wed Apr 08, 2009 4:07 pm    Post subject: [Xorg 1.5] Super instable depuis mise à jour (+/- Résolu) Reply with quote

Salut à tous,

Depuis la mise à jour de Xorg en version 1.5.3, ce dernier à tendance à se crasher en beauté très régulièrement. Une manip simple le fait exploser à chaque fois: je passe une fenêtre quelconque en avant plan devant une fenêtre mplayer avec alt+tab (en cliquant dessus à la souris tout va bien... enfin j'ai pas reproduit le bug c'est p-e un hasard) et boum... me revoilà à l'écran de login :evil:

J'ai recompilé xorg, les drivers, certaines libs, tout xfce, mplayer... mais rien n'y fait :( et j'avoue que j'y comprend pas grand chose...

Voilà des infos sur ma config, mais je ne sais pas trop quoi donner...

Emerge --info:
Code:

emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.25-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r7-i686-Intel-R-_Pentium-R-_Dual_CPU_T2310_@_1.46GHz-with-glibc2.0
Timestamp of tree: Wed, 08 Apr 2009 08:20:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r13, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ "
LANG="fr_BE.UTF-8"
LC_ALL="fr_BE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr fr_BE"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa avi bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt css cups dbus divx4linux dri dvd dvdr dvdread eds emboss encode esd evo fam ffmpeg firefox flac fortran ftp gdbm gif gphoto2 gpm gstreamer gtk gtk2 hal iconv imagemagick ipv6 isdnlog java jpeg ldap libnotify libwww lm_sensors mad man midi mikmod mmx mp3 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf pdflib perl png posix ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session slang spell spl sse ssl startup-notification svg sysfs tcpd tetex tiff truetype unicode usb video vod vorbis win32codecs x86 xml xorg xosd xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" DVB_CARDS="usb-dib0700" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics  evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_BE" USERLAND="GNU" VIDEO_CARDS="i810 intel v4l vesa"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Le xorg.conf
Code:

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        Option          "AIGLX" "true"
EndSection

Section "Files"
        FontPath     "/usr/share/fonts/misc/"
        FontPath     "/usr/share/fonts/TTF/"
        FontPath     "/usr/share/fonts/OTF"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/100dpi/"
        FontPath     "/usr/share/fonts/75dpi/"
        FontPath     "/usr/share/fonts/dejavu"
        FontPath     "/usr/share/fonts/corefonts"
        FontPath     "/usr/share/fonts/cronyx"
        FontPath     "/usr/share/fonts/freefonts"
        FontPath     "/usr/share/fonts/sharefonts"
        FontPath     "/usr/share/fonts/Speedo"
        FontPath     "/usr/share/fonts/terminus"
        FontPath     "/usr/share/fonts/encodings"
        FontPath     "/usr/share/fonts/freefonts-ttf"
        FontPath     "/usr/share/fonts/intlfonts"
EndSection

Section "Module"
        Load  "extmod"
        Load  "dri"
        Load  "record"
        Load  "GLcore"
        Load  "xtrap"
        Load  "dbe"
        Load  "glx"
#Load  "type1"
#       Load  "freetype"
        Load    "ddc"
        Load   "drm"
        Load "synaptics"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "AUO"
        ModelName    "6287"
EndSection

Section "Device"
        Option     "DRI"        "TRUE"          # [<bool>]
        Identifier  "intel"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName   "Mobile Integrated Graphics Controller"
        BusID       "PCI:0:2:0"
        Option  "AccelMethod" "EXA"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "intel"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "dri"
          Group   0
            Mode         0666
EndSection


Les fichiers de conf xml:

/etc/hal/fdi/policy/10-x11-input.fdi
Code:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>         
    <match key="info.capabilities" contains="input.keys">
      <merge key="input.x11_options.XkbLayout" type="string">be</merge>
    </match>
  </device>
</deviceinfo>


et /etc/hal/fdi/policy/11-x11-synaptics.fdi

Code:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
        <merge key="input.x11_driver" type="string">synaptics</merge>
        <!-- Arbitrary options can be passed to the driver using
             the input.x11_options property since xorg-server-1.5. -->
        <merge key="input.x11_options.SHMConfig" type="string">true</merge>
        <merge key="input.x11_options.Protocol" type="string">auto-dev</merge>
        <merge key="input.x11_options.LeftEdge" type="string">130</merge>
        <merge key="input.x11_options.RightEdge" type="string">840</merge>
        <merge key="input.x11_options.TopEdge" type="string">130</merge>
        <merge key="input.x11_options.BottomEdge" type="string">640</merge>
        <merge key="input.x11_options.FingerLow" type="string">7</merge>
        <merge key="input.x11_options.FingerHigh" type="string">8</merge>
        <merge key="input.x11_options.MaxTapTime" type="string">180</merge>
        <merge key="input.x11_options.MaxTapMove" type="string">110</merge>
        <merge key="input.x11_options.EmulateMidButtonTime" type="string">75</merge>
        <merge key="input.x11_options.VertScrollDelta" type="string">20</merge>
        <merge key="input.x11_options.HorizScrollDelta" type="string">20</merge>
        <merge key="input.x11_options.MinSpeed" type="string">0.25</merge>
        <merge key="input.x11_options.MaxSpeed" type="string">0.50</merge>
        <merge key="input.x11_options.AccelFactor" type="string">0.035</merge>
        <merge key="input.x11_options.EdgeMotionMinSpeed" type="string">200</merge>
        <merge key="input.x11_options.EdgeMotionMaxSpeed" type="string">200</merge>
        <merge key="input.x11_options.UpDownScrolling" type="string">1</merge>
        <merge key="input.x11_options.CircularScrolling" type="string">1</merge>
        <merge key="input.x11_options.CircScrollDelta" type="string">0.1</merge>
        <merge key="input.x11_options.CircScrollTrigger" type="string">2</merge>
        <merge key="input.x11_options.Emulate3Button" type="string">on</merge>
        <merge key="input.x11_options.TapButton1" type="string">1</merge>
    </match>
  </device>
</deviceinfo>


De plus certaines applications sont beaucoup plus lentes ou prennent beaucoup plus de CPU qu'avant...
Conky prend plus de 10% du CPU (Intel Dual Core @1.46GHz) pour s'afficher sur le bureau, firefox est beaucoup plus lent et consomme plus de CPU qu'avant sur certaines pages, ...

Avez-vous une idée, une piste vers où chercher?

Merci d'avance...

P.
_________________
Microsoft is not the answer. Microsoft is the question. NO, is the answer.


Last edited by Poch on Thu Apr 09, 2009 8:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Wed Apr 08, 2009 6:57 pm    Post subject: Reply with quote

T'as du AIGLX...
Allez, avoue, ya du compiz pas loin derrière :)

Autre piste, éventuellement upgrade ton noyal pour avoir un driver graphique Intel plus récent. 2.6.25, c'est presque "vieux" :)

Enfin tu as peut être une config Xorg à affiner, on voit que tu as 3 drivers (VIDEO_CARDS). Tu utilises lequel? Peut être que certains pourront t'aider là dessus.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Wed Apr 08, 2009 7:25 pm    Post subject: Reply with quote

C'est peut-être l'option EXA essaye en XAA, elle m'a créé des soucis, j'ai eu ça avec une ati.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Poch
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2006
Posts: 105
Location: Namur, Belgique

PostPosted: Wed Apr 08, 2009 10:04 pm    Post subject: Reply with quote

El_Goretto wrote:
T'as du AIGLX...
Allez, avoue, ya du compiz pas loin derrière :)

Autre piste, éventuellement upgrade ton noyal pour avoir un driver graphique Intel plus récent. 2.6.25, c'est presque "vieux" :)

Enfin tu as peut être une config Xorg à affiner, on voit que tu as 3 drivers (VIDEO_CARDS). Tu utilises lequel? Peut être que certains pourront t'aider là dessus.


J'ai AIGLX mais non pas (enfin, plus) compiz :wink: Ce qui n'est peut-être pas très utile alors? Je ne sais pas trop...

Pour l'upgrade du kernel, oui j'y avais aussi pensé mais la dernière tentative s'était soldée par un échec (kernel panic au boot) en rapport avec la libata et je sais plus trop quoi... Je pensais attendre le 2.6.28 avec le GEM pour voir, mais je vais p-e y passer plus vite que prévu :)

Et pour les drivers je pense que le driver intel est le seul "utile", je vais nettoyer mon make.conf

titoucha wrote:

C'est peut-être l'option EXA essaye en XAA, elle m'a créé des soucis, j'ai eu ça avec une ati.


Ben cette option posait problème lors de la mise à jour justement, avant c'était XAA et j'ai dû changer en EXA (qui est, d'après le man intel, la nouvelle option mieux tout ça) ...
_________________
Microsoft is not the answer. Microsoft is the question. NO, is the answer.
Back to top
View user's profile Send private message
Poch
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2006
Posts: 105
Location: Namur, Belgique

PostPosted: Thu Apr 09, 2009 9:16 am    Post subject: Reply with quote

Petite mise à jour des données du problèmes...

En regardant les messages de /var/log/messages, j'ai ceci qui concerne gdm et qui correspond à mes plantages:

Code:

Apr  9 11:05:30 laptop gdm[6366]: WARNING: gdm_slave_xioerror_handler : erreur X fatale - Redémarrage de :0
Apr  9 11:05:30 laptop gdm[6366]: pam_unix(gdm:session): session closed for user


Je cherche en ce moment sur bugzilla et le forum pour trouver un bug similaire et le résoudre, mais si quelqu'un à une idée, je suis évidemment preneur :)

Edit: J'ai mis (un peu au hasard) l'option NoAccel à true dans le xorg.conf, et commenté AccelMethod et pour le moment ça ne plante plus... c'est déjà ça...
_________________
Microsoft is not the answer. Microsoft is the question. NO, is the answer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum