Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[badblocks] Différents des softs constructeurs (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Trapamoosch
Apprentice
Apprentice


Joined: 08 May 2004
Posts: 203

PostPosted: Mon Apr 06, 2009 6:46 pm    Post subject: [badblocks] Différents des softs constructeurs (résolu) Reply with quote

Bonsoir à tous,

Depuis quelques temps, mon disque dur externe formaté en XFS a un comportement étrange. Des fichiers se corrompent tout seul, même si je n'y touche absolument pas, que ce soit en lecture ou en écriture. Je lance donc un badblocks pour voir, et effectivement il me trouve pas mal de blocks défectueux.
Avant de jeter le disque (qui a juste un peu plus d'un an), je lance quand même l'utilitaire constructeur (le disque est un Hitachi Deskstar donc j'ai récupéré leur "Drive Fitness Test"). Je fais le test complet, et là il me dit que tout est ok. Par curiosité, je tente avec l'utilitaire Western Digital ("WD Diagnostics") : idem, sur le test long pour lui tout est OK.

Du coup, je ne sais pas trop qui croire, badblocks ou les utilitaires constructeurs ? (sachant que des données se sont fait la malle donc le disque a un souci, mais peut-être réparable).


Last edited by Trapamoosch on Wed Apr 15, 2009 9:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
anigel
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 1889
Location: Un petit bled pas loin de Limoges ;-)

PostPosted: Tue Apr 07, 2009 10:23 am    Post subject: Reply with quote

Bonjour,

Que te dit smartctl ?

(installe smartmontools, puis lance un smartctl -a /dev/mondisque)
_________________
Il y a 10 sortes d'individus en ce bas-monde : ceux qui causent binaire, et les autres.
Back to top
View user's profile Send private message
Trapamoosch
Apprentice
Apprentice


Joined: 08 May 2004
Posts: 203

PostPosted: Tue Apr 07, 2009 5:05 pm    Post subject: Reply with quote

Voila ce que ça donne :
Code:
smartctl version 5.38 [x86_64-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF INFORMATION SECTION ===
Model Family:     Hitachi Deskstar T7K500
Device Model:     Hitachi HDT725040VLAT80
Serial Number:    VF6301R3104Z0F
Firmware Version: V5COA4NA
User Capacity:    400 088 457 216 bytes
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   7
ATA Standard is:  ATA/ATAPI-7 T13 1532D revision 1
Local Time is:    Tue Apr  7 18:57:48 2009 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00)   Offline data collection activity
               was never started.
               Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0)   The previous self-test routine completed
               without error or no self-test has ever
               been run.
Total time to complete Offline
data collection:        (7441) seconds.
Offline data collection
capabilities:           (0x5b) SMART execute Offline immediate.
               Auto Offline data collection on/off support.
               Suspend Offline collection upon new
               command.
               Offline surface scan supported.
               Self-test supported.
               No Conveyance Self-test supported.
               Selective Self-test supported.
SMART capabilities:            (0x0003)   Saves SMART data before entering
               power-saving mode.
               Supports SMART auto save timer.
Error logging capability:        (0x01)   Error logging supported.
               General Purpose Logging supported.
Short self-test routine
recommended polling time:     (   1) minutes.
Extended self-test routine
recommended polling time:     ( 124) minutes.
SCT capabilities:           (0x003f)   SCT Status supported.
               SCT Feature Control supported.
               SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   100   100   016    Pre-fail  Always       -       0
  2 Throughput_Performance  0x0005   100   100   050    Pre-fail  Offline      -       0
  3 Spin_Up_Time            0x0007   099   099   024    Pre-fail  Always       -       503 (Average 499)
  4 Start_Stop_Count        0x0012   100   100   000    Old_age   Always       -       534
  5 Reallocated_Sector_Ct   0x0033   100   100   005    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   100   100   020    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0012   100   100   000    Old_age   Always       -       728
 10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       298
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       540
193 Load_Cycle_Count        0x0012   100   100   000    Old_age   Always       -       540
194 Temperature_Celsius     0x0002   200   200   000    Old_age   Always       -       30 (Lifetime Min/Max 12/59)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       0

SMART Error Log Version: 1
ATA Error Count: 3
   CR = Command Register [HEX]
   FR = Features Register [HEX]
   SC = Sector Count Register [HEX]
   SN = Sector Number Register [HEX]
   CL = Cylinder Low Register [HEX]
   CH = Cylinder High Register [HEX]
   DH = Device/Head Register [HEX]
   DC = Device Command Register [HEX]
   ER = Error register [HEX]
   ST = Status register [HEX]
Powered_Up_Time is measured from power on, and printed as
DDd+hh:mm:SS.sss where DD=days, hh=hours, mm=minutes,
SS=sec, and sss=millisec. It "wraps" after 49.710 days.

Error 3 occurred at disk power-on lifetime: 687 hours (28 days + 15 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 51 01 10 01 ea ff

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  fe a2 01 10 01 0a f0 02      01:10:03.400  [VENDOR SPECIFIC]
  fe a1 00 00 00 00 b0 02      01:10:03.400  [VENDOR SPECIFIC]
  fe a6 50 60 59 49 b0 00      01:10:03.200  [VENDOR SPECIFIC]
  c1 00 00 00 00 00 b0 02      01:10:03.200  [VENDOR SPECIFIC]
  fe a6 50 60 59 49 b0 00      01:10:03.100  [VENDOR SPECIFIC]

Error 2 occurred at disk power-on lifetime: 686 hours (28 days + 14 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 51 01 10 01 ea ff

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  fe a2 01 10 01 0a f0 02      00:40:51.500  [VENDOR SPECIFIC]
  fe a1 00 00 00 00 b0 02      00:40:51.500  [VENDOR SPECIFIC]
  fe a6 50 60 00 00 b0 00      00:40:51.300  [VENDOR SPECIFIC]
  c1 00 00 00 00 00 b0 02      00:40:51.300  [VENDOR SPECIFIC]
  fe a6 50 60 00 00 b0 00      00:40:51.200  [VENDOR SPECIFIC]

Error 1 occurred at disk power-on lifetime: 686 hours (28 days + 14 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 51 01 10 01 ea ff

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  fe a2 01 10 01 0a f0 02      00:38:50.200  [VENDOR SPECIFIC]
  fe a1 00 00 00 00 b0 02      00:38:50.200  [VENDOR SPECIFIC]
  fe a6 50 60 00 00 b0 00      00:38:50.100  [VENDOR SPECIFIC]
  c1 00 00 00 00 00 b0 02      00:38:50.100  [VENDOR SPECIFIC]
  fe a6 50 60 00 00 b0 00      00:38:50.000  [VENDOR SPECIFIC]

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed without error       00%       728         -
# 2  Short offline       Completed without error       00%       709         -
# 3  Short offline       Completed without error       00%       704         -
# 4  Short offline       Completed without error       00%       689         -

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.


Par contre, une autre info : le disque est d'ordinaire monté dans un boitier USB externe. Quand je l'ai testé avec badblocks, il était dans le boitier USB. Quand je l'ai testé avec les softs constructeurs, il était dans le PC, branché en IDE.
Par curiosité, je lance un badblocks pendant qu'il est branché en IDE est là, pas de blocs foireux (pour le moment, le test est en cours, mais j'en avais bien avant ça avec le boitier).

Quelqu'un a déjà vu un boitier interface USB/IDE corrompre des données ?
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Tue Apr 07, 2009 5:15 pm    Post subject: Reply with quote

Ben ya sûrement un contrôleur top niveau dans ton boîtier USB (qui a dit "JMicron"? :)). C'est peut être lui le fautif, indeed.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
anigel
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 1889
Location: Un petit bled pas loin de Limoges ;-)

PostPosted: Tue Apr 07, 2009 5:16 pm    Post subject: Reply with quote

Ca peut être lié à ton contrôleur USB en effet.

Mais quoi qu'il en soit, ton disque a enregistré 3 erreurs internes. Donc c'est pas bon...
_________________
Il y a 10 sortes d'individus en ce bas-monde : ceux qui causent binaire, et les autres.
Back to top
View user's profile Send private message
Trapamoosch
Apprentice
Apprentice


Joined: 08 May 2004
Posts: 203

PostPosted: Wed Apr 15, 2009 9:06 pm    Post subject: Reply with quote

Après quelques tests, je confirme que le fautif est bien mon boitier USB.
Disque dans le PC, j'ai dupliqué plusieurs fois un dossier. Comparés avec un "diff -r", aucun ne présente d'erreur.
Disque dans le boitier, même procédure. Et là, aucun ne présente PAS d'erreur :roll: ...

Donc on va dire que le souci est "résolu".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum