Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
проблема с gentoo && huawei EC500
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
nechto
n00b
n00b


Joined: 05 Apr 2009
Posts: 4

PostPosted: Sun Apr 05, 2009 4:30 pm    Post subject: проблема с gentoo && huawei EC500 Reply with quote

Ситуация такова:
Раньше подключение поднималось,но входящий трафф не шёл.
Сейчас постоянно сбрасывает подключение.

журнал wvdial/gnome-ppp

Code:

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L3DT#777
--> Waiting for carrier.
ATM1L3DT#777
CONNECT
~[7f]}#@!}!}&} }5}"}&} } } } }#}%B#}%}%}&A)0 fx~~[7f]}#@!}!}'} }5}"}&} } } } }#}%B#}%}%}&A)0 0'~~[7f]}#@!}!}(} }5}"}&} } } } }#}%B#}%}%}&A)0 fa~
--> Carrier detected.  Waiting for prompt.
~[7f]}#@!}!})} }5}"}&} } } } }#}%B#}%}%}&A)0 0>~
--> PPP negotiation detected.
--> Starting pppd at Sun Apr  5 20:20:59 2009
--> Pid of pppd: 4525
--> [0c][08]
--> Disconnecting at Sun Apr  5 20:21:00 2009
--> The PPP daemon has died: Fatal pppd error (exit code = 1)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.



/cat/var/log/messages

Code:


Apr  5 20:09:18 localhost pppd[4450]: pppd 2.4.4 started by root, uid 0
Apr  5 20:09:18 localhost pppd[4450]: Couldn't set tty to PPP discipline: Invalid argument
Apr  5 20:09:18 localhost pppd[4450]: Exit.
Apr  5 20:09:30 localhost pppd[4467]: pppd 2.4.4 started by root, uid 0
Apr  5 20:09:30 localhost pppd[4467]: Couldn't set tty to PPP discipline: Invalid argument
Apr  5 20:09:30 localhost pppd[4467]: Exit.
Apr  5 20:09:49 localhost pppd[4474]: pppd 2.4.4 started by root, uid 0
Apr  5 20:09:49 localhost pppd[4474]: Couldn't set tty to PPP discipline: Invalid argument
Apr  5 20:09:49 localhost pppd[4474]: Exit.
Apr  5 20:10:16 localhost pppd[4479]: pppd 2.4.4 started by root, uid 0
Apr  5 20:10:16 localhost pppd[4479]: Couldn't set tty to PPP discipline: Invalid argument
Apr  5 20:10:16 localhost pppd[4479]: Exit.
Apr  5 20:11:05 localhost pppd[4488]: pppd 2.4.4 started by root, uid 0
Apr  5 20:11:05 localhost pppd[4488]: Couldn't set tty to PPP discipline: Invalid argument
Apr  5 20:11:05 localhost pppd[4488]: Exit.
Apr  5 20:20:45 localhost pppd[4518]: pppd 2.4.4 started by root, uid 0
Apr  5 20:20:45 localhost pppd[4518]: Couldn't set tty to PPP discipline: Invalid argument
Apr  5 20:20:45 localhost pppd[4518]: Exit.
Apr  5 20:20:59 localhost pppd[4525]: pppd 2.4.4 started by root, uid 0
Apr  5 20:20:59 localhost pppd[4525]: Couldn't set tty to PPP discipline: Invalid argument
Apr  5 20:20:59 localhost pppd[4525]: Exit.


cat /etc/wvdial.conf сконфигурирован автоматически:

Code:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = ATM0
Password = internet
Phone = #777
Modem Type = Analog Modem
Stupid Mode = on
Band = 921600
Baud = 9600
Dial Command = ATDP
Modem = /dev/ttyUSB0
Init = ATZ
ISDN = 0
Username = mobile
Carrier Chek = no
Auto Reconnect = on



есть у кого нибудь мысли?
Back to top
View user's profile Send private message
nechto
n00b
n00b


Joined: 05 Apr 2009
Posts: 4

PostPosted: Tue Apr 07, 2009 9:05 pm    Post subject: Reply with quote

Решено.проблема была в конфиге wvdial && в том,что по какой то причине,мне неизвестной перед использованием модемного соединения нужно отрубать eth0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum