Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[New USE] are incorrectly set (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Fri Apr 03, 2009 6:42 am    Post subject: [New USE] are incorrectly set (résolu) Reply with quote

Bonjour,

j'ai ce message et je n'y comprends... rien :?
Quote:
emerge -uDpv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] dev-db/sqlite-3.6.12 [3.6.11] USE="threadsafe -debug -doc -soundex -tcl" 2,705 kB
[ebuild U ] sys-devel/m4-1.4.13 [1.4.12] USE="-examples" 985 kB
[ebuild U ] sys-apps/sandbox-1.7 [1.6] 310 kB
[ebuild UD] app-emacs/emacs-common-gentoo-0.3 [1.0] USE="(-X%*)" 15 kB
[ebuild NS ] sys-libs/db-4.7.25_p3 [4.5.20_p2-r1, 4.6.21_p4] USE="-doc -java -nocxx -tcl -test" 12,829 kB
[ebuild U ] sys-apps/coreutils-7.2 [7.1] USE="acl nls -caps% (-selinux) -static -vanilla -xattr" 9,446 kB
[ebuild U ] app-emacs/org-mode-6.25 [6.24b] 1,945 kB

Total: 7 packages (5 upgrades, 1 downgrade, 1 in new slot), Size of downloads: 28,232 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-emacs/emacs-common-gentoo:0

('ebuild', '/', 'app-emacs/emacs-common-gentoo-0.3', 'merge') pulled in by
app-emacs/emacs-common-gentoo required by world

('installed', '/', 'app-emacs/emacs-common-gentoo-1.0', 'nomerge') pulled in by
>=app-emacs/emacs-common-gentoo-1[X] required by ('installed', '/', 'app-editors/emacs-22.3-r2', 'nomerge')
>=app-emacs/emacs-common-gentoo-1[X] required by ('installed', '/', 'app-editors/emacs-cvs-23.0.9999-r1', 'nomerge')
(and 1 more)

Explanation:

New USE for 'app-emacs/emacs-common-gentoo:0' are incorrectly set. In
order to solve this, adjust USE to satisfy '>=app-emacs/emacs-common-
gentoo-1[X]'.


là je sèche. À votre bon coeur Messieurs Dames :roll:

EDIT : moi je conçois la chose comme ceci : app-emacs/emacs-common-gentoo demande un flag (X) qui n'existe plus pour.... app-emacs/emacs-common-gentoo, bug?

EDIT : je viens seulement de remarquer le downgrade pour cet ebuild. (le emerge-webrsync date de ce matin)
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo


Last edited by Mickael on Wed Apr 15, 2009 5:46 am; edited 1 time in total
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Fri Apr 03, 2009 11:38 am    Post subject: Re: [New USE] are incorrectly set Reply with quote

Mickael wrote:
!!! into the dependency graph, resulting in a slot conflict:

app-emacs/emacs-common-gentoo:0

('ebuild', '/', 'app-emacs/emacs-common-gentoo-0.3', 'merge') pulled in by
app-emacs/emacs-common-gentoo required by world

('installed', '/', 'app-emacs/emacs-common-gentoo-1.0', 'nomerge') pulled in by
>=app-emacs/emacs-common-gentoo-1[X] required by ('installed', '/', 'app-editors/emacs-22.3-r2', 'nomerge')
>=app-emacs/emacs-common-gentoo-1[X] required by ('installed', '/', 'app-editors/emacs-cvs-23.0.9999-r1', 'nomerge')
(and 1 more)

Explanation:

New USE for 'app-emacs/emacs-common-gentoo:0' are incorrectly set. In
order to solve this, adjust USE to satisfy '>=app-emacs/emacs-common-
gentoo-1[X]'.


Déjà, il y a un downgrade qui est pas net ... Si tu y regarde bien, tu peux voir que la version 0.3 est requise par "world" (donc, c'est toi qui l'a ajouté ... recompilé sans -1 (one shoot) ) .. alors que la version 1 est installée pour des dépendances "emacs*" ... DONC? moi je virerais la version 0.3 QUI EST INutile.

Après, pour le use, c'est soit un +X soit un -X à faire pour ce paquet ... (à noter dans /etc/portage/package.uses ptet)...
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Fri Apr 03, 2009 4:23 pm    Post subject: Re: [New USE] are incorrectly set Reply with quote

loopx wrote:


Déjà, il y a un downgrade qui est pas net ... Si tu y regarde bien, tu peux voir que la version 0.3 est requise par "world" (donc, c'est toi qui l'a ajouté ... recompilé sans -1 (one shoot) ) .. alors que la version 1 est installée pour des dépendances "emacs*" ... DONC? moi je virerais la version 0.3 QUI EST INutile.

Déjà vu :wink: regarde les edits.
loopx wrote:

Après, pour le use, c'est soit un +X soit un -X à faire pour ce paquet ... (à noter dans /etc/portage/package.uses ptet)...

Ouais, pour la version 1 +X. Mais cela ne change rien, la régression entraîne le conflit d'où mon interrogation sur ma demande de bug.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sat Apr 04, 2009 8:54 pm    Post subject: Reply with quote

tu as unmerge la version 0.3?
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Mon Apr 06, 2009 7:07 am    Post subject: Reply with quote

Mais non loopx le emerge -uDpv world demande un dowgrade, donc il n'est pas installé... :wink:
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Mon Apr 06, 2009 3:03 pm    Post subject: Reply with quote

Mickael wrote:
Mais non loopx le emerge -uDpv world demande un dowgrade, donc il n'est pas installé... :wink:



Ah oki, désolé :lol:


un nouveau sync ptet ...
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Mon Apr 06, 2009 3:22 pm    Post subject: Reply with quote

Mickael wrote:
Mais non loopx le emerge -uDpv world demande un dowgrade, donc il n'est pas installé... :wink:


J'ai depuis ce matin les mêmes symptômes que toi pour un autre ebuild et j'ai trouvé ce message dans le changelog
Quote:
Preparation for new eclass. Unprefixing misc apps.
donc vérifie si tu n'es pas dans le même cas.




Edit: après une nouvelle synchro ça c'est résolu.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Wed Apr 15, 2009 5:47 am    Post subject: Reply with quote

Cela c'est résolu probablement après une mise à jour. Je pense qu'un petit bug aurait été nécessaire.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum