Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Layman not working - XML parsing failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 391

PostPosted: Wed Apr 01, 2009 2:13 am    Post subject: Layman not working - XML parsing failed Reply with quote

Hello -

I am trying to update my layman repositories and it keeps telling me the following:

* Running command "/usr/bin/svn co "http://overlays.gentoo.org/svn/dev/pythonhead/" "/usr/local/portage/layman/pythonhead""...
svn: XML parsing failed: (411 Length Required)

I don't know what is causing this. I have version svn 1.5.4, which is stable, but I am using the webdav-serf. Whenever I tried to build it with webdav-neon, which is what I used to always use, it would not provide the ra_neon module.

It all worked before and I am not sure what happened. Any ideas?

Thanks.
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 391

PostPosted: Wed Apr 01, 2009 2:36 am    Post subject: Reply with quote

I tried removing all the layman directories and reinstalling layman. It still tells me svn is having a problem parsing. I suppose this is an svn problem, but not sure what it could be. Any help is greatly appreciated.
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 391

PostPosted: Wed Apr 01, 2009 2:54 am    Post subject: Reply with quote

Tried rebuilding 1.5.6 with neon - still get:

Running command "/usr/bin/svn co "http://overlays.gentoo.org/svn/proj/sunrise/reviewed//" "/usr/local/portage/layman/sunrise""...
svn: OPTIONS of 'http://overlays.gentoo.org/svn/proj/sunrise/reviewed': could not connect to server (http://overlays.gentoo.org)
* Failed to add overlay "sunrise".
* Error was: Adding the overlay failed! Possible remains of the opration have NOT been removed and may be left at /usr/local/portage/layman/sunrise. Please remove them manually if required.


Will try 1.5.4 (stable) with neon.
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 391

PostPosted: Wed Apr 01, 2009 3:05 am    Post subject: Reply with quote

Hope this helps anyone else - It turns out I was using an unstable neon. Stable neon + stable svn = happiness. Hope this helps someone else. I am going to get beer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum