Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[WORLD] Plus moyen de mettre à jour world [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
lbr
Guru
Guru


Joined: 05 Apr 2004
Posts: 503
Location: Paris

PostPosted: Tue Mar 24, 2009 3:18 pm    Post subject: [WORLD] Plus moyen de mettre à jour world [résolu] Reply with quote

Bonjour à tous,
Depuis un moment : pas moyen de mettre à jour world !
Code:
lbr ~ # emerge -avtD --newuse world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-db/libpq:4

  ('ebuild', '/', 'dev-db/libpq-8.2.7', 'merge') pulled in by
    ~dev-db/libpq-8.2.7 required by ('ebuild', '/', 'dev-db/postgresql-8.2.7', 'merge')

  ('installed', '/', 'dev-db/libpq-8.0.15', 'nomerge') pulled in by
    =dev-db/libpq-8.0* required by ('installed', '/', 'dev-libs/cyrus-sasl-2.1.22-r2', 'nomerge')
    =dev-db/libpq-8.0* required by ('installed', '/', 'dev-db/pgadmin3-1.8.2', 'nomerge')
    =dev-db/libpq-8.0* required by ('ebuild', '/', 'net-misc/asterisk-1.2.31.1', 'merge')
    (and 6 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "=gnome-base/orbit-0*".
(dependency required by "gnome-base/gnome-libs-1.4.2" [installed])
(dependency required by "world" [argument])

J'ai essayé
Code:
revdep-rebuild -v
qui abouti à :
Code:
emerge: there are no ebuilds to satisfy "gnome-base/gnome-libs:1".

J'ai beau chercher : je suis le seul dans ce cas (ce qui m'inquiète !).
Code:
lbr ~ # emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.25-gentoo-r7lbr i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r7lbr-i686-Intel-R-_Pentium-R-_4_CPU_2.80GHz-with-glibc2.0
Timestamp of tree: Mon, 23 Mar 2009 23:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer -mfpmath=sse -funroll-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer -mfpmath=sse -funroll-loops"
DISTDIR="/usr/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://pandemonium.tiscali.de/pub/gentoo/ http://mirror.switch.ch/mirror/gentoo/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="fr_FR@euro"
LC_ALL="fr_FR@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="fr fr_FR"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/desktop-effects /usr/local/portage"
SYNC="rsync://JANUS/gentoo-portage"
USE="X acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread emboss encode esd evo fam firefox fortran gdbm gif glitz gnome gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog java jpeg ldap libnotify mad midi mikmod mp3 mpeg mudflap mysql ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl png postgres ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session softmmu spell spl ssl startup-notification svg sysfs tcpd tiff truetype type1 ubicode unicode usb vorbis win32codecs x86 xinerama xml xorg xulrunner xv zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Une idée ?
Merci par avance.


Last edited by lbr on Wed Mar 25, 2009 9:09 am; edited 1 time in total
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue Mar 24, 2009 5:00 pm    Post subject: Reply with quote

ben lis le message que te files emerge -avtD --newuse world :wink:

apparament t'as un vieux truc qui traine. gnome-libs-1.4 ça existe plus ça.

pour la libpq, c'est parce que tu as démasqué postgresql. La nouvelle version 8.2.7 a besoin de la libpq-8.2.7 elle meme masquée. Comme dis le message tu peux jouer sur /etc/portage/placakge.mask pour éviter ce genre de chose en masquant dans ton cas postgresql pour qu'il reste à ta version actuelle par exemple. Ou alors tu démasques la libpq, au choix.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
lbr
Guru
Guru


Joined: 05 Apr 2004
Posts: 503
Location: Paris

PostPosted: Wed Mar 25, 2009 9:08 am    Post subject: Reply with quote

Merci,
j'ai donc "demergé" (emerge -C) de tous les paquets qui me conduisaient à emerger gnome-libs et mon emerge world en en cours.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum