Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Impostare il bitrate della scheda wifi
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Sat Mar 21, 2009 3:13 pm    Post subject: [RISOLTO] Impostare il bitrate della scheda wifi Reply with quote

Vorrei che all'avvio il mio dispositvo wifi avesse lo stesso bit rate di quando da shell scrivo

Code:
 iwconfig wlan0 rate 5.5M fixed


Devo modifcare il file /etc/conf.f/net?
Grazie per ogni eventuale risposta.

PS
Al file /etc/conf.f/net ho provato ad aggiungere:

Code:
 rate_wlan0 = ( "5.5M fixed" )


ma senza ottenere risultati.


Last edited by nearthesoul on Mon Mar 23, 2009 2:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sat Mar 21, 2009 5:45 pm    Post subject: Reply with quote

Dal file di esempio si legge:
Code:

# Setup any other config commands. This is basically the iwconfig argument
# without the iwconfig $iface.
#iwconfig_eth0=""


quindi suppongo che tu debba mettere li dentro il comando per settare il rate (comando completo ma SENZA il nome dell'interfaccia).

P.s. non so perche tu voglia fare cio, comunque vorrei ricordarti che se lo fai per problemi di prestazioni, esiste il nuovo algoritmo "minstrel" che regola il rate che funziona meglio di quello vecchio. Mi pare sia anche di default sui nuovi kernel... dal 2.6.28 (vado a memoria).
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Sat Mar 21, 2009 6:30 pm    Post subject: Reply with quote

Grazie per la risposta. Ho provato ad inserie nel file /etc/conf.d/net la seguente riga
Code:
 iwconfig_wlan0 = "rate 1M fixed"

ma quando dò il comando
Code:
 /etc/init.d/net.wlan0 restart

ottengo proprio in prossimità della riga aggiunta
Code:
 /etc/conf.d/net: line 9: iwconfig_wlan0: command not found
[/quote]

L'esigenza del bitrate basso nasce dal fatto che ho un dispositivo wifi basato sul chipset RTL8187 che dà svariati problemi soprattutto con i programmi p2p. Ad ogni modo la versione del mio kernel è la 2.6.28-r4.
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sat Mar 21, 2009 6:50 pm    Post subject: Reply with quote

Forse devi metterlo in
Code:

/etc/conf.d/wireless


anche se leggo che è deprecato come file. Prova.

Altrimenti ricontrolla /etc/conf.d/net.
Ma hai messo "modules=( "iwconfig" )" in /etc/conf.d/net ?

P.s. dai anche un occhio veloce qui http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=4&chap=4&style=printable
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Sat Mar 21, 2009 7:04 pm    Post subject: Reply with quote

Avevo già provato a metterlo in /etc/conf.d/wireless e ho anche messo

Code:
 modules=( "iwconfig" )


in /etc/conf.d/net.
Ora ho provato a ricompilare il kernel abilitando il minstrel per vedere come va.
La prima cosa che ho osservato con il minstrel è che come prima (se non si fissa il bitrate) il bitrate sale da solo (e sempre) fino a 54M e la connesione diventa inutilizzabile.
Cmq tante grazie per la disponibilità
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sat Mar 21, 2009 7:36 pm    Post subject: Reply with quote

Sai cosa ti dico...

Prova a infilare il comando completo per settare il rate in "/etc/conf.d/net" sotto(inteso dentro) la funzione postup(){} .
Dovrebbe essere la funzione che viene chiamata DOPO che la connessione è avvenuta.

Un po' sporco ma dovrebbe funzionare. Anche perché questo post mi ha sollevato parecchi dubbi sullo stato delle guide gentoo.

Fammi sapere se funziona.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Sat Mar 21, 2009 7:49 pm    Post subject: Reply with quote

nearthesoul wrote:
Grazie per la risposta. Ho provato ad inserie nel file /etc/conf.d/net la seguente riga
Code:
 iwconfig_wlan0 = "rate 1M fixed"


Non devi mettere gli spazi fra la variabile, l'= ed il suo valore, riprova con
Code:
iwconfig_wlan0="rate 1M fixed"
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Sat Mar 21, 2009 7:52 pm    Post subject: Reply with quote

GRANDE!!! Dopo aver inserito il codice

Code:
postup(){
iwconfig wlan0 rate 1M fixed
}


nel file /etc/conf.d/net tutto funziona!!!
Fra l'altro, con attivo il minstrel nel kernel, ancora non ho perso la connessione (anche se sono pessimista a riguardo),

GRAZIE.
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Sat Mar 21, 2009 7:54 pm    Post subject: Reply with quote

però se ci sono i metodi definiti, vedi le variabili della configurazione, converebbe utilizzarli.
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Sat Mar 21, 2009 8:24 pm    Post subject: Reply with quote

L'aggiunta della riga

Code:

iwconfig_wlan0="rate 1M fixed"


nel file /etc/conf.d/net (che a differenza di "iwconfig_wlan0 = "rate 1M fixed"" non ha gli spazi prima e dopo l'uguale) funziona PERFETTAMENTE!!!

GRAZIE.
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sat Mar 21, 2009 9:10 pm    Post subject: Reply with quote

Be a questo punto direi che si può mettere(che puoi mettere, visto che sei il proprietario della discussione) il tag [Risolto] alla discussione.

P.s. chiedo scusa per aver accusato ingiustamente le guide gentoo.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Sat Mar 21, 2009 10:45 pm    Post subject: Reply with quote

Come si mette il tag [Risolto]?

PS
Cmq grazie mi sei stato utilissimo perchè con la storia del minstrel penso di aver risolto un gran problema che affligge migliaia di utenti che hanno l'RTL8187
Back to top
View user's profile Send private message
nearthesoul
n00b
n00b


Joined: 21 Mar 2009
Posts: 53

PostPosted: Sun Mar 22, 2009 12:15 pm    Post subject: [Risolto] Impostare il bitrate della scheda wifi Reply with quote

Grazie
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sun Mar 22, 2009 4:31 pm    Post subject: Reply with quote

In pratica ti logghi e poi clicchi sul pulsante "modifica" del primo post. (Pulsante in alto a destra del post).
Da qui editi il titolo del post e ci aggiungi un [Risolto] all'inizio.
Ovviamente dopo dai conferma per salvare il post.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum