Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cgfourteen anyone?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
zeke7237
n00b
n00b


Joined: 07 Aug 2003
Posts: 24

PostPosted: Wed Aug 13, 2003 4:43 pm    Post subject: cgfourteen anyone? Reply with quote

Preemptive question, as I'm probably going to try building my kernel and emerging X today .. is anyone running SS20 with CGfourteen built-in framebuffer? I've managed to find an 8M simm for it, so it actually was working in 24 bit color at some point in the past (on Debian) .. but I don't remember anything about how I got it running :(
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Wed Aug 13, 2003 5:21 pm    Post subject: Reply with quote

I haven't used a cg14, but I can try to give a little information about using
one, based on the xf86 source & install:


  • the driver (in the "Device" section) is "suncg14"
  • the driver wants depth 32.


Other than that, just about any of the Config files posted in this forum should
work for you.

Not much information, but maybe of some use to you.

Regards,
Back to top
View user's profile Send private message
zeke7237
n00b
n00b


Joined: 07 Aug 2003
Posts: 24

PostPosted: Thu Aug 21, 2003 4:51 pm    Post subject: Reply with quote

Well, I've got it "sort of" working ..

I get a black screen with an "X" cursor, but no visible window manager :(
I also seem to be getting lots of unresolved errors around xf86ExecX86int10 and xf86int10Addr ...
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Thu Aug 21, 2003 6:06 pm    Post subject: Reply with quote

I don't know about the unresolved references, and such. For your amusement,
here is a complete, working /etc/X11/Xf86Config file for a CG6; for the
cg14, I think you want the default depth=32, and you probably don't want
PseudoColor.

Code:

# Created by hand, mostly

Section "ServerLayout"
  Identifier    "Modified_for_4.3.0-r2"
  Screen         0 "Screen0" 0 0
  InputDevice   "Mouse0" "CorePointer"
  InputDevice   "Keyboard0" "CoreKeyboard"
  Option        "HandleSpecialKeys" "Always"
  Option        "DontVTSwitch"  "off"
EndSection

Section "Files"
  RgbPath       "/usr/X11R6/lib/X11/rgb-local"
  ModulePath    "/usr/X11R6/lib/modules"
  FontPath      "/usr/X11R6/lib/X11/fonts/local"
  FontPath      "/usr/X11R6/lib/X11/fonts/misc:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/misc"
  FontPath      "/usr/X11R6/lib/X11/fonts/75dpi"
  FontPath      "/usr/X11R6/lib/X11/fonts/100dpi"
  FontPath      "/usr/X11R6/lib/X11/fonts/Type1"
  FontPath      "/usr/X11R6/lib/X11/fonts/cyrillic"
  FontPath      "/usr/X11R6/lib/X11/fonts/truetype"
  FontPath      "/usr/X11R6/lib/X11/fonts/CID"
  FontPath      "/usr/X11R6/lib/X11/fonts/TTF"
EndSection

Section "ServerFlags"
  Option        "StandbyTime"   "10"
  Option        "SuspendTime"   "20"
  Option        "OffTime"       "30"
  Option        "AllowMouseOpenFail"  "true"
EndSection

Section "Module"
  Load  "dbe"
  Load  "type1"
  Load  "speedo"
  Load  "drm"
  Load  "dri"
  Load  "glx"
  Load  "freetype"
  Load  "record"
  Load  "extmod"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "keyboard"
  Option      "Protocol"    "Standard"
  Option      "XkbKeycodes" "sun(type5)"
  Option      "XkbModel"    "type5"
  Option      "XkbRules"    "sun"
  Option      "XkbLayout"   "en_US"
  Option      "XkbGeometry" "sun(type5)"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "MouseSystems"
  Option      "Device" "/dev/sunmouse"
  Option        "Emulate3Buttons"       "false"
  Option        "Buttons" "3"
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Sony"
  ModelName    "GDM-20E20"
  Option       "DPMS"   "on"
EndSection

Section "Device"
  Identifier  "Card0"
  BoardName   "Sun|CG6"
  VendorName  "Sun Microsystems"
  Driver      "suncg6"
EndSection

Section "Screen"
  Identifier   "Screen0"
  Device       "Card0"
  Monitor      "Monitor0"
  DefaultDepth 8
  SubSection   "Display"
        Depth     1
  EndSubSection
  SubSection   "Display"
        Depth     4
  EndSubSection
  SubSection   "Display"
        Depth     8
        Visual  "PseudoColor"
  EndSubSection
  SubSection   "Display"
        Depth     15
  EndSubSection
  SubSection   "Display"
        Depth     16
  EndSubSection
  SubSection   "Display"
        Depth     24
  EndSubSection
  SubSection   "Display"
        Depth     32
  EndSubSection
EndSection

Section "DRI"
 Group          "video"
 Mode           0666
EndSection
Back to top
View user's profile Send private message
phygradmarko
n00b
n00b


Joined: 13 Jul 2003
Posts: 26
Location: Buffalo, NY

PostPosted: Sat Aug 23, 2003 1:45 pm    Post subject: Reply with quote

I can attest a 4M VSIMM will work in a ss20 (quite well in fact). The correct depth to use is depth=32. I do recall reading the 8M VSIMM having some issues. I believe the workaround was to set it to a depth=16. I do not have an 8M VSIMM so I cannot verify this.

Of course, this may be true only for older versions of XFree. Newer versions may not need the workaround...
Back to top
View user's profile Send private message
bent
n00b
n00b


Joined: 26 Mar 2003
Posts: 74
Location: New Zealand

PostPosted: Fri Aug 29, 2003 4:26 am    Post subject: Reply with quote

No problems at all using an 8MB vsimm in my SS20.
running 32 bit 1280x1024, best display in the house.

However, if I use Stop-A or the system watchdogs/panics
(quite often) the interleaving of the Prom display gets
messed up. Only Stop-A from a console.

CG6 doesn't have this problem, nor does Solaris using the
cgfourteen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum