Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gecko-mediaplayer
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Fri Mar 20, 2009 1:29 am    Post subject: gecko-mediaplayer Reply with quote

Salve a tutti, nell'installare gecko-mediaplayer (che è masked) mi fa downgradare firefox. Sono andato a vedere l'ebuild e ho trovato
Code:

RDEPEND="dev-libs/dbus-glib
   >=media-video/gnome-mplayer-0.6.2
   || ( =net-libs/xulrunner-1.8*
      =www-client/mozilla-firefox-2*
      =www-client/seamonkey-1*
      www-client/epiphany )"
DEPEND="${RDEPEND}
   dev-util/pkgconfig
   sys-devel/gettext"


Hi epiphany installato, allora perché non considera la dipendenza risolta? Non sono un grande esperto di ebuild, ma non capisco proprio perché lo faccia.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Mar 20, 2009 11:21 am    Post subject: Re: gecko-mediaplayer Reply with quote

publiosulpicio wrote:
=www-client/mozilla-firefox-2*
vuol dire che vuole mozilla-firefox (non mozilla-firefox-bin) 2.x installato od in alternativa xulrunner 1.8 (quello di firefox 2.x). Quale versione di firefox hai? Tieni conto che non sono una scimmia ma una lucertola (quindi non ho idea di quali possano essere le dipendenze) ma a naso mi pare che puoi usarlo solo con firefox 3.x compilato. Prova ad installare manualmente xulrunner slot 1.8 ed abilitare globalmente la use corrispondente.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Mar 20, 2009 11:48 am    Post subject: Reply with quote

oppure puoi cercare su bugzilla gli ebuild aggiornati alle ultime versioni ( 0.9.5 ), se non ricordo male dipendono su firefox-3x
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Fri Mar 20, 2009 5:28 pm    Post subject: Re: gecko-mediaplayer Reply with quote

Con xulrunner 1.8 funziona, però resta una cosa che non ho capito, le righe
publiosulpicio wrote:
Code:

   || ( =net-libs/xulrunner-1.8*
      =www-client/mozilla-firefox-2*
      =www-client/seamonkey-1*
      www-client/epiphany )"


non significano che devo avere almeno uno dei quattro pacchetti installato (alle specifiche versioni)? Ho epiphany, quindi non capisco perché non consideri la dipendenza risolta.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum