Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200903-32 ] phpMyAdmin: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Wed Mar 18, 2009 11:26 pm    Post subject: [ GLSA 200903-32 ] phpMyAdmin: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: phpMyAdmin: Multiple vulnerabilities (GLSA 200903-32)
Severity: normal
Exploitable: remote
Date: March 18, 2009
Bug(s): #237781, #244914, #246831, #250752
ID: 200903-32

Synopsis

Multiple vulnerabilities have been discovered in phpMyAdmin, the worst of which may allow for remote code execution.

Background

phpMyAdmin is a web-based management tool for MySQL databases.

Affected Packages

Package: dev-db/phpmyadmin
Vulnerable: < 2.11.9.4
Unaffected: >= 2.11.9.4
Architectures: All supported architectures


Description

Multiple vulnerabilities have been reported in phpMyAdmin:
  • libraries/database_interface.lib.php in phpMyAdmin allows remote authenticated users to execute arbitrary code via a request to server_databases.php with a sort_by parameter containing PHP sequences, which are processed by create_function (CVE-2008-4096).
  • Cross-site scripting (XSS) vulnerability in pmd_pdf.php allows remote attackers to inject arbitrary web script or HTML via the db parameter, a different vector than CVE-2006-6942 and CVE-2007-5977 (CVE-2008-4775).
  • Cross-site request forgery (CSRF) vulnerability in phpMyAdmin allows remote authenticated attackers to perform unauthorized actions as the administrator via a link or IMG tag to tbl_structure.php with a modified table parameter. NOTE: this can be leveraged to conduct SQL injection attacks and execute arbitrary code (CVE-2008-5621).
  • Multiple cross-site request forgery (CSRF) vulnerabilities in phpMyAdmin allow remote attackers to conduct SQL injection attacks via unknown vectors related to the table parameter, a different vector than CVE-2008-5621 (CVE-2008-5622).


Impact

A remote attacker may execute arbitrary code with the rights of the webserver, inject and execute SQL with the rights of phpMyAdmin or conduct XSS attacks against other users.

Workaround

There is no known workaround at this time.

Resolution

All phpMyAdmin users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-2.11.9.4"


References

CVE-2006-6942
CVE-2007-5977
CVE-2008-4096
CVE-2008-4775
CVE-2008-5621
CVE-2008-5622
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum