Joined: 12 May 2004
|Posted: Wed Mar 18, 2009 11:26 pm Post subject: [ GLSA 200903-32 ] phpMyAdmin: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: phpMyAdmin: Multiple vulnerabilities (GLSA 200903-32)
Date: March 18, 2009
Bug(s): #237781, #244914, #246831, #250752
Multiple vulnerabilities have been discovered in phpMyAdmin, the worst of which may allow for remote code execution.
phpMyAdmin is a web-based management tool for MySQL databases.
Vulnerable: < 184.108.40.206
Unaffected: >= 220.127.116.11
Architectures: All supported architectures
Multiple vulnerabilities have been reported in phpMyAdmin:
- libraries/database_interface.lib.php in phpMyAdmin allows remote authenticated users to execute arbitrary code via a request to server_databases.php with a sort_by parameter containing PHP sequences, which are processed by create_function (CVE-2008-4096).
- Cross-site scripting (XSS) vulnerability in pmd_pdf.php allows remote attackers to inject arbitrary web script or HTML via the db parameter, a different vector than CVE-2006-6942 and CVE-2007-5977 (CVE-2008-4775).
- Cross-site request forgery (CSRF) vulnerability in phpMyAdmin allows remote authenticated attackers to perform unauthorized actions as the administrator via a link or IMG tag to tbl_structure.php with a modified table parameter. NOTE: this can be leveraged to conduct SQL injection attacks and execute arbitrary code (CVE-2008-5621).
- Multiple cross-site request forgery (CSRF) vulnerabilities in phpMyAdmin allow remote attackers to conduct SQL injection attacks via unknown vectors related to the table parameter, a different vector than CVE-2008-5621 (CVE-2008-5622).
A remote attacker may execute arbitrary code with the rights of the webserver, inject and execute SQL with the rights of phpMyAdmin or conduct XSS attacks against other users.
There is no known workaround at this time.
All phpMyAdmin users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-18.104.22.168"