Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems after last gnome update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
casidiablo
n00b
n00b


Joined: 30 Dec 2008
Posts: 23
Location: Colombia

PostPosted: Mon Mar 16, 2009 5:39 pm    Post subject: Problems after last gnome update Reply with quote

Hi guys,

Some days ago I was updating my Gentoo system, and I noticed that one of the main updates was the Gnome. While it was compiling I was to have some coffee, but when I came back to my computer it was so weird. It seems that the Lock Screen was freeze or something like that, so I just restarted the X.

Then, I realized that the Gnome panels were not appearing, so I reinstalled just that part (gnome-panel). But, now I realize that the System->Preferences menu has disappeared. And also, when I lock the screen for iI need to restart the X.

So, I'd like to know how to solve that, or maybe how to reinstall the whole gnome... or if you have a piece of advice for me, it'd be great.

Thanks for reading.
Back to top
View user's profile Send private message
Dammital
Apprentice
Apprentice


Joined: 05 Nov 2004
Posts: 189

PostPosted: Mon Mar 16, 2009 7:28 pm    Post subject: Reply with quote

If I understand you properly, the original emerge was running in an xterm when the system locked up (or you restarted X), and it did not complete.

I suggest that you update your system again (emerge -puvDN world followed by emerge -uvDN world) and then make sure you've got all your dependencies installed (revdep-rebuild -pi followed by revdep-rebuild).

(I find it helpful to execute long-running emerges through a vterm rather than from inside X. When I must use an xterm or ssh session, I start a screen first, which will tolerate hang-ups.)
Back to top
View user's profile Send private message
casidiablo
n00b
n00b


Joined: 30 Dec 2008
Posts: 23
Location: Colombia

PostPosted: Mon Mar 16, 2009 8:31 pm    Post subject: Reply with quote

When I execute emerge -puvDN and emerge -uvDN world, it does not install anything (the system is completly updated). But when I execute revdep-rebuild, it says that Rythmbox needs to be recompiled, but the compilation fails:

Code:
In file included from rb-shell.c:83:
../lib/rb-proxy-config.h:69: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
make[3]: *** [rb-shell.lo] Error 1
make[3]: *** Se espera a que terminen otras tareas....
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DGNOMELOCALEDIR=\"/usr/share/locale\" -DG_LOG_DOMAIN=\"Rhythmbox\" -I.. -I../lib -I../metadata -I../rhythmdb -I../widgets -I../sources -I../podcast -I../lib -I../plugins -I../backends -DPIXMAP_DIR=\"/usr/share/pixmaps\" -DSHARE_DIR=\"/usr/share/rhythmbox\" -DDATADIR=\"/usr/share\" -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/gail-1.0 -I/usr/include/libglade-2.0 -I/usr/include/gnome-vfs-module-2.0 -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -DORBIT2=1 -pthread -I/usr/include/totem-pl-parser/1/plparser -I/usr/include/libxml2 -I/usr/include/evolution-data-server-2.24 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/libsoup-2.4 -I/usr/include/libbonobo-2.0 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DDBUS_API_SUBJECT_TO_CHANGE -pthread -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/libnautilus-burn -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/include/hal -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -D_XOPEN_SOURCE -D__EXTENSIONS__ -D_BSD_SOURCE -I/usr/include/libsoup-2.2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -DLIBNOTIFY_VERSION_MAJOR=0 -DLIBNOTIFY_VERSION_MINOR=4 -DLIBNOTIFY_VERSION_MICRO=4 -DORBIT2=1 -pthread -I/usr/include/gnome-media -I/usr/include/gconf/2 -I/usr/include/gtk-2.0 -I/usr/include/libglade-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -O2 -pipe -MT rb-source-header.lo -MD -MP -MF .deps/rb-source-header.Tpo -c rb-source-header.c -o rb-source-header.o >/dev/null 2>&1
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DGNOMELOCALEDIR=\"/usr/share/locale\" -DG_LOG_DOMAIN=\"Rhythmbox\" -I.. -I../lib -I../metadata -I../rhythmdb -I../widgets -I../sources -I../podcast -I../lib -I../plugins -I../backends -DPIXMAP_DIR=\"/usr/share/pixmaps\" -DSHARE_DIR=\"/usr/share/rhythmbox\" -DDATADIR=\"/usr/share\" -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/gail-1.0 -I/usr/include/libglade-2.0 -I/usr/include/gnome-vfs-module-2.0 -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -DORBIT2=1 -pthread -I/usr/include/totem-pl-parser/1/plparser -I/usr/include/libxml2 -I/usr/include/evolution-data-server-2.24 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/libsoup-2.4 -I/usr/include/libbonobo-2.0 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DDBUS_API_SUBJECT_TO_CHANGE -pthread -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/libnautilus-burn -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/include/hal -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -D_XOPEN_SOURCE -D__EXTENSIONS__ -D_BSD_SOURCE -I/usr/include/libsoup-2.2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -DLIBNOTIFY_VERSION_MAJOR=0 -DLIBNOTIFY_VERSION_MINOR=4 -DLIBNOTIFY_VERSION_MICRO=4 -DORBIT2=1 -pthread -I/usr/include/gnome-media -I/usr/include/gconf/2 -I/usr/include/gtk-2.0 -I/usr/include/libglade-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -O2 -pipe -MT rb-shell-player.lo -MD -MP -MF .deps/rb-shell-player.Tpo -c rb-shell-player.c -o rb-shell-player.o >/dev/null 2>&1
make[3]: se sale del directorio `/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/work/rhythmbox-0.10.1/shell'
make[2]: *** [all] Error 2
make[2]: se sale del directorio `/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/work/rhythmbox-0.10.1/shell'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/work/rhythmbox-0.10.1'
make: *** [all] Error 2
 *
 * ERROR: media-sound/rhythmbox-0.10.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2739:  Called gnome2_src_compile
 *             environment, line 2079:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/environment'.
 *

>>> Failed to emerge media-sound/rhythmbox-0.10.1-r1, Log file:

>>>  '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/build.log'

 * Messages for package media-sound/rhythmbox-0.10.1-r1:

 *
 * ERROR: media-sound/rhythmbox-0.10.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2739:  Called gnome2_src_compile
 *             environment, line 2079:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/environment'.
 *


But, I don't think my problems are due to Rhythmbox... what can I do?
Back to top
View user's profile Send private message
casidiablo
n00b
n00b


Joined: 30 Dec 2008
Posts: 23
Location: Colombia

PostPosted: Mon Mar 16, 2009 8:39 pm    Post subject: Reply with quote

I forgot to tell you... my multimedia keys are not working neither :(
Back to top
View user's profile Send private message
biojayc
n00b
n00b


Joined: 22 Aug 2007
Posts: 14
Location: Dallas, TX

PostPosted: Tue Mar 17, 2009 5:21 am    Post subject: Reply with quote

Yes, rhythmbox is comletely broken on my system too. I finally got passed most of the other issues except that one.

at first I noticed that rhythmbox just wasn't working, so I tried a revdep-rebuild, and it failed. So I unmerged rythmbox and re emerged it. failed as well. here's the error:
Code:

make: *** [all] Error 2
 *
 * ERROR: media-sound/rhythmbox-0.10.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2656:  Called gnome2_src_compile
 *             environment, line 2005:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/environment'.
 *

>>> Failed to emerge media-sound/rhythmbox-0.10.1-r1, Log file:

>>>  '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/build.log'

 * Messages for package media-sound/rhythmbox-0.10.1-r1:

 *
 * ERROR: media-sound/rhythmbox-0.10.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2656:  Called gnome2_src_compile
 *             environment, line 2005:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/rhythmbox-0.10.1-r1/temp/environment'.
 *


any ideas?
Back to top
View user's profile Send private message
OneOfMany
Tux's lil' helper
Tux's lil' helper


Joined: 19 Nov 2003
Posts: 108
Location: Portland, OR USA

PostPosted: Tue Mar 17, 2009 5:43 am    Post subject: Reply with quote

biojayc - the info you show isn't enough. It doesn't contain the actual error, just that the build died. You'd need to open the file it points at inside /var/tmp to know if this is the same issue. I get the same UI output as you now that I have emerge doing parallel compiles using the jobs and average load flags to get more stuff done at once.

casidiablo - I looked around for that package and error on Gentoo's bug and forum areas, but didn't see anything. A search on the web (http://code.google.com/p/pyproj/issues/detail?id=5) so far pointed at the standard headers being installed wrong. They had other errors higher in their output that pointed at this, but you might try an "emerge gcc glibc" and see what happens when you rerun your rhythmbox emerge. Might be useful to look for the first error in the log file too (if this isn't it). To see if this isn't the real issue you need to fix.
Back to top
View user's profile Send private message
alexdu
n00b
n00b


Joined: 25 Oct 2005
Posts: 49
Location: Moscow, Russia

PostPosted: Tue Mar 17, 2009 11:14 am    Post subject: Reply with quote

I had exactly the same problem.
This helped me...

https://forums.gentoo.org/viewtopic-p-5568065.html#5568065

more info is here...

https://bugs.gentoo.org/show_bug.cgi?id=256016
Back to top
View user's profile Send private message
paluszak
Apprentice
Apprentice


Joined: 28 Jun 2004
Posts: 228
Location: Warsaw, Poland

PostPosted: Wed Mar 18, 2009 4:02 pm    Post subject: Reply with quote

alexdu wrote:
I had exactly the same problem.
This helped me...

https://forums.gentoo.org/viewtopic-p-5568065.html#5568065

more info is here...

https://bugs.gentoo.org/show_bug.cgi?id=256016


I have exactly the same problem. I noticed some issues with libxklavier-3.8 so it's maske on my system so that's not the problem. All broken packages compiled fine after gnome upgrade except rhythmox. :(
Back to top
View user's profile Send private message
alexdu
n00b
n00b


Joined: 25 Oct 2005
Posts: 49
Location: Moscow, Russia

PostPosted: Thu Mar 19, 2009 12:03 pm    Post subject: Reply with quote

paluszak wrote:
All broken packages compiled fine after gnome upgrade except rhythmox. :(
Ohh... rhythmbox... sorry!:roll:

Try this:
Code:
echo "=media-sound/rhythmbox-0.11.6-r1" >> /etc/portage/package.keywords
emerge -1v media-sound/rhythmbox


Now it merged:
Code:
[I] media-sound/rhythmbox
     Available versions:  0.10.1-r1 ~0.11.2-r1 (~)0.11.6-r1 {X cdr daap dbus debug doc flac gnome-keyring hal ipod libnotify lirc mad mtp musicbrainz nsplugin python tagwriting test vorbis}
     Installed versions:  0.11.6-r1(02:52:49 PM 03/19/2009)(X cdr dbus doc gnome-keyring hal ipod libnotify musicbrainz python tagwriting -daap -debug -lirc -mtp -nsplugin -test)
     Homepage:            http://www.rhythmbox.org/
     Description:         Music management and playback software for GNOME
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum