Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Langage] Toutes mes applis sont passées en anglais [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Thesalan
n00b
n00b


Joined: 16 Nov 2006
Posts: 69
Location: Belfort (90)

PostPosted: Thu Mar 05, 2009 8:18 pm    Post subject: [Langage] Toutes mes applis sont passées en anglais [Résolu] Reply with quote

Bonsoir a tous

Je viens d'installer OpenBox et toutes mes applis (xchat, pidgin, thunar...) y sont en anglais, alors que jusqu'a présent je tournai sous e17 et mes applis etait bien en francais (et le sont toujours...)

Lorsque je lance une appli depuis une console j'ai le message d'erreur suivant:
Quote:
Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.


J'ai esssayer de recompiler la glibc mais ca n'a rien changer....

Pour info:
Quote:
$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=fr_FR.utf8@euro
LC_CTYPE="fr_FR.utf8@euro"
LC_NUMERIC="fr_FR.utf8@euro"
LC_TIME="fr_FR.utf8@euro"
LC_COLLATE="fr_FR.utf8@euro"
LC_MONETARY="fr_FR.utf8@euro"
LC_MESSAGES="fr_FR.utf8@euro"
LC_PAPER="fr_FR.utf8@euro"
LC_NAME="fr_FR.utf8@euro"
LC_ADDRESS="fr_FR.utf8@euro"
LC_TELEPHONE="fr_FR.utf8@euro"
LC_MEASUREMENT="fr_FR.utf8@euro"
LC_IDENTIFICATION="fr_FR.utf8@euro"
LC_ALL=fr_FR.utf8@euro


Quote:
$ locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
fr_FR.iso88591@euro
fr_FR@euro


Quote:
$ cat /etc/env.d/02locale
LANG="fr_FR.utf8@euro"
LC_COLLATE="C"
LC_ALL="fr_FR.utf8@euro"
LC_CTYPE=fr_FR.utf8


Quote:
$ cat /etc/locale.gen
fr_FR@euro ISO-8859-1


Last edited by Thesalan on Fri Mar 06, 2009 1:32 am; edited 2 times in total
Back to top
View user's profile Send private message
Thesalan
n00b
n00b


Joined: 16 Nov 2006
Posts: 69
Location: Belfort (90)

PostPosted: Thu Mar 05, 2009 11:21 pm    Post subject: Reply with quote

C'est bon, le problème venait de mon /etc/locale.gen:

Quote:
$ cat /etc/locale.gen
fr_FR@euro UTF-8
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3755
Location: Lyon, France

PostPosted: Fri Mar 06, 2009 12:46 am    Post subject: Reply with quote

Salut, peux-tu tout de même mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)
_________________
Google+ | Twitter
Back to top
View user's profile Send private message
Thesalan
n00b
n00b


Joined: 16 Nov 2006
Posts: 69
Location: Belfort (90)

PostPosted: Fri Mar 06, 2009 1:33 am    Post subject: Reply with quote

Oui désolé, mais je ne savais pas trop quoi mettre comme catégorie au début, vu que ca venait pas d'openbox..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum