Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No desktop Icons in Xfce [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sall
Guru
Guru


Joined: 08 Jun 2008
Posts: 314
Location: WV, USA

PostPosted: Tue Mar 03, 2009 4:21 pm    Post subject: No desktop Icons in Xfce [SOLVED] Reply with quote

I would like to have a desktop with no icons in Xfce. However, when I go to Settings > Desktop Settings and uncheck "Allow Xfce to manage desktop" I no longer have a wallpaper. Is there anyway to have no icons on Desktop but still use a wallpaper instead of solid color background? Thanks in advance!Wallpaper when
_________________
Sall

* AMD Turion(tm) 64 Mobile Technology ML-32
* 1Gb RAM
* 2.6.27-gentoo-r8 x86_64
* Xfce4


Last edited by sall on Mon May 04, 2009 3:18 pm; edited 2 times in total
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 432

PostPosted: Tue Mar 03, 2009 4:34 pm    Post subject: Reply with quote

You can set wallpaper with feh --bg-scale for example and then put in autostart
Code:
eval `cat $HOME/.fehbg`


Then you can for example use mirage, nice viewer and you can configure custom actions so add one for Set Wallpaper and you can easily change them.
Back to top
View user's profile Send private message
sall
Guru
Guru


Joined: 08 Jun 2008
Posts: 314
Location: WV, USA

PostPosted: Tue Mar 03, 2009 4:43 pm    Post subject: Reply with quote

Code:

feh --bg-scale /home/scarecrow/Wallpaper/skullwallpaper.jpg


Results in grey background and that's it. Whether with .png or .jpg

Also, in Ristretto under view I cannot select Set as Wallpaper
_________________
Sall

* AMD Turion(tm) 64 Mobile Technology ML-32
* 1Gb RAM
* 2.6.27-gentoo-r8 x86_64
* Xfce4
Back to top
View user's profile Send private message
sall
Guru
Guru


Joined: 08 Jun 2008
Posts: 314
Location: WV, USA

PostPosted: Thu Mar 05, 2009 2:06 am    Post subject: Reply with quote

Well, I figured it out. Easy fix actually. Don't know how I missed it!

Settings > Desktop Settings > Behavior > Desktop Icons > None
_________________
Sall

* AMD Turion(tm) 64 Mobile Technology ML-32
* 1Gb RAM
* 2.6.27-gentoo-r8 x86_64
* Xfce4
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5999
Location: Pomona, California.

PostPosted: Thu Mar 19, 2009 4:59 am    Post subject: Reply with quote

To get the icons back, do the following:

1) echo "=media-libs/libpng-1.2.35" >> /etc/portage/package.mask...or add =media-libs/libpng-1.2.35 to /etc/portage/package.mask.
2) emerge -av libpng.

Apparently, libpng is broken again. I'm going to check bugzilla and post a bug report if one doesn't exist.

Please verify. I am away from home, and can only check on pappy-lap.

Blessed be!
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5999
Location: Pomona, California.

PostPosted: Sun Mar 22, 2009 9:07 am    Post subject: Reply with quote

Or not. Apparently, that only worked on one machine...and not too well. Entering emerge -av x11-themes/tango-icon-theme actually works. Nevermind the above post. My bad. :oops:

Blessed be!
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1133
Location: 127.0.0.1

PostPosted: Mon Mar 23, 2009 10:43 pm    Post subject: Reply with quote

bad pappy, go to your room no dinner for you tonight
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5999
Location: Pomona, California.

PostPosted: Tue Mar 24, 2009 4:50 am    Post subject: Reply with quote

hehehe

BB!
P
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
azmodai
n00b
n00b


Joined: 07 Jul 2006
Posts: 63

PostPosted: Wed Dec 23, 2009 8:25 pm    Post subject: Xfce's icons don't appear. Reply with quote

Hello,

Since I installed the latest XFce some icons are lacking in the panel and menus. (lacking icons are replaced by "default white-and-crossed-out icons").
I tried to change icon themes several times but lacking icons still lack, nothing replace them ....
Is there a path problem somewhere ? Did you experience a similar problem with XFce ?

this is not that important but it's annoying .....

thanks,
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8078
Location: ~Brussels - Belgique

PostPosted: Wed Dec 23, 2009 9:19 pm    Post subject: Reply with quote

Hello,

What icon themes are installed ?

In my case, I emerged
Code:
x11-themes/tangerine-icon-theme
x11-themes/tango-icon-theme
x11-themes/tango-icon-theme-extras

and I have all icons ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
s0ulslack
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2003
Posts: 134
Location: Idaho

PostPosted: Thu Dec 24, 2009 7:45 am    Post subject: Reply with quote

Indeed, you just need a complete theme. As suggested, Tango is a fairly complete theme but you can also poke over http://xfce-look.org for others :)
Back to top
View user's profile Send private message
azmodai
n00b
n00b


Joined: 07 Jul 2006
Posts: 63

PostPosted: Fri Dec 25, 2009 7:53 am    Post subject: Reply with quote

I've installed the three pkgs and two or maybe three more icons appeared :-(
Thanks for your help,
I'm going to download some more complete themes and see what happen
Back to top
View user's profile Send private message
Nerevar
l33t
l33t


Joined: 31 May 2008
Posts: 720

PostPosted: Fri Dec 25, 2009 8:04 am    Post subject: Reply with quote

These are the two I install:
Code:
x11-themes/xfce4-icon-theme
x11-themes/gnome-icon-theme
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Fri Dec 25, 2009 3:48 pm    Post subject: Reply with quote

merged above five posts here
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
maratbn
n00b
n00b


Joined: 04 Jan 2012
Posts: 12

PostPosted: Thu Sep 21, 2017 5:16 am    Post subject: Emerging 'x11-themes/gnome-icon-theme' worked for me. Reply with quote

Emerging 'x11-themes/gnome-icon-theme' got the icons under Panel -> Panel Preferences -> Items working for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum