Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] app-editor/scribes error "failed to send buffer"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cynapsis
n00b
n00b


Joined: 14 Nov 2010
Posts: 35

PostPosted: Wed Dec 15, 2010 11:36 am    Post subject: [solved] app-editor/scribes error "failed to send buffe Reply with quote

Hello there..

my Scribes is broken anyhow and I have no clue how to fix it.

That's what I get when I execute it in shell:
Code:

$ scribes
** Message: pygobject_register_sinkfunc is deprecated (GtkWindow)
** Message: pygobject_register_sinkfunc is deprecated (GtkInvisible)
** Message: pygobject_register_sinkfunc is deprecated (GtkObject)

** (scribes:30357): WARNING **: Failed to send buffer

** (scribes:30357): WARNING **: Failed to send buffer


Here's the output of strace: http://pastebin.com/NPqshNec

And here's my emerge --info:
Code:

Portage 2.1.9.25 (default/linux/amd64/10.0/desktop, gcc-4.4.5, glibc-2.12.1-r3, 2.6.35-zen2navi x86_64)
=================================================================
System uname: Linux-2.6.35-zen2navi-x86_64-AMD_Athlon-tm-_64_Processor_3800+-with-gentoo-2.0.1
Timestamp of tree: Tue, 14 Dec 2010 07:00:01 +0000
ccache version 3.1.3 [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 2.7, 3.1.3
dev-util/ccache:     3.1.3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.5, 4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y --jobs=10 --load-average=5.0"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US de ja ko"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/berkano /var/lib/layman/mpd /var/lib/layman/pro-audio /var/lib/layman/zugaina /var/lib/layman/ladi /var/lib/layman/belak /var/lib/layman/secondlife /var/lib/layman/sunrise /var/lib/layman/games /var/lib/layman/gamerlay /var/lib/layman/zentoo /var/lib/layman/benf /var/lib/layman/x11 /var/lib/layman/mozilla /var/lib/portage_custom /usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acl acpi alsa amd64 anthy apm asf audiofile avahi berkdb branding bzip2 cairo cdr cjk cli consolekit cracklib crypt cups curl cvs cxx dbus dri dts emboss enca encode exif fam ffmpeg fftw flac fluidsynth fontconfig fortran gdbm gif gimp git gnome-keyring gnutls gpm gtk iconv imagemagick ipv6 jack jpeg jpeg2k ladspa lame lash lastfmradio lcms ldap libnotify libsamplerate lm_sensors logrotate lv2 m17n-lib mad matroska midi mikmod mmx mmxext mng modplug modules mp3 mp4 mpd mpeg mplayer mudflap multilib multimedia musepack mysql ncurses nforce2 nls nptl nptlonly nvidia ogg opengl openmp pam pango pcre pdf perl pmu png postgres ppds pppd pulseaudio python readline rss scanner scim sdl session sftp sndfile sox spell sse sse2 ssh ssl startup-notification subversion svg sysfs taglib tcmalloc tcpd theora threads tiff truetype udev unicode usb vim-syntax vorbis vpx wacom wavpack webkit x264 xcb xml xorg xv xvid zlib" ALSA_CARDS="intel8x0 ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="wacom evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US de ja ko" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Both, revdep-rebuild and python-updater say that my system is clean. Python 2.6.6 is the Python version i'm using systemwide.

I hope someone has a hint how to fix that problem.


bb Lia


Last edited by cynapsis on Wed Jan 19, 2011 12:22 am; edited 1 time in total
Back to top
View user's profile Send private message
rsa4046
l33t
l33t


Joined: 07 Feb 2005
Posts: 660
Location: The Big H, a bit SSW

PostPosted: Tue Jan 18, 2011 7:58 pm    Post subject: Reply with quote

I was having similar:
Code:
** Message: pygobject_register_sinkfunc is deprecated (GtkWindow)
** Message: pygobject_register_sinkfunc is deprecated (GtkInvisible)
** Message: pygobject_register_sinkfunc is deprecated (GtkObject)

** (scribes:21896): WARNING **: Failed to send buffer

** (scribes:21896): WARNING **: Failed to send buffer

But the scribes-0.4-r778.ebuild on bugzilla and the sandbox patch got it working for me. Post back if the above makes no sense. HTH
Back to top
View user's profile Send private message
cynapsis
n00b
n00b


Joined: 14 Nov 2010
Posts: 35

PostPosted: Wed Jan 19, 2011 12:21 am    Post subject: Reply with quote

Ah.. I've made the ebuild on bugzilla because of the bugs with the version in portage.
So yes the version in portage is old and broken.. my ebuild on bugzilla is for the most recent version and that one is working. ^^

bb Lia
Back to top
View user's profile Send private message
rsa4046
l33t
l33t


Joined: 07 Feb 2005
Posts: 660
Location: The Big H, a bit SSW

PostPosted: Tue May 03, 2011 11:02 am    Post subject: new error on app-editors/scribes-0.4-r778 Reply with quote

This was working, but now a new error has appeared:
Code:
$ scribes
Traceback (most recent call last):
  File "/usr/bin/scribes", line 11, in <module>
    main()
  File "/usr/lib64/python2.6/site-packages/SCRIBES/Main.py", line 5, in main
    __fork_scribes()
  File "/usr/lib64/python2.6/site-packages/SCRIBES/Main.py", line 50, in __fork_scribes
    if not can_fork(): return
  File "/usr/lib64/python2.6/site-packages/SCRIBES/ForkScribesMetadata.py", line 13, in get_value
    database.close()
$
UnboundLocalError: local variable 'database' referenced before assignment
Anyone else with this problem?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum