Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] ERROR: net-libs/gnutls-2.7.4 failed.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Feb 16, 2009 11:30 am    Post subject: [RISOLTO] ERROR: net-libs/gnutls-2.7.4 failed. Reply with quote

Facendo un emerge world mi esce un errore mentre prova a tirar su gnutls.
Sicuramente su questa macchina all'epoca ho installato anche troppa roba rispetto a quella che mi serviva e siccome ho esigenza di lavorare e anche abbastanza in fretta prima di occuparmi di questo errore volevo capire se questo pacchetto era importante per il mio sistema o meno.

Quindi due domande:
1. come posso vedere quali pacchetti richiedono questo gnutils ?
2. eventualmente come posso risolvere sot errore che googlando non ho trovato niente (e di solito con google mi appaiono anche i risultati di questo forum)

forse inquadrando meglio il problema intanto capisco come procedere....

Qui l'ultima parte dell'errore:
Code:

configure: summary of build options:

  version:          2.7.4 shared 39:0:13
  Host type:        i686-pc-linux-gnu
  Install prefix:   /usr
  Compiler:         i686-pc-linux-gnu-gcc -std=gnu99
  Warning flags:     -Wall -W -Wformat-nonliteral -Wformat-security -Winit-self -Wmissing-include-dirs -Wunused -Wunknown-pragmas -Wstrict-aliasing -Wfloat-equal -Wdeclaration-after-statement -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wmissing-noreturn -Wmissing-format-attribute -Wpacked -Wredundant-decls -Wnested-externs -Winline -Winvalid-pch -Wlong-long -Wvolatile-register-var -Wdisabled-optimization -Wstack-protector -Wattributes -Wmultichar -Wunused-macros -Wno-missing-field-initializers -Wno-sign-compare -Wno-pointer-sign -Wno-unused-parameter -fdiagnostics-show-option
  Library types:    Shared=yes, Static=yes
  Valgrind:         valgrind
  Linker script:    yes
  Guile wrappers:   no
  C++ library:      yes
  OpenSSL library:  yes

>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-libs/gnutls-2.7.4/work/gnutls-2.7.4 ...
make
make: *** No rule to make target `m4/libtool.m4', needed by `Makefile.in'.  Stop.
 *
 * ERROR: net-libs/gnutls-2.7.4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2573:  Called _eapi2_src_compile
 *               ebuild.sh, line  629:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-libs/gnutls-2.7.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/gnutls-2.7.4/temp/environment'.
 *


Last edited by lsegalla on Tue Feb 17, 2009 12:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon Feb 16, 2009 11:47 am    Post subject: Re: ERROR: net-libs/gnutls-2.7.4 failed. Reply with quote

lsegalla wrote:

1. come posso vedere quali pacchetti richiedono questo gnutils ?


Code:
# qdepends -Q <pacchetto>

(portage-utils)
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Feb 16, 2009 12:01 pm    Post subject: Reply with quote

Purtroppo per me lo devo tenere :D
Passiamo alla seconda fase: HELP ! :P
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Feb 16, 2009 12:32 pm    Post subject: Reply with quote

chi è causa del suo mal pianga se stesso
mi spieghi a che ti serve una versione "masked" di gnutls?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Mon Feb 16, 2009 12:42 pm    Post subject: Reply with quote

djinnZ wrote:
chi è causa del suo mal pianga se stesso
mi spieghi a che ti serve una versione "masked" di gnutls?

Sniff sniff, etc. etc... :(

Suppongo di averlo installato perchè all'epoca mi servivano NTFSPROGS e gli altri pacchettini che richiedono GNUTLS
Code:

gentoo-linux luca # qdepends -Q gnutls
sys-fs/ntfsprogs-2.0.0
net-ftp/filezilla-3.1.3.1
net-libs/libsoup-2.4.1
net-libs/libsoup-2.2.105-r2


Al momento ho rimascherato GNUTLS e a quanto pare ha già fatto l'emerge.
Vediamo se mi completa tutto e poi eventualmente marco come RISOLTO
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum