Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ebuild digest downloads package from incorrect location
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
xipi
n00b
n00b


Joined: 15 Feb 2009
Posts: 3

PostPosted: Sun Feb 15, 2009 2:50 pm    Post subject: Ebuild digest downloads package from incorrect location Reply with quote

Hi,

I've tried with ebuilds for gnome-commander and xoscope applications, and I'm finding following trouble:

in /usr/local/portage, when I do

# ebuild xoscope-1.12.ebuild digest

in order to generate its manifest, it DOES NOT download the package from correct location. I mean, although SRC_URI in the ebuild itself tells a correct location, ebuild first tries to download from official gentoo mirrors. It gets several 404, and keeps trying other mirrors, until one of them (http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles), happens to answer a 200 and gives back an HTML telling something like "the page you're looking for is not here, dude". Thus, ebuild downloads this HTML, and stores it in /usr/portage/distfiles with filename 'xoscope-1.12.tgz'. I.e., we have an HTML named like a package now. Then, generates the checksum and takes the size of this HTML as the one it has to expect from the package.

This results in that, when doing:

# emerge xoscope

It does not download it (as the "package", though corrupted, is already in /usr/portage/distfiles), tries to unpack it, and obviously fails (as it is an HTML).

I tried removing the corrupted file from /usr/portage/distfiles. What then emerge does is downloading it (this time, from the correct location), but as the size and checksum does not fit with the Manifest generated by the ebuild, it does not install it.

In front of this issue, I wonder several questions:

-Where are located the list of gentoo mirrors that portage is using on my system? (one idea is that, if I delete the infamious server that answer with a 200 to an invalid URL, maybe 'ebuild' command will end up downloading the package from the correct location)

-Is there any reason for which 'ebuild' first tries to download the package from official gentoo mirrors rather than the SRC_URI specified in the ebuild i've placed? I can't see the sense in that (if I placed the ebuild myself, is because it is NOT in the official gentoo mirrors).

-Is there any command to cleanup all what 'ebuild whatever.ebuild digest' has done? (i.e., downloading the package and creating the Manifest)

Thanks and greetings,
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Sun Feb 15, 2009 3:15 pm    Post subject: Reply with quote

Please, don't duplicate threads. I've moved the other thread to the unsupported section for a good reason.

Closing this thread and moving the relevant posts to the other thread.

https://forums.gentoo.org/viewtopic-t-737471-highlight-.html
_________________
Gentoo Handbook | My website


Last edited by i92guboj on Sun Feb 15, 2009 3:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum