Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Need help resolving package conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
EugeneTheJeep
n00b
n00b


Joined: 17 May 2017
Posts: 65

PostPosted: Mon May 22, 2017 1:10 pm    Post subject: [solved]Need help resolving package conflict Reply with quote

Hi, after running

Code:
# emerge --pretend --update --deep --changed-use --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies  . ........... done!
[ebuild     UD ] dev-libs/gobject-introspection-common-1.42.0 [1.50.0]
[ebuild     U  ] dev-libs/vala-common-0.36.3 [0.34.8]
[ebuild  N     ] dev-libs/libunistring-0.9.7  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-libs/npth-1.3 [1.3]
[ebuild   R    ] dev-libs/openssl-1.0.2k  USE="-bindist*"
[ebuild     U *] x11-base/xorg-drivers-9999 [1.18-r1] VIDEO_CARDS="-i915% -i965%"
[ebuild     U  ] app-admin/eselect-1.4.9 [1.4.8] USE="(-multischema)"
[ebuild   R    ] app-eselect/eselect-pinentry-0.7 [0.7]
[ebuild   R    ] dev-lang/python-3.4.5  USE="-sqlite*"
[ebuild   R    ] dev-lang/python-2.7.12  USE="-sqlite*"
[ebuild   R    ] media-libs/freetype-2.8  USE="-bindist*"
[ebuild  N     ] x11-libs/libxkbcommon-0.6.0  USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-libs/libXinerama-1.1.3  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-util/gtk-doc-am-1.25-r1 [1.25-r1]
[ebuild   R    ] dev-libs/boehm-gc-7.4.2  USE="threads*"
[ebuild  N     ] x11-libs/libXfont2-2.0.1  USE="bzip2 ipv6 truetype -doc -static-libs"
[ebuild   R    ] www-client/w3m-0.5.3-r9  USE="-gtk*"
[ebuild   R    ] sys-devel/gettext-0.19.8.1 [0.19.8.1]
[ebuild   R    ] dev-libs/libgpg-error-1.27-r1 [1.27-r1]
[ebuild   R    ] dev-libs/libgcrypt-1.7.6 [1.7.6]
[ebuild   R    ] dev-libs/libassuan-2.4.3-r1 [2.4.3-r1]
[ebuild  N     ] net-dns/libidn2-0.16-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] net-libs/gnutls-3.5.12 [3.3.26] USE="idn%* seccomp%* sslv3%* tls-heartbeat%* -openpgp% -sslv2% (-test-full) -tools% -valgrind%"
[ebuild  N     ] sys-libs/libomp-3.9.1  USE="-hwloc -ompt" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-devel/clang-runtime-3.9.1  USE="openmp -libcxx" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] sys-devel/llvm-3.9.1-r1  USE="clang*"
[ebuild  N     ] sys-devel/clang-3.9.1-r100  USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[ebuild   R    ] media-libs/mesa-13.0.5  USE="-bindist*"
[ebuild  N     ] virtual/opengl-7.0-r1  ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] dev-util/gdbus-codegen-2.42.2 [2.50.3] PYTHON_TARGETS="(-python3_6)"
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.29.0  USE="-doc {-test}"
[ebuild  N     ] media-libs/glfw-3.2.1  USE="-examples -wayland"
[ebuild     U  ] x11-base/xorg-server-1.19.2 [1.18.4] USE="-debug% -kdrive*"
[ebuild  rR    ] x11-drivers/xf86-video-intel-2.99.917_p20170216
[ebuild  rR    ] x11-drivers/xf86-video-dummy-0.3.8
[ebuild  rR    ] x11-drivers/xf86-video-amdgpu-1.2.0
[ebuild  rR    ] x11-drivers/xf86-input-mouse-1.9.2
[ebuild  rR    ] x11-drivers/xf86-video-vesa-2.3.4
[ebuild  rR    ] x11-drivers/xf86-input-keyboard-1.9.0
[ebuild  rR    ] x11-drivers/xf86-video-ati-7.8.0
[ebuild  rR    ] x11-drivers/xf86-video-fbdev-0.4.4
[ebuild  rR    ] x11-drivers/xf86-video-nouveau-1.0.13
[ebuild  N     ] sys-apps/dbus-1.10.18  USE="X -debug -doc -elogind (-selinux) -static-libs (-systemd) {-test} -user-session" ABI_X86="(64) -32 (-x32)"
[ebuild  r  UD ] dev-libs/glib-2.42.2-r1 [2.50.3-r1]
[blocks b      ] <dev-util/gdbus-codegen-2.50.3 ("<dev-util/gdbus-codegen-2.50.3" is blocking dev-libs/glib-2.50.3-r1)
[ebuild  N     ] gnome-base/dconf-0.22.0  USE="X {-test}"
[ebuild     UD ] dev-libs/gobject-introspection-1.42.0-r1 [1.50.0]
[ebuild   R    ] dev-libs/libcroco-0.6.12-r1 [0.6.12-r1]
[ebuild  N     ] dev-libs/dbus-glib-0.102  USE="-debug -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] x11-libs/gdk-pixbuf-2.36.4 [2.36.6]
[ebuild     UD ] dev-libs/atk-2.14.0 [2.22.0]
[ebuild   R    ] sys-fs/eudev-3.1.5  USE="introspection*"
[ebuild     UD ] app-accessibility/at-spi2-core-2.14.1 [2.22.1]
[ebuild     U  ] app-text/poppler-0.54.0 [0.45.0] USE="-qt4*"
[ebuild     UD ] x11-libs/pango-1.36.8-r1 [1.40.5]
[ebuild     UD ] app-accessibility/at-spi2-atk-2.14.1 [2.22.0]
[ebuild     UD ] dev-util/gtk-update-icon-cache-3.14.15 [3.22.2]
[ebuild  N     ] app-text/mupdf-1.11-r1  USE="X curl opengl openssl -javascript (-libressl) -static -static-libs -vanilla"
[ebuild   R    ] gnome-base/librsvg-2.40.17 [2.40.17]
[ebuild  rR    ] dev-libs/libgudev-230-r1
[ebuild     UD ] x11-themes/adwaita-icon-theme-3.14.1-r2 [3.22.0-r1]
[ebuild  rR    ] x11-drivers/xf86-input-libinput-0.24.0
[ebuild     UD ] dev-libs/libgusb-0.2.7 [0.2.9]
[ebuild   R    ] app-text/ghostscript-gpl-9.20-r1  USE="-gtk*"
[ebuild     U  ] net-print/cups-filters-1.12.0 [1.5.0] USE="pdf%* postscript%*"
[ebuild   R    ] app-crypt/libsecret-0.18.5 [0.18.5]
[ebuild     U  ] sys-auth/pambase-20150213-r1 [20150213] USE="consolekit* gnome-keyring* -elogind%"
[ebuild   R    ] net-misc/openssh-7.3_p1-r7  USE="X* ldap* -bindist*"
[ebuild   R    ] sys-auth/polkit-0.113  USE="-gtk*"
[ebuild     UD ] sys-auth/consolekit-0.4.6 [1.1.0-r1] USE="-systemd-units%"
[ebuild     UD ] x11-misc/colord-1.2.12 [1.3.4]
[ebuild     UD ] x11-libs/gtk+-3.14.15 [3.22.15]
[ebuild     UD ] app-crypt/gcr-3.14.0 [3.20.0] USE="-vala*"
[ebuild   R    ] app-crypt/pinentry-0.9.7-r1 [0.9.7-r1] USE="-gtk* -qt4*"
[ebuild     U  ] app-crypt/gnupg-2.1.21 [2.1.20-r1]
[ebuild     UD ] gnome-base/gnome-keyring-3.14.0 [3.20.0]
[ebuild   R    ] gnome-base/libgnome-keyring-3.12.0 [3.12.0]
[ebuild     U  ] sys-apps/openrc-0.26.2 [0.24.2]
[blocks B      ] <x11-drivers/xf86-video-virtualbox-5.1.14 ("<x11-drivers/xf86-video-virtualbox-5.1.14" is blocking x11-base/xorg-drivers-9999)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed) pulled in by
    <x11-base/xorg-server-1.19:0/1.18.4=[-minimal] required by (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, installed)
    ^                     ^^^^^^^^^^^^^^                                                                                         
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, installed) pulled in by
    ~x11-drivers/xf86-video-virtualbox-5.0.32 required by (app-emulation/virtualbox-guest-additions-5.0.32:0/0::gentoo, installed)
    x11-drivers/xf86-video-virtualbox required by @selected

  (x11-base/xorg-drivers-9999:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-drivers-1.18 required by (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed)
    >=x11-base/xorg-drivers-1.19 required by (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (dev-libs/glib-2.42.2-r1:2/42::dantrell-gnome, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/libgudev-230-r1:0/0::gentoo, ebuild scheduled for merge)
  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-video-vesa-2.3.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-dummy-0.3.8:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-mouse-1.9.2:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-nouveau-1.0.13:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-amdgpu-1.2.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-ati-7.8.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.917_p20170216:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-libinput-0.24.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-fbdev-0.4.4:0/0::gentoo, ebuild scheduled for merge)

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


I can see that

Code:
 Error: The above package list contains packages which cannot be
 installed at the same time on the same system.


Code:
Multiple package instances within a single package slot have been pulled
into the dependency graph, resulting in a slot conflict


Can somebody please help me understand the concept of package slots, why I'm getting this error, and how to resolve it? Does it mean @world doesn't match what I actually have installed?


Last edited by EugeneTheJeep on Mon May 22, 2017 6:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16579
Location: here

PostPosted: Mon May 22, 2017 1:33 pm    Post subject: Reply with quote

You have masked =x11-base/xorg-drivers-1.19 in /etc/portage/package.mask?
It's strange that portage propose a 9999 package.

EDIT: And furthermore, you should to unmask virtualbox to version >=5.1.x with xorg-server-1.19
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
EugeneTheJeep
n00b
n00b


Joined: 17 May 2017
Posts: 65

PostPosted: Mon May 22, 2017 1:42 pm    Post subject: Reply with quote

I unmasked it and reran:
Code:
spacepaste

new
Paste details
reply | raw | toggle line wrapping
 
# emerge --pretend --update --deep --changed-use --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies  . .... done!
[ebuild     UD ] dev-libs/gobject-introspection-common-1.42.0 [1.50.0]
[ebuild     U  ] dev-libs/vala-common-0.36.3 [0.34.8]
[ebuild  N     ] dev-libs/libunistring-0.9.7  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-libs/npth-1.3 [1.3]
[ebuild   R    ] dev-libs/openssl-1.0.2k  USE="-bindist*"
[ebuild     U *] x11-base/xorg-drivers-9999 [1.18-r1] VIDEO_CARDS="-i915% -i965%"
[ebuild     U  ] app-admin/eselect-1.4.9 [1.4.8] USE="(-multischema)"
[ebuild   R    ] app-eselect/eselect-pinentry-0.7 [0.7]
[ebuild   R    ] dev-lang/python-3.4.5  USE="-sqlite*"
[ebuild   R    ] dev-lang/python-2.7.12  USE="-sqlite*"
[ebuild   R    ] media-libs/freetype-2.8  USE="-bindist*"
[ebuild  N     ] x11-libs/libxkbcommon-0.6.0  USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-libs/libXinerama-1.1.3  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-util/gtk-doc-am-1.25-r1 [1.25-r1]
[ebuild   R    ] dev-libs/boehm-gc-7.4.2  USE="threads*"
[ebuild  N     ] x11-libs/libXfont2-2.0.1  USE="bzip2 ipv6 truetype -doc -static-libs"
[ebuild   R    ] www-client/w3m-0.5.3-r9  USE="-gtk*"
[ebuild   R    ] sys-devel/gettext-0.19.8.1 [0.19.8.1]
[ebuild   R    ] dev-libs/libgpg-error-1.27-r1 [1.27-r1]
[ebuild   R    ] dev-libs/libgcrypt-1.7.6 [1.7.6]
[ebuild   R    ] dev-libs/libassuan-2.4.3-r1 [2.4.3-r1]
[ebuild  N     ] net-dns/libidn2-0.16-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] net-libs/gnutls-3.5.12 [3.3.26] USE="idn%* seccomp%* sslv3%* tls-heartbeat%* -openpgp% -sslv2% (-test-full) -tools% -valgrind%"
[ebuild  N     ] sys-libs/libomp-3.9.1  USE="-hwloc -ompt" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-devel/clang-runtime-3.9.1  USE="openmp -libcxx" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] sys-devel/llvm-3.9.1-r1  USE="clang*"
[ebuild  N     ] sys-devel/clang-3.9.1-r100  USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[ebuild   R    ] media-libs/mesa-13.0.5  USE="-bindist*"
[ebuild  N     ] virtual/opengl-7.0-r1  ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] dev-util/gdbus-codegen-2.42.2 [2.50.3] PYTHON_TARGETS="(-python3_6)"
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.29.0  USE="-doc {-test}"
[ebuild  N     ] media-libs/glfw-3.2.1  USE="-examples -wayland"
[ebuild     U  ] x11-base/xorg-server-1.19.2 [1.18.4] USE="-debug% -kdrive*"
[ebuild  rR    ] x11-drivers/xf86-video-intel-2.99.917_p20170216
[ebuild  rR    ] x11-drivers/xf86-video-vesa-2.3.4
[ebuild  rR    ] x11-drivers/xf86-video-ati-7.8.0
[ebuild  rR    ] x11-drivers/xf86-video-dummy-0.3.8
[ebuild  rR    ] x11-drivers/xf86-input-mouse-1.9.2
[ebuild  rR    ] x11-drivers/xf86-video-nouveau-1.0.13
[ebuild  rR    ] x11-drivers/xf86-video-amdgpu-1.2.0
[ebuild  rR    ] x11-drivers/xf86-video-fbdev-0.4.4
[ebuild  rR    ] x11-drivers/xf86-input-keyboard-1.9.0
[ebuild  N     ] sys-apps/dbus-1.10.18  USE="X -debug -doc -elogind (-selinux) -static-libs (-systemd) {-test} -user-session" ABI_X86="(64) -32 (-x32)"
[ebuild  r  UD ] dev-libs/glib-2.42.2-r1 [2.50.3-r1]
[blocks b      ] <dev-util/gdbus-codegen-2.50.3 ("<dev-util/gdbus-codegen-2.50.3" is blocking dev-libs/glib-2.50.3-r1)
[ebuild  N     ] gnome-base/dconf-0.22.0  USE="X {-test}"
[ebuild     UD ] dev-libs/gobject-introspection-1.42.0-r1 [1.50.0]
[ebuild   R    ] dev-libs/libcroco-0.6.12-r1 [0.6.12-r1]
[ebuild  N     ] dev-libs/dbus-glib-0.102  USE="-debug -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] x11-libs/gdk-pixbuf-2.36.4 [2.36.6]
[ebuild     UD ] dev-libs/atk-2.14.0 [2.22.0]
[ebuild   R    ] sys-fs/eudev-3.1.5  USE="introspection*"
[ebuild     UD ] app-accessibility/at-spi2-core-2.14.1 [2.22.1]
[ebuild     U  ] app-text/poppler-0.54.0 [0.45.0] USE="-qt4*"
[ebuild     UD ] x11-libs/pango-1.36.8-r1 [1.40.5]
[ebuild     UD ] app-accessibility/at-spi2-atk-2.14.1 [2.22.0]
[ebuild     UD ] dev-util/gtk-update-icon-cache-3.14.15 [3.22.2]
[ebuild  N     ] app-text/mupdf-1.11-r1  USE="X curl opengl openssl -javascript (-libressl) -static -static-libs -vanilla"
[ebuild   R    ] gnome-base/librsvg-2.40.17 [2.40.17]
[ebuild  rR    ] dev-libs/libgudev-230-r1
[ebuild     UD ] x11-themes/adwaita-icon-theme-3.14.1-r2 [3.22.0-r1]
[ebuild  rR    ] x11-drivers/xf86-input-libinput-0.24.0
[ebuild     UD ] dev-libs/libgusb-0.2.7 [0.2.9]
[ebuild   R    ] app-text/ghostscript-gpl-9.20-r1  USE="-gtk*"
[ebuild     U  ] net-print/cups-filters-1.12.0 [1.5.0] USE="pdf%* postscript%*"
[ebuild   R    ] app-crypt/libsecret-0.18.5 [0.18.5]
[ebuild     U  ] sys-auth/pambase-20150213-r1 [20150213] USE="consolekit* gnome-keyring* -elogind%"
[ebuild   R    ] net-misc/openssh-7.3_p1-r7  USE="X* ldap* -bindist*"
[ebuild   R    ] sys-auth/polkit-0.113  USE="-gtk*"
[ebuild     UD ] sys-auth/consolekit-0.4.6 [1.1.0-r1] USE="-systemd-units%"
[ebuild     UD ] x11-misc/colord-1.2.12 [1.3.4]
[ebuild     UD ] x11-libs/gtk+-3.14.15 [3.22.15]
[ebuild     UD ] app-crypt/gcr-3.14.0 [3.20.0] USE="-vala*"
[ebuild   R    ] app-crypt/pinentry-0.9.7-r1 [0.9.7-r1] USE="-gtk* -qt4*"
[ebuild     U  ] app-crypt/gnupg-2.1.21 [2.1.20-r1]
[ebuild     UD ] gnome-base/gnome-keyring-3.14.0 [3.20.0]
[ebuild   R    ] gnome-base/libgnome-keyring-3.12.0 [3.12.0]
[ebuild     U  ] sys-apps/openrc-0.26.2 [0.24.2]
[blocks B      ] <x11-drivers/xf86-video-virtualbox-5.1.14 ("<x11-drivers/xf86-video-virtualbox-5.1.14" is blocking x11-base/xorg-drivers-9999)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed) pulled in by
    <x11-base/xorg-server-1.19:=[-minimal] required by (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, installed)
    ^                     ^^^^ ^                                                                                         
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, installed) pulled in by
    x11-drivers/xf86-video-virtualbox required by @selected
    ~x11-drivers/xf86-video-virtualbox-5.0.32 required by (app-emulation/virtualbox-guest-additions-5.0.32:0/0::gentoo, installed)

  (x11-base/xorg-drivers-9999:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-drivers-1.19 required by (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge)
    >=x11-base/xorg-drivers-1.18 required by (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-input-libinput-0.24.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-ati-7.8.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-dummy-0.3.8:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-amdgpu-1.2.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-nouveau-1.0.13:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-fbdev-0.4.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-vesa-2.3.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.917_p20170216:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-mouse-1.9.2:0/0::gentoo, ebuild scheduled for merge)
  (dev-libs/glib-2.42.2-r1:2/42::dantrell-gnome, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/libgudev-230-r1:0/0::gentoo, ebuild scheduled for merge)

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.
 
Powered by spacepaste. Paste removal.


I don't know why it's suggesting a 9999 package. I've installed guest-additions 5.0.32 and layman. I saw the other thread where the solution is to upgrade guest additions to 5.1.14
https://forums.gentoo.org/viewtopic-t-1060438.html

Should I just uninstall guest additions, upgrade to that version and see if it works?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39060
Location: 56N 3W

PostPosted: Mon May 22, 2017 1:51 pm    Post subject: Reply with quote

EugeneTheJeep,

All -9999 packages are keyword masked.
Does
Code:
x11-base/xorg-drivers **
appear in your package.accept_keywords?

If you really need xf86-video-virtualbox then you cannot use
Code:
x11-drivers/xf86-video-intel
x11-drivers/xf86-video-ati
x11-drivers/xf86-video-nouveau
x11-drivers/xf86-video-amdgpu

You really don't want to use x11-drivers/xf86-video-dummy accidentally as it does not generate any video output.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
EugeneTheJeep
n00b
n00b


Joined: 17 May 2017
Posts: 65

PostPosted: Mon May 22, 2017 2:02 pm    Post subject: Reply with quote

@NeddySeagoon yes:

Code:
# cat /etc/portage/package.accept_keywords
#=sys-apps/dbus-1.10.16-r1 ~amd64
# required by x11-base/xorg-server-1.19.2::gentoo[xorg]
# required by x11-drivers/xf86-input-keyboard-1.9.0::gentoo
# required by @__auto_slot_operator_replace_installed__ (argument)
=x11-base/xorg-drivers-9999 **


remove it?

I'm running Gentoo as a guest in Virtualbox so I (think) I don't need those other drivers as it uses a virtual graphics card. I'm really new to this so I can't be 100% sure of anything.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39060
Location: 56N 3W

PostPosted: Mon May 22, 2017 2:37 pm    Post subject: Reply with quote

EugeneTheJeep,

Yes, remove it. -9999 versions are 'live' from the upstream repository, commit by commit, as it happens.
Unless you have a reason to use versions like that, you should avoid them.

The other drivers I listed are all harmless bloat, apart from dummy, which will appear to work but will give no output.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
EugeneTheJeep
n00b
n00b


Joined: 17 May 2017
Posts: 65

PostPosted: Mon May 22, 2017 4:20 pm    Post subject: Reply with quote

I removed the keyword and reran:

Code:
reply | raw | toggle line wrapping
 
# emerge --pretend --update --deep --changed-use --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies  ..... done!

The following packages are causing rebuilds:

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-input-mouse-1.9.2:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-libinput-0.24.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-ati-7.8.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-virtualbox-5.1.18:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-nouveau-1.0.13:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-fbdev-0.4.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-amdgpu-1.2.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.917_p20170216:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-dummy-0.3.8:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-vesa-2.3.4:0/0::gentoo, ebuild scheduled for merge)
  (dev-libs/glib-2.42.2-r1:2/42::dantrell-gnome, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/libgudev-230-r1:0/0::gentoo, ebuild scheduled for merge)
[ebuild     UD ] dev-libs/gobject-introspection-common-1.42.0 [1.50.0]
[ebuild     U  ] dev-libs/vala-common-0.36.3 [0.34.8]
[ebuild  N     ] dev-libs/libunistring-0.9.7  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-libs/npth-1.3 [1.3]
[ebuild   R    ] dev-libs/openssl-1.0.2k  USE="-bindist*"
[ebuild     U *] x11-base/xorg-drivers-9999 [1.18-r1] VIDEO_CARDS="-i915% -i965%"
[ebuild     U  ] app-admin/eselect-1.4.9 [1.4.8] USE="(-multischema)"
[ebuild   R    ] app-eselect/eselect-pinentry-0.7 [0.7]
[ebuild   R    ] dev-lang/python-3.4.5  USE="-sqlite*"
[ebuild   R    ] dev-lang/python-2.7.12  USE="-sqlite*"
[ebuild   R    ] media-libs/freetype-2.8  USE="-bindist*"
[ebuild  N     ] x11-libs/libXinerama-1.1.3  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-libs/libxkbcommon-0.6.0  USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-util/gtk-doc-am-1.25-r1 [1.25-r1]
[ebuild   R    ] dev-libs/boehm-gc-7.4.2  USE="threads*"
[ebuild  N     ] x11-libs/libXfont2-2.0.1  USE="bzip2 ipv6 truetype -doc -static-libs"
[ebuild   R    ] www-client/w3m-0.5.3-r9  USE="-gtk*"
[ebuild   R    ] sys-devel/gettext-0.19.8.1 [0.19.8.1]
[ebuild   R    ] dev-libs/libgpg-error-1.27-r1 [1.27-r1]
[ebuild   R    ] dev-libs/libgcrypt-1.7.6 [1.7.6]
[ebuild   R    ] dev-libs/libassuan-2.4.3-r1 [2.4.3-r1]
[ebuild  N     ] net-dns/libidn2-0.16-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] net-libs/gnutls-3.5.12 [3.3.26] USE="idn%* seccomp%* sslv3%* tls-heartbeat%* -openpgp% -sslv2% (-test-full) -tools% -valgrind%"
[ebuild  N     ] sys-libs/libomp-3.9.1  USE="-hwloc -ompt" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-devel/clang-runtime-3.9.1  USE="openmp -libcxx" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] sys-devel/llvm-3.9.1-r1  USE="clang*"
[ebuild  N     ] sys-devel/clang-3.9.1-r100  USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[ebuild   R    ] media-libs/mesa-13.0.5  USE="-bindist*"
[ebuild  N     ] virtual/opengl-7.0-r1  ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] dev-util/gdbus-codegen-2.42.2 [2.50.3] PYTHON_TARGETS="(-python3_6)"
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.29.0  USE="-doc {-test}"
[ebuild  N     ] media-libs/glfw-3.2.1  USE="-examples -wayland"
[ebuild     U  ] x11-base/xorg-server-1.19.2 [1.18.4] USE="-debug% -kdrive*"
[ebuild  rR    ] x11-drivers/xf86-video-ati-7.8.0
[ebuild  rR    ] x11-drivers/xf86-video-nouveau-1.0.13
[ebuild  rR    ] x11-drivers/xf86-video-intel-2.99.917_p20170216
[ebuild  rR    ] x11-drivers/xf86-video-dummy-0.3.8
[ebuild  rR    ] x11-drivers/xf86-video-amdgpu-1.2.0
[ebuild  rR    ] x11-drivers/xf86-video-vesa-2.3.4
[ebuild  rR    ] x11-drivers/xf86-input-mouse-1.9.2
[ebuild  rR    ] x11-drivers/xf86-video-fbdev-0.4.4
[ebuild  rR    ] x11-drivers/xf86-input-keyboard-1.9.0
[ebuild  rR   ~] x11-drivers/xf86-video-virtualbox-5.1.18
[ebuild  r  UD ] dev-libs/glib-2.42.2-r1 [2.50.3-r1]
[blocks b      ] <dev-util/gdbus-codegen-2.50.3 ("<dev-util/gdbus-codegen-2.50.3" is blocking dev-libs/glib-2.50.3-r1)
[ebuild  N     ] gnome-base/dconf-0.22.0  USE="X {-test}"
[ebuild     UD ] dev-libs/gobject-introspection-1.42.0-r1 [1.50.0]
[ebuild   R    ] dev-libs/libcroco-0.6.12-r1 [0.6.12-r1]
[ebuild  N     ] dev-libs/dbus-glib-0.102  USE="-debug -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] x11-libs/gdk-pixbuf-2.36.4 [2.36.6]
[ebuild     UD ] dev-libs/atk-2.14.0 [2.22.0]
[ebuild   R    ] sys-fs/eudev-3.1.5  USE="introspection*"
[ebuild     UD ] app-accessibility/at-spi2-core-2.14.1 [2.22.1]
[ebuild     U  ] app-text/poppler-0.54.0 [0.45.0] USE="-qt4*"
[ebuild     UD ] x11-libs/pango-1.36.8-r1 [1.40.5]
[ebuild     UD ] app-accessibility/at-spi2-atk-2.14.1 [2.22.0]
[ebuild     UD ] dev-util/gtk-update-icon-cache-3.14.15 [3.22.2]
[ebuild  N     ] app-text/mupdf-1.11-r1  USE="X curl opengl openssl -javascript (-libressl) -static -static-libs -vanilla"
[ebuild   R    ] gnome-base/librsvg-2.40.17 [2.40.17]
[ebuild  rR    ] dev-libs/libgudev-230-r1
[ebuild     UD ] x11-themes/adwaita-icon-theme-3.14.1-r2 [3.22.0-r1]
[ebuild  rR    ] x11-drivers/xf86-input-libinput-0.24.0
[ebuild     UD ] dev-libs/libgusb-0.2.7 [0.2.9]
[ebuild   R    ] app-text/ghostscript-gpl-9.20-r1  USE="-gtk*"
[ebuild     U  ] net-print/cups-filters-1.12.0 [1.5.0] USE="pdf%* postscript%*"
[ebuild   R    ] app-crypt/libsecret-0.18.5 [0.18.5]
[ebuild     U  ] sys-auth/pambase-20150213-r1 [20150213] USE="consolekit* gnome-keyring* -elogind%"
[ebuild   R    ] net-misc/openssh-7.3_p1-r7  USE="X* ldap* -bindist*"
[ebuild   R    ] sys-auth/polkit-0.113  USE="-gtk*"
[ebuild     UD ] sys-auth/consolekit-0.4.6 [1.1.0-r1] USE="-systemd-units%"
[ebuild     UD ] x11-misc/colord-1.2.12 [1.3.4]
[ebuild     UD ] x11-libs/gtk+-3.14.15 [3.22.15]
[ebuild     UD ] app-crypt/gcr-3.14.0 [3.20.0] USE="-vala*"
[ebuild   R    ] app-crypt/pinentry-0.9.7-r1 [0.9.7-r1] USE="-gtk* -qt4*"
[ebuild     U  ] app-crypt/gnupg-2.1.21 [2.1.20-r1]
[ebuild     UD ] gnome-base/gnome-keyring-3.14.0 [3.20.0]
[ebuild   R    ] gnome-base/libgnome-keyring-3.12.0 [3.12.0]
[ebuild     U  ] sys-apps/openrc-0.26.2 [0.24.2]

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by x11-base/xorg-server-1.19.2::gentoo[xorg]
# required by x11-drivers/xf86-video-dummy-0.3.8::gentoo
# required by @__auto_slot_operator_replace_installed__ (argument)
=x11-base/xorg-drivers-9999 **

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


I put it there in the first place because I originally got this message (I forgot I did that :roll: I honestly didn't know what a 9999 package was)

What is the best way to proceed from here? I checked out this but it wasn't obvious to me what the correct thing to do is in my case.

I noticed that the x11-drivers/xf86-video-dummy-0.3.8 that you warned me about was in the build. Should I just remove that manually?
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5918
Location: Saint Amant, Acadiana

PostPosted: Mon May 22, 2017 4:23 pm    Post subject: Reply with quote

Why you need all those video drivers? VIDEO_CARDS variable is unset?
_________________
Please learn how to denote units correctly!

Political Correctness is all about replacing imaginary injustice with real injustice.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39060
Location: 56N 3W

PostPosted: Mon May 22, 2017 4:27 pm    Post subject: Reply with quote

EugeneTheJeep,

Code:
# required by x11-drivers/xf86-video-dummy-0.3.8::gentoo

You really don't want that driver.

Don't remove it manually, something will pull it back in.
Follow Jaglovers hint.

I'll add to it. There should be exactly one entry in VIDEO_CARDS.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
EugeneTheJeep
n00b
n00b


Joined: 17 May 2017
Posts: 65

PostPosted: Mon May 22, 2017 5:02 pm    Post subject: Reply with quote

to /etc/portage/make.conf I added:
Code:

VIDEO_CARDS="virtualbox"
INPUT_DEVICES="evdev"


The extraneous video card entries are now gone.
Code:

emerge --pretend --update --deep --changed-use --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies  .. ... done!

The following packages are causing rebuilds:

  (dev-libs/glib-2.42.2-r1:2/42::dantrell-gnome, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/libgudev-230-r1:0/0::gentoo, ebuild scheduled for merge)
  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-input-libinput-0.24.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-mouse-1.9.2:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-virtualbox-5.1.18:0/0::gentoo, ebuild scheduled for merge)
[ebuild     UD ] dev-libs/gobject-introspection-common-1.42.0 [1.50.0]
[ebuild     U  ] dev-libs/vala-common-0.36.3 [0.34.8]
[ebuild  N     ] dev-libs/libunistring-0.9.7  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-libs/npth-1.3 [1.3]
[ebuild   R    ] dev-libs/openssl-1.0.2k  USE="-bindist*"
[ebuild     U *] x11-base/xorg-drivers-9999 [1.18-r1] VIDEO_CARDS="virtualbox* -amdgpu* -dummy* -fbdev* -i915% -i965% -intel* -nouveau* -radeon* -radeonsi* -vesa*"
[ebuild     U  ] app-admin/eselect-1.4.9 [1.4.8] USE="(-multischema)"
[ebuild   R    ] app-eselect/eselect-pinentry-0.7 [0.7]
[ebuild   R    ] dev-lang/python-3.4.5  USE="-sqlite*"
[ebuild   R    ] dev-lang/python-2.7.12  USE="-sqlite*"
[ebuild   R    ] media-libs/freetype-2.8  USE="-bindist*"
[ebuild   R    ] x11-libs/libdrm-2.4.75  VIDEO_CARDS="-amdgpu* -intel* -nouveau* -radeon*"
[ebuild  N     ] x11-libs/libXinerama-1.1.3  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-libs/libxkbcommon-0.6.0  USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-util/gtk-doc-am-1.25-r1 [1.25-r1]
[ebuild   R    ] dev-libs/boehm-gc-7.4.2  USE="threads*"
[ebuild  N     ] x11-libs/libXfont2-2.0.1  USE="bzip2 ipv6 truetype -doc -static-libs"
[ebuild   R    ] www-client/w3m-0.5.3-r9  USE="-gtk*"
[ebuild   R    ] sys-devel/gettext-0.19.8.1 [0.19.8.1]
[ebuild   R    ] dev-libs/libgpg-error-1.27-r1 [1.27-r1]
[ebuild   R    ] dev-libs/libgcrypt-1.7.6 [1.7.6]
[ebuild   R    ] dev-libs/libassuan-2.4.3-r1 [2.4.3-r1]
[ebuild  N     ] net-dns/libidn2-0.16-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] net-libs/gnutls-3.5.12 [3.3.26] USE="idn%* seccomp%* sslv3%* tls-heartbeat%* -openpgp% -sslv2% (-test-full) -tools% -valgrind%"
[ebuild  N     ] sys-libs/libomp-3.9.1  USE="-hwloc -ompt" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-devel/clang-runtime-3.9.1  USE="openmp -libcxx" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] sys-devel/llvm-3.9.1-r1  USE="clang*"
[ebuild  N     ] sys-devel/clang-3.9.1-r100  USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[ebuild   R    ] media-libs/mesa-13.0.5  USE="-bindist*" VIDEO_CARDS="-intel* -nouveau* -radeon* -radeonsi*"
[ebuild  N     ] virtual/opengl-7.0-r1  ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] dev-util/gdbus-codegen-2.42.2 [2.50.3] PYTHON_TARGETS="(-python3_6)"
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.29.0  USE="-doc {-test}"
[ebuild  N     ] media-libs/glfw-3.2.1  USE="-examples -wayland"
[ebuild  r  UD ] dev-libs/glib-2.42.2-r1 [2.50.3-r1]
[blocks b      ] <dev-util/gdbus-codegen-2.50.3 ("<dev-util/gdbus-codegen-2.50.3" is blocking dev-libs/glib-2.50.3-r1)
[ebuild  N     ] gnome-base/dconf-0.22.0  USE="X {-test}"
[ebuild     UD ] dev-libs/gobject-introspection-1.42.0-r1 [1.50.0]
[ebuild   R    ] dev-libs/libcroco-0.6.12-r1 [0.6.12-r1]
[ebuild  N     ] dev-libs/dbus-glib-0.102  USE="-debug -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] x11-libs/gdk-pixbuf-2.36.4 [2.36.6]
[ebuild     UD ] dev-libs/atk-2.14.0 [2.22.0]
[ebuild     UD ] app-accessibility/at-spi2-core-2.14.1 [2.22.1]
[ebuild     U  ] app-text/poppler-0.54.0 [0.45.0] USE="-qt4*"
[ebuild     UD ] x11-libs/pango-1.36.8-r1 [1.40.5]
[ebuild     UD ] app-accessibility/at-spi2-atk-2.14.1 [2.22.0]
[ebuild     UD ] dev-util/gtk-update-icon-cache-3.14.15 [3.22.2]
[ebuild  N     ] app-text/mupdf-1.11-r1  USE="X curl opengl openssl -javascript (-libressl) -static -static-libs -vanilla"
[ebuild   R    ] gnome-base/librsvg-2.40.17 [2.40.17]
[ebuild     UD ] x11-themes/adwaita-icon-theme-3.14.1-r2 [3.22.0-r1]
[ebuild   R    ] sys-fs/eudev-3.1.5  USE="introspection*"
[ebuild  rR    ] dev-libs/libgudev-230-r1
[ebuild     U  ] x11-base/xorg-server-1.19.2 [1.18.4] USE="-debug% -kdrive*"
[ebuild  rR    ] x11-drivers/xf86-input-keyboard-1.9.0
[ebuild  rR    ] x11-drivers/xf86-input-mouse-1.9.2
[ebuild  rR    ] x11-drivers/xf86-input-libinput-0.24.0
[ebuild     UD ] dev-libs/libgusb-0.2.7 [0.2.9]
[ebuild   R    ] app-text/ghostscript-gpl-9.20-r1  USE="-gtk*"
[ebuild     U  ] net-print/cups-filters-1.12.0 [1.5.0] USE="pdf%* postscript%*"
[ebuild   R    ] app-crypt/libsecret-0.18.5 [0.18.5]
[ebuild  rR   ~] x11-drivers/xf86-video-virtualbox-5.1.18
[ebuild     U  ] sys-auth/pambase-20150213-r1 [20150213] USE="consolekit* gnome-keyring* -elogind%"
[ebuild   R    ] net-misc/openssh-7.3_p1-r7  USE="X* ldap* -bindist*"
[ebuild   R    ] sys-auth/polkit-0.113  USE="-gtk*"
[ebuild     UD ] sys-auth/consolekit-0.4.6 [1.1.0-r1] USE="-systemd-units%"
[ebuild     UD ] x11-misc/colord-1.2.12 [1.3.4]
[ebuild     UD ] x11-libs/gtk+-3.14.15 [3.22.15]
[ebuild     UD ] app-crypt/gcr-3.14.0 [3.20.0] USE="-vala*"
[ebuild   R    ] app-crypt/pinentry-0.9.7-r1 [0.9.7-r1] USE="-gtk* -qt4*"
[ebuild     U  ] app-crypt/gnupg-2.1.21 [2.1.20-r1]
[ebuild     UD ] gnome-base/gnome-keyring-3.14.0 [3.20.0]
[ebuild   R    ] gnome-base/libgnome-keyring-3.12.0 [3.12.0]
[ebuild     U  ] sys-apps/openrc-0.26.2 [0.24.2]

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by x11-base/xorg-server-1.19.2::gentoo[xorg]
# required by x11-drivers/xf86-input-mouse-1.9.2::gentoo
# required by @__auto_slot_operator_replace_installed__ (argument)
=x11-base/xorg-drivers-9999 **

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


are x11-base/xorg-server-1.19.2 and x11-drivers/xf86-input-mouse looking for x11-base/xorg-drivers-9999? How do I get rid of this error?

EDIT: running env-update then rerunning emerge --pretend --update --deep --changed-use --with-bdeps=y @world seems to have fixed it:

Code:
# emerge --pretend --update --deep --changed-use --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies  .. .... done!
[ebuild     UD ] dev-libs/gobject-introspection-common-1.42.0 [1.50.0]
[ebuild     U  ] dev-libs/vala-common-0.36.3 [0.34.8]
[ebuild  N     ] dev-libs/libunistring-0.9.7  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-libs/npth-1.3 [1.3]
[ebuild   R    ] dev-libs/openssl-1.0.2k  USE="-bindist*"
[ebuild     U  ] x11-base/xorg-drivers-1.19 [1.18-r1] INPUT_DEVICES="evdev* -keyboard* -libinput* -mouse*" VIDEO_CARDS="virtualbox* -amdgpu* -ark% -dummy* -fbdev* -i915% -i965% -intel* (-newport) -nouveau* -radeon* -radeonsi* -sis% -vesa*"
[ebuild  N     ] x11-drivers/xf86-input-evdev-2.10.5
[ebuild     U  ] app-admin/eselect-1.4.9 [1.4.8] USE="(-multischema)"
[ebuild   R    ] app-eselect/eselect-pinentry-0.7 [0.7]
[ebuild   R    ] dev-lang/python-3.4.5  USE="-sqlite*"
[ebuild   R    ] dev-lang/python-2.7.12  USE="-sqlite*"
[ebuild   R    ] media-libs/freetype-2.8  USE="-bindist*"
[ebuild   R    ] x11-libs/libdrm-2.4.75  VIDEO_CARDS="-amdgpu* -intel* -nouveau* -radeon*"
[ebuild  N     ] x11-libs/libXinerama-1.1.3  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-libs/libxkbcommon-0.6.0  USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] dev-util/gtk-doc-am-1.25-r1 [1.25-r1]
[ebuild   R    ] dev-libs/boehm-gc-7.4.2  USE="threads*"
[ebuild  N     ] x11-libs/libXfont2-2.0.1  USE="bzip2 ipv6 truetype -doc -static-libs"
[ebuild   R    ] www-client/w3m-0.5.3-r9  USE="-gtk*"
[ebuild   R    ] sys-devel/gettext-0.19.8.1 [0.19.8.1]
[ebuild   R    ] dev-libs/libgpg-error-1.27-r1 [1.27-r1]
[ebuild   R    ] dev-libs/libgcrypt-1.7.6 [1.7.6]
[ebuild   R    ] dev-libs/libassuan-2.4.3-r1 [2.4.3-r1]
[ebuild  N     ] sys-libs/libomp-3.9.1  USE="-hwloc -ompt" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-devel/clang-runtime-3.9.1  USE="openmp -libcxx" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-dns/libidn2-0.16-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] net-libs/gnutls-3.5.12 [3.3.26] USE="idn%* seccomp%* sslv3%* tls-heartbeat%* -openpgp% -sslv2% (-test-full) -tools% -valgrind%"
[ebuild  r  UD ] dev-libs/glib-2.42.2-r1 [2.50.3-r1]
[ebuild  N     ] gnome-base/dconf-0.22.0  USE="X {-test}"
[ebuild  N     ] dev-libs/dbus-glib-0.102  USE="-debug -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] dev-util/gdbus-codegen-2.42.2 [2.50.3] PYTHON_TARGETS="(-python3_6)"
[ebuild   R    ] dev-libs/libcroco-0.6.12-r1 [0.6.12-r1]
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.29.0  USE="-doc {-test}"
[ebuild     UD ] dev-libs/gobject-introspection-1.42.0-r1 [1.50.0]
[ebuild     UD ] x11-libs/gdk-pixbuf-2.36.4 [2.36.6]
[ebuild     UD ] dev-libs/atk-2.14.0 [2.22.0]
[ebuild  rR    ] dev-libs/libgudev-230-r1
[ebuild     UD ] app-accessibility/at-spi2-core-2.14.1 [2.22.1]
[ebuild     UD ] dev-libs/libgusb-0.2.7 [0.2.9]
[ebuild     UD ] app-accessibility/at-spi2-atk-2.14.1 [2.22.0]
[ebuild     UD ] dev-util/gtk-update-icon-cache-3.14.15 [3.22.2]
[ebuild   R    ] app-text/ghostscript-gpl-9.20-r1  USE="-gtk*"
[ebuild   R    ] sys-devel/llvm-3.9.1-r1  USE="clang*"
[ebuild  N     ] sys-devel/clang-3.9.1-r100  USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[ebuild   R    ] media-libs/mesa-13.0.5  USE="-bindist*" VIDEO_CARDS="-intel* -nouveau* -radeon* -radeonsi*"
[ebuild  N     ] virtual/opengl-7.0-r1  ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] app-text/poppler-0.54.0 [0.45.0] USE="-qt4*"
[ebuild  N     ] media-libs/glfw-3.2.1  USE="-examples -wayland"
[ebuild     UD ] x11-libs/pango-1.36.8-r1 [1.40.5]
[ebuild  N     ] app-text/mupdf-1.11-r1  USE="X curl opengl openssl -javascript (-libressl) -static -static-libs -vanilla"
[ebuild   R    ] gnome-base/librsvg-2.40.17 [2.40.17]
[ebuild     U  ] net-print/cups-filters-1.12.0 [1.5.0] USE="pdf%* postscript%*"
[ebuild     UD ] x11-themes/adwaita-icon-theme-3.14.1-r2 [3.22.0-r1]
[ebuild   R    ] sys-fs/eudev-3.1.5  USE="introspection*"
[ebuild     U  ] x11-base/xorg-server-1.19.2 [1.18.4] USE="-debug% -kdrive*"
[ebuild  rR   ~] x11-drivers/xf86-video-virtualbox-5.1.18
[ebuild   R    ] app-crypt/libsecret-0.18.5 [0.18.5]
[ebuild     U  ] sys-auth/pambase-20150213-r1 [20150213] USE="consolekit* gnome-keyring* -elogind%"
[ebuild   R    ] net-misc/openssh-7.3_p1-r7  USE="X* ldap* -bindist*"
[ebuild   R    ] sys-auth/polkit-0.113  USE="-gtk*"
[ebuild     UD ] sys-auth/consolekit-0.4.6 [1.1.0-r1] USE="-systemd-units%"
[ebuild     UD ] x11-misc/colord-1.2.12 [1.3.4]
[ebuild     UD ] x11-libs/gtk+-3.14.15 [3.22.15]
[ebuild     UD ] app-crypt/gcr-3.14.0 [3.20.0] USE="-vala*"
[ebuild   R    ] app-crypt/pinentry-0.9.7-r1 [0.9.7-r1] USE="-gtk* -qt4*"
[ebuild     U  ] app-crypt/gnupg-2.1.21 [2.1.20-r1]
[ebuild     UD ] gnome-base/gnome-keyring-3.14.0 [3.20.0]
[ebuild   R    ] gnome-base/libgnome-keyring-3.12.0 [3.12.0]
[ebuild     U  ] sys-apps/openrc-0.26.2 [0.24.2]

The following packages are causing rebuilds:

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-video-virtualbox-5.1.18:0/0::gentoo, ebuild scheduled for merge)
  (dev-libs/glib-2.42.2-r1:2/42::dantrell-gnome, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/libgudev-230-r1:0/0::gentoo, ebuild scheduled for merge)

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39060
Location: 56N 3W

PostPosted: Mon May 22, 2017 5:59 pm    Post subject: Reply with quote

EugeneTheJeep,

That looks much better. Go for it.

x11-drivers/xf86-input-mouse and x11-drivers/xf86-input-keyboard are the old mouse and keyboard drivers that nobody except me uses any more :)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
EugeneTheJeep
n00b
n00b


Joined: 17 May 2017
Posts: 65

PostPosted: Mon May 22, 2017 6:03 pm    Post subject: Reply with quote

Thanks so much for your assistance. Marking as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum